Instalando o KDE 4.1 no Slackware 12.1

O KDE 4.1 acabou de sair do forno e eu, como bom entusiasta do opensource e do KDE, já instalei. Descrevo aqui as minhas venturas e desventuras na instalação desse maravilhoso ambiente de trabalho, agora numa versão muito estável e bonita.

[ Hits: 42.302 ]

Por: André Vitor Matos em 01/08/2008 | Blog: http://www.google.com/profiles/andre.vmatos


Introdução



O KDE 4 estava sendo esperado como uma revolução. Porém, quando a versão 4.0 foi lançada, houve, de certa forma, um desapontamento geral, mesmo tendo sido avisado como uma versão instável.

Então a equipe de desenvolvimento do KDE prometeu que a versão 4.1 viria para consolidar o uso desse gerenciador de janelas nas massas. De fato essa versão está incomparavelmente mais estável do que a 4.0. Está linda, com os plasmoids funcionando perfeitamente, quase sem bugs (até onde pude ver), além de diversos recursos adicionados, que melhoram muito a convivência do usuário com o computador.

Agradecemos aqui ao rlworkman, conhecido usuário e desenvolvedor do Slackware, que disponibilizou em tempo recorde os pacotes, slackbuilds e dependências para o KDE 4.1 em seu site, do qual vamos pegar os arquivos.

Então, mãos a massa.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Downloads
   3. Instalando a tralha toda
   4. Screenshots
Outros artigos deste autor

Quebrando a criptografia RSA

MOC - O player de áudio para consoles

Leitura recomendada

Instalando antivírus LinuxShield no SuSE e OpenSuSE

Instalando o Gentoo GNU/Linux

Clonando discos utilizando o G4U ("Ghost para Unix")

Intel GVT-g: compartilhando a GPU Intel com convidados QEMU/KVM

O comando LS de A a Z

  
Comentários
[1] Comentário enviado por andrebsilva em 01/08/2008 - 12:16h

Parabéns, excelente artigo.

Agora sim nasceu uma super interface gráfica. O novo KDE arrasa a concorrência e olhe que eu uso GNOME mas, tenho que aceitar que o KDE 4 é um luxo só.

Ponto para o software livre, ponto para o Linux e todos os sistemas operacionais que podem usar o novo KDE. É só esperar o novo KUbuntu e o novo Kurumim.

dez

[2] Comentário enviado por tekmania em 01/08/2008 - 14:32h

muito obrigado pela dica, ja vou instalar no meu slackware

[3] Comentário enviado por kalib em 01/08/2008 - 14:47h

Vocês gostaram mesmo dele? o.O
Eu também achei um luxo ao ver e tal..
Mas ao instalar.. :/ Fiquei decepcionado com várias coisas...
Achei ele muito limitado se comparado ao antigo..limitado no sentido de customização...
Ele não me permite modificar tanto as coisas quanto o antigo...
Ele não me permite ter ícones em minha área de trabalho...apenas se for com aquele quadro tosco lá... uma segunda camada..nojento...
Ele também tem problema com transparências que não sejam nativas dele..Por exemplo..meu yakuake nele não pode mais ficar transparente...meu gkreelm também não funciona com tema transparente..etc..etc..
O systray continua com muitos problemas...
enfim..eu esperava muito desse KDE pelas propagandas..sempre fui fanático por KDE...mas esse me decepcionou..instalei ontem aqui no meu arch..mas já estou me planejando para tirar e voltar ao antigo nesse fds. :/

[4] Comentário enviado por andre.vmatos em 01/08/2008 - 16:01h

Obrigado, pessoal, pelos elogios. Fico feliz de ter contribuido com a comunidade. que pena, kalib, vc ter essa opinião. eu particularmente, gostei muito dessa nova versão do KDE. Realmente, não tem TANTAS opções de configuração como na versão 3.5.x, mas acredito que está muito boa. ainda existem muitas opções de configuração, porém, estão mais concentradas nas Configurações do Sistema, do que nos menus de contexto e parentes. Achei ele muito bonito mesmo, rápido e leve. Problemas com o systray? Poderiamos ajudar? Eu não tive nenhum. Não tive nenhum problema com todo o KDE, apenas com o amarok, mas eh alpha. com o resto, nenhum bug sequer, até agora. Talvez esses problemas sejam relacionados ao KDEMod que vc usou no seu archlinux. Pelo que li, o kdemod 4.1 não está 100% no arch. Flwss

[5] Comentário enviado por removido em 01/08/2008 - 16:59h


Apesar de não usar mais o Slackware seu artigo ficou muito bom.

[6] Comentário enviado por mcleber em 01/08/2008 - 17:20h

Parabéns pelo artigo, ficou muito bom mesmo... Vou instalar,
[ ]'s

[7] Comentário enviado por Daniel_Vieceli em 01/08/2008 - 19:22h

vlw aee

[8] Comentário enviado por dbahiaz em 01/08/2008 - 19:35h

Realmente ta lindo,leve e poderoso :) Tem coisas à corrigir sim, mais estão no caminho certo, uso no opensuse 11 e ta muito funcional.

[9] Comentário enviado por sl4x em 01/08/2008 - 21:41h

show de bola! parabens pelo artigo! está bem mais estável que o 4.0!

[10] Comentário enviado por removido em 01/08/2008 - 22:29h

Concordo totalmente com o Kalib. A ultima vez que usei o kde foi a versão 4 que acabava de ser lançada no Slack. Agora instalei a 4.1 em meu Arch e a meu ver deixa muito a desejar na principal filosofia do Linux, a liberdade. Liberdade de se deixar o Desktop do jeito que quer. O dolphin está muito melhor e o visual nem se fala, mas ainda prefiro meu bom e velho Gnome.

Parabéns pelo excelente artigo.

[11] Comentário enviado por mySOsMADEofSLACK em 02/08/2008 - 11:13h

Que ficou mais bonito que o 3.5 ficou, mas acho que não vai rodar legal no meu duron 750 com 312 de ram hehehe...

Bonitão você ein! xD

[12] Comentário enviado por andre.vmatos em 02/08/2008 - 12:46h

Ah, axo que vai funcionar bem sim. O meu PC tem 256 de RAM (jah ta me deixando louco), apenas o processador eh bom, eh um celeron d 2.8, mas o KDE usa pouco processamento. ele usa mais RAM msm. No meu caso, tem funfado blz com 256 de ram, usando um pquinho de swap, mas ta mais leve q qdo tava com o 3.5. Recomendo vc tentar instalar. Rsrs, obrigado pelo elogio =]

[13] Comentário enviado por BlueFox em 02/08/2008 - 13:52h

Amigo, fiz o download de todos os pacotes e segui o modo de instalação, agora quando tenta iniciar o ambiente gráfico ele não carrega e retorna um erro.
Tento pelo starx, X, Xorg, mas todos começa a carregar, fica o X do mouse no meio da tela mas depois da erro.
Instalei no Slackware 12.1.
Sou novato em linux e tava indo bem, instalando tudo, só faltava o samba....... agora ferrei meu ambiente gráfico e não sei como copiar log de erro, pode me ajudar ou vou ter que instalar o Slackware tuuuuuuudo de novo ?
Valeu, aguardo retorno urgente... Brigadão.

[14] Comentário enviado por andre.vmatos em 02/08/2008 - 13:59h

Hmm, eu tenho esse erro com frequencia, mas não tem nada a ver com o KDE. Você usa placa de vídeo NVidia? Qdo eu tenho esse erro, eu reinstalo o driver da placa, e funfa blzinha. Definitivamente, esse erro não tem nada a ver com o KDE. Hmmm, tente remover o arquivo /usr/share/config/kdm/kdmrc ou então, mover ele para um backup. Flwss

[15] Comentário enviado por BlueFox em 02/08/2008 - 14:03h

Andre, se ajudar alguma coisa, acabei de encontrar o Explore2fs, que enxerga as part do linux.
Aguardo ajuda sua ou de alguem, por favor.

[16] Comentário enviado por BlueFox em 02/08/2008 - 14:06h

Minha placa de video é uma VIA Chrome9 HC IGP, em not positivo.
Vou tentar e retorno, meu msn se puder ajudar: wln_tom@hotmail.com

[17] Comentário enviado por BlueFox em 02/08/2008 - 14:10h

Cara, não tem a pasta /kdm, chego até /usr/share/config.
Att.

[18] Comentário enviado por grandmaster em 02/08/2008 - 15:01h

Show o artigo.

Vou testar hj e se conseguir volto mais tarde para postar :D

Renato de Castro Henriques
CobiT Foundation 4.1 Certified ID: 90391725
http://www.renato.henriques.nom.br

[19] Comentário enviado por BlueFox em 02/08/2008 - 16:01h

Alguem me ajude por favor...... quero usar o slack e não carrega o video....como postei acima.

[20] Comentário enviado por isaac em 02/08/2008 - 16:59h

Instalei ele no Mandriva 2008 Spring.
O Dolphin está meio bugado ainda.
Volta e meia, ele some do desktop.
Isso e um bug pequeno aqui e outro ali.
Acho que ele vai estar 100% mesmo, na versão 4.2 (será lançada em 29/01/09)

[21] Comentário enviado por sl4x em 02/08/2008 - 19:19h

alguém tem ideia de como fazer o monitor de bateria funcionar?
ja tentei subir alguns modulos mas nao funciona... o monitor aparece mas não marca nenhum valor :(
se alguem souber de algo, agradeço :)

os modulos que carreguei:
modprobe battery
modprobe ac
modprobe button
modprobe fan
modprobe processor



[22] Comentário enviado por QuestLoder em 03/08/2008 - 15:25h

Bom dia pessoal, baixei os pacotes conforme a dica acima, realizei a atualização, só que o modo gráfico não está subindo...
Está aparecendo Coult not start kstartupconfig4, check your installation...

Que pau é este??????
Obrigado pela atenção....

[23] Comentário enviado por maran em 04/08/2008 - 07:36h

@andre.vmatos, show de bola este seu artigo, muito bom mesmo, assim que tiver um tempo estarei testando, grande abraço.

[24] Comentário enviado por redhat2 em 04/08/2008 - 11:51h

Cara muito bom,legal tudo bem explicado

[25] Comentário enviado por k4mus em 09/08/2008 - 15:48h

Ola fera! Parabens pelo artigo.


Gosti muito do kde 4.1 , mas aqui esta dando um erro quando clico pra fazer logout. Nesta hora passa quase um minuto passando um monte de logs na tela, o qual a ultima parte eh esta:

kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-mng.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 716) for
"/usr/share/mime/video/x-mng.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-mng.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-ms-asf.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 717) for
"/usr/share/mime/video/x-ms-asf.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-ms-asf.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-ms-wmv.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 718) for
"/usr/share/mime/video/x-ms-wmv.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-ms-wmv.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-msvideo.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 719) for
"/usr/share/mime/video/x-msvideo.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-msvideo.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-nsv.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 720) for
"/usr/share/mime/video/x-nsv.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-nsv.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-ogm+ogg.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 721) for
"/usr/share/mime/video/x-ogm+ogg.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-ogm+ogg.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-sgi-movie.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 722) for
"/usr/share/mime/video/x-sgi-movie.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-sgi-movie.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/video/x-theora+ogg.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 723) for
"/usr/share/mime/video/x-theora+ogg.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/video/x-theora+ogg.xml" for ""
["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/x-epoc" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 726) for "/usr/share/mime/x-epoc"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed Dir "/usr/share/mime/x-epoc" for "" ["KDirWatch-1"]
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: path= "/usr/share/mime/x-epoc/x-sisx-app.xml" sub_entry: 0x0
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 10, 725) for
"/usr/share/mime/x-epoc/x-sisx-app.xml"
kded(3421)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed File "/usr/share/mime/x-epoc/x-sisx-app.xml" for ""
["KDirWatch-1"]
kded(3421) KHotKeys::ShortcutsHandler::removeAction: Removing action for "{2cda7cf8-0000-4000-9c6c-c2308e0ae4a1}"
kded(3421) KHotKeys::ShortcutsHandler::~ShortcutsHandler: Goodbye from shortcuts_handler
kded4: Fatal IO error: client killed


..Voce poderia sugerir alguma solucao??



Grato

[26] Comentário enviado por andre.vmatos em 09/08/2008 - 19:07h

Nuss, que erro esquisito. Hmm, se fosse comigo, antes de eu reinstalar o SO e tentar instalar nele "puro" o kde 4.1, tentaria reinstalar o KDE 4.1, e, pelo que vi, são erros relacionados com mime. Tente reinstalar o pacote shared-mime-info, não sei se tem a ver, mas é um bom começo. Erro muito estranho mesmo.
O meu KDE ta funcionando perfeitamente, já instalei alguns plasmas, ta mto legal. Vlww, galera.

[27] Comentário enviado por k4mus em 10/08/2008 - 10:31h

Eh meu amigo eu ja tinha feito isso, mas nao resolveu. Vou continuar usando assim mesmo afinal o restante esta funcionando beleza. Esta versao esta muito legal. to ansioso pra proxima versao do slack q vai vim com ele padrao :)

vlw

[28] Comentário enviado por noelcaldeira em 14/08/2008 - 11:34h

Fiz recentemente a instalacao do slackware 12.1, porem ao fazer o boot a tela grafica nao carregava.
Lendo seu artigo baixeir o KDE 4.1 e gravei os arquivos em um cdrom.
Montado o cdrom, executei as instrucoes recomendadas e mesmo assim o KDE nao abre.
Sou novato com o linux e preciso de instrucoes tutoriais (todos os passos a seguir) para poder instalar o sistema, o KDE e uma placa wireless IEEE 802.11g.
Se for complicado explanar as instrucoes aqui, eu agradeco se mandar para meu email noelcaldeira@acia.com.br
grato

[29] Comentário enviado por andre.vmatos em 14/08/2008 - 15:43h

Olá. noelcaldeira. Hmm, parece que o problema não é no KDE, e sim no X. Execute, no console mesmo, o comando startx e poste a saída, por favor. Esse comando inicia o X, porém debugando os erros que acontecerem. Ai, só você postar o que aparecer na tela quando vc der esse comando. Ai poderemos tentar resolver. Flwss, t+

[30] Comentário enviado por noelcaldeira em 15/08/2008 - 09:32h

Oi Andre
Valeu, o KDE funcionou.
Entao vale a pergunta: como executar o startx durante o boot? Em qual arquivo deve ser escrito esse comando?
Se for possivel gostaria de algumas dicas para instalar a placa wireless.
grato

[31] Comentário enviado por andre.vmatos em 15/08/2008 - 13:58h

Não, não. Não eh uma boa idéia executar o startx no boot. Startx eh soh pra testar se há algum erro, pq ele executa o modo gráfico como root (e isso não eh uma boa idéia). Mas, se o KDE iniciou com o startx, então o problema só pode ser no kdm. Hmmm, tente substituir o arquivo /usr/share/config/kdm/kdmrc pelo kdmrc.new na mesma pasta. O comando é:
mv /usr/share/config/kdm/kdmrc.new /usr/share/config/kdm/kdmrc
, responsável pelas configurações do KDM. Assim, ele deve executar o KDM com o novo arquivo, com as configurações padrão. Tente isso ai, ou então, avise se não der certo, que eu te envio meu kdmrc. Axo que o problema está nele. Enquanto isso, já q não tem jeito, pode ir usando o KDE no startx msm. Flwss

[32] Comentário enviado por caarlos0 em 18/08/2008 - 14:11h

meee rapaz,
que filé que tá esse kde4,

tá mui vista-like, mais ta massa =D

asdiadoad


agora to na facul, net muito lenta pra baixaar ; em chegando em casa os down vão comer =)

o mais curioso é que nem era isso que eu tava procurando, tava fuçando sobre o apache, e me aparece um tuto ótimo desse, bem explicado e pá ;D

Graaaaaaande VOL (Y)


abraço

[33] Comentário enviado por laund em 19/08/2008 - 12:31h

Otimo artigo . . ja instalei aqui . . porém após instalá-lo meu Virtual Box não funciona . . fiz o passo mencionado acima do Gtk, porem na configuração do sistema na me dá as opções "Configurações do Sistema / Aparência / GTK Styles and Fonts". Você pode me ajudar ?

Abraços parabens pelo artigo

[34] Comentário enviado por andre.vmatos em 19/08/2008 - 12:39h

Hmm, vc quis dizer que nessa sessão das configurações, depois de instalado o gtk-qt-engine, ele não te dá a opção GTK Styles and Fonts? Se ele não oferecer essa opção, tente baixar novamente do SVN e recompilar. Caso der algum erro em algum dos comandos de instação, poste ai pra gente ver se resolve. Flwsss

[35] Comentário enviado por noelcaldeira em 20/08/2008 - 20:07h

Fiz a movimentação do kdmrc.new para o kdmrc e mesmo assim não funcionou.
Usando a distribuição ubutu ou kubuntu o kde funciona automaticamente, sendo assim qual o arquivo dos ubuntus que posso verificar para ver o que está faltando?
Ainda não consegui instalar a placa wireless.

[36] Comentário enviado por luizzeross em 24/08/2008 - 00:46h

Yas! Ficou bom o artigo, e os snapshots do kde4 ficaram bonitões, tirando o do Dolphin, pois eu não suporto ele, e ainda a foto sua, ai ficou pior ainda.... huahuhaua!! Brincadeiras à parte, vou testar, eu teste o Kde 4.0 no OpenSuSE 10.3, e tava bem ruinzinho ainda. Eu encontrei problemas aqui, em compilar o "gtk-qt", diz que não acha o qmake, mas eu tenho qmake. Será que o cmake está procurando pela versão 4 (qt 4) e eu to ainda na 3 (ainda não instalei o kde4) ? Ele não menciona problemas de versão. É pq aqui, no kde3 também tem o velho problema do GTK ficar pobre e gordo, dai to tentando utilizar esta versão do svn.

[37] Comentário enviado por andre.vmatos em 24/08/2008 - 01:47h

noel, não entendo pq desse erro. Aki funfou blzinha. Tvz seja o X. Tente fazer um novo conf com "X -configure", movendo o arquivo que será criado de /root/xorg.conf.new pra /etc/X11/xorg.conf. De resto, não consigo imaginar o q seja. Tvz o drive da placa de video, sei lá. Posta mais alguma informação ae, como a saida do erro no startx.
Luizzeross, o negocio eh o seguinte. o GTK-Qt-Engine, a partir da versão 1.0, é exclusivamente pra kde/qt 4. Então, pra usar no seu kde3, tente baixar a ultima versão disponivel antes da 1.0. Axo q eh 0.8. alguma coisa. Ai, tenta com ela. Se não der assim msm, procure no ./configure --help alguma opção pra indicar a localização do seu qmake. Flwss, pessoal.

[38] Comentário enviado por nunesvictor em 02/09/2008 - 09:31h

instalei o KDE 4.0 no Mandriva e foi uma decepção...
=/
mas notei uma coisa... vc ta usando o comando "upgradepkg --install-new ..." mas aí, se vc não gostar não tem como voltar ao antigo...
=/
no meu mandriva eu podia escolher qual sessão iniciar, kde ou kde4
ñ tem como fazer isso no slackware?!

[39] Comentário enviado por andre.vmatos em 02/09/2008 - 09:46h

axo que tem sim, mas não esses pacotes. axo q eles foram feitos pra serem instalados por cima do kde3. se quiser tentar instalar os dois, use installpkg. mas não testei dessa forma. Até pq estou feliz com meu KDE4, e não qro voltar pro 3 =]
Flwss

[40] Comentário enviado por enricolo4 em 07/09/2008 - 16:50h

E quem usa sistema 64 bits pode instalar esse kde4 normalmente, pois eu uso o slamd64 uma versao 64 bits do slackware, sera que nao tem problemas?

[41] Comentário enviado por andre.vmatos em 07/09/2008 - 17:32h

Enricolo4, pra falar a verdade eu não sei. Acredito que não, porque é uma suite muito grande, e acredito que deva ser compilado para a arquitetura específica. Mas, neste mesmo site de downloads, tem os sources com os Slackbuilds. Axo que, com eles, vai ser fácil vc compilar o KDE4 para 64 bits. Flwss

[42] Comentário enviado por wagmiguel em 08/09/2008 - 11:49h

Boa Tarde!

Baixei todos os pacotes, instalei as dependencias e depois mandei atualizar o KDE.
Quando tento startar o X me retorna esse erro:

Could not start kstartupconfig4, check your installation...
GLIBCXX_3.4.9' not found (required by"nome de um arquivo que eu não lembro")

Eu acho que a minha versão do GLIBC esta desatualizada, mas não consegui resolver.
Sera que algume pode me ajudar.

Utilizo o slackware 12

Muito Obrigado

[43] Comentário enviado por andre.vmatos em 08/09/2008 - 17:47h

Hmm, axo que deve ser porque esses pacotes são feitos com base em pacotes da versão 12.1 do Slackware. Tenta atualizar o Slack, e depois instalar o KDE, que acredito que não terá erro. Flwss

[44] Comentário enviado por douglascrp em 09/09/2008 - 14:51h

publiquei um passo-a-passo no meu blog
para quem estiver interessado, segue o link
http://douglascrp.blogspot.com/2008/09/kde-41-no-slackware-121.html

abraços

[45] Comentário enviado por angrasbss em 11/09/2008 - 16:44h

Meu som sumiu de vez, já fiz de tudo para o som funcionar e nada.Maldita hora que resolvi trocar esse kde

[46] Comentário enviado por shutdown4sss em 12/09/2008 - 17:54h

Gostei do tuto, já tô baixando pra instalar no slack 12.1!

[47] Comentário enviado por wagmiguel em 15/09/2008 - 17:48h

Atualizei para o Slackware 12.1 e instalei o KDE 4.1, bem legal, to configurando para deixar do meu gosto, mas estou gostando, achei ja um bugzinho no descompactador mas nada que comprometa.
Valeu André pela dia de atualizar para versão 12.1

[48] Comentário enviado por andre.vmatos em 15/09/2008 - 22:25h

Rsrs, NP. Obrigado pelos elogios, e qqr coisa, só perguntar. A comunidade está ai pra ajudar. Vlww

[49] Comentário enviado por xerxeslins em 21/09/2008 - 22:23h

olá! eu fiz o que voce disse e as bordas das janelas sumiram!
fora isso esta tudo otimo. como eu corrijo isso?

[50] Comentário enviado por xerxeslins em 21/09/2008 - 22:51h

o meu KDE ficou sem borda e quando tento executar o kde-window-decorator aparece a seguinte mensagem:

kde-window-decorator: error while loading shared libraries: libkdecorations.so.1: cannot open shared object file: No such file or directory


por favor, sabe o que pode corrigir esse defeito?

[51] Comentário enviado por andre.vmatos em 22/09/2008 - 00:14h

Hmm, vc deve ter esquecido de instalar algum dos pacotes. Aqui no meu PC existe o arquivo /usr/lib/libkdecorations.so.4
Tente linkar "ln -s /usr/lib/libkdecorations.so.4 /usr/lib/libkdecorations.so.1"
Tvz seja apenas isso. Qqr coisa, tente reinstalar o KDE, e verifique se baixou tds os arquivos. Flwsss

[52] Comentário enviado por xerxeslins em 23/09/2008 - 17:31h

Oi cara,

Reinstalei tudo denovo e executei o comando que você disse para criar atalho, mas mesmo assim continua sem borda.

Vou tentar mais aqui.. Qualquer coisa eu aviso.

Valeu!

[53] Comentário enviado por xerxeslins em 23/09/2008 - 18:08h

parece que o arquivo "kdesdk-4.1.0-i486-1_rlw.tgz" está corrompido! Pelo menos aparece isso quando eu tento instalar:

Installing package kdesdk-4.1.0-i486-1_rlw...
PACKAGE DESCRIPTION:
kdesdk: kdesdk
kdesdk:
kdesdk: KDE Software Development Kit. This is a collection of applications
kdesdk: and tools used by KDE developers. It also has example code for use
kdesdk: in learning KDE programming or starting a new KDE application.
kdesdk:
Unable to install ./kdesdk-4.1.0-i486-1_rlw.tgz: tar archive is corrupt (tar returned error code 2)

Já baixei denovo, mas ele vem corrompido do link.

[54] Comentário enviado por andre.vmatos em 23/09/2008 - 18:18h

Hmm, tente baixar do repo do slackware, que já add os packs na current do slackware. Soh dar uma procurada lá. Flwss

[55] Comentário enviado por xerxeslins em 23/09/2008 - 18:33h

Bem... cara.. eu baixei só o pacote que estava corrompido e instalei.. eu tinha instalado o fusion-icon tbm e mudei para kwin ao inves de compiz e está tudo funcionando perfeitamente. Agora vou tentar fazer funcionar com o compiz.

Muito obrigado cara =)

Excelente artigo!

Abraço

[56] Comentário enviado por xerxeslins em 24/09/2008 - 17:45h

Olá.. tenho uma dúvida,

eu fui em -> Configurações do Sistema / Aparência / mas não achei nenhuma opção "GTK Styles and Fonts"

=(

o que eu preciso fazer?

Detalhe:

já fiz o

"svn co http://gtk-qt.ecs.soton.ac.uk/svn/gtk-qt/trunk/gtk-qt-engine"

e etc;

[57] Comentário enviado por xerxeslins em 24/09/2008 - 18:16h

é o seguinte: eu instalei o GTK-Qt 1.1 pelo procedimento normal, ./configure, make, make install... e depois fiz os comandos que vc disse do svn, fiz certo?

infelizmente nas opções de aparencia nao tem a opção de GTJ Styles and Fonts

[58] Comentário enviado por jorge.s em 27/09/2008 - 01:06h

cara, instalei a pouco tempo tiri menos de uma comigo funcionou que foi uma maravilha como root, como usuario comum ficou em ingles lento cheio de falhas nem os sons do sistema funciona tipow se eu colocar uma musica ou qualquer coisa toca na boa mais os do proprio kde so toca como root fora que é estranho essa lentidão toda:

athlon X2 64 bits
2GB de ram

acho que com essa configuração éra pra rodar ao menos utilizavel e não lerdo do modo que esta...

assim pelo que vi até agora não gostei não...

mas parabens pelo artigo...

[59] Comentário enviado por andre.vmatos em 27/09/2008 - 09:16h

Hmmm, não desgoste do KDE4 só por causa disso, porque não é do KDE em si, e sim, da configuração, pq aki, e em vários outros PCs que instalaram, o KDE funfa normalmente como usuário comum. Quanto ao problema do som, vc adicionou seu usuário aos grupos básicos que o slackware fornece? Para o som funcionar como usuário comum, o seu usuário deve participar de alguns grupos. Dê uma pesquisada no /etc/group
Flwss, espero ter ajudado

[60] Comentário enviado por fabri em 25/11/2008 - 21:09h

Parabens pro seu tutorial, bem escrito, elaborado.
Existe alguns outros por aí, achei o seu mais melhor de bom, aí né fiz tudinho e o KDE inicia quando abrir o desktop trava tudo, refiz, removi, baixei novamente, refiz toda leitura, sua e de outros como disse.........................nada ...................trava de novo
mas o flux, gnome e outros funfam legal................
e aí poderia dizer o que está dando errado p aqui.
p4 2800ghz
mb azus p4s800
2500m de ram
video ati radeon 9200

[61] Comentário enviado por andre.vmatos em 25/11/2008 - 21:20h

Hmmm. Estranho. Não tive ainda esse tipo de relato de problema. Ele iniciou pelo menos uma vez, depois de instalado, normal? Imagino o que pode ser que dá essa travada. Tvz seja que os efeitos que pedem aceleração estejam ativados, mas seu x11 não esteja configurado para isso, ow o módulo não suporte. Tente reinstalar o módulo da sua placa de vídeo. É um tiro no escudo, apenas uma suposição, pq problemas com a aceleração podem travar o KDE.

[62] Comentário enviado por fabri em 25/11/2008 - 21:47h

Não companheiro, após a instalação nunca funcionou

[63] Comentário enviado por fabri em 25/11/2008 - 21:49h

pergunto ainda qual o modulo para ati radeon 9200 que devo instalar, e onde poderia encontra-la?

[64] Comentário enviado por andre.vmatos em 25/11/2008 - 22:00h

Hmm =/
Não imagino o que possa ser. Tente usar os pacotes oficiais, que agora estão disponíveis no repo do slackware. Além de ser oficiais, ainda são mais atualizados, 4.1.2. Talvez assim, com um novo empacotamento, o problema se resolva por si só. Se não, é algo externo ao KDE mesmo, como incompatibilidade com a placa de vídeo, ou hardware, ou outras coisas mais obscuras.
ftp://ftp.slackware-brasil.com.br/slackware-current/testing/packages/kde4/
Quanto ao módulo, acredito que o mais recomendável seja o oficial, mesmo sendo fechado (=\)
Axo que o link é esse: http://ati.amd.com/support/drivers/linux/linux-radeon.html
Abraços. Qqr coisa, pode postar ai, que tentaremos dar alguma luz.

[65] Comentário enviado por pelo em 01/03/2009 - 16:58h

Boa tarde pessoal,

Eu tive problema com biblioteca. Uso Slackware 12.0 e atualizei glibc e gcc para resolver o problema.
Baixe todos os glibc que estão em
ftp://ftp.slackware-brasil.com.br/slackware-current/slackware/l/
E o gcc em
ftp://ftp.slackware-brasil.com.br/slackware-current/slackware/d/

Com todos os pacotes em algum diretótio do slack, dentro dele execute:
upgradepkg glibc

E o mesmo procedimento para o gcc.

[]'s

Sérgio Abrantes


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts