Linux + Rails + Ruby + Mongrel + PostgreSQL + NetBeans 6 Preview

Este artigo demonstra a criação de um ambiente de desenvolvimento completo Ruby on Rails com a nova IDE baseada em Java NetBeans 6 (Development).

[ Hits: 44.987 ]

Por: Perfil removido em 22/08/2007


Baixando e instalando PostgreSQL + Ruby + Rails



Indo na filosofia da comunidade Java, "Compatibility Matters!", descreverei os passos para a instalação no Ubuntu (ou qualquer Debian Based), Slackware e de maneira genérica.

Primeiramente vamos ao nosso Banco de Dados do Elefante:

Debian Based:

$ sudo apt-get install postgresql-common
$ sudo apt-get install postgresql-lib
$ sudo apt-get install postgresql-utils


Slackware:

Baixe: http://www.linuxpackages.net/download.php?id=10609

# installpkg postgresql-8.2.0-i486-1asz.tgz

Genérica:

Baixe todos os pacotes de: http://www.postgresql.org/ftp/source/v8.2.4/

Siga o padrão em todos eles: descompacte -> Entre na pasta -> ./configure && make && make install.

Baixando e instalando o Ruby:

Debian Based:

$ sudo apt-get install ruby

Slackware:

Baixe: http://www.linuxpackages.net/download.php?id=10721

# installpkg ruby-1.8.6-i486-1kjz.tgz

Genérica:

Baixe: ftp://ftp.ruby-lang.org/pub/ruby/ruby-1.8.6.tar.gz

$ tar -zxvf ruby-1.8.6.tar.gz
$ ./configure
$ make
$ su
# make install


Baixando e instalando o Ruby Gems:

Debian Based:

$ sudo apt-get install ruby-gems

Slackware:

Baixe: http://www.linuxpackages.net/download.php?id=10722

# installpkg rubygems-0.9.2-noarch-1kjz.tgz

Genérica:

http://rubyforge.org/frs/download.php/20989/rubygems-0.9.4.tgz (Não se iluda, isso não é um pacote para Slackware!)

$ tar -zxvf rubygems-0.9.4.tgz
$ su
# ruby setup.rb


Baixando e instalando o Rails:

A partir deste ponto não interessa se você utiliza Debian Based, Red Hat Based, Slackware ou BSD. Como Rails é um framework para Ruby e Ruby é interpretado, logo iremos nos preocupar em instalar coisas para Ruby e não para o Sistema em questão. A convenção de diretórios do Ruby é muito boa, pode crer no que estou falando.

Não faça: apt-get install rails

Embora funcione, você não terá o seu Ruby Gem atualizado, e você verá a dor de cabeça quando sair um novo Rails e nos repositórios do apt-get ele ainda não está lá. Então, utilizaremos o Gem:

# gem install rails --include-dependencies

É o mesmo comando em qualquer *NIX da vida (eu sei que é estranho alguém falar isso, mas não sei como é no *Uíndous*, só mexo com *NIX a mais de 6 anos).

Legal, instalamos o Elefante (PostgreSQL), a pedrinha de rubí (Ruby) e os trilhos (Rails). Agora vamos tomar café (Java) e catar feijões (NetBeans)...

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Baixando e instalando PostgreSQL + Ruby + Rails
   3. Vai um café? Com feijões?
   4. Configurando o NetBeans IDE para o Ruby nativo
   5. Uma agenda em Rails
Outros artigos deste autor

IPtables - Trabalhando com Módulos

Criando um álbum de fotos no Linux

Mencoder ripando DVD para DIVX

Instalando o OSS4 no Ubuntu 11.04

Avaliando as dicas de segurança do Banco do Brasil

Leitura recomendada

Trabalhando com classes e métodos em Java

Linux com Java 1.7 + JBoss 7

Jmeter com qualidade e performance

Trabalhando com a interface gráfica em Java

Java Native Interface

  
Comentários
[1] Comentário enviado por fabio em 22/08/2007 - 04:35h

Ótimo artigo, muito boa a didática, parabéns!

[2] Comentário enviado por alyssonmartins em 22/08/2007 - 09:22h

bacana... é isso ae

[3] Comentário enviado por removido em 22/08/2007 - 11:40h

Não aprendemos apenas como instalar ruby, java, e toda a "parafernalha" de programador... rsrsrs...
Aprendemos à como escrever um artigo de VERGONHA!!!
Acabou com a frase do programador vb... "Em casa funcionou"... este artigo funciona em qualquer lugar, eu qualquer distro...
Franklin Ronald é um dos que entenderam meu artigo "Linux for Human Beings?"
Parabéns Franklin, mais uma demonstração de sua genialidade imparcial...
Abraços...

[4] Comentário enviado por m1ss0 em 22/08/2007 - 13:24h

Legal o artigo. Eu fiz algo parecido, mas compilei o Ruby e usei o Aptana com IDE e ficou muito bom também.

Parabéns!

[5] Comentário enviado por Ed_slacker em 23/08/2007 - 00:56h

O que mais gostei deste artigo foram duas coisas:

1) a didática dele está simplesmente perfeita;
2) não se prende aos "apt-get" da vida (que inclusive seu uso não é mais recomendado pela equipe do Debian), deixando os passos para aqueles que não usam Debian's based. Eu, por exemplo, uso Slackware (e quebrando a cabeça com o FreeBSD).

Muito bom meeeeeeeeeeeeeeeeeeeesmo!!!

[6] Comentário enviado por removido em 23/08/2007 - 10:01h

Muito obrigado à todos!

fabio, muito obrigado pelo comentário e espaço cedido. Graças à atitudes suas e de mais várias pessoas que possuem mente aberta, estamos conseguindo aos poucos convencer que contribuir é muito mais importante que competir. Valeu mesmo!

alyssonmartins, Muito obrigado cara! Esse é o 2° artigo que escrevo... acho que se eu continuar nesse ritmo, as experiências serão cada vez melhores rsrsrs.

rodrigo.capelini, esse é meu truta de guerra. Cara, começamos essa "peleja" juntos, e cada vez mais o mundo da informática nos ensina a ser profissionais competentes fissurados por máquinas e humanos com sentimento de colaboração aguçado.

m1ss0, deixou outra dica bem legal, o Aptana com Rad Rails é uma ótima pedida também! Aí vai de gosto rsrsrs. Testei esta combinação e está muito ótima, na verdade mais estável que o NetBeans que como citei no artigo é Preview (nem Beta). A versão final e estável desse PARRUDO e IMPRESSIONANTE novo NetBeans sairá no dia 28 de Novembro deste ano, se não houver atrasos. O Roadmap se encontra em: www.netbeans.org/community/releases/roadmap.html

edi_oliver, muito obrigado pelos elogios. Uma coisa que devemos ter em mente é que: "Compatibilidade é importante". Já ví muitos profissionais que QUEREM compatibilidade e ficam raivozos quando algo não funciona... mas nunca fornece algo compatível! Interessante este conceito de pensar como o "cliente", olhar com a visão de quem "precisa". O motivo de eu usar Ubuntu não quer dizer que todas as pessoas usem. Bem... enquanto todos não elegem um binário de instalação padrão como o ".package", acho de vital importância o comprometimento de informação compatível e flexível.

Bem, abraço à todos e mais uma vez, muito obrigado!

[7] Comentário enviado por IcePeak em 27/08/2007 - 21:02h

1º coisa: Para o instalador funcionar, tive q desabilitar o Beryl (uso o Debian Etch r1) :)

2º coisa: Virei teu fâ! Artigo impecável, meus parabéns! Até hoje tava caçando como instalar o RoR no Debian e só penava, e eis aqui a solução! Sem palavras para descrever! Imparcialidade total, como já disse o amigo acima! continue assim!

3º coisa: Para os interessados de plantão, uma boa IDE é o RadRails, procurem! Baseado no Eclipse! Show de bola!

Até!

[8] Comentário enviado por removido em 28/08/2007 - 11:37h

Muito obrigado IcePeak!
Olha, para o instalador funcionar sem precisar desabilitar o Beryl, execute no terminal:

export AWT_TOOLKIT=MToolkit

no mesmo terminal prossiga com a instalação.

Abraço amigo! E valeu pelo toque do instalador.

[9] Comentário enviado por h3rz1 em 11/09/2007 - 13:17h

Muito bom...
estou ancioso para testar em casas...
Valeu pela dica


Contribuir com comentário