openSUSE - As várias formas de atualizá-lo e de instalar pacotes

Este artigo sumariza, revisa e descreve quase todos os métodos conhecidos para instalar pacotes no openSUSE ou atualizar totalmente essa distribuição. Dentre esses métodos, recomenda-se aos iniciantes, principalmente o uso do YaST (clássico) e do 1-Click Install, e para os usuários experientes, o comando zypper.

[ Hits: 145.638 ]

Por: Alberto Federman Neto. em 10/03/2011 | Blog: https://ciencialivre.blog/


Usando Zypper



1) Usando Zypper em linha de comando

Zypper é um moderno e ótimo instalador de pacotes em linha de comando para o openSUSE. É a interface de comando do gerenciador de pacotes Zypp.

É rápido, poderoso, tem muitas opções e bastante fácil, mesmo ao iniciante, apesar de ser só em linha de comando. Por isso tem sido muito usado (como neste exemplo).

Como o antigo Rug (Página 9) no qual se baseia, ele usa arquivo ZMD, mas não o mantém residente nem carregado como serviço.

Em nosso exemplo, Zypper usado para instalar o muito conhecido navegador de Internet Opera.

1a) Primeiro procura-se o pacote (no caso, o Opera) com o comando:

zypper se (ou search) opera

Observe como ele acha fácil os pacotes:

zypper se opera
Carregando os dados do repositório...

S | Nome | Resumo | Tipo
--+------------+--------------------------------------+-------------
| opera | Opera Web Browser (11.00 build 1156) | pacote
| opera | Opera Web Browser (11.00 build 1156) | pacote fonte
| opera | opera security update | correção
| opera-gtk | Opera GTK engine | pacote
| opera-kde4 | Opera KDE4 engine | pacote


Agora, vamos instalar:

sudo zypper -v (ou --verbose) in (ou install) opera

Observe como o gerenciamento das dependências é perfeito, e ele instala o pacote ou atualiza o Opera:

sudo zypper -v in opera
root's password:
Detalhamento: 1
Argumentos sem opção do programa: 'opera'
Inicializando destino
Verificando se é necessário atualizar os metadados para Atualizações para openSUSE 11.3 11.3-1.82
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para NVIDIA Repository
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para NVIDIA Repository
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - GNOME:STABLE:2.30
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - GNOME:Apps
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - KDE:Extra
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - LXDE
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - Mozilla
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - Java:packages
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - Drivers para webcams
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE BuildService - XFCE
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE-11.3 11.3-1.82
Verificando se é necessário atualizar os metadados para Packman Repository
Obtendo: repomd.xml [concluído]
Verificando se é necessário atualizar os metadados para openSUSE-11.3-Non-Oss
Obtendo: content [concluído (0 B/s)]
Obtendo: media [concluído]
Verificando se é necessário atualizar os metadados para openSUSE-11.3-Oss
Obtendo: content [concluído (0 B/s)]
Obtendo: media [concluído]
Carregando os dados do repositório...
Lendo os pacotes instalados...
Forçar resolução: Não
Selecionando 'opera-11.00-1.2.1.x86_64' do repositório 'Atualizações para openSUSE 11.3 11.3-1.82' para instalação.
Resolvendo as dependências de pacote...
Forçar resolução: Não
Os seguintes pacotes NOVOS serão instalados:
opera 11.00-1.2.1
opera-gtk 11.00-1.2.1
opera-kde4 11.00-1.2.1
Os seguintes pacotes recomendados foram selecionados automaticamente:
opera-gtk 11.00-1.2.1
opera-kde4 11.00-1.2.1
3 novos pacotes a serem instalados.
Tamanho total do download: 10,4 MiB. Após a operação, 32,6 MiB adicionais serão utilizados.
Continuar? [s/n/?] (s): s
submetendo
Obtendo pacote opera-11.00-1.2.1.x86_64 (1/3), 10,4 MiB (32,4 MiB descomprimido)
Obtendo: opera-11.00-1.2.1.x86_64.rpm [concluído (227,7 KiB/s)]
Instalando: opera-11.00-1.2.1 [concluído]
Obtendo pacote opera-gtk-11.00-1.2.1.x86_64 (2/3), 40,0 KiB (112,0 KiB descomprimido)
Obtendo: opera-gtk-11.00-1.2.1.x86_64.rpm [concluído (0 B/s)]
Instalando: opera-gtk-11.00-1.2.1 [concluído]
Obtendo pacote opera-kde4-11.00-1.2.1.x86_64 (3/3), 36,0 KiB (102,0 KiB descomprimido)
Obtendo: opera-kde4-11.00-1.2.1.x86_64.rpm [concluído]
Instalando: opera-kde4-11.00-1.2.1 [concluído]
submetendoCommitResult 3 (errors 0, remaining 0, srcremaining 0, updateMessages 0)


Em um outro exemplo não usual, Zypper foi usado para instalar o pacote SMART (Pagina 7). Aconteceu que o SMART não estava nos repositórios padrão por isso, o repositório necessário especificado no comando do instalador, como pode ver:

sudo zypper sa (ou search add) -r http://download.opensuse.org/repositories/smart/openSUSE_10.3/smart.repo
sudo zypper ref smart
$ sudo zypper -v in smart


Observação: Procedimento baseado em:
1b) O Zypper é também muito útil para atualizar completamente o openSUSE.

Ele pode ser usado para adicionar os repositórios, mas isso é feito de modo mais prático, no YaST (Página 2). Se já feito, o Zypper usará os mesmos repositórios que já estão no YaST. Atualize esses repositórios usando o Zypper:

sudo zypper ref (ou refresh)

Atualizados os repos, liste e veja as atualizações possíveis:

zypper lu (ou list-updates)

Agora atualize os pacotes (isto equivale ao "apt-get update" do Ubuntu):

sudo zypper up (ou update)

Finalmente, se desejar, atualize toda a distro.

sudo zypper dup (ou dist-upgrade)

Pronto, openSUSE atualizado, como se pode ver pela saída do comando:

zypper lu
Carregando os dados do repositório...
Lendo os pacotes instalados...
Nenhuma atualização encontrada.


Fácil, não?

Em meus testes, a atualização completa do openSUSE não é arriscada para o sistema, como pode acontecer com as distros tipo Debian (desde que não Rolling Release).

De fato, uma evidência disso, este artigo está sendo escrito em openSUSE 11.3 totalmente atualizado com Zypper, inclusive com alguns pacotes do 11.4 de testes, sem nenhum problema de estabilidade.

Página anterior     Próxima página

Páginas do artigo
   1. Introdução, resumo e objetivo do artigo e instalação do openSUSE
   2. Instalar pacotes e/ou atualizar usando YaST
   3. Usando 1-Click Install
   4. Usando PackageKit e suas interfaces gráficas
   5. Usando Zypper
   6. Usando RPMs diretamente
   7. Usando SMART
   8. Usando YUM
   9. Outros métodos e maneiras de instalar pacotes
   10. Observações e conclusão
Outros artigos deste autor

Recuperação do arquivo sudoers - comandos su e sudo não funcionam mais [Resolvido]

Regulando o desktop para trabalhar em máxima performance

Emmi Linux - Uma Revisão, Primeiras Impressões e Testes

Gentoo: Interfaces gráficas para Portage/Emerge - substitutos do Kuroo

BOINC - Computação distribuída e aplicações científicas

Leitura recomendada

Como montar um pacote RPM

Garantindo o funcionamento de serviços com o restartd

Monitorando automaticamente o Docker com Zabbix

Softmodem em Linux com dois kernels

Instalando o Gaim-vv no Slackware 10

  
Comentários
[1] Comentário enviado por Fabio_Farias em 10/03/2011 - 13:36h

Excelente! Excelente! Excelente!

Um belo trabalho seu sobre essa distro Alberto.

Um guia de referência inigualável sobre o gerenciamento de pacotes no openSUSE. Como usuário (iniciante) dessa distro dou-lhe os parabéns por disponibilizar esse excelente material sobre o uso dos diversos modos de gerenciar pacotes no openSUSE.

Ficou ótimo ainda mais pela coincidência com o lançamento da nova versão do openSUSE que ocorreu hoje por volta das 12:00.

http://pt.opensuse.org

Um abraço e obrigado pelo trabalho realizado. Vai contribuir e muito para os usuários dessa distro.

Parabéns!

[2] Comentário enviado por izaias em 10/03/2011 - 15:25h

Justa referência você fez aos nossos amigos e colaboradores do openSUSE.

Complementou e enriqueceu os trabalhos sobre o openSUSE.

Ótimo trabalho!

[3] Comentário enviado por yaakov bourne em 10/03/2011 - 16:42h

Alguém sabe me informar se o OpenSuse 11.4 já tem suporte nativo a placa de rede sem fio da Realtek rtl8191SEva?
Ou ainda é preciso compilar o drive manualmente?

[4] Comentário enviado por Fabio_Farias em 10/03/2011 - 17:08h

Dê uma procurada nesse repositório e veja se tem o que você precisa:

http://download.opensuse.org/repositories/driver:/wireless/openSUSE_11.3/

Tem essa dica também:

http://oseomessias.wordpress.com/2010/12/28/instalando-a-rtl8191se-no-opensuse-11-3-do-jeito-facil/


Abraços!

[5] Comentário enviado por dbahiaz em 10/03/2011 - 18:09h

Belo trabalho, já é Favoritos!


[6] Comentário enviado por possiventura em 13/03/2011 - 10:39h

alberto, como configurar a internet no openSUSE 11.3 ( speedy ) ?
tadeu

[7] Comentário enviado por possiventura em 13/03/2011 - 10:40h

p.s. é LiveCD dp openSUSE !!!

[8] Comentário enviado por Fabio_Farias em 13/03/2011 - 20:10h

Olá amigo
Tente isso:

Pelo YaST:
Configurações da Rede > Aba opções globais > Método tradicional com o ifup. Confirme com um Ok.

De volta ao YaST > DSL > Adicionar > PPP sobre Ethernet > Ativar dispositivo durante a inicialização > Próximo > Provedores Personalizados > Novo > Nome do Provedor + Nome de Usuário + Senha > Próximo > Próximo > Ok.

Reinicie o computador e veja se conecta.

Pelo KNetworkManager:
No YaST em Configurações da Rede > Aba opções globais > Controlado pelo usuário com o NetworkManager > Ok.

Abra o KNetworkManager > Gerenciar conexões > Aba DSL > Adicionar > Nome do Serviço + Nome de Usuário + Senha. Marque a opção conectar automaticamente > Ok

Se aparecer a janela do KWallet cancele até ele desaparecer e quando puder remova ele. Eu pelo menos não gosto de usar ele para gerenciar senhas.

Reinicie o computador e veja se conectou.

Retorne para sabermos se deu certo.

Abraços!

[9] Comentário enviado por possiventura em 14/03/2011 - 03:06h

Fábio ,
muito obrigado pela dica.Estou navegando e digitando aqui do LiveCD openSUSE 11.3 GNOME.
tadeu
p.s. espero que funcione outras vezes (...não sei se aprendi direito )

[10] Comentário enviado por possiventura em 14/03/2011 - 05:17h

p.s. captura de tela ( screenshot ) para provar :
http://vivaolinux.com.br/screenshot/Gnome-consegui_openSUSE_14Mar11
Home » Screenshots » consegui_openSUSE_14Mar11

[11] Comentário enviado por albfneto em 14/03/2011 - 12:07h

ainda há outras possibilidades.
se o knetworkmanager falhar, tente com o WICD. funciona para todos os tipos de conexão, mas funciona principalmente nas wireless.

ainda, se vc configurar seu modem com roteador (rotear o modem) ou como bridge+rooter (como o meu DSLink) vai conecytar direto, pq a senha e login ficam embutidos na config do modem, deste modo, tudo vai conectar direto, qualquer Linux (inclusive do Live CD) e qualquer Windows.
também não uso Kwallet. se só voce mexe no micro, não é necessário. eu desativo em todos os meus linux.

Fábio, excesso de modéstia, vc não é um Iniciante no OpenSUSE. Inclusive, eu uso OpenSUSE, mas uso mais Sabayon do que OpenSUSE. Sabayon é a minha Distro principal.

[12] Comentário enviado por Fabio_Farias em 14/03/2011 - 13:57h

@possiventura
Obrigado pelo retorno. Que bom que deu certo. Precisando estamos aí.

@alberto
Obrigado por mostrar outras possibilidades de conexão. Eu não conhecia o wicd.
E não é excesso de modéstica não amigo, é verdade, eu sei pouco sobre o openSUSE. Mexo só na interface gráfica por isso não me arrisco em coisas complexas justamente pela falta de conhecimento e experiência nessa distro.

Seu trabalho ficou ótimo. Obrigado pela contribuição que deu aos usuários de openSUSE.

Abraços!

[13] Comentário enviado por removido em 14/03/2011 - 17:13h

Excelente artigo, parabéns!

[14] Comentário enviado por danilobs em 15/03/2011 - 20:01h

Vou testar o openSUSE...gostei muito do artigo!
Bom trabalho...

Abraço!

[15] Comentário enviado por Fabio_Farias em 15/03/2011 - 20:44h

Olá Danilo
No que precisar, se puder ajudar, conte conosco!
Abraços!

[16] Comentário enviado por albfneto em 19/03/2011 - 12:34h

COMPLEMENTOS e ATUALIZAÇÃO DO ARTIGO:

11 de Outubro de 2018.

1. PACOTES PARA OPENSUSE

Agora. anos depois, há uma outra maneira de achar pacotes para OpenSUSE. Use este Search Engine:

https://software.opensuse.org/search

1) MAIS UM JEITO DE ATUALIZAR REPOSITORIOS NO OpenSUSE:

1) Depois da publicação do artigo, encontrei mais uma maneira de atualizar os reposítórios para o OpenSUSE. Trata-se de uma Web, que automáticamente, adiciona repositórios para o OpenSUSE. Chama-se YaSTRS, o equivalente OpenSUSE do Easy URPMI (do Mandriva):

http://yastrs.hardon.co.il/index.php

2) LISTA DOS ESPELHOS OpenSUSE:

Lista dos Espelhos de OpenSUSE, contendo todos os Países, veja:

http://en.opensuse.org/openSUSE:Mirrors
http://mirrors.opensuse.org/
http://mirrors.opensuse.org/list/11.4.html

Veja também:

http://www.vivaolinux.com.br/dica/Repositorios-OpenSuSE-10.2/

3) USANDO PACOTES NOVOS

Recomendado apenas como Experimento,para usuários experientes.

Técnicamente falando, OpenSUSE não é Rolling Release,mas você pode deixar seu OpenSUSE com muitos pacotes novos
Isso pode ser feito com o comando zypper:

http://www.linux.com/learn/tutorials/225596-enhancing-opensuse-112-adding-repositories-and-packages-

ou edição manual de arquivos:

http://en.opensuse.org/Build_Service/Tips_and_Tricks#Adding_multiple_repositories_to_a_project

mas exige cuidado:

http://forums.opensuse.org/english/get-technical-help-here/applications/443275-i-ruined-my-yast-repo...

O jeito mais fácil e seguro, é abrir o Yast, como se fosse para adicionar mais repos, e ao invés disso, editar a linha de cada repositório, trocando as strings dos repos antigos pelos novos, em todos eles.

Alternativamente, edite cada arquivo da Pasta /etc/zypp/repos.d, trocando as strings .

Para facilitar, eis uma lista dos repositórios que uso:

OSS e non-OSS uso os do Brasil, UFPR.


modificados os repositórios, atualize a Distro com o YaST ou com o Zypper.

Depois abra o YaST e refine sua atualização,por exemplo removendo OpenOffice antigo etc...




[17] Comentário enviado por removido em 21/03/2011 - 20:41h

Muito bom mesmmo cara!!

Acabei de começar no openSUSE e estou lendo seu artigo.E ele está me ajudando muito a conhecer essa distro e usa-lá corretamente!!

Muito bom mesmo

+favoritos

=D

[18] Comentário enviado por possiventura em 10/08/2011 - 11:40h

fábio , no openSUSE 11.04 ( KDE e GNOME ) nõa consigo navegar na internet . pede sempre a instalação de um pacote : " linux-atm-lib " ". não sei o que fazer no 11.3 funciona tudo direito ( tanto que fix o download do 11.4 por causa dissso) . Houve alguma mudança ?
atenciosamente ,
tadeu filippini

[19] Comentário enviado por Fabio_Farias em 10/08/2011 - 12:04h

Tadeu. Você está tentando navegar através do LiveCD?

Abra um tópico novo com essa dúvida e já coloque essa informação que lhe pedi e me contate novamente.

Abraços!

[20] Comentário enviado por possiventura em 10/08/2011 - 13:27h

fábio , agora eu estou navagando através do LiveCD ..só que é do openSUSE 11.3 KDE .
funcionando bem !!!
vou abrir o tópico. obrigado pela dica. abraços.
tadeu filippini

[21] Comentário enviado por xerxeslins em 04/09/2011 - 18:58h

Que beleza de artigo! Parabéns mais uma vez! Está sendo de grande ajuda.

[22] Comentário enviado por samus em 06/07/2013 - 20:47h

olha... parabens pelo tempo e conhecimento dedicado neste material, não poderia sair do post sem pelo menos agradecer seu comprometimento.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts