Alternativas ao Flash Player no openSUSE

Com essas alternativas, é possível usar as versões mais recentes do Flash no openSUSE. As dicas são para o navegador Firefox, meu favorito, uma vez que o Google Chrome traz o Flash Player sempre atualizado, através do uso do Pepper Plugin API (PPAPI). Em todas elas deve-se remover antes o Flash Player da Adobe, para evitar conflitos.

[ Hits: 8.927 ]

Por: Fábio Farias em 18/07/2014


Instalação



Das três alternativas que testei no openSUSE 13.1, o Pipelight foi a que apresentou resultados melhores, utilizando-se da ultima versão do Flash Player e funcionando em todos os sites que visitei durante os testes.

Além disso, ele tem a vantagem de fazer funcionar não somente o Flash, mas também outros plugins, como o Silverlight.

Pipelight

Para instalar o Pipelight, adicione os seguintes repositórios:

# zypper ar --refresh http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/openSUSE_13.1/ Dark_Player
# zypper ar --refresh http://download.opensuse.org/distribution/13.1/repo/oss/suse/ Standard
# zypper ar --refresh http://download.opensuse.org/repositories/windows:/mingw:/win32/openSUSE_13.1/ Win32
# zypper ar --refresh http://download.opensuse.org/repositories/windows:/mingw:/win64/openSUSE_13.1/ Win64

E depois, execute:

# zypper in pipelight
Linux: Alternativas ao Flash Player no openSUSE   Linux: Alternativas ao Flash Player no openSUSE

Durante a instalação, será solicitada as chaves dos repositórios adicionados. Aceite-as para continuar. Após o término da instalação, execute os comandos abaixo para habilitar os plugins:

# pipelight-plugin --enable flash
# pipelight-plugin --enable silverlight

Pronto. A primeira alternativa ao Flash Player está instalada e pronta para usar.

Fresh Player

Essa é a segunda alternativa ao Flash Player para o openSUSE.

Eu a recomendo no caso de problemas com o Pipelight. Nessa parte do artigo, tive a ajuda do Xerxeslins. Para instalar o Fresh Player, execute os seguintes procedimentos:

1. Instale o Google Chrome, pois é a partir do Flash Player disponível nele, que faremos o mesmo funcionar no Firefox. Para isso, acesse a seguinte página:
2. Selecione a versão correspondente à sua arquitetura (32 ou 64 bits) e selecione para Abrir com o Instalador do Apper (Gerenciador de Pacotes) e depois disso, é só seguir os passos apresentados para instalar o navegador.

O Fresh Player necessita de algumas dependências que devem ser instaladas manualmente.

As instruções contidas no programa indicam uma lista delas, mas no openSUSE, tive que instalar algumas diferentes. Como parti de uma instalação limpa, tive que instalar algumas coisas a mais para poder compilar o pacote adequadamente.

Segue a lista do que deve ser instalado. Instale-as antes de prosseguir.

# zypper in git alsa-devel xorg-x11 gegl liburiparser-devel libconfig++-devel cairo-devel pango-devel imhangul cmake automake libxinerama-devel Mesa-libGLESv2-devel libvent-devel gtk2-devel gcc gcc-c++ nano libevent-devel
Linux: Alternativas ao Flash Player no openSUSE   Linux: Alternativas ao Flash Player no openSUSE

Feito isso, abra uma nova aba do terminal, ou mesmo uma outra instância. Desta vez, logado como usuário comum e execute os comandos abaixo:

git clone https://github.com/i-rinat/freshplayerplugin
cd freshplayerplugin
mkdir build
cd build
cmake ..
make

No meu caso, tive que criar o diretório onde vai o plugin que acabamos de compilar com o comando abaixo. Se você já possuir esse diretório, ignore esse procedimento.

cd /home/seu_nome_de_usuário/.mozilla/
mkdir plugins
cd /home/ seu_nome_de_usuário/freshplayerplugin/build/

Agora, copie o plugin para o diretório plugins do Firefox

cp libfreshwrapper* ~/.mozilla/plugins/

Acesse o diretório /home/seu_nome_de_usuário/.mozilla/plugins/ e crie um arquivo de texto com o seguinte conteúdo.

plugin_path = "/opt/google/chrome/PepperFlash/libpepflashplayer.so"


Use o nano via terminal, ou um editor de texto gráfico mesmo, se preferir. Salve-o com o nome: freshwrapper.conf

Reinicie o navegador e o Fresh Player estará pronto para ser usado.

Lightspark

Essa foi a solução que apresentou os menores resultados, pois além de utilizar uma versão antiga do Flash Player, não funcionou em todos o sites que testei.

Em todo caso, essa opção é ainda melhor que usar a versão nativa do Flash Player para GNU/Linux. É fácil de instalar e pode ser usada em caso de problemas com a opções anteriores.

Para instalar:

# zypper in lightspark-plugin
Linux: Alternativas ao Flash Player no openSUSE

E depois de instalado, reinicie o Firefox.

Instalado e pronto para usar.

Conclusão

Com as alternativas apresentadas, consegue-se obter um bom suporte a Flash no openSUSE.

Espero que, em breve, não sejamos mais reféns de softwares proprietários como esse, pois além de manter o desenvolvimento fechado, ainda deixa de lado usuários de sistemas como o Linux, não oferecendo mais novas versões do software em questão.

   

Páginas do artigo
   1. Instalação
Outros artigos deste autor

Backup com o Konserve

Convertendo Sistemas de Arquivos

Particionamento de disco (HD)

Tumbleweed, o openSUSE Rolling Release

Sistema de arquivos EXT4 no OpenSuSE 11.1

Leitura recomendada

KDEmod: Tornando mais simples o KDE do seu Arch Linux

Todos os atalhos do Cinnamon

Chakra Linux - Apresentação, instalação e configuração

Introdução ao Linux: O editor de texto Nano

Resumo LPI 102: Tópico 107 - Tarefas Administrativas

  
Comentários
[1] Comentário enviado por izaias em 18/07/2014 - 14:43h

Fábio,

O Tumbleweed tem o Pipe em seus repositórios Packman, basta um: zypper in pipelight
Veja: http://i.imgur.com/uXCZGkW.png

Viu? Mais uma vantagem do Tumbleweed. :)

[2] Comentário enviado por Fabio_Farias em 18/07/2014 - 14:54h

Você chegou a testá-lo?

Porque no repositório Packman do 13.1 tem esse pacote também mas sozinho ele não funcionou. Precisou dos outros repositórios citados para instalar a versão modificada do wine, necessário para o funcionamento do plugin.

[3] Comentário enviado por izaias em 18/07/2014 - 15:02h

Sim! Por enquanto sem o menor problema.
Removi o Flash da Adobe e instalei o Pipe agora mesmo.

Ao acessar o Youtube pela primeira vez após instalação, o Firefox pede para instalar o Flash, é só dispensar.

Acessei Youtube em 720p, 360p, etc.
Animações de sites bancários também estão funcionando sem problemas.

* Detalhe: é o repositório "packman_tumbleweed".

[4] Comentário enviado por starkiller em 18/07/2014 - 18:32h

Obrigado pelo artigo, muito bom e super necessário para iniciantes como eu.

[5] Comentário enviado por Fabio_Farias em 18/07/2014 - 21:55h

@willther
Obrigado!

[6] Comentário enviado por xerxeslins em 18/07/2014 - 21:59h

Legal :)


[7] Comentário enviado por Fabio_Farias em 18/07/2014 - 22:14h

Estranho essa questao do pipelight do packman. Aqui em nenhum site fica pedindo para instalarno flash. Teste em outros sites para verificar.

[8] Comentário enviado por Fabio_Farias em 18/07/2014 - 22:30h

Obrigado xerxes pela ajuda na parte do Fresh Player.

[9] Comentário enviado por izaias em 18/07/2014 - 23:24h


[7] Comentário enviado por Fabio_Farias em 18/07/2014 - 22:14h:

Estranho essa questao do pipelight do packman. Aqui em nenhum site fica pedindo para instalarno flash. Teste em outros sites para verificar.


Tem razão, Fábio.

Neste site de joguinhos online: http://va.mu/2jnH agora pede para instalar o plugin.
Quando instalei o Pipe hoje a tarde, estava funcionando normalmente. Reiniciei o navegador após instalar.

Agora que INICIEI o sistema, não funciona mais. Pede para instalar o plugin.

[10] Comentário enviado por Fabio_Farias em 19/07/2014 - 19:02h

Estava estranhando mesmo. Mas tudo bem. Obrigado pelo retorno!

[11] Comentário enviado por corrosiontears em 23/07/2014 - 11:36h

Já que estou por aqui gostaria de saber quais são as dependências para o Fedora ?
Alguém poderia me passar? Obrigado! E EXCELENTE dica mesmo!

[12] Comentário enviado por Fabio_Farias em 23/07/2014 - 14:47h

Para o Fedora eu não sei. Mas na pasta que você baixa do Fresh Player tem um arquivo chamado CMakeLists.txt. Lá tem uma lista das dependências necessárias. No caso do openSUSE essas dependências tem nomes diferentes, que foi as que descrevi no artigo. Eu sugiro tentar instalar e ver quais são as dependências que acusam faltar. Foi o que fiz quando instalei o Fresh Player no openSUSE.

[13] Comentário enviado por deusdara em 23/07/2014 - 20:29h


[10] Comentário enviado por Fabio_Farias em 19/07/2014 - 19:02h:

Estava estranhando mesmo. Mas tudo bem. Obrigado pelo retorno!


Olá

No Fedora veja aqui

07 Jun 2014 16:51 CEST written by Pipelight Team

Installation - Fedora

http://pipelight.net/cms/install/installation-fedora.html


[14] Comentário enviado por antoniusfarias em 27/12/2014 - 16:31h

Fábio Farias,
Ótimo artigo sobre Flash, silver, pipe no Opensuse.
Foi tiro e queda!
Até problemas no Netflix, que os próprios atendentes dizem sem solução (claro que tem, eles só não querem dar o braço a torcer), resolvi com seu artigo no Firefox e Chrome.
Obrigado.

[15] Comentário enviado por Fabio_Farias em 05/01/2015 - 09:45h

Fico feliz que tenha sido útil.

[16] Comentário enviado por dk_ em 14/01/2015 - 14:14h

Testei o Pipelight no openSUSE 13.2, e por enquanto esta normal, inclusive jogos em flash, mas para instalar segui apenas as recomendações do site

openSUSE 13.2:

openSUSE 13.2:

zypper ar --refresh http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/openSUSE_13.2/home:DarkPlayer:...

zypper ref
zypper install pipelight
pipelight-plugin --update

sudo pipelight-plugin --enable pluginname

Fonte: http://pipelight.net/cms/install/installation-opensuse.html



[17] Comentário enviado por dk_ em 17/01/2015 - 13:36h

Pessoal, duvida simples.

Quando tento remover o flash com o comando zypper rm <nome do pacote> ele tenta instalar um plugin do chromium e da erro, evitando a remoção do flash.

Como fazer para apenas remover o flash, sem tentar instalar o plugin? ?

zypper rm flash-player
Carregando os dados do repositório...
Lendo os pacotes instalados...
Resolvendo as dependências de pacote...

Os seguintes 3 pacotes NOVOS serão instalados:
chromium-pepper-flash freshplayerplugin libconfig9

O seguinte pacote será REMOVIDO:
flash-player

3 novos pacotes a serem instalados, 1 para remover.
Tamanho total do download: 4,8 MiB. Já baixado: 33,8 KiB Após a operação, 3,9 MiB será
liberado.
Continuar? [s/n/p/? exibe todas as opções] (s): s
No cache libconfig9-1.4.9-6.1.2.x86_64.rpm (1/3), 33,8 KiB ( 74,1 KiB descomprimido)
Obtendo pacote chromium-pepper-flash-16.0.0.235-2.1.x86_64
(2/3), 4,7 MiB ( 16,6 MiB descomprimido)
Obtendo: chromium-pepper-flash-16.0.0.235-2.1.x86_64.rpm ...........................[erro]
Arquivo './Essentials/x86_64/chromium-pepper-flash-16.0.0.235-2.1.x86_64.rpm' não encontrado na mídia 'http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/'

[18] Comentário enviado por Fabio_Farias em 19/01/2015 - 10:44h

Você pode bloquear os pacotes para não instalar:

# zypper al <nome do pacote>


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts