Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

49. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 11/03/2017 - 19:34h

Windows faz tempo que usa esse módulo. Muitos usuários instalavam o user agent de firefox para simular que entravam com Linux e assim, com java, no precisavam desse módulo.
O programa é uma gambiarra, não tem mais que fazer uma pesquisa no Google. Se entram na página da Gas Tecnologia em Facebook vão encontrar inúmeros comentários de usuários de Windows chateados: nunca vi tanta gente detonar com essa raiva.
Mac e Linux têm até o 31 de março para instalar o programa.
Talvez não solucione nada, mas eu já reclamei na ouvidoria do BB. O telefone é o seguinte: 0800 729 5678
Imagino que se não tem mais pessoas reclamando é porque muita gente usa o aplicativo do celular, que tem um índice de satisfação maior: na loja de google play está muito bem pontuado.


  


50. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Fernando Marroquim
fmarroquim

(usa Ubuntu)

Enviado em 11/03/2017 - 20:09h

O BB resolveu o meu problema Ubuntu 12.04 e Firefox 52
Removeu o pacote hda-bb_0.1_all.deb e substituiu pelo warsaw_64_installer.run
Foi feito
> chmod a+x warsaw_64_installer.run
>sudo ./warsaw_64_installer.run









51. link para o warsaw

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 20:42h

E qual o link para o warsaw_64_installer.run?

Eu encontrei este:
https://aur.archlinux.org/packages/warsaw/

Será que dá no Ubuntu?


52. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 11/03/2017 - 20:46h

fmarroquim escreveu:

O BB resolveu o meu problema Ubuntu 12.04 e Firefox 52
Removeu o pacote hda-bb_0.1_all.deb e substituiu pelo warsaw_64_installer.run
Foi feito
> chmod a+x warsaw_64_installer.run
>sudo ./warsaw_64_installer.run


Pode passar o passo a passo?
Onde está o warsaw_64_installer.run?




53. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 11/03/2017 - 21:05h

fmarroquim escreveu:

O BB resolveu o meu problema Ubuntu 12.04 e Firefox 52
Removeu o pacote hda-bb_0.1_all.deb e substituiu pelo warsaw_64_installer.run
Foi feito
> chmod a+x warsaw_64_installer.run
>sudo ./warsaw_64_installer.run







O BB? O suporte técnico? Ubuntu 12.04? Em abril termina o suporte. O BB pediu para instalar esse arquivo, .rum? Em Ubuntu? Não faz sentido. É o maior absurdo que já vi.




54. Funcionou

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 21:08h

Fiz os passos do fmarroquim usando o arquivo warsaw que encontrei na internet e, surpresa, funcionou. Mas não sei se isso é muito bom. Meu Ubuntu é 14.04 LTS.


55. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 11/03/2017 - 21:12h

AngelicaMaria escreveu:

fmarroquim escreveu:

O BB resolveu o meu problema Ubuntu 12.04 e Firefox 52
Removeu o pacote hda-bb_0.1_all.deb e substituiu pelo warsaw_64_installer.run
Foi feito
> chmod a+x warsaw_64_installer.run
>sudo ./warsaw_64_installer.run


Pode passar o passo a passo?
Onde está o warsaw_64_installer.run?


esse programa está na web de Gas Tecnologia, em pacote .deb, já o testei e não dá certo. Eu entrei no chat da empresa, mas como demoravam em responder, enviei a minha queixa por e-mail, mas ainda não responderam. Ele até fica instalado, mas quanto tenta acessar na conta diz que não tem instalado o módulo de segurança.



56. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 11/03/2017 - 22:30h

Não instalem o Warsaw_32_instaler.run!!! Não funciona e não encontro o jeito de desinstalá-lo. É lixo!!!!


57. Não instalem

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 22:37h

Não instalem. Eu instalei e, embora o acesso ao bb funcione, meu ubuntu ficou todo bugado. Terei de fazer uma instalação limpa.


58. Solução: Instalação manual no Ubuntu (Testei no 14 LTS)

Alexsandro
Alexbr

(usa Ubuntu)

Enviado em 12/03/2017 - 13:01h

Hoje tive o mesmo problema ao tentar acessar o Internet Banking do BB. O problema ocorre porque o FF não suporta mais o plugin Java, então é preciso instalar o Módulo de Segurança que é o Warsaw.

Infelizmente, como ocorre esses erros de dependências insatisfeitas, a instalação tem que ser feita manualmente, conforme abaixo:

Obs.: Todos os arquivos abaixo foram baixados em ~/Downloads.

1) Baixe o Yad 0.27.0-1.1 que é uma das dependências solicitadas e a única realmente necessária para programa rodar (apesar da versão abaixo ser para o Xenial, serve também para Ubuntu 14):

x64: http://packages.ubuntu.com/xenial/amd64/yad/download
x86: http://packages.ubuntu.com/xenial/i386/yad/download

1.1 - Abra o Terminal, entre no diretório onde baixou o Yad e efetue a instalação:
cd ~/Downloads
sudo dpkg -i yad_0.27.0-1.1_amd64.deb

Ou, para versão 32 bits:

sudo dpkg -i yad_0.27.0-1.1_i386.deb


2) Baixe o aplicativo hda-bb no link:
https://cloud.gastecnologia.com.br/bb/downloads/ws/hda-bb_0.1_all.deb

Obs.: Esse é o mesmo link que está disponível para download no site do BB (https://seg.bb.com.br/home.html)

2.1) Agora descompacte o arquivo hda-bb_0.1_all.deb, clicando nele com o botão direito do mouse e selecionando a opção "extrair aqui".

2.2 - Abra o Terminal e entre no subdiretório que foi descompactado:
cd ~/Downloads/hda-bb_0.1_all/usr/local/bin/

2.3 - Copie a pasta HDA_BB para /usr/local/bin
sudo cp -R HDA_BB/ /usr/local/bin

2.4 - Aplique todas as permissões na pasta HDA_BB
sudo chmod 777 -Rf /usr/local/bin/HDA_BB/

2.5 - Copie o arquivo HDA_BB.desktop para /usr/share/applications
sudo cp /usr/local/bin/HDA_BB/HDA_BB.desktop /usr/share/applications/

2.6 - Crie um link do arquivo HDA_BB em /usr/bin
sudo ln -s /usr/local/bin/HDA_BB/HDA_BB /usr/bin/hda_bb

Obs.1: Antes de abrir o aplicativo, por via das dúvidas, eu desativei o Firewall para evitar problemas de conexão.
Obs.2: Este aplicativo não é o Módulo de Segurança, o mesmo precisa ser instalado ainda.

2.7 - Abra o aplicativo hda_bb com superusuário:
sudo hda_bb

Clique em Diagnóstico >> Dependências e peça pra instalar as dependências.

Independente de ter sucesso ou não nessa etapa, siga para o próximo passo:

Obs.: Nesse aplicativo é que se deve instalar o Módulo de Segurança (Warsaw), porém, ainda que clicando em Instalar, o aplicativo fez o download e acusou a instalação do mesmo, mas na verdade o Módulo de Segurança não foi instalado. Então tive que baixar o Warsaw manualmente. Se este for seu caso, então siga para o próximo passo:


3) Baixe o Warsaw nos links:

x64: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.deb
x32: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup.deb

3.1 - Instale o Warsaw:

cd ~/Downloads
sudo dpkg -i warsaw_setup64.deb

Ou, para 32 bits:
sudo dpkg -i warsaw_setup.deb

Reinicie a máquina e ao retornar abra novamente o hda_bb (com sudo) e em Diagnóstico veja se todas as opções estão habilitadas. Em seguida tente acessar o site do BB.


59. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 12/03/2017 - 14:33h

FlaUurubuntu escreveu:

Hoje tive o mesmo problema ao tentar acessar o Internet Banking do BB. O problema ocorre porque o FF não suporta mais o plugin Java, então é preciso instalar o Módulo de Segurança que é o Warsaw.

Infelizmente, como ocorre esses erros de dependências insatisfeitas, a instalação tem que ser feita manualmente, conforme abaixo:

Obs.: Todos os arquivos abaixo foram baixados em ~/Downloads.

1) Baixe o Yad 0.27.0-1.1 que é uma das dependências solicitadas e a única realmente necessária para programa rodar (apesar da versão abaixo ser para o Xenial, serve também para Ubuntu 14):

x64: http://packages.ubuntu.com/xenial/amd64/yad/download
x86: http://packages.ubuntu.com/xenial/i386/yad/download

1.1 - Abra o Terminal, entre no diretório onde baixou o Yad e efetue a instalação:
cd ~/Downloads
sudo dpkg -i yad_0.27.0-1.1_amd64.deb

Ou, para versão 32 bits:

sudo dpkg -i yad_0.27.0-1.1_i386.deb


2) Baixe o aplicativo hda-bb no link:
https://cloud.gastecnologia.com.br/bb/downloads/ws/hda-bb_0.1_all.deb

Obs.: Esse é o mesmo link que está disponível para download no site do BB (https://seg.bb.com.br/home.html)

2.1) Agora descompacte o arquivo hda-bb_0.1_all.deb, clicando nele com o botão direito do mouse e selecionando a opção "extrair aqui".

2.2 - Abra o Terminal e entre no subdiretório que foi descompactado:
cd ~/Downloads/hda-bb_0.1_all/usr/local/bin/

2.3 - Copie a pasta HDA_BB para /usr/local/bin
sudo cp -R HDA_BB/ /usr/local/bin

2.4 - Aplique todas as permissões na pasta HDA_BB
sudo chmod 777 -Rf /usr/local/bin/HDA_BB/

2.5 - Copie o arquivo HDA_BB.desktop para /usr/share/applications
sudo cp /usr/local/bin/HDA_BB/HDA_BB.desktop /usr/share/applications/

2.6 - Crie um link do arquivo HDA_BB em /usr/bin
sudo ln -s /usr/local/bin/HDA_BB/HDA_BB /usr/bin/hda_bb

Obs.1: Antes de abrir o aplicativo, por via das dúvidas, eu desativei o Firewall para evitar problemas de conexão.
Obs.2: Este aplicativo não é o Módulo de Segurança, o mesmo precisa ser instalado ainda.

2.7 - Abra o aplicativo hda_bb com superusuário:
sudo hda_bb

Clique em Diagnóstico >> Dependências e peça pra instalar as dependências.

Independente de ter sucesso ou não nessa etapa, siga para o próximo passo:

Obs.: Nesse aplicativo é que se deve instalar o Módulo de Segurança (Warsaw), porém, ainda que clicando em Instalar, o aplicativo fez o download e acusou a instalação do mesmo, mas na verdade o Módulo de Segurança não foi instalado. Então tive que baixar o Warsaw manualmente. Se este for seu caso, então siga para o próximo passo:


3) Baixe o Warsaw nos links:

x64: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.deb
x32: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup.deb

3.1 - Instale o Warsaw:

cd ~/Downloads
sudo dpkg -i warsaw_setup64.deb

Ou, para 32 bits:
sudo dpkg -i warsaw_setup.deb

Reinicie a máquina e ao retornar abra novamente o hda_bb (com sudo) e em Diagnóstico veja se todas as opções estão habilitadas. Em seguida tente acessar o site do BB.


e pro arch?
nem aquele do aur tá funcionando...
eu postei esses dias, um tópico aqui, com umas gambiarras com o arquivo do warsaw da caixa.
em uma máquina, funcionou, nas outras, não
não sei mais o que fazer com esse maldito plugin...


60. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Alexsandro
Alexbr

(usa Ubuntu)

Enviado em 12/03/2017 - 16:27h

Oi Piu,

Vi seu tópico sobre a instalação no Arch. Acho que estão com descaso para com usuários Linux. Não tem outra explicação, todos reclamam praticamente dos mesmos problemas.

Mas lhe pergunto, no diagnóstico do seu hda_bb apresenta todas as opções ativas?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts