Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

13. Problemas de dependências

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 09/03/2017 - 09:07h

Eu estou com o mesmo problema. BB obrigou a instalar um programa desenvolvido pela GAS tecnologia, módulo warsaw. Eles colocaram um tutorial para várias distribuções Linux. Aparentemente tudo é simples.
Quando você começa, pela central de programas, encontra a primeira dificuldade, falta o programa yad. Eu o consegui no launchpad de Canonical, mas no Debiam também está disponível. Então você instala yad e tenta de novo com o módulo, mas surge um novo inconveniente: "a dependência não é contável: libdbus-1-3 > 1.9.14. Ao procurar essa livraria você encontra que ela está em estado experimental. Não dá para usar um componente em fase experimental.
É ridículo, até parece que o fornecedor do BB nem testou a solução. Yad não está no repositório oficial, então o tutorial deveria começar explicando como é que você consegue. Não tudo usuário Linux é desenvolvedor e se vira.
Além disso, eu não gosto desses programas invasivos. Tem foros onde o usuários de Windows reclamam dele e há até que usava "user agent" para simular Linux e poder usar o módulo de Java.
Eu estou esperando uma ligação do suporte técnico especializado do Banco, mas, na verdade, só pessimista, nunca resolveram nada.


  


14. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 09:17h

Uso o BB tranquilamente no Manjaro e Ubuntu, ontem e hoje mesmo. Vamos ver até quando....

No Ubuntu/Linux Mint, devem instalar o Java da Oracle pelos repositórios do site webupd8:

sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt install oracle-java8-installer


Mas lembrem-se de remover o openjdk, que é a versão open source, se a instalou antes.

Depois instalem o plugin icedtea, importante também.
Se mesmo assim não conseguirem acessar, vejam os passos dos comentários anteriores sobre o yad e como instalar o pacote .deb.

Se mesmo assim não conseguirem..... sorry!


15. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Anthon
Anthon

(usa Linux Mint)

Enviado em 09/03/2017 - 09:50h

entao. sempre usei distribuicao linux pra fazer homebanking. como nao queria ficar instalando programas por questao de tempo sempre usei o Linux mint pois o icedtea ja vem preinstalado (manjaro tb). porem com essa implementacao do modulo de segunca. o negocio ficou dificil. testei varias distribuicoes (manjaro (nao sou familiar com os comandos do arch), ubuntu, lubuntu, elementary, zorin, etc). e a unica que consegui instalar o modulo foi o Linux Mint 18.1.

baixe o aplicativo do banco do brasil hda-bb_0.1_all.deb

no terminal

sudo chmod +x hda-bb_0.1_all.deb
sudo gdebi hda-bb_0.1_all.deb


vai instalar. apos instalacao no terminal

sudo hda_bb &

vai abrir o aplicativo.

va em diagnostico . instale as dependencias primeiro.

depois selecione instalar modulo de seguranca.

se tudo ficou verde no diagnostico

http://imgur.com/a/Y69ex

depois teste no site do bb (http://seg.bb.com.br)

http://imgur.com/a/Jeqdk

espero ter ajudado


16. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 09/03/2017 - 10:05h

Eu já tinha pensado em provar com outras distribuições. Inclusive já tenho uma usb com Linux Mint 18.1. Agora, eu gostaria de saber o que é que você fez para instalar as dependências. Estão na central de programas? Tem que buscar por ai? É o yad uma dessas dependências?


17. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Anthon
Anthon

(usa Linux Mint)

Enviado em 09/03/2017 - 10:40h

Miguel G. escreveu:

Eu já tinha pensado em provar com outras distribuições. Inclusive já tenho uma usb com Linux Mint 18.1. Agora, eu gostaria de saber o que é que você fez para instalar as dependências. Estão na central de programas? Tem que buscar por ai? É o yad uma dessas dependências?


quando digita @ hda_bb &


abre o aplicativo do bb. ao clicar em diagnostico. algumas coisas estarao em vermelho pois nao esta instalado. clique primeiro nas dependencias.

tenta ai e veja se consegue






18. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 11:58h

izaias escreveu:

Mais uma tentativa:

cd ~/Downloads

sudo dpkg -i hda-bb_0.1_all.deb
sudo apt-get -f install


Feche o navegador e reabra. Veja se consegue acessar.
Aparentemente deu certo, até deu a opção s/n, coloquei s
Nos 2 comandos a tela se encheu de comandos, parecia que tinha dado tudo certo, mas não deu certo
Fechei, abri o navegador, renicializei o computador



*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************





19. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 12:12h

flaviofcjr escreveu:

Pessoal, estou com o mesmo problema....
Ontem, acessei o site do banco e fiz pagamentos por ele, sem qualquer problema.
Hoje, fui acessá-lo e diz "Erro W03", módulo de segurança desatualizado.
Baixei esse arquivo HDA aí, instalei (mesmo falando que faltava a dependência yad). Procuro ele na Dash (uso Ubuntu 16.04 LTS) e nem aparece na lista dos programas instalados (detalhe: na central de programas, ele aparece como "remover", significando que está instalado).
Mais alguém aí com esse problema?


Sim, eu, pra mim não consigo instalar....fui no site da Java (www.java.com) e acho que pode ser isso...dê uma olhada no site.
De todo modo voce pode acessar o BB pelo APP dele e acessar normalmente



20. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 12:25h

Anthon escreveu:

entao. sempre usei distribuicao linux pra fazer homebanking. como nao queria ficar instalando programas por questao de tempo sempre usei o Linux mint pois o icedtea ja vem preinstalado (manjaro tb). porem com essa implementacao do modulo de segunca. o negocio ficou dificil. testei varias distribuicoes (manjaro (nao sou familiar com os comandos do arch), ubuntu, lubuntu, elementary, zorin, etc). e a unica que consegui instalar o modulo foi o Linux Mint 18.1.

baixe o aplicativo do banco do brasil hda-bb_0.1_all.deb

no terminal

sudo chmod +x hda-bb_0.1_all.deb
sudo gdebi hda-bb_0.1_all.deb


vai instalar. apos instalacao no terminal

sudo hda_bb &

vai abrir o aplicativo.

va em diagnostico . instale as dependencias primeiro.

depois selecione instalar modulo de seguranca.

se tudo ficou verde no diagnostico

http://imgur.com/a/Y69ex

depois teste no site do bb (http://seg.bb.com.br)

http://imgur.com/a/Jeqdk

espero ter ajudado


Oi, tá dando essa msg: Dependency is not satisfiable: libdbus-1-3 (>= 1.9.14)


21. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 12:28h

Anthon escreveu:

Miguel G. escreveu:

Eu já tinha pensado em provar com outras distribuições. Inclusive já tenho uma usb com Linux Mint 18.1. Agora, eu gostaria de saber o que é que você fez para instalar as dependências. Estão na central de programas? Tem que buscar por ai? É o yad uma dessas dependências?


quando digita @ hda_bb &


abre o aplicativo do bb. ao clicar em diagnostico. algumas coisas estarao em vermelho pois nao esta instalado. clique primeiro nas dependencias.

tenta ai e veja se consegue
Oi, o aplicativo chama a Central para abrir, mas dá msg de erro








22. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 12:38h

Miguel G. escreveu:

Eu estou com o mesmo problema. BB obrigou a instalar um programa desenvolvido pela GAS tecnologia, módulo warsaw. Eles colocaram um tutorial para várias distribuções Linux. Aparentemente tudo é simples.
Quando você começa, pela central de programas, encontra a primeira dificuldade, falta o programa yad. Eu o consegui no launchpad de Canonical, mas no Debiam também está disponível. Então você instala yad e tenta de novo com o módulo, mas surge um novo inconveniente: "a dependência não é contável: libdbus-1-3 > 1.9.14. Ao procurar essa livraria você encontra que ela está em estado experimental. Não dá para usar um componente em fase experimental.
É ridículo, até parece que o fornecedor do BB nem testou a solução. Yad não está no repositório oficial, então o tutorial deveria começar explicando como é que você consegue. Não tudo usuário Linux é desenvolvedor e se vira.
Além disso, eu não gosto desses programas invasivos. Tem foros onde o usuários de Windows reclamam dele e há até que usava "user agent" para simular Linux e poder usar o módulo de Java.
Eu estou esperando uma ligação do suporte técnico especializado do Banco, mas, na verdade, só pessimista, nunca resolveram nada.


Eu te agradeceria se desse o retorno! :)
Até resolver o problema baixe o APP no celular, dá para acessar o BB normal.
Parece que houve uma mudança no Java, acesse o site e veja: www.java.com
Estou usando o Firefox 52.0
Veja: https://seg.bb.com.br/duvidas.html?question=6


23. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 09/03/2017 - 13:20h

Eu estou instalando Linux Mint para fazer testes. Mas, também provei uma live usb de Linux Mint e deu certo com o Java. Esta solução provisória vale até o 31 de março. É importante deixar a usb com o sistema original, sem mudar nada. Ela tem Firefox menor que 52, é por isso que dá certo.


24. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Anthon
Anthon

(usa Linux Mint)

Enviado em 09/03/2017 - 14:36h

AngelicaMaria escreveu:

Oi, quando dou o primeiro comando dá a msg: chmod: não é possível acessar deb, arquivo ou diretorio nao encontrado


abra um terminal e vá de root logo. testa la.

ps. sugestão, grave um linux mint 18.1 num pendrive e faça os procedimentos. quebre um pouco a cabeça até conseguir funcionar, como eu consegui. depois tente ver se funciona no ubuntu. Particularmente, acho mais seguro fazer internet banking por live cd/usb.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts