Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

73. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Fernando Marroquim
fmarroquim

(usa Ubuntu)

Enviado em 13/03/2017 - 19:10h

Prezados,
Complementando a minha mensagem anterior.
Va para o menu
systemtools>preferences>StartupApplications
desabilite o warsaw

Faça shutdown.
Religue.
Desta forma o warsaw nao eh mais ativado
mas o acesso ao BB via firefox continua OK.





  


74. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Alexsandro
Alexbr

(usa Ubuntu)

Enviado em 13/03/2017 - 20:17h

Piu escreveu:

com certeza, é um [*****] descaso...
não, ele dá como módulo não instalado, mas, está e funcionando...


Consegui instalar numa VM com Debian seguindo os passos que já havia postado na mensagem anterior e lá o hda-bb também apresenta que o Módulo e as Dependências não estão instaladas, apesar de estar tudo instalado e funcionando.

Então, para que o hda-bb passe a informação correta eu apenas editei o script hda_bb, adicionando as informações referente ao Debian, pois no mesmo só consta a configuração para as distros Ubuntu, Mint, Fedora e openSUSE.

1) Então, no primeiro campo do script com título "DISTRO_CHECK":

==DISTRO_CHECK==
BITS=$(uname -i)
if [[ $BITS != "x86_64" ]]; then
BITS="x86_32"
fi
while read LINHA; do
if [[ $LINHA == *"Ubuntu"* ]]; then
DIST=Ubuntu
break



Eu acrescentei as informação retornadas pelo comandos uname -i e cat /etc/os-release, e essa parte ficou assim:

==DISTRO_CHECK==
BITS=$(uname -i)
if [[ $BITS != "x86_64" ]] || [[ $BITS != "unknow" ]]; then
BITS="x86_32"
fi
while read LINHA; do
if [[ $LINHA == *"Ubuntu"* ]]; then
DIST=Ubuntu
break
if [[ $LINHA == *"Debian"* ]]; then
DIST=Debian
break


O "unknow" é o retorno do uname -i na VM.


2) Campo "WARSAW_CHECK":

==WARSAW_CHECK==
if [[ "$DIST" == "Ubuntu" ]] || [[ "$DIST" == "Mint" ]]; then
dpkg -l warsaw >> /dev/null
if [ "$?" = 0 ]; then
WARSAW=true
fi



Ficou assim:

 if [[ "$DIST" == "Ubuntu" ]] || [[ "$DIST" == "Mint" ]] || [[ "$DIST" == "Debian" ]]; then
dpkg -l warsaw >> /dev/null
if [ "$?" = 0 ]; then
WARSAW=true
fi


Nesse caso, para uma distro diferente do Debian e derivadas terá que substituir o comando dpkg -l por um equivalente.


3) Campo "LIB_WARSAW_CHECK":

==LIB_WARSAW_CHECK==
if [[ "$DIST_BITS" == "Ubuntu_x86_64" ]] || [[ "$DIST_BITS" == "Ubuntu_x86_32" ]] ... ; then
DEPENDS="openssl libnss3-tools libcurl3"
dpkg -l $DEPENDS &>> /dev/null
if [ "$?" = 0 ]; then
CHAVELIBNSS3=true
else
CHAVELIBNSS3=false
fi



Ficou assim:

==LIB_WARSAW_CHECK==
if [[ "$DIST_BITS" == "Ubuntu_x86_64" ]] || [[ "$DIST_BITS" == "Ubuntu_x86_32" ]] || [[ "$DIST_BITS" == "Debian_unknow" ]] || [[ "$DIST_BITS" == "Debian_x86_64" ]] || [[ "$DIST_BITS" == "Debian_x86_32" ]]; then
DEPENDS="openssl libnss3-tools libcurl3"
dpkg -l $DEPENDS &>> /dev/null
if [ "$?" = 0 ]; then
CHAVELIBNSS3=true
else
CHAVELIBNSS3=false
fi


Novamente, deverá substituir o dpkg -l pelo comando equivalente da distro diferente do Debian, bem como o nome das dependências openssl, libnss3-tools e libcurl3 pelos nomes equivalentes da distro.

Essas alterações foram suficientes para o hda-bb reconhecer a instalação do Módulo e das Dependências no Debian da VM.


75. Warsaw danifica SO

Haroldo Barbosa
marloweb

(usa Outra)

Enviado em 14/03/2017 - 10:00h

Uso Linux Mint 17.3. Com base na discussão aqui do Fórum, desinstalei o Firefox 52 e instalei o Firefox ESR. Quando acessei o site do BB, indicou cou para instalar o warsaw. Infelizmente instalei o mesmo e o SO não reinicia mais. Danificou o sistema. Não recomendo instalar.


76. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 14/03/2017 - 10:01h

Eu cheguei até o final, abro o programa hda_bb, tudo está em verde. Vou a página do BB e diz que eu tenho instalado o módulo de segurança e posso acessar à minha conta. Mas depois, quando tento acessar, não sai do canto, "aguarde, iniciando o acesso", mas sem terminar.
Eu segui o tutorial de AlexBr. Instalei o programa no Linux Mint 18.1 via gestor de programas. Abri hda_bb, cliquei em diagnóstico e esta vez, diferentemente das anteriores, as dependências estavam instaladas. Então reiniciei o computador e instalei o warsaw_setup. deb, também pelo gestor. Abri de novo o hda_bb e no diagnóstico apareceu tudo verde. Fechei, abri Firefox e tentei sem sucesso o acesso.
Ainda não atualizei a Firefox 52, em consequência, tive que desativar o icedtea para fazer a tentativa com o novo módulo de segurança. Se o ativo, acesso sem problemas pela via normal do icedtea. Também apaguei o caché e reiniciei Firefox, mas também não deu certo.


77. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Alexsandro
Alexbr

(usa Ubuntu)

Enviado em 14/03/2017 - 11:08h

Miguel G. escreveu:

Eu cheguei até o final, abro o programa hda_bb, tudo está em verde. Vou a página do BB e diz que eu tenho instalado o módulo de segurança e posso acessar à minha conta. Mas depois, quando tento acessar, não sai do canto, "aguarde, iniciando o acesso", mas sem terminar.


Miguel, vc instalou o warsaw_setup.deb correto em relação à arquitetura do seu sistema (32 ou 64 bits)?
Outra coisa, em vez de desativar o plugin IcedTea, vá no diretório de plugins do Firefox e o remova (mova-o para outro diretório como backup - se não funcionar é só copiá-lo de volta), porque pode estar havendo algum conflito entre o Warsaw e o IcedTea.


Tenta também o comando:
telnet localhost 30900 

Para ver se há comunicação com a porta utilizada pelo Websocket.


78. Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Paulo Jorge
Pjorge25

(usa Ubuntu)

Enviado em 14/03/2017 - 11:32h

Estou com este mesmo problemas, pesquisei a versão da dependência sugerido pelo BB (>=1.9.14) e não encontro, existe apenas a 1.3 que é a que já existe na minha maquina.


79. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/03/2017 - 11:34h

Pjorge25 escreveu:

Estou com este mesmo problemas, pesquisei a versão da dependência sugerido pelo BB (>=1.9.14) e não encontro, existe apenas a 1.3 que é a que já existe na minha maquina.


Gostaria de agradecer a todos que tanto se empenharam em ajudar nessa questão.
A conclusão que chego é a seguinte: se ficar o bicho pega, se correr o bicho come!!
Se não instalo fico sem acesso, se instalo posso danificar meu computador e acabar com minha privacidade!
Instalar um modulo de um banco que se mostra extremamente invasivo e que compromete teu computador, acho que não vale a pena.
No meu caso não vale a pena mesmo porque sou aposentada e o dinheiro que tenho no BB é tão pouco que não vale o risco de comprometer meu computador nem minha privacidade.
Aquela merreca que eu ganho dá pra gerenciar no APP do BB no celular...tranquilo!
Quais os motivos de um banco ter colocado um acesso que na verdade não funciona?
Ou voces acham que eles não "sabiam" da encrenca?
Talvez detonar o Linux, talvez forçar o uso do App (que é muito bom, reconheço)...um motivo existe mas...mistério!
Vai saber?!!
De todo modo, vou deixar o tópico "Não resolvido" porque ainda pode que a coisa funcione, alguém ache uma solução e poste aqui :)
Sorte é que lembrei do meu velho NetBook que estava escondido no meio do meu artesanato e lá a versão do FF está 47.0!
Estou acessando por lá, desabilitei a atualização e assim eu resolvi o problema!
Obrigada a todos, foi um bom aprendizado!
Valeu muito! :)


80. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 14/03/2017 - 12:29h

Alexbr,

Eu desinstalei o icedtea. Já não aparece entre os plugins do Mozilla.
Com relação a:

Tenta também o comando:
telnet localhost 30900 

Para ver se há comunicação com a porta utilizada pelo Websocket.


Connection closed by foreign host







81. hda_bb no lubuntu

marcio
MSP

(usa Outra)

Enviado em 14/03/2017 - 17:09h


mesma coisa:

telnet localhost 30900
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

como aparece o daemom de segurança no gerenciador de processos? (não encontrei rodando....talvez esse o problema?)




82. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Guilherme
guipsp

(usa Ubuntu)

Enviado em 14/03/2017 - 19:43h

Fui surpreendido hoje quando outra pessoa de casa tentou acessar o bankline. Lendo os relatos dos confrades decidi seguir a dica postada para reativar o plugin temporariamente http://www.omgubuntu.co.uk/2017/03/force-enable-firefox-52-npapi-support

Mas tive outro detalhe no caminho, mesmo com o plugin ativo o banco exigia a instalação do programa. Como solução instalei esse plugin https://addons.mozilla.org/pt-br/firefox/addon/user-agent-overrider/ e troquei o user agent pelo firefox 44 com apenas um clique. Aparentemente o banco está identificando a versão 52 do navegador e exigindo o método novo.

Agradeço a todos que postaram seus relatos. Ubuntu 14.04

Uma imagem de como ficou: http://imgur.com/a/cAjvY


83. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/03/2017 - 21:42h

Alexbr escreveu:

valdemar1990 escreveu:

Aparentemente funciona (não houve mensagens de erro), mas deu erro de websocket ao tentar acessar. Como não sei como se resolve isso (não tenho muita experiência), parei nesse ponto.

Num outro tópico em que discutimos sobre o warsaw aqui no VOL, chegamos à conclusão que é melhor usar o aplicativo no smartfone. Dá menos dor de cabeça... e parece ser a solução, pelo menos por enquanto.

Vamos todos ligar no SAC e na Ouvidoria do banco reclamando sobre esse assunto. Afinal, pagamos para termos soluções, e não problemas a resolver.



Olha esse link sobre uma falha de segurança no Warsaw:
https://tecnoblog.net/195255/warsaw-plugin-bancos-falha-seguranca/

E dentre os comentários, consta este que realmente é preocupante:

Devaldo Junior • 10 meses atrás

O grande problema desses plugins da GAS Tecnology é que ele não verifica as transações bancárias, eles verificam a sua vida no computador, ficando ativo durante o tempo que o computador está ligado e conectado. É colocado um driver interfaceando a placa de rede e o sistema operacional, tudo que passa pela comunicação de rede é verificado/copiado. Tudo que vc faz no computador a GAS sabe. Temos a NSA brasileira, rsrs. Fato é que, essa empresa, que é uma terceirizada, servindo a alguns bancos (como informado na matéria) sabe tudo que cada um de nós faz no computador, não apenas nas transações bancárias, mas tudo o que vc faz no computador. Dessa forma vc não está protegido, quem está protegido é o banco. Se acontecer alguma coisa em suas transações bancárias, e vc tiver um comportamento promíscuo no computador, é provável que o Banco vai dizer que a culpa é sua. Por isso, que alguns sistemas operacionais abertos, não apresentam esse problema (pelo menos por enquanto), eles fizeram um modulo meia boca, só pra autorizar as transações, o mesmo acontecia com o osx a algum tempo atrás. Eu realmente desejo tudo de mal a esses bancos e essa empresa GAS Tecnology.


Isso confirma o que o colega @homemsemnome me disse num outro tópico sobre esse "mardito" warsaw, postado na comunidade sobre Banco do Brasil.
Definitivamente, perdi toda a vontade de tentar instalar esse lixo no PC; não parece valer o risco. Vou só de smartfone mesmo...

Dei um +1 ao @guipsp pela dica do user agent.


84. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/03/2017 - 23:45h

Meu Firefox do Manjaro atualizou pra versão 52.
Acabou minha farra: http://imgur.com/a/nqeTB


Só vou usar no smart agora ou no janelas... :(


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts