Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

37. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/03/2017 - 20:57h

Miguel G. escreveu:

Eu estou com o mesmo problema. BB obrigou a instalar um programa desenvolvido pela GAS tecnologia, módulo warsaw. Eles colocaram um tutorial para várias distribuções Linux. Aparentemente tudo é simples.
Quando você começa, pela central de programas, encontra a primeira dificuldade, falta o programa yad. Eu o consegui no launchpad de Canonical, mas no Debiam também está disponível. Então você instala yad e tenta de novo com o módulo, mas surge um novo inconveniente: "a dependência não é contável: libdbus-1-3 > 1.9.14. Ao procurar essa livraria você encontra que ela está em estado experimental. Não dá para usar um componente em fase experimental.
É ridículo, até parece que o fornecedor do BB nem testou a solução. Yad não está no repositório oficial, então o tutorial deveria começar explicando como é que você consegue. Não tudo usuário Linux é desenvolvedor e se vira.
Além disso, eu não gosto desses programas invasivos. Tem foros onde o usuários de Windows reclamam dele e há até que usava "user agent" para simular Linux e poder usar o módulo de Java.
Eu estou esperando uma ligação do suporte técnico especializado do Banco, mas, na verdade, só pessimista, nunca resolveram nada.


Sim, o problema é esse, então é aguardar que o BB entre em contato com voce, depois nos repasse a solução que eles deram.
Grata




  


38. Re: Módulo de seguranca do BB: como instalar via terminal? Não consigo pela Central de Programas

Thiago Souza
Tito JP

(usa Outra)

Enviado em 10/03/2017 - 05:56h

Anthon escreveu:

entao. sempre usei distribuicao linux pra fazer homebanking. como nao queria ficar instalando programas por questao de tempo sempre usei o Linux mint pois o icedtea ja vem preinstalado (manjaro tb). porem com essa implementacao do modulo de segunca. o negocio ficou dificil. testei varias distribuicoes (manjaro (nao sou familiar com os comandos do arch), ubuntu, lubuntu, elementary, zorin, etc). e a unica que consegui instalar o modulo foi o Linux Mint 18.1.

baixe o aplicativo do banco do brasil hda-bb_0.1_all.deb

no terminal

sudo chmod +x hda-bb_0.1_all.deb
sudo gdebi hda-bb_0.1_all.deb


vai instalar. apos instalacao no terminal

sudo hda_bb &

vai abrir o aplicativo.

va em diagnostico . instale as dependencias primeiro.

depois selecione instalar modulo de seguranca.

se tudo ficou verde no diagnostico

http://imgur.com/a/Y69ex

depois teste no site do bb (http://seg.bb.com.br)

http://imgur.com/a/Jeqdk

espero ter ajudado


Fiz o cadastro no fórum para agradecer. Segui sua dica a partir de ""sudo hda_bb &"" e deu certo! uso o Lubuntu 16.04 LTS (acho que é isso).

Edit. Já estava com o arquivo deb instalado (baixei no site do bb seguindo aquele passo-a-passo)


39. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 10/03/2017 - 08:07h

Eu já fiz o procedimento de Anthon, tentei pelo menos 20 vezes, mas ainda não deu certo. O proceso avança sem problemas até a hora de instalar as dependências. Então aparece isto na terminal:

telnet: Unable to connect to remote host: Connection refused
stat: no se puede efectuar `stat' sobre '/usr/local/bin/warsaw/core': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/etc/xdg/autostart/warsaw.desktop': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/lib/warsaw/ld-linux-x86-64.so.2': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/lib/warsaw/ld-linux.so.2': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/etc/init.d/warsaw': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/etc/warsaw/local.cfg': No existe el archivo o el directorio

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.




40. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/03/2017 - 12:36h

Tito JP escreveu:

Anthon escreveu:

entao. sempre usei distribuicao linux pra fazer homebanking. como nao queria ficar instalando programas por questao de tempo sempre usei o Linux mint pois o icedtea ja vem preinstalado (manjaro tb). porem com essa implementacao do modulo de segunca. o negocio ficou dificil. testei varias distribuicoes (manjaro (nao sou familiar com os comandos do arch), ubuntu, lubuntu, elementary, zorin, etc). e a unica que consegui instalar o modulo foi o Linux Mint 18.1.

baixe o aplicativo do banco do brasil hda-bb_0.1_all.deb

no terminal

sudo chmod +x hda-bb_0.1_all.deb
sudo gdebi hda-bb_0.1_all.deb


vai instalar. apos instalacao no terminal

sudo hda_bb &

vai abrir o aplicativo.

va em diagnostico . instale as dependencias primeiro.

depois selecione instalar modulo de seguranca.

se tudo ficou verde no diagnostico

http://imgur.com/a/Y69ex

depois teste no site do bb (http://seg.bb.com.br)

http://imgur.com/a/Jeqdk

espero ter ajudado


Fiz o cadastro no fórum para agradecer. Segui sua dica a partir de ""sudo hda_bb &"" e deu certo! uso o Lubuntu 16.04 LTS (acho que é isso).

Edit. Já estava com o arquivo deb instalado (baixei no site do bb seguindo aquele passo-a-passo)


Uso Ubuntu 14.04 pra mim deu essa msg: Dependency is not satisfiable: libdbus-1-3 (>= 1.9.14)


41. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/03/2017 - 12:49h

AngelicaMaria escreveu:

O Banco do Brasil criou um novo modulo de segurança.
Depois que faço o download do programa, chama a Central para instalar, mas não instala, dá a mensagem de erro: "a dependencia não é contentável: yad (>=0.16.1)"
Uso o Ubuntu 14.04, Debian
O arquivo do BB seria: hda-bb_0.1_all.deb
Fico muito grata quem me ajudar porque não estou podendo acessar o BB!

Depois de instalar o Yad, agora está dando a msg: Dependency is not satisfiable: libdbus-1-3 (>= 1.9.14)




42. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Miguel González
Miguel G.

(usa Ubuntu)

Enviado em 10/03/2017 - 12:51h

Libdbus-1.3 > 1.9 é uma versão experimental, seria absurdo usá-la, é só para desenvolvedores por causa da sua instabilidade. Pelo enquanto, Ubuntu não tem jeito. A minha versão é 14.04 e hoje provei 16.04, mas também não deu certo. Até hoje, sou duas pessoas conseguiram neste fórum, uma com Linux Mint 18.1 e outra com Lubuntu 16.04.
Eu fiquei perto com Linux Mint 18.1, que instalei num computador velho. Cogito, se a opção do Linux Mint der certo, ter dual boot com Ubuntu e Linux Mint.
Esta manhã chamei ao SAC do BB, falei que o suporte era altamente incompetente e que não me deram o retorno que prometeram. Eu falei dos problemas que tinham outros usuários e detonei esse aplicativo (mesmo que der certo me incomoda ter esse lixo no meu computador). Vão me dar retorno em até 5 dias. Vamos ver o que é que acontece.
A minha dica é que grave por enquanto linux mint em um pendrive o use como live usb, desse modo vai poder acessar à sua conta até o 31 com o java. Espero que daqui a esse dia o problema seja resolvido.


43. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/03/2017 - 13:09h

Miguel G. escreveu:

Libdbus-1.3 > 1.9 é uma versão experimental, seria absurdo usá-la, é só para desenvolvedores por causa da sua instabilidade. Pelo enquanto, Ubuntu não tem jeito. A minha versão é 14.04 e hoje provei 16.04, mas também não deu certo. Até hoje, sou duas pessoas conseguiram neste fórum, uma com Linux Mint 18.1 e outra com Lubuntu 16.04.
Eu fiquei perto com Linux Mint 18.1, que instalei num computador velho. Cogito, se a opção do Linux Mint der certo, ter dual boot com Ubuntu e Linux Mint.
Esta manhã chamei ao SAC do BB, falei que o suporte era altamente incompetente e que não me deram o retorno que prometeram. Eu falei dos problemas que tinham outros usuários e detonei esse aplicativo (mesmo que der certo me incomoda ter esse lixo no meu computador). Vão me dar retorno em até 5 dias. Vamos ver o que é que acontece.
A minha dica é que grave por enquanto linux mint em um pendrive o use como live usb, desse modo vai poder acessar à sua conta até o 31 com o java. Espero que daqui a esse dia o problema seja resolvido.


Certo, aguardamos o retorno do suporte do BB com a solução.
Creio que isso talvez tenha sido feito de propósito, para detonar o Linux.
Se possível nos diga a solução do BB aqui no fórum,grata :)



44. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 11/03/2017 - 11:36h

Marcando para acompanhar o tópico.


45. Mesmíssimo problema

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 12:46h

Estou exatamente no mesmo ponto que o Miguel. Encontrei um repositório do yad aqui:

https://www.vivaolinux.com.br/artigo/Yad-016-Eu-quero-sempre-mais-de-ti

Instalar o Yad foi barbada, foi instalada a versão yad 0.38.2-1~webupd8~trusty0. Mas ao instalar na linha de comando obtenho novas dependencias:

A preparar para desempacotar hda-bb_0.1_all.deb ...
A descompactar hda-bb (0.1-0ubuntu1.16.10.1330) ...
dpkg: problemas com dependências impedem a configuração de hda-bb:
hda-bb depende de libdbus-1-3 (>= 1.9.14); porém:
Versão de libdbus-1-3:amd64 no sistema é 1.6.18-0ubuntu4.5.
hda-bb depende de libfontconfig1 (>= 2.11.94); porém:
Versão de libfontconfig1:amd64 no sistema é 2.11.0-0ubuntu4.2.
hda-bb depende de libglib2.0-0 (>= 2.41.1); porém:
Versão de libglib2.0-0:amd64 no sistema é 2.40.2-0ubuntu1.
hda-bb depende de libstdc++6 (>= 5.2); porém:
Versão de libstdc++6:amd64 no sistema é 4.8.4-2ubuntu1~14.04.3.

Estou aguardando ligação do suporte técnico, mas já percebi que vai ser um rabo de foguete isso.



Mas


46. Sobre o Java no Firefox....

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 15:15h

A propósito, de fato essa coisa toda tem a ver com o fato de que o suporte a plugins do Java foi interrompido a partir do Firefox 52. Então me parece que o BB foi obrigado a preparar às pressas uma solução tosca.


47. Duas maneiras de fazer o Java funcionar no Firefox 52

Rogério Nunes Wolff
rogeriowolff

(usa Ubuntu)

Enviado em 11/03/2017 - 15:26h

Neste link há duas maneiras de fazer o Java funcionar, eu ainda não as testei. Pode ser que aí o site do BB "veja" o Java e aceite a solução antiga.

http://www.omgubuntu.co.uk/2017/03/force-enable-firefox-52-npapi-support


48. Re: Módulo de seguranca do BB: como instalar via terminal? [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 11/03/2017 - 15:31h

rogeriowolff escreveu:

A propósito, de fato essa coisa toda tem a ver com o fato de que o suporte a plugins do Java foi interrompido a partir do Firefox 52. Então me parece que o BB foi obrigado a preparar às pressas uma solução tosca.



No Manjaro, o FF ainda está na versão 51. Por isso que consigo acessar normalmente aqui.

Mas então, como farão os bancos? Não está na hora deles reverem outra forma de validação sem esse ultrapassado plugin?
Como fazem então quem usa o Safari ou o próprio FF no Mac OS ????

Outra coisa, até o Edge, navegador padrão do Win10, pede para abrir o Internet Explorer.
Absurdo!!!


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts