Testando o novo Firefox (Minefield) e compatibilizando quase todas as extensões

Publicado por Alberto Federman Neto. em 13/12/2007

[ Hits: 12.483 ]

Blog: https://ciencialivre.blog/

 


Testando o novo Firefox (Minefield) e compatibilizando quase todas as extensões



O excelente navegador Firefox é atualmente, o principal navegador em Linux e tem um número crescente de usuários em Windows.

A dica abaixo, aplica-se às duas versões, Windows e Linux.

Há alguns artigos e dicas mostrando como instalar extensões ("Add-Ons") e temas em Firefox.

Exemplos:
O que ocorre, é que nas últimas versões oficiais disponibilizadas em português do Brasil, 2.0.0.10 e 2.0.0.11, muitas das extensões não são instaláveis porque são consideradas pelo sistema incompatíveis. Isto, porém, geralmente ocorre porque o desenvolvedor da extensão só a compatibilizou até a última versão do Firefox para a qual a testou.

Muitas extensões, aparentemente incompatíveis, podem, na verdade, não serem!

Vocês conhecem o Minefield? É o nome do Firefox 3.0, atualmente experimental e a ser lançado dentro de um ano aproximadamente.

A Fundação Mozilla permite os testes livres, públicos e gratuitos do Minefield e de outros aplicativos Mozilla.

Estou testando o Minefield. Está atualmente na versão 3.0 beta 2, e novos "builds" são lançados semanalmente, contendo expansões de recursos, mas os betas são suficientemente estáveis para serem utilizados como navegador de rotina, sendo inclusive mais rápidos e com mais recursos que as atuais versões do Firefox 2.

Desejando testar, acesse o link:
E baixe o Minefield para Linux e/ou para Windows (no momento, disponíveis somente versões em inglês EUA).

Compatibilizando quase todas as extensões, em Minefield e Firefox:

Há três métodos principais para fazê-lo:

1) Abra o Minefield, ou o Firefox e digite no campo da URL, como se fosse um endereço de rede:

about:config

Veja a mensagem de segurança, e abra o configurador.

Clique com o botão direito do mouse, em algum local vazio da tela.

Escolha "New", escolha "Boolean"

Digite (ou copie e cole):

extensions.checkCompatibility

E escolha a expressão booleana "false".

A linha vai ficar assim:

Name = extensions.checkCompatibility
Status = user set, ou em algumas versões de Firefox, em português, "modificado"
type = boolean
value = false

Feche e reinicie o navegador. Agora, a checagem de compatibilidade estará desativada. Você pode instalar todas as extensões que quiser:
2) O segundo método é instalar uma extensão especial, feita para uso de desenvolvedores e testadores beta Mozilla, chamada "Nightly Tester Tools". Dentre suas opções de configuração, entre outras coisas, ela permite desativar a verificação de compatibilidade.

3) O terceiro método é menos recomendado, por ser mais trabalhoso e delicado. Ele se baseia na expansão total da extensão comprimida, edição do arquivo "install.rdf", e recompressão ou recompilação da extensão. Desejando utilizar este método veja:
Compatibilizadas pelos métodos acima, quase todas as extensões vão funcionar.

Nos poucos casos em que não funcionarem, você pode perder o acesso ao Firefox, não conseguirá abrí-lo, mas há uma solução para isso.

Inicie o Firefox em modo de segurança. Desse modo, todas as extensões são desabilitadas, e é só remover a extensão que causou o problema, em: "Ferramentas" -> "Add-Ons".

Entretanto, com o Minefield, até agora somente encontrei uma extensão que não funcionou, nas mais de 20 que testei!

Outras dicas deste autor

MLDonkey - Um cliente P2P para várias redes e para compartilhamento direto

Onde achar pacotes e distribuições antigas

Sabayon Linux: Entropy sem espaço temporário para atualizar [Resolvido]

Diminuindo tamanho de imagens (truques simples)

Instalando webcams simples em Linux

Leitura recomendada

Baixando arquivos com parênteses ")(" com o wget

Instalando o Mercury (cliente MSN)

Instalando placa wireless RTL8185 no Debian Sarge 3.1

Placa de rede wireless Realtek RTL8187B no Debian Linux

IPv4 - Internet e o esgotamento dos números IP

  

Comentários
[1] Comentário enviado por Hqxriven em 16/12/2007 - 02:21h

Valeu amigo, agora vou poder testar as novas versões!!!

[2] Comentário enviado por caarlos0 em 20/12/2007 - 13:59h

valeuuuu caraaaaaaaaa!!!!!!!!

eu não conceguia instalar o flash-plugin no firefox 2.0.0.11 nem a pau!
fiz isso aí e deu certo!!!

abração!!
;DDD

[3] Comentário enviado por albertguedes em 30/04/2008 - 18:42h

E aí meu chará ? : )
Realmente sua dica é muito boa. Usei aqui no beta 5 do firefox 3.0 e tudo funcionou legal.
Valeu mesmo.

[4] Comentário enviado por alexffox em 01/05/2008 - 20:29h

conseguiu utilizar a extensão tab mix plus no fire 3b5
essa mesmo alterando o arq. install.rdf ela aparece porem não funciona!!
se tiver alguma dica ....

[5] Comentário enviado por albertguedes em 01/05/2008 - 21:52h

Essas extensão não usei não.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts