Configurando Placa Wireless Broadcom BCM43142 no SlackWare 14.2

Saudações à todos os usuários Slackers que não desistem nunca desse pinguim que toma um pouco do seu tempo no início, mas que te ensina muito no final: SlackWare! Neste artigo veremos os procedimentos para configuração da placa wireless Broadcom BCM43142.

[ Hits: 7.541 ]

Por: lindberg em 03/03/2017


Dúvidas e considerações finais



Ao final do último comando, o Wireless estará instalando, mas não ativo. Como, no momento da instalação, não sabia o comando para fazer funcionar a placa de rede wireless, reiniciei o notebook e, pela primeira vez, todas as redes Wireless disponíveis foram detectadas, sem haver necessidade de configurações posteriores.
Antes de tentar estes procedimentos, eu havia testado vários outros comandos, como por exemplo a dica do "lcavalheiro" no tópico:
e do Carlos Morimoto (saudosas lembranças do tão amado Kurumim...) no link:
Então, se algum destes comandos dos links consultados fizeram com que, ao final do meu procedimento aqui descrito, a minha Wireless viesse a "funfar", eu simplesmente não sei. Só sei que o procedimento por mim realizado e aqui descrito foi o que realmente fez com que a minha placa fosse, finalmente, instalada.

Fico muito feliz se este artigo ajudar alguém com o mesmo problema, porque sinceramente, estou muito feliz por, depois de quase 10 anos, poder voltar a usar o Slack novamente.

Feel like a boy...

Abraço a todos os Slackers e vaqueiros de GNUs... :)

Página anterior    

Páginas do artigo
   1. Usando o SlackBuild
   2. Instalação e correções
   3. Dúvidas e considerações finais
Outros artigos deste autor

Instalação do winmodem HSP56 Pctel no Slackware

Atualizando sua versão Slackware - upgrade de pacotes

Instalando e Configurando o Modem HSP56 MicroModem no RedHat 9.0

Empacotando e Instalando a versão 7.0 (alfa) do LibreOffice no SlackWare Current

"Usando" 2 Slackwares instalados no mesmo HD - O problema: vmlinuz

Leitura recomendada

NET Virtua, Bloqueio de DNS, SmartTVs, Netflix e Youtube, uma mistura explosiva

Sincronizando Bases OpenLDAP e Active Directory

A ferramenta Nagios aplicada a IPv6

icinga no Ubuntu 13.10 - Instalação e configuração

Roubando bits - Receita para cálculo de sub-redes

  
Comentários
[1] Comentário enviado por pingulin em 03/03/2017 - 15:27h

mano, enquanto eu executava o slackbuild o compilador retornou uma pancada de erros e finalizou assim:

23.271/src/wl/sys/wl_cfg80211_hybrid.o' failed
make[1]: *** [/tmp/SBo/broadcom-sta-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
Makefile:1490: recipe for target '_module_/tmp/SBo/broadcom-sta-6.30.223.271' failed
make: *** [_module_/tmp/SBo/broadcom-sta-6.30.223.271] Error 2
make: Leaving directory '/usr/src/linux-4.9.12'

eu tinha atualizado o kernel pro 4.9, pode ser isso?

[2] Comentário enviado por lindbergluiz em 04/03/2017 - 00:48h


[1] Comentário enviado por mateusrg em 03/03/2017 - 15:27h

mano, enquanto eu executava o slackbuild o compilador retornou uma pancada de erros e finalizou assim:

23.271/src/wl/sys/wl_cfg80211_hybrid.o' failed
make[1]: *** [/tmp/SBo/broadcom-sta-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
Makefile:1490: recipe for target '_module_/tmp/SBo/broadcom-sta-6.30.223.271' failed
make: *** [_module_/tmp/SBo/broadcom-sta-6.30.223.271] Error 2
make: Leaving directory '/usr/src/linux-4.9.12'

eu tinha atualizado o kernel pro 4.9, pode ser isso?


mateus,

vc corrigiu o nome do README, como no artigo? Realmente, fiz esse procedimento no 4.4.14. Não quero me precipitar e responder que foi porque vc atualizou o kernel. Confira se vc baixou 32 ou 64bits...

[3] Comentário enviado por pingulin em 04/03/2017 - 01:27h

olá, eu acabei reinstalando o slack e consegui fazer o procedimento normalmente, ele ainda nao reconhece nenhuma rede wireless mas pelo menos ja reconhece a interface. darei uma fuçada aqui e se resolver eu aviso. Se tiver mais algum toque pra me dar sobre isso ficarei grato.

PS: eu fiquei espantado com a coincidência de brotar uma postagem sobre o problema que estive tentando resolver nos ultimos dias kkkk, nao sei pq a bcm43142 eh tao problematica assim.

[4] Comentário enviado por lindbergluiz em 05/03/2017 - 01:11h

oi Mateus,

De fato, não penso que o problema seja com a broadcom, mas porque realmente algumas coisas, senão várias, precisam ser configuradas manualmente no slack. Se não for assim, não é slackware :)

ps. to com um problema não resolvido do rc.local que acho também que, se eu quiser resolver, preciso reinstalar o slack. Pensando.... :/

[5] Comentário enviado por lindbergluiz em 06/03/2017 - 15:13h


[3] Comentário enviado por mateusrg em 04/03/2017 - 01:27h

olá, eu acabei reinstalando o slack e consegui fazer o procedimento normalmente, ele ainda nao reconhece nenhuma rede wireless mas pelo menos ja reconhece a interface. darei uma fuçada aqui e se resolver eu aviso. Se tiver mais algum toque pra me dar sobre isso ficarei grato.

PS: eu fiquei espantado com a coincidência de brotar uma postagem sobre o problema que estive tentando resolver nos ultimos dias kkkk, nao sei pq a bcm43142 eh tao problematica assim.


Quando resolver, não esqueça de postar aqui.

[6] Comentário enviado por pingulin em 07/03/2017 - 17:05h

resolvido, problema duplo: gateway e dns.

1 - Primeiro no arquivo /etc/rc.d/rc.inet1.conf botei a linha GATEWAY="192.168.25.1", eh claro que isso depende da configuração do seu roteador (geralmente eh 192.168.0.1). Esse erro rola pq no arquivo /etc/rc.d/rc.inet1, na hora de definir o roteador ele puxa essa variável ($GATEWAY) do arquivo de configuração que, por padrão, vem vazia, então, quando o programa inicia ela não vai definir o roteador, apesar de conseguir conectar ao gateway tranquilamente (basta testar: $ ping 192.168.25.1). Por final eu reiniciei a interface de rede: # /etc/rc.d/rc.inet1 restart.

2 - Esse segundo problema eh o mais estupido possível, o arquivo /etc/rc.d/rc.bind estava sem permissão de execução, dessa forma, sem o servidor dns definido, so eh possível conectar aos sites pelo ip. Após dar um # chmod +x /etc/rc.d/rc.bind; /etc/rc.d/rc.bind start, consegui conectar tranquilamente.

Nao bastava eu ter sido premiado por estar com a maldita bcm43142, tinha que vir mais esses problemas de brinde. kkk


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts