Configurando Placa Wireless Broadcom BCM43142 no SlackWare 14.2

Saudações à todos os usuários Slackers que não desistem nunca desse pinguim que toma um pouco do seu tempo no início, mas que te ensina muito no final: SlackWare! Neste artigo veremos os procedimentos para configuração da placa wireless Broadcom BCM43142.

[ Hits: 7.542 ]

Por: lindberg em 03/03/2017


Instalação e correções



No terminal, descompactei o pacote do SlackBuild broadcom-sta.tar.gz:

# tar -zxvf broadcom-sta.tar.gz

e movi o pacote do driver para a pasta criada:

# mv hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz broadcom-sta

A intenção aqui é converter o pacote do driver de .tar.gz para .tgz, que é instalável pelo Slackware.

Na pasta criada,

# cd broadcom-sta

é necessário fazer com que o arquivo broadcom-sta.SlackBuild seja executável:

# chmod +x broadcom-sta.SlackBuild

Após isso, executei o mesmo:

# ./broadcom-sta.SlackBuild

O que me retornou uma mensagem de erro devido o arquivo README estar nomeado diferente do requisitado pelo SlackBuild (README_6.30.223.271.txt). Para corrigir o problema, basta renomear o arquivo que se encontra dentro da pasta atual para o nome sugerido (README_6.30.223.271.txt), ou o nome que apareça no fim da mensagem de erro, caso este artigo se aplique à outras versões/drivers etc.

Após isso, rodei o comando anterior novamente:

# ./broadcom-sta.SlackBuild

que agora, com sucesso, criou o pacote de instalação para o Slackware na pasta /tmp (chamado hybrid-v35_64-nodebug-pcoem-6_30_223_271.tgz).

Não sendo necessário ir até a pasta, basta dar o comando de instalação diretamente para o diretório /tmp:

# installpkg /tmp/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tgz

O que irei descrever a seguir pode ajudar, caso, depois de tudo realizado, não tenha dado certo para você.

Página anterior     Próxima página

Páginas do artigo
   1. Usando o SlackBuild
   2. Instalação e correções
   3. Dúvidas e considerações finais
Outros artigos deste autor

Metodologia LFS - Contruindo seu Linux do zero

Instalando e Configurando o Modem HSP56 MicroModem no RedHat 9.0

Instalação do winmodem HSP56 Pctel no Slackware

Empacotando e Instalando a versão 7.0 (alfa) do LibreOffice no SlackWare Current

Atualizando sua versão Slackware - upgrade de pacotes

Leitura recomendada

Zabbix Server 2.0 no CentOS - Instalação e configuração

Roubando bits (parte 2): como resolver questões rapidamente sem calculadora

WebHTB - Controle de banda de internet

Configuração de serviço do Nagios para monitorar o APT do Ubuntu

Instalando o oVirt 4.3 Single Host

  
Comentários
[1] Comentário enviado por pingulin em 03/03/2017 - 15:27h

mano, enquanto eu executava o slackbuild o compilador retornou uma pancada de erros e finalizou assim:

23.271/src/wl/sys/wl_cfg80211_hybrid.o' failed
make[1]: *** [/tmp/SBo/broadcom-sta-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
Makefile:1490: recipe for target '_module_/tmp/SBo/broadcom-sta-6.30.223.271' failed
make: *** [_module_/tmp/SBo/broadcom-sta-6.30.223.271] Error 2
make: Leaving directory '/usr/src/linux-4.9.12'

eu tinha atualizado o kernel pro 4.9, pode ser isso?

[2] Comentário enviado por lindbergluiz em 04/03/2017 - 00:48h


[1] Comentário enviado por mateusrg em 03/03/2017 - 15:27h

mano, enquanto eu executava o slackbuild o compilador retornou uma pancada de erros e finalizou assim:

23.271/src/wl/sys/wl_cfg80211_hybrid.o' failed
make[1]: *** [/tmp/SBo/broadcom-sta-6.30.223.271/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
Makefile:1490: recipe for target '_module_/tmp/SBo/broadcom-sta-6.30.223.271' failed
make: *** [_module_/tmp/SBo/broadcom-sta-6.30.223.271] Error 2
make: Leaving directory '/usr/src/linux-4.9.12'

eu tinha atualizado o kernel pro 4.9, pode ser isso?


mateus,

vc corrigiu o nome do README, como no artigo? Realmente, fiz esse procedimento no 4.4.14. Não quero me precipitar e responder que foi porque vc atualizou o kernel. Confira se vc baixou 32 ou 64bits...

[3] Comentário enviado por pingulin em 04/03/2017 - 01:27h

olá, eu acabei reinstalando o slack e consegui fazer o procedimento normalmente, ele ainda nao reconhece nenhuma rede wireless mas pelo menos ja reconhece a interface. darei uma fuçada aqui e se resolver eu aviso. Se tiver mais algum toque pra me dar sobre isso ficarei grato.

PS: eu fiquei espantado com a coincidência de brotar uma postagem sobre o problema que estive tentando resolver nos ultimos dias kkkk, nao sei pq a bcm43142 eh tao problematica assim.

[4] Comentário enviado por lindbergluiz em 05/03/2017 - 01:11h

oi Mateus,

De fato, não penso que o problema seja com a broadcom, mas porque realmente algumas coisas, senão várias, precisam ser configuradas manualmente no slack. Se não for assim, não é slackware :)

ps. to com um problema não resolvido do rc.local que acho também que, se eu quiser resolver, preciso reinstalar o slack. Pensando.... :/

[5] Comentário enviado por lindbergluiz em 06/03/2017 - 15:13h


[3] Comentário enviado por mateusrg em 04/03/2017 - 01:27h

olá, eu acabei reinstalando o slack e consegui fazer o procedimento normalmente, ele ainda nao reconhece nenhuma rede wireless mas pelo menos ja reconhece a interface. darei uma fuçada aqui e se resolver eu aviso. Se tiver mais algum toque pra me dar sobre isso ficarei grato.

PS: eu fiquei espantado com a coincidência de brotar uma postagem sobre o problema que estive tentando resolver nos ultimos dias kkkk, nao sei pq a bcm43142 eh tao problematica assim.


Quando resolver, não esqueça de postar aqui.

[6] Comentário enviado por pingulin em 07/03/2017 - 17:05h

resolvido, problema duplo: gateway e dns.

1 - Primeiro no arquivo /etc/rc.d/rc.inet1.conf botei a linha GATEWAY="192.168.25.1", eh claro que isso depende da configuração do seu roteador (geralmente eh 192.168.0.1). Esse erro rola pq no arquivo /etc/rc.d/rc.inet1, na hora de definir o roteador ele puxa essa variável ($GATEWAY) do arquivo de configuração que, por padrão, vem vazia, então, quando o programa inicia ela não vai definir o roteador, apesar de conseguir conectar ao gateway tranquilamente (basta testar: $ ping 192.168.25.1). Por final eu reiniciei a interface de rede: # /etc/rc.d/rc.inet1 restart.

2 - Esse segundo problema eh o mais estupido possível, o arquivo /etc/rc.d/rc.bind estava sem permissão de execução, dessa forma, sem o servidor dns definido, so eh possível conectar aos sites pelo ip. Após dar um # chmod +x /etc/rc.d/rc.bind; /etc/rc.d/rc.bind start, consegui conectar tranquilamente.

Nao bastava eu ter sido premiado por estar com a maldita bcm43142, tinha que vir mais esses problemas de brinde. kkk


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts