Compiz no Debian Etch

Instalar o Compiz em um Debian Etch (stable) pode ser uma missão chata devido ao sistema ser mais voltado para o uso em servidores. Nesse artigo pretendo facilitar o instalação e também a execução do Compiz neste sistema.

[ Hits: 52.293 ]

Por: Perfil removido em 24/01/2008


Verificando a aceleração 3d



Todos os procedimentos foram testados em um micro com essa configuração:
  • Pentium 4(2.8ghz)
  • 2 gb de ram
  • hd 80 gb
  • Placa de vídeo, GeForce FX 5500

Vamos verificar a aceleração:

# glxinfo | grep direct

Caso não exista:

# apt-get install mesa-utils

Rode o comando de novo, se a resposta for:

direct rendering: Yes

Tudo ok.
Se for diferente, tente instalar a aceleração 3d por esse artigo:
    Próxima página

Páginas do artigo
   1. Verificando a aceleração 3d
   2. Instalando o Compiz
   3. Configurando o X
   4. Instalando o CCSM (menu do Compiz)
   5. Considerações finais
Outros artigos deste autor

A camada de enlace de dados

Restaurando o LILO com o Slackware 9.1 (HOWTO)

A importância de um backup

Instalação e configuração do Ubuntu Gusty Gibbon na linha de notebooks HP/Compaq

Apollon no Conectiva Linux 10

Leitura recomendada

Convertendo de AVI para AMV nativamente

Anima Beat

Exiv2 - Manipulando Metadados de Arquivos de Imagens

Quando o rosto vira espelho

Publicidade e software LIVRE? De novo?

  
Comentários
[1] Comentário enviado por walber em 24/01/2008 - 13:08h

Muito bom o artigo, irei testar e depois posto o resultado.

[2] Comentário enviado por removido em 24/01/2008 - 19:19h

vlw........
qualquer coisa estamos aí !!!!!!!!!!!!!!!!!!!!!

[3] Comentário enviado por dbahiaz em 24/01/2008 - 21:05h

Boa eu!noel, funfou de prima...cliente satisfeito! Abraço.

[4] Comentário enviado por removido em 24/01/2008 - 21:08h

vlw.............
vc não sabe a satisfação que isso me deu !!!!!!!!!!
eu amo ajudar quem quer ser ajudado!!!!!!!!

[5] Comentário enviado por dbahiaz em 25/01/2008 - 00:49h

Cara, a um tempão estava tentando colocar o etch pra rodar o compiz-fusion, mais os artigos que vi usavam repositorios do lenny, e tinha medo de quebrar o sistema, intao , acabava desistindo de instalar,e usava o compiz que vem padrão, mais agora ta de boa mesmo.

Só acrescentando...no artigo o
comando pra parar o compiz-manager é

metacity --replace &

vlw!

[6] Comentário enviado por removido em 25/01/2008 - 11:37h

obrigado fique a vontade para melhorar o que achar que deve !!!!!!!!!!
infelizmente não uso mais o Debian eu uso o Slackware agora mais espero que possa ajudar mais gente !!!!!!!!!!!!!!
obirgado vlw..............

[7] Comentário enviado por maran em 25/01/2008 - 22:32h

o maravilha em....
fico feliz de saber que esta se dando bem com o Debian.. isso ae meu velho, espero que venham muitos outros artigos envolvendo o debian principalmente, isso ae cara
se cuida

Te Mais...

[8] Comentário enviado por percival em 27/01/2008 - 14:50h

Boa dica...

Funcionou perfeitamente aqui, com exceção do CCSM quie rodou de primeira, sem precisar alterar nada...

Só uma dúvida: e seu eu não quiser o EMERALD? Tem como deixar o Etch com a cara padrão, mas com os efeitos do Compiz?

Abraço.

[9] Comentário enviado por edsoncsouza em 24/03/2008 - 12:04h

Olá
Já está tudo feito na minha maquina do jeito que está no tutorial
no arquivo ccsm ta assim
if gtk.pygtk_version < (2,8,0):
print "PyGtk 2.80.0 or later required"
e os outros com os comentarios nos lugares certos porem ja reiniciei a maquina e não tive resultados o ccsm ainda não funciona
testei em um script do python o que estava retornando o comando "print gtk.pygtk_version" e ele me retornou (2,8,6)
pelo pouco que entendo de python isso deveria funcionar pois o script soh irá funcionar caso a versão for menor que 2,8,0.
Agradeço a ajuda de vocês

[10] Comentário enviado por removido em 19/05/2008 - 23:21h

?comentario= Boa noite...

Primeiramente gostaria de agradeçer pelo otimo artigo ...

nota 1000 velho... valeu mesmo...

como nosso amigo edsoncsouza...

eu tambem to com problema.. comentei todas as linhas mandadas.. e reiniciei porem ainda ta voltando o erro

Info: No sexy-python package found, don't worry it's optional.
PyGtk 2.10.0 or later required

ao execultar o ccsm

se poder ajudar... agradeço

flw

[11] Comentário enviado por removido em 20/05/2008 - 14:40h

os repositórios mudaram desde que escrevi o artigo,
tb não uso mais o Debian,
e não sei mais se ele usa o PyGtk 2.8 .

[12] Comentário enviado por jaca69 em 23/05/2008 - 17:52h

Meu, só consegui fazer o compiz funcionar com uma placa ATI com a novo versão do driver randeon (x1300 é a minha) que foi disponibilizado na semana passada.
Porém, quando vou assistir um video ele fica piscando, sabes dizer o por quê?
O restante dos efeitos estão ok.

PS: Estou usando o Debian Lenny

[13] Comentário enviado por evaldo1 em 05/08/2008 - 02:58h

Caro 'noel,
Sofri um bucado com esse negõcio, mas foi muito divertido e instrutivo também. Realmente, algumas coisas mudaram desde que o artigo foi postado, mas só mudou para melhor e o artigo continua sendo utilíssimo. Os efeitos estão lindos e tudo roda que é uma beleza.
Valeu, amigo!!
Ah, e quanto àquele papo de que o Debian não é pra iniciantes, ahahah, sou uma exceção.

[14] Comentário enviado por femars em 26/02/2009 - 22:23h

olha soh, comigo deu erro ao tentar logo no comando do compiz-manager:

xico@A1200:~$ compiz-manager
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity

Aqui uso o Debian4 Etch com GeForce2 mx 400 64mb, o driver está instalado. O que vc acha que está acontecendo?

[15] Comentário enviado por nocyvo em 23/04/2009 - 23:02h

Opa....
consegui 90% do tuto
Mas não consigo ativar os efeitos
entro na janela do ccsm mas o efeito não roda
Sabe oq pode ser?



vlw


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts