VirtualBox: VERR_SUPLIB_OWNER_NOT_ROOT VMMR0.r0

Publicado por Wilker Azevedo em 23/05/2011

[ Hits: 9.463 ]

 


VirtualBox: VERR_SUPLIB_OWNER_NOT_ROOT VMMR0.r0



Para aqueles que estão enfrentando esse problema no VirtualBox vai aqui a dica...

Estou utilizando a versão 4.0.6 r71433, mas o bug acompanha desde a versão 2 por aí.

Aqui está o ticket no relatório de bugs:
Muitos acusam do bug ocorrer após um update. Mas no meu caso aconteceu após criar uma VM para WinXP (maldito win, até assim ele atrapalha kkkkk)

Diagnóstico:

Ao tentar iniciar qualquer VM um alerta surge na tela com a mensagem sobre "VERR_SUPLIB_OWNER_NOT_ROOT" e outras coisas.

Solução antiga:

Nas versões antigas do VirtualBox, acho que no máximo até a 2, a solução era editar o arquivo Makefile no fonte do vboxdrv, descomentando a linha: VBOX_USE_INSERT_PAGE = 1 e compilando novamente com "/etc/init.d/vboxdrv setup" (ou "/etc/rc.d/rc.vboxdrv setup" no Slackware).

Mas nas versões atuais não existe essa linha, por tanto, o bug não tem muito a ver com isso mesmo.

Descobri que "do nada", o vbox mudou o dono do diretório de instalação do vbox, no meu caso: /opt Reparei que não era mais do root, e sim do meu próprio user.

Então basta voltar:

sudo chown root.root /opt

Pronto, agora tudo normal, mas é bom verificar se mudou de mais algum diretório. No meu foi só opt mesmo.

Outras dicas deste autor

Corrigindo o bug "file format not recognized" após atualizar glib2

Listnux - Lista de programas no estilo wiki

Emulador x86 em Javascript rodando GNU/Linux. Falta o que agora?

Impressora HP no CUPS e HPLIP depois de um update no Slackware [Resolvido]

Trocar Linux de patição / HD sem clonagem

Leitura recomendada

Encontre os melhores drivers

Instalação do Skype no Debian GNU/Linux 64 bits

Módulo de Segurança Warsaw da Caixa no Arch Linux

Winex Cedega

TimeShift no Slackware

  

Comentários
[1] Comentário enviado por fabioarnoni em 23/05/2011 - 18:56h

Hummm pegadinha do malandro essa hein!? Talvez se ativar o SGID ou o SUID isso não aconteça mais. Abraços!

[2] Comentário enviado por gamaroque em 29/06/2011 - 12:06h

Nossa, quando verifiquei meu barra (/), as pastas
/usr
/usr/bin
/usr/share
e algumas outras menos importantes, estavam com o "dono" do diretório/grupo alterado também :o

mudei para root.root e voltou a fununciar :)

Bizarro!

[3] Comentário enviado por pmartelotta em 22/06/2013 - 22:04h


[2] Comentário enviado por gamaroque em 29/06/2011 - 12:06h:

Nossa, quando verifiquei meu barra (/), as pastas
/usr
/usr/bin
/usr/share
e algumas outras menos importantes, estavam com o "dono" do diretório/grupo alterado também :o

mudei para root.root e voltou a fununciar :)

Bizarro!


Aconteceu igualzinho comigo agora depois de umas atualizações no Ubuntu, hehehe.

[4] Comentário enviado por Targaryen em 12/05/2015 - 16:55h


No Debian 8, o /usr e /etc foram alterados para user user. Mudei o /usr para root root, funcionou. Claro, depois alterei o /etc também.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts