Impressora HP no CUPS e HPLIP depois de um update no Slackware [Resolvido]

Publicado por Wilker Azevedo em 01/11/2016

[ Hits: 3.048 ]

 


Impressora HP no CUPS e HPLIP depois de um update no Slackware [Resolvido]



Olá galera!

Esta dica é o prêmio depois de ralar muito!!! Fiquei sofrendo com isso por muitos meses até que finalmente descobri como fazer funcionar!

Há um tempo atrás, na época do Slackware 14.1, imprimir usando HP era uma maravilha! Mas depois de uma atualização para o 14.2 ou atualizando apenas o cups e hplip... lá vai a bugadeira!

Primeiro de tudo... bastava instalar o cups-filter para não imprimir mais (mensagem Filter failed no cups). O único jeito era arrancando cups, cups-filter e removendo manualmente o diretório /etc/cups pra depois instalar o cups e a impressora. Mas se colocasse o cups-filter bugava outra vez.

Conforme um post que fiz, existe a solução:
Mas infelizmente (felizmente) chegou o dia em que eu precisei atualizar o libc por causa de um programa que preciso usar, daí já sabem... tem que atualizar glibc, gcc... kernel... quilos de coisas, porque vem naquele efeito borboleta em que todos os pacotes estão amarrados uns nos outros kkkk. É claro! Até o KDE entrou na história, resumindo... upgrade-all.

Depois disso, nem reza brava fez imprimir novamente, e as mensagens de erro foram outras desta vez. Então bati cabeça por mais de 1 mês e finalmente a solução definitiva.

Dê uma olhada no dilema postado para que eu não precise repetir tudo novamente:
Primeiro de tudo... se você fuçou até não aquentar mais, então sugiro zerar as configurações removendo o cups, cups-filter, e hplip. REMOVA O DIRETÓRIO /etc/cups. Agora reinstale os pacotes novamente... Pronto! Podemos continuar...

Instalou o cups-filter? Não? Ah tá! O bug né?!!! Esquece! Não era bug!!!!!!!! kkkk, o cups-filter precisa do qpdf.

Instale o cups-filter e também o qpdf !!!!! Manda uma impressão pra ver!

Ok!!!! Agora está 100% né? Tudo por causa do qpdf? Não! Antes tinha bug mesmo. A maior sacanagem é que no background não dá uma mensagem de erro do tipo...

Error while loading shared libraries: xxx.so.1: cannot open shared object file: No such file or directory

Fui encontrar a mensagem no log de erro do cups:

D [16/Oct/2016:14:21:42 -0200] [Job 77] Photosmart_D110: error while loading shared libraries: libqpdf.so.17: cannot open shared object file: No such file or directory

Então foi só instalar o qpdf que resolveu.

Se mesmo assim der aquele erro de lpr:

Unsupported document-format "application/postscript"

Então verifique se no /etc/cups tem mime.types... Se não tiver, ele está em /usr/share/cups/mime/, crie um link simbólico que a mensagem some. Só não sei porque ele não leu lá de onde está mesmo. Fazer o quê né... pelo menos está imprimindo! kkkk

Pra quem tem pressa, resumo da dica:

Instale o pacote qpdf!

Outras dicas deste autor

VirtualBox: VERR_SUPLIB_OWNER_NOT_ROOT VMMR0.r0

Slackabduction - Excelente site de pacotes para Slackware

Multi boot com ELILO (Linux + Windows 8)

Onde está o autopackage?

Erro procurando TkCximage ao iniciar aMSN (mais aprofundado)

Leitura recomendada

Driver spca5xx (webcam) pré-compilado para Slackware

Troca-troca de identificação (placa de rede) no Linux

ETPS/2 Elantech Touchpad - Multi-touch no Ubuntu (sem patch)

Webcam Clone no Ubuntu Linux 9.04

Hardware ideal para servidor

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts