Instalando VMware no Ubuntu Gutsy 7.10

Publicado por Leonardo Pinheiro de Sousa em 23/11/2007

[ Hits: 39.808 ]

Blog: http://www.caosdevelopers.com

 


Instalando VMware no Ubuntu Gutsy 7.10



Era muito fácil instalar a VMWare no Ubuntu 7.04, mas com a chegada do Ubuntu 7.10 não dava mais pra utilizar o comando "aptitude install vmware-server", então fui na internet atrás de algo que pudesse me ajudar e depois de ler bastante e conversar com um amigo sobre isso, cheguei na maneira correta de instalar o vmware-server no Ubuntu 7.10.

Baixando e instalando os pacotes do Kernel 2.6.22

Você vai precisar instalar os seguintes pacotes antes de instalar a sua VMWare. Os pacotes são:
  • linux-headers-2.6.22-14-generic
  • xinetd
  • build-essential

Vá no terminal e digite o comando:

# aptitude install linux-headers-2.6.22-14-generic xinetd build-essential

Ele fará o download e instalará os pacotes automaticamente.

Obs: No seu repositório deixe como servidor o Brasil, pois o pacote build-essential não tem no servidor principal.

Estes pacotes são necessários para a compilação do Kernel 2.6.22

Baixando os pacotes, instalando e configurando a Vmware

Baixe o pacote vmware-* no site www.vmware.com.

E seu patch no link:

http://ftp.cvut.cz/vmware/vmware-any-any-update109.tar.gz

Copie os arquivos para /usr/src e descompacte-os com o comando:

# tar -xzvf <nome do pacote>

Entre no diretório vmware-server e rode vmware-install.pl, escolha as opções padrão mais não compile o kernel.

Entre no diretório vmware-any-any e rode ./runme.pl e escolha todas as opções padrão novamente, nesse segundo diretório ele ira compilar o kernel e instalar a vmware.

Pronto, sua VMWare já está instalada!

Finalizando, vai precisar de um serial para poder rodar a sua vmware, pois ela necessita de um para poder funcionar, você pode obter uma através do próprio site.

Espero ter contribuído com essa dica para a instalação da vmware, quaisquer dúvidas só postar que estarei respondendo.

Grato,

Leonardo de Sousa
Analista de Suporte Linux.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Como restaurar o Ubuntu (removendo suas variações) 11.10 Oneiric

Emesene, o mensageiro simples e rápido com a cara do MSN

Tutorial de instalação do serviço de FTP no Debian 9.3 (Stretch)

Como instalar Cinnamon no Fedora

Instalando placa wireless 3DSP no Ubuntu 9.10

  

Comentários
[1] Comentário enviado por nixrider em 23/11/2007 - 13:22h

Leonardo, ainda há a necessidade de aplicar o patch citado acima ??
Estou no Gutsy rodando o VMware 1.0.4 build-56528 sem o patch e a instalação/compilação ocorreu sem problemas.
Apenas pra confirmar...


[2] Comentário enviado por leopinso em 26/11/2007 - 14:31h

Bom, eu escrevi essa dica já faz um tempinho quando eu instalei a vmware no ubuntu ele precisava pois ainda nao tinha suporte sem esse patch, mais se o seu ja esta funcionando entao ta tranquilo.

Leonardo de Sousa
Analista de Suporte Linux

[3] Comentário enviado por arturvsantos em 28/12/2007 - 06:40h

Quando eu tentei instalar o VMWare no GG ele pediu serial. O.o

[4] Comentário enviado por piqueno em 29/12/2007 - 11:29h

Eu instalei o vmware no ubuntu 7.10 com apenas o comando aptitude install vmware.

[5] Comentário enviado por joentpn em 26/02/2008 - 21:46h

bom aqui rolou tudo blz sem o patch porem nao funcionou o USB estou usando o Ubuntu e o vmware server com windows xp ja instalei o vmware tools e o windows reconheceus os drives de usb ja adicionei o suporte a usb na VM porem ate agora nada da USB funcionar

alguem mais esta com o mesmo problema ?? ou conhece uma solução ?

[6] Comentário enviado por nixrider em 09/03/2008 - 01:50h

Problema de USB no vmware/gutsy:
Edite o arquivo /etc/init.d/mountdevsubfs.sh
Descomente essas linhas:
#Magic to make /proc/bus/usb work
#
mkdir -p /dev/bus/usb/.usbfs
domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
ln -s .usbfs/devices /dev/bus/usb/devices
mount --rbind /dev/bus/usb /proc/bus/usb

E execute o .sh
Não lembro agora se é preciso reiniciar o vmware.
Abs.

[7] Comentário enviado por cromado em 16/04/2008 - 18:35h

Não precisa desse path.aqui rolou sussa , sem path.

[8] Comentário enviado por madrigal em 02/05/2008 - 11:50h

Poderia indicar o que devo mudar neste tutorial para ser compatível à instalação no Ubuntu 8.04?

[9] Comentário enviado por cromado em 02/05/2008 - 12:15h

Nada Madrigal.
Pule a parte do Path , que não precisa , o resto é a mesma coisa.

abç.

[10] Comentário enviado por madrigal em 02/05/2008 - 13:15h

Quando dei o comando:
# aptitude install linux-headers-2.6.22-14-generic xinetd build-essential

Deu o seguinte erro:
...
Não foi possível encontrar nenhum pacote cujo nome ou descrição casasse com "linux-headers-2.6.22-14-generic"
Não foi possível encontrar nenhum pacote cujo nome ou descrição casasse com "linux-headers-2.6.22-14-generic"
Nenhum pacote será instalado, atualizado ou removido.
...

Por isso acho que devo mudar algo nesta versão 8.10, afinal é outro kernel. Agradeço a ajuda.

[11] Comentário enviado por cromado em 02/05/2008 - 13:34h

O kernel pode ser outro , atualize a base do aptitude e procure o kernel da sua distro:

#aptitude update
#aptitude search linux-headers

vai aparecer tudo que tiver headers disponível pra vc , aí veja qual o linux-headers é o que serve pra vc.

o camando , uname -r , vai te ajudar qual linux-headers escolher.

att

[12] Comentário enviado por leopinso em 02/05/2008 - 16:14h

bom como ja disse, eu fiz essa dica logo quando saiu o 7.10, depois de umas semanas nao foi mais necessario a aplicação do patch, como foi dito só procurar o kernel de acordo com sua distribuição !!!

[13] Comentário enviado por madrigal em 02/05/2008 - 22:23h

Valeu cromado, deu certo quanto a verificar o kernel e baixar o equivalente, mas tentei instalar mas dá erro, o comando que eu dei foi:

[email protected]:/usr/src/vmware-server-distrib# ./vmware-install.pl

Está correto? Ao final deu o erro:
...
/tmp/vmware-config1/vmmon-only/linux/driver.c:1659: erro: ‘struct mm_struct’ has no member named ‘dumpable’
make[2]: ** [/tmp/vmware-config1/vmmon-only/linux/driver.o] Erro 1
make[1]: ** [_module_/tmp/vmware-config1/vmmon-only] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.24-16-generic'
make: ** [vmmon.ko] Erro 2
make: Saindo do diretório `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.


[14] Comentário enviado por jiraya-sama em 06/05/2008 - 00:43h

tambem estou tendo o mesmo erro do madrigal, ate cheguei a baixar a versao 2.0.2 pensado que podia ser algo com a ultima versao e mesmo assim o problema persiste, alguem tem alguma dica pra gente?

[15] Comentário enviado por jiraya-sama em 06/05/2008 - 12:34h

Madrigal,
..consegui instalar aqui no kubuntu 8.06 (kernel 2.6.24), baixando o arquivo (vmware-any-any-update-116.tgz) e copiando seu conteudo para dentro da pasta /lib/modulos/source do wmware...
http://uruz.org/files/vmware-any-any-update-116.tgz

...espero que funcione para vc, pois antes disso eu já havia baixados trocentos pacotes que varios outros tutoriais recomendaram...

Abraços

fonte: http://penguim.wordpress.com/2008/04/17/instalando-o-vmware-server-105-no-ubuntu-804-hardy-heron/

[16] Comentário enviado por madrigal em 06/05/2008 - 21:39h

Bem, consegui agora, valeu jiraya-sama!

Só dois detalhes:

Não apareceu o programa no menu Aplicações>Ferramentas do Sistema, pra poder abrir, preciso abrir o terminal e digitar vmware, deve estar faltando instalar algo.

Uma outra coisa, aproveitei o vmware que eu tinha em outra partição, mas ao abrir, não reconhece o driver de cd, aparece a mensagem quando tento montar:
Unable to open host CD-ROM drive "/dev/hdd": No such file or directory.
Failed to connect virtual device ide1:0.

Agradeço se puderem me auxiliar a concluir estes detalhes.

[17] Comentário enviado por Ger008 em 22/05/2008 - 10:24h

preciso de uma ajudinha eu tenho o ubuntu 8.04 e n consigo instalar cmo voces esplicam podiam explicar com mais detalhes....

[18] Comentário enviado por madrigal em 24/05/2008 - 01:10h

Consegui instalar legal no 8.04 por este tutorial:
http://www.howtoforge.com/the-perfect-desktop-ubuntu-8.04-lts-hardy-heron-p5

Refaça a instalação por este tutorial que aí aparece em Aplicações>Ferramentas do Sistema.

[19] Comentário enviado por lordhulk em 01/10/2008 - 21:05h

Eu escrevi recentemente um tutorial sobre como instalar vmware no linux, com foco no ubuntu e debian. tentei ser bem detalhista e abordar erros que costumam acontecer. Espero que seja útil: http://jeferson.info/instalar-vmware-linux



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts