Backtrack 5 - Problemas de inicialização do modo gráfico

Publicado por Renato Carneiro Pacheco em 07/06/2012

[ Hits: 24.730 ]

 


Backtrack 5 - Problemas de inicialização do modo gráfico



Olá,

Devido a escassa informação acerca deste problema, resolvi caçar na Internet a solução que muitas pessoas estão enfrentando com a distribuição Backtrack 5 r2.

Atualmente a maioria dos notebooks estão possuindo o chipset de vídeo da Intel, mais precisamente o i915. Entretanto, nesta distribuição em específico, quando se tenta utilizar a interface gráfica do sistema, a tela simplesmente fica preta e os leds do Caps Lock e Scroll Lock ficam piscando, como se houvesse um Kernel Panic (ou realmente houve, mas não mostra nada).

A solução para este problema é inserir o parâmetro i915.modeset=1 na linha de boot do Grub, desta forma:
  • Dê o boot pelo pendrive/CD/DVD com a sua distribuição Backtrack 5 r2 GNU/Linux;
  • Na tela do Grub (mostrada abaixo, criada pelo UNetbootin), aperte <TAB> para abrir o editor do menu escolhido. Vai aparecer uma linha logo abaixo com os parâmetros daquele menu que você escolheu;
    Linux: Problemas de inicialização do modo gráfico no Backtrack 5 r2
  • Adicione o parâmetro i915.modeset=1 à frente do último parâmetro da linha e aperte ENTER para inicializar normalmente.

Pronto! Utilize o comando "startx" para comprovar o funcionamento do ambiente gráfico.

Procurando sobre o porquê do parâmetro, me deparei que este módulo necessitava rodar como KMS (Kernel Mode Setting). Este modo permite alterar a resolução da tela e número de cores no momento do boot, em vez de ser carregado no momento em que o usuário chama o módulo (UMS - User Mode Setting).

Concluindo, o erro é da distribuição que não deixou esta opção habilitada no módulo por padrão. Ainda bem que é r2 (release 2).

Referências:
Outras dicas deste autor

Fazendo o adaptador de rede sem fio RT2501USB funcionar

Leitura recomendada

Iniciando mais de uma instância de memcached no mesmo servidor

Debian: autenticando usuários via LDAP

MP3 no XMMS - Fedora Core 2

Imprimindo em impressoras térmicas com CUPS e Kprinter

Como fazer os sensores da placa mãe funcionarem no Slackware

  

Comentários
[1] Comentário enviado por KaioRamos em 01/07/2012 - 21:45h

Fiz como você disse e deu certo no meu note. Instalei td normal e foi de boa.
Agora com ele instalado fui iniciá-lo e o problema da tela preta continua.
O q eu faço agora? D:
Procurei resposta em outros lugares mas não achei, e ou em outros lugares elas não eram claras ):

Não sei se é relevante, mas meu note é um Inspiron N4030.

[2] Comentário enviado por renato_pacheco em 02/07/2012 - 09:09h

Depois d instalar, vc tem q fazer a msm coisa no menu do grub. Depois disso, vc tem q acrescentar esse parâmetro dentro do /etc/grub/grub.cfg (se não me engano).

[3] Comentário enviado por znorte em 16/07/2012 - 09:33h

Obrigado pela dica.
fiz como você postou ae,a diferença é que dei um boot novamente pelo pendrive e fui na partição onde instalei o BackTrack ex: raiz /boot/grub/grub.cfg
editei a cfg no final como vc falou apagando o vga e colocando o i915.modeset=1 reniciei o sistema sem o pendrive e( ah mulekeeee) vlw cara.
abraço....

[4] Comentário enviado por Oliveira_diego em 27/09/2012 - 14:40h

Cara sua dica foi top, tava a um tempão tentando instalar no meu note e não tava dando, valeu mesmo!!!!!!!!


(Só usuário linux conta com o privilégio de ter uma comunidade inteira se ajudando e crescendo cada dia mais!!)

[5] Comentário enviado por fabio.adsistema em 11/10/2012 - 00:30h

Cara, fiz isso e não deu certo. A tela aparece do unetbootin e aperto TAB na opção DEFAULT e aparece o seguinte:
/ubnken initrd=/ubninit file=/cdrom/ preseed/ custom.seed boot=casper text splash vga=791--
Como vc falou, apago "vga=791--" e coloco 'i915.modeset=1' e ainda não consigo acessar em modo gráfico.
Até onde tenho que apagar? Ou tem outra coisa que posso fazer?

Grato!!

[6] Comentário enviado por renato_pacheco em 11/10/2012 - 11:17h

fabio.adsistema, não falei para apagar o parâmetro "vga=791--". Falei apenas para acrescentar a opção "i915.modeset=1" no final da linha. Tente d novo e veja se dá certo.

[7] Comentário enviado por leeoazevedo em 06/06/2013 - 19:28h

Cara, tem como explicar melhor como entrar na tela unebootin ? Preciso ter o Ubuntu?

[8] Comentário enviado por renato_pacheco em 06/06/2013 - 21:54h

@leeoazevedo, baixe a imagem do Backtrack pra DVD e baixe tb o Unetbootin (tem versões para Windows e Linux). Ele é um aplicativo q grava a ISO no pendrive para poder inicializar corretamente pelo sistema.

http://unetbootin.sourceforge.net/?;

[9] Comentário enviado por Juliabe em 09/06/2013 - 18:44h

Cara, eu tenho um notebook Hp g42-433BR, tentei iniciar o backtrack normal e com essa dica que você falou, mas não tá dando certo, fica a tela preta e as luzes piscando, dá um help aí véi, vlw.

[10] Comentário enviado por renato_pacheco em 09/06/2013 - 23:37h

@Juliabe, se as luzes estão piscando, o problema é maior do que apenas o vídeo. Quando ocorre isso, é pq deu kernel panic. Neste caso, acredito q deve t algo com a sua BIOS q possa estar dando alguma incompatibilidade. Procure algo na Internet relacionado ao seu notebook e linux.

[11] Comentário enviado por wass em 22/07/2013 - 21:38h

Valeu pela dica, funcionou bacana.

[12] Comentário enviado por senhorf em 30/08/2013 - 07:59h

no codigo vai ter vga=791--, apague o -- e deixe assim:

vga=791 y915.modeset=1

Isso faz o backtrack iniciar em computadores com placa de vídeo ATI e NVIDIA mas, após a instalação, se reiniciar o comptuador o problema persiste.

Então pesquisei por: Instalar placa de video ubuntu. Tem um tutorial no baixaki facinho. O problema que estou tendo agora é como habilitar download no backtrack.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts