Fazendo o adaptador de rede sem fio RT2501USB funcionar

Publicado por Renato Carneiro Pacheco em 20/06/2009

[ Hits: 9.478 ]

 


Fazendo o adaptador de rede sem fio RT2501USB funcionar



Olá, pessoal!

Recentemente ganhei um adaptador de rede sem fio chamado Level One. Eu nem tinha ideia de como instalá-lo em meu humilde Slackware 12.1 (kernel 2.6.29.2). Quando o inseri no meu laptop e dei o comando "lsusb", veio a mensagem:

Bus 001 Device 003: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter

Descobri que o danado tinha o chipset da Ralink RT2501USB e resolvi listar os dispositivos sem fio com o comando "iwconfig". Para a minha surpresa, o meu kernel já tinha o módulo carregado desse adaptador:

wlan1 IEEE 802.11bg ESSID:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not Associated
          Bit Rate=1 Mb/s   Tx-Power=11 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off   Security mode:open
     Power Management:off

No meu caso, como no meu laptop já tem uma placa de rede sem fio, o adaptador foi detectado como wlan1.

Pensei: "bão d+! Vou botar pra funcionar.", mas como alegria de pobre dura pouco, quando resolvi me conectar ao meu ponto de acesso, veio a mensagem:

# wpa_supplicant -Dwext -iwlan1 -c/etc/wpa_supplicant.conf.default
SIOCSIFFLAGS: No such file or directory
Could not set interface 'wlan1' UP
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - l2_packet_receive - recvfrom: Network is down
ioctl[SIOCSIWSCAN]: Network is down
Failed to initiate AP scan.
ioctl[SIOCSIWSCAN]: Network is down
.
.
.

Achei muito esquisito o que aconteceu e resolvi verificar nos logs do sistema (eles sempre nos diz alguma coisa). O comando foi:

# tail /var/log/messages

E apareceram as seguintes linhas:

Jun 14 14:56:26 camarao kernel: rt73usb 1-5:1.0: firmware: requesting rt73.bin
Jun 14 14:56:26 camarao firmware.sh[7664]: Cannot find firmware file 'rt73.bin'
Jun 14 14:56:28 camarao vmnetBridge: RTM_NEWLINK: name:wlan1 index:8 flags:0x00001002

Portanto concluí que estava faltando a firmware do chipset. Não procurei muito no oráculo (Google) e encontrei no site da ralink:
Dentro do arquivo compactado existe um arquivo chamado rt73.bin. Basta movê-lo para dentro do diretório /lib/firmware:

# mv rt73.bin /lib/firmware

Concluído! Seu adaptador está pronto a ser utilizado.

Obs.: A partir do kernel 2.6.25, os módulos para esse chipset (rt2500usb, rt73usb...) já vem instalados, não precisando fazer a compilação destes módulos outra vez, ok?

Até mais, galera!

Outras dicas deste autor

Backtrack 5 - Problemas de inicialização do modo gráfico

Leitura recomendada

Configurar teclado ABNT2 no Slackware 14 - 64 bits

Softmodem compatível com Linux

Mudando o MAC da placa de rede

Pendrive que não é reconhecido, nem formata? Truque para... RESOLVER!

Instalando modem SmartLink no Slackware e Debian

  

Comentários
[1] Comentário enviado por Matrizero em 20/06/2009 - 17:25h

Boa dica Renato!

Se não fossem as incessantes horas de ajuda desse cara, meu Backtrack estaria até hoje sem rede sem fio!

valeu irmão, fica na paz!

Robert Zero

[2] Comentário enviado por alcarafe em 02/03/2010 - 15:30h

Estou a procura de uma solução. Quero colocar este adaptador USB em modo master (acess point) e não estou conseguindo.

[3] Comentário enviado por renato_pacheco em 02/03/2010 - 15:35h

Vc deve pesquisar se essa placa possui suporte a esse tipo d modalidade. Acredito q não, mas vale a pena pesquisar por isso...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts