Logando o Windows XP no Samba

Você domina o Samba, conhece o smb.conf de cabo à rabo, vai instalar um servidor Linux numa rede heterogênea e dá de cara com estações Windows XP. E agora, o que fazer? Hum, leia esse artigo e obtenha a resposta.

[ Hits: 97.096 ]

Por: Joabes Carlos de Carvalho em 21/09/2003 | Blog: http://www.fwsnet.com.br


Introdução



Depois de ter seu Samba devidamente instalado e configurado com todas as estações Win95/98 logando corretamente, iremos ao assunto que interessa no escopo deste artigo, a autenticação das estações Windows XP.

Primeiramente, temos que ter o usuário root criado no Samba. Recomendo colocar uma senha diferente da senha do root do seu sistema (motivos de segurança).

# smbpasswd -a root

Nota: sim, no Samba existirão duas contas para o mesmo usuário. Uma gerenciada pelo sistema operacional (passwd) e outra pelo Samba (smbpasswd).

Depois temos que adicionar a maquina XP no Samba da seguinte forma:

# adduser -g grupo -s /dev/null -d /dev/null nome_da_maquina$
# smbpasswd -a -m nome_da_maquina


OBS: o $ no final do nome da máquina XP e necessário para o Samba diferenciar nome de conta com nome de máquina.

Depois disso vem a parte mais chata, mexer no Windows XP. Logue no XP como um usuário local e administrador do sistema.

Vá no painel de controle -> sistema. Clique na guia Nome do Computador e depois no botão ID da rede.

Na nova janela que irá parecer, clique em avançar, selecione o ítem "Este computador faz parte de uma rede corporativa ...", clique em avançar, selecione "Minha empresa usa uma rede com um domínio", clique em avançar, avançar novamente.

Em nome do usuário digite um usuário que já existe no Samba devidamente configurado, sua respectiva senha e o domínio que sua rede pertence, clique em avançar.

Digite o nome do seu computador (aquele que você adicionou no Samba sem o $) e o domínio da sua rede novamente, clique em avançar. No nome de usuário digite o usuário root (que foi adicionado ao Samba anteriormente) e sua respectiva senha e domínio do Samba. Depois isso é só clicar em OK na mensagem: "Bem Vindo ao domínio ...".

Pronto, agora você reinicia seu XP com a opção de logar no domínio da sua rede com qualquer usuário que esteja devidamente cadastrado no Samba.

OBS: Em nossas pesquisas encontramos diversos artigos dizendo que era necessário alterar 3 parâmetros no registro do sistema, mas em nosso teste não foi necessário promover essas alterações. Caso tudo isso não funcione, envie-nos um e-mail solicitando as alterações no registro.

Fontes:
Arthur Muller - Analista de sistemas
Gilberto Villani Brito - Admin. de redes

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor

Proxy Squid Transparente

Leitura recomendada

Configurar SAMBA como PDC com usuário fixo

Impressora virtual no Samba para gerar arquivos PDF

Configurando administradores de domínio no Samba

Samba: Servidor de arquivos Linux com estações Windows

Howto Servidor Samba + ACL

  
Comentários
[1] Comentário enviado por fabio em 21/09/2003 - 23:05h

Rapaz, esse artigo vai me ser útil. Essa semana precisarei fazer o XP autenticar no Samba num cliente :)
Obrigado.

[2] Comentário enviado por neoform em 23/09/2003 - 09:51h

Tem um problema, não consigo imprimir do XP para um servidor de impressão linux... o que pode ser?

[3] Comentário enviado por arnaldo em 23/09/2003 - 15:47h

Tive mudar algumas configurações nas policies.. e o engraçado é que ele está mapeando o HOME 2 vezes.. alguem sabe o que pode ser?

[4] Comentário enviado por joabes em 23/09/2003 - 22:16h

Que impressora está utilizando em seu Linux?
Você a compartilhou no Samba?
Quando você manda imprimir a impressora recebe o arquivo mais não imprime?

Preciso dessas respostas para saber o que pode ser.

Abraços.

[5] Comentário enviado por joabes em 23/09/2003 - 22:21h

Cara me manda o conf que você está usando para que eu possa dar uma olhada, assim fica difícil de saber .


Abraços, aguardo o arquivo.

[6] Comentário enviado por marcolinux em 24/09/2003 - 12:30h

Só um detalhe, sabe se isto vai funcionar no Windows XP Home ? ALLguém sabe ?

[7] Comentário enviado por cesarcardoso em 25/09/2003 - 00:52h

Quanto aos patches no registro, caramba, você deu sorte no seu XP :) Eu sempre precisei deles. E os que estavam com ServicePack, então, sem o patch nem com reza brava :)

[8] Comentário enviado por jameschinen em 26/09/2003 - 10:21h

não consigo terminar de configurar o windows xp. Segui todos os passos descrito no artigo, porém na última tela eu coloco o nome de usuário como root, digito a senha, coloco o domínio e ele dá o seguinte erro: "Seu computador não pode ingressar no domínio porque ocorreu o seguinte erro:
A conta usada é uma conta de computador. Utilize a conta de usuario global ou local para ter acesso a este servidor. "

As minhas estações windows 98 logan normalmente. Será que vai ser necessário alterar alguns parametros do registro do sistema??

Alguém pode me ajudar???

[9] Comentário enviado por joabes em 28/11/2003 - 23:26h

Ae galera desculpe responder só agora, no caso do XP logando no samba o interessante é fazer a atualização do XP, se mesmo assim não conseguirem logar ele, ainda essa semana estarei disponibilizando as alterações necessárias que deverão ser alteradas no registro.

Abraços

[10] Comentário enviado por jcbart em 09/01/2004 - 14:11h

Meu amigo, consegui colocar o XP no domínio, mas não consegui logar.
Gostaria q vc me enviasse aquleas pequenas alterações q tenho q fazer....


Obrogado

Jcbart

[11] Comentário enviado por sandrinha em 02/03/2004 - 11:08h

Oi Pessoal!
Gostaria de saber se é possível vcs me enviarem as alterações que devem ser feitas no registro do xp, pois ele dá uma erro de controlador de domínio ao tentar fazer login no samba. Valeu!
[email protected]
Sandra

[12] Comentário enviado por igorcb em 11/03/2004 - 11:36h

é eu tb configurei tudo certinho, ta aperecendo o dominio e tudo na tela de logon, mas quando coloco o usuario e senha ele diz que:
"O Windows não pode se conectar ao dominio porque o controlodar de dominio está inoperante ou não está acessivel sua conta de computador não foi encontrada". Estou usando o mesmo usuario que conecto no win98

[13] Comentário enviado por joabes em 11/03/2004 - 15:30h

Amigo, logue-se no dominio com o usuário root do linux e depois comece a logar normalmente com seu usuário, porém verifique se o usuário que vc está usando foi criado para o linux e o samba.

Até, dúvidas entre em contato.

[14] Comentário enviado por vpf em 22/03/2004 - 15:05h

Uso a distro Suse pro 8.1 e SAMBA 2.2.8a. Meu Windows XP já esta em no domínio, o problema é que quando vou logar no domínio simplesmente aparece uma mensagem dizendo que usuário e senha estão incorretos. É e não estão! O que fazer nesta situação???

[15] Comentário enviado por asclows em 24/03/2004 - 11:04h

Estou tendo um problema parecido com a maioria deste acima. Lembrando que já possuo duas máquinas (1 XP, 1 2000) logando normalmente, apenas quando ingresso uma nova máquina no domínio ao tentar efetuar o primeiro logon me é retornada a mensagem abaixo:

"O Windows não pode se conectar ao dominio porque o controlodar de dominio está inoperante ou não está acessivel sua conta de computador não foi encontrada".

O usuário que estou tentando logar já previamente cadastrado no Linux e Samba e a máquina também.

Estamos tentando de tudo, até mesmo minha superior aqui começo a configurar arquivos como resolv.conf e hosts.allow para permitir a conexão e parece que está dando certo. Minha dúvida então...

Preciso editar estes arquivos para configuração de rede sendo que o samba tem por exemplo, uma opção:

hosts allows= 192.168.0.

Ou melhor, preciso configurar arquivos de rede do sistema para que o samba opere sem problemas ou as opções do smb.conf me garantem o funcionamento correto do Samba?

[16] Comentário enviado por igorcb em 30/03/2004 - 16:48h

Continuando o comentario do dia 11/03/04.
Eu jah tentei com o usuario root, e criei tb outros usuario só do samba e nada.

[17] Comentário enviado por joabes em 30/03/2004 - 23:11h

Prezados, estarei essa semana respondendo todas as perguntas para que vocês possam logor facilmente no samba usando o XP.


Abraços.

[18] Comentário enviado por joabes em 29/04/2004 - 18:57h

Galera apenas mais um informação o XP HOME não autentica em um servidor PDC, já fiz de tudo e realmente não, já coletei diversas informações é somente o PROFESSIONAL que funciona.

Essa semana estarei disponibilizando meu novo conf do samba, para estações XP e WIN em geral.

Abraços

[19] Comentário enviado por p4n1c em 02/06/2004 - 10:34h

Já que eu to aqui.. já to logado mesmo, vo responde...
pra logar o windows XP home em dominio samba, voce precisa duma ferarmenta x-teq x-setup .. e obvio, nao vo escreve o texto de como fazer, mas voce pode acessa-lo em: http://vowe.net/archives/001639.html
detalhe; em ingles

[20] Comentário enviado por override em 03/06/2004 - 17:24h

aew, desculpa eu dar um comentario com uma coisa nada a ver.. mais nao consegui enviar uma pergunta no site, como faço pra enviar ? please
[email protected]

[21] Comentário enviado por joabes em 03/06/2004 - 18:45h

Basta postar aqui que responde-mos sua dúvidas,


Abraços

[22] Comentário enviado por carlosaguiar em 08/06/2004 - 11:14h

Tenho que cadastrar a máquina no caso de versões 9x?
Obrigado,

[23] Comentário enviado por joabes em 08/06/2004 - 11:51h

Exato amigo, é necessário que você cadastre as estações para que elas possam logar, ou mesmo se enxergarem na rede.

Dúvidas entre em contato.

Abraços.

[24] Comentário enviado por bornskip em 14/07/2004 - 03:53h

coé eu tbm ñ consigu logar o windows xp pro ñ consegue entrar no dominio...
tentei criar uma conta para a maquina com o comando smbpasswd -am e tbm ñ funciona
se alguem souber alguma coisa

agradeço

[25] Comentário enviado por gustavo_marcon em 30/07/2004 - 12:07h

Desculpe minha ignorância, mas o que seria o Domínio do Computador, que o XP pede?

Eu sei só qual é o domínio de logon, que é o nome do server Linux, mas e o Domínio do Computador é o que? O Grupo de Trabalho?

[26] Comentário enviado por estevaoes em 03/08/2004 - 13:11h

configurei tudo certinho e parecia que ia funcionar, mas ao entrar com o usuário no dominio segue a mensagem "O Windows não pode se conectar ao dominio porque o controlodor de dominio está inoperante ou não está acessivel sua conta de computador não foi encontrada"
Só consigo logar na maquina local, como faço para acrescentar a pemissão de dominio no usuário cadastrado no XP (que é o usuário que está no SMB e Linux)?

[27] Comentário enviado por samurai em 11/08/2004 - 17:22h

configurei tudo certo, meu problema é que se alguem precisa compartilhar algo pelo ambiente de rede aparece "erro desconhecido 31" e não acessa o XP alguem pode me ajudar ???

[28] Comentário enviado por lopes em 08/09/2004 - 11:04h

Ultilizo como servidor um pc com RedHat 9 e consegui realizar a configuração do samba normalmente, as maquinas com XP logan no dominio porem sempre ao final do login aparece mensagem informando que a senha expira hoje, a senha é trocada porem no proximo logon a mensagem torna a aparecer. Se a senha não for trocada o logon não é bloqueado. Alguem poderia me ajudar?

[29] Comentário enviado por hookdigao em 15/09/2004 - 17:38h

Uso uma distribuição kurumin e toda vez que tento cadastrar a maquina com comando #adduser -g grupo -s /dev/null -d /dev/null nome_da_maquina$ da o seguinte erro: adduser:nao mais de dois nomes

alguem pode me ajudar?

[30] Comentário enviado por sombrafam em 21/09/2004 - 17:46h

Eu estou com serios problemas na hora de carregar o perfil. Toda vez que eu faco logon na rede, oXP fala que naum conseguiu carregar nem o perfil movel nem o local. Eu queria saber como eu faco pra configurar para que seja carregado o perfil no Samba ou mesmo como eu faco para o XP armazenar o perfil localmente...

[31] Comentário enviado por well em 27/09/2004 - 13:24h

Olá,
Gostaria de uma ajuda!!
Fiz todos os procedimentos acima, como ex: nome do grupo coloquei windowsxp...
logo fiz a linha de comando useradd ..
e depois foi realizar os passos no Windows XP no botão ID rede deu problema (na tela de validação). Ex.: O Windows não conseguiu encontrar uma conta para seu computador no dominio TAL.
O que eu faço agora???

Wellington R.Felisberto - 27/09/04
[email protected]

[32] Comentário enviado por zotz em 07/10/2004 - 14:13h

estou com um problema meio chato, o windows XP loga, mais o nome de usuario, aparece todo estranho, cheio de "virgulas"..alguem sabe me falar oque possa ser?

[33] Comentário enviado por rbn_jesus em 20/10/2004 - 16:28h

e quando não se tem outro win alem do XP como testo a conectivade do samba?

[34] Comentário enviado por marvin em 11/11/2004 - 05:55h

tem 1 probleminha....
q é o lance do registro... !!! :P
tem umas linhas q tem q alterar...

salvem isso : num arquivo winxp.reg

REGEDIT

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netlogon\parameters]
"RequireSignorSeal"=dword:00000000
"SignSecureChannel"=dword:00000000

[35] Comentário enviado por marvin em 11/11/2004 - 05:56h

Ops... esqueci de dizer... depois eh soh dar 2 cliques nele :P !!!

[36] Comentário enviado por edvan em 30/11/2004 - 16:25h

Olá Galera, sou novato por aqui, mas lendo esse tópico vi que nosso amigo VPF está tendo dificuldades em autenticar o úsuário, o erro é de login incorreto, se o acontecimento é apenas no XP, vc deve mudar o valor reg_dword de 0 para 1 de todas as chaves que contiverem a palavra enableplaintextpassword, exatamente dessa forma.

Espero ter ajudado

Um abraço a todos

[37] Comentário enviado por luiscarlos em 09/12/2004 - 13:15h

Cara, configurei o samba para que os usuários loguem sem senha e usuário, para montar o compartilhamento em máquinas linux vai blz, o logon anonimo funciona, mas como faço nas máuqinas windows, como faço logon anonimo em áquina windows?, valeu se puder ajudar!

[38] Comentário enviado por joabes em 09/12/2004 - 16:33h

Você não irá conseguir logar as máquinas sem especificar uma senha, terá que ter senha.

Sem mais.

Atenciosamente
Joabes

[39] Comentário enviado por removido em 17/03/2005 - 16:17h

Após fazer todas as mudanças no linux adicionado usuários e mudando o registro do windows xp quando vou mudar o id de rede digitando a senha de root ocorre o seguinte erro: "Não são permitidas várias conexões a um servidor ou recurso compartilhado pelo mesmo usuário, usando mais de um nome de usuário. Desconecte todas as conexões anteriores ao servidor ou recurso compartilhado e tente novamente.
Caso alguém possa me ajudar, agradeço desde já

Gustavo
[email protected]

[40] Comentário enviado por [Evandro] em 25/04/2005 - 12:39h

Olá amigos,

para os que estão com dificuldades de ingressar as máquinas com windows XP num domínio samba:

vão ao painel de controle-ferramentas administrativas-diretivas de segurança local. Abram a opção diretivas locais - opções de segurança e desative todas as diretivas que começarem com "membro de domínio".
Desative também o firewall do windows xp antes de ingressar a máquina no domínio.

caso seja apresentado erro de "a conta utulizada é uma conta de máquina", renomeio o grupo de trabalho de "grupo" pra outro nome qualquer e depois de reiniciar o micro tente ingressar de novo.

[41] Comentário enviado por rafaelmontek em 11/05/2005 - 08:27h

O meu ta com o seguinte problema:
Fiz tudo direito, confgurei todo smb.conf, tanto que ele chega a entrar no dominio quando vamos lá em nome da maquina e alterar. "SEJA BEM VINDO AO DOMINIO LABORATORIO" mas quando eu reinicio a maquina para surtir efeito e tento logar no dominio ele diz que o servidor está fora do ar ou desabilitado ou a conta não existe, tenta mais tarde ou contacte o administrador - QUE SOU EU, MAS QUE ME... É ESSA ??? se ele entra no dominio com o mesmo usuario que tento logar depois e NADA !!! VCS PODERIAM ME AJUDAR !!!

[42] Comentário enviado por brunocampinas em 17/05/2005 - 17:53h

Ola gente,...
pelo visto é muitos problemas mesmo q acontece..o meu
problema é com o profile..qndo o usuario entra ele demora 15 minuto para logar com o profile do usuario porque o profile esta no servidor, como faço para deixar o profile localmente no pc do usuario?
tenho que mudar o que no smb.conf?
aguardo...obs estou com o red hat 8.0

[43] Comentário enviado por srf em 21/05/2005 - 13:49h

Amigo até então eu utilizo o samba 3 do Redhat 3.0 mas agora estou utilizando o samba 3.0.10-1.4E do Redhat 4.0 AS e quando digito o comando:
# adduser -g grupo -s /dev/null -d /dev/null nome_da_maquina$
mostra o seguinte erro:
Invalid user name 'nome_da_maquina$'

[44] Comentário enviado por jgama em 25/12/2005 - 22:31h

Não querendo ser corveiro, mas irei postar uma dúvida sobre o logon de usuarios em estações WinXP, Como todos sabem, em plataformas Windows onde tem um Server 2000 ou 2003 todos o usuarios cadastrado no Active Directory conseguem logar após se autenticarem, fora isso nem adinta que não acessa a máquina certo, há não ser que tenha uma conta de administrador local.

Mas no Samba como PDC já fiz varios testes e os usuarios num astação com WinXo mesmo que o Samba PDC esta desabilitado ou seja o serviço não levantou os usuario cadastrado no Servidor consegue logar e acessar a estação.

Alguém sabe porque isso e como resolver este problema?

Abraço e Feliz Natal a todos.

[45] Comentário enviado por thaise vian em 02/01/2006 - 18:25h

ola, meu micro estava funcionando normal ate q tive q formata-lo, depois disso qdo vou fazer o logon ele diz nao conseguir encontrar um dominio...etc..bom mas depois q eu logo como administrador eu consigo acessar a rede normalmente.. o q mais tenho q fazer para conseguir logar direto?

[46] Comentário enviado por edson_nasilva em 16/02/2006 - 15:47h

ola, eu estou com um problema parecido com de vcs, fiz toda a configuração no samba e nas estações do winodws XP. Mudei toda a configuração do registro do Windows. Mas a mensagem que parace é. Seu computador não pôde ingressar no domínio porque ocorreu o seguinte erro:Não foi feito mapeamento entre os nomes de conta e as identificações de segurança.

Alguém poderia me ajudar sobre este poblema.

Muito obrigado.

[47] Comentário enviado por rapha81 em 30/05/2006 - 21:29h

Existe alguma solução para fazer o XP Home funcionar conectar no Samba?

[48] Comentário enviado por vinnyj em 17/07/2006 - 09:07h

Ja fiz tudo isso ai a maquina xp entra no dominio mas nao loga retorna um erro que o servidor esta inoperante, por favor me ajude nao sei mais o que fazer!

[49] Comentário enviado por riesdra em 01/08/2006 - 14:09h

Nao sei se eh a sessao certa, mas estou com um problema, no windows XP quando entro no dominio, com o mesmo usuario do windows q ja existia antes eu naum consigo ter acesso aos documentos pessoais dele no samba ele cria uma outra pasta pessoal exemplo
c:\documents and settings\Usuario\.....
ai ele cria uma outra pasta particular ex
c:\documents and settings\Usuario.Dominio\..... Se alguem puder me ajudar agradeco.

[50] Comentário enviado por nissieloin em 10/08/2006 - 09:16h

Você vai ter que copiar os arquivos dele como adm da máquina pra dentro do perfil usuario.dominio, pq eles são dois usuarios diferentes, um é da máquina e outro é do domínio.
OK!?

[51] Comentário enviado por jrsnet em 28/08/2006 - 11:02h

Caro amigo, estou com o mesmo problema do que enviado por riesdra,(c:\documents and settings\Usuario\.....
ai ele cria uma outra pasta particular ex
c:\documents and settings\Usuario.Dominio) o problema que ja tenho minha rede implantada. Tem algo que possa ser feito para que eu possa intregar estes computadores sem ter que executar esta copia do perfil.
Obs.: Ao copiar o perfil, me diz que há alguns arquivos em uso que não poderão ser substituidos. Grato

[52] Comentário enviado por nissieloin em 28/08/2006 - 11:17h

O problema na verdade nao e com a rede e sim com os usuários locais, é necessários que os usuários da rede sejam utilizados e nao existam nas maquinas, uma vez que este problema sempre irá ocorrer.
======
Pra solucionar este problemas, as coisas ja ficam mais no Windows, uma área que nao me interesso muito, porém ja mexi com algo assim, da uma procurada sobre herança: Inheritance no que se diz respeito aos grupos e usuários no Windows...

Espero ter ajudado.
T+

[53] Comentário enviado por clon¥ em 30/08/2006 - 23:17h

Porque logo após eu executar este comando:
adduser -g grupo -s /dev/null -d /dev/null nome_da_maquina$

aparece a seguinte mensagem (Kurumin - Debian)?
"No more than two names"

[54] Comentário enviado por jandairs em 13/08/2008 - 08:58h

Ola galera tou com um grande problema no samba ele funcionou perfeitamente na primenira vez que adcionei o usuario e a maquina so que no outro dia fui tentar loga de novo com o terminal ele não logou disse que o dominio não esta disponivel alguem pode me dar uma ajudinha ai talvez vcs possam ter uma configuração do smb.conf completa que funcione sem dar este pal desde ja agradeço e conto com a força de vcs ok abraço a todos


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts