Instalando o amule a partir da source

Algumas pessoas acham que é dificil instalar esse programa no Linux. Pessoas essas que já tentaram usar qualquer tipo de programa P2P e não tiveram sucesso. Bom, nesse artigo mostro que não é tão dificil quanto parece ser.

[ Hits: 44.319 ]

Por: em 04/03/2006


Introdução



Muitas pessoas acham que é muito difícil instalar esse programa no Linux. Pessoas que já tentaram usar qualquer tipo de programa P2P e não tiveram sucesso.

Nesse artigo mostro que não é tão difícil quanto parece ser.

Download dos componentes


São duas dependências que ele precisa, uma delas é o wxGTK acima da versão 2.6.0, nesse artigo vou usar a versão 2.6.2. A outra dependência é wxWidgets-2.6.0, que também precisa ser acima da versão 2.6.0.

Download do wxGTK-2.6.2:
http://prdownloads.sourceforge.net/wxwindows/wxGTK-2.6.2.tar.gz

Download do wxWidgets-2.6.2:
http://prdownloads.sourceforge.net/wxwindows/wxWidgets-2.6.2.tar.gz

Agora vamos fazer download do programa aMule, que é o principal.

Download do aMule-2.0.3:
http://prdownloads.sourceforge.net/amule/aMule-2.0.3.tar.gz

    Próxima página

Páginas do artigo
   1. Introdução
   2. Instalando as dependências
   3. Instalando e executando o aMule
Outros artigos deste autor

Instalando o Cedega 5

Instalando e usando o linphone no Slackware

Instalando Freerock Gnome 2.12.1

10 dicas para aprender a programar por conta própria

Leitura recomendada

Jabberd2 - Completo e sem mistérios

Qual distribuição Linux devo escolher?

Software envelhece?

Implementando servidor de aplicações PHP utilizando Zend Framework

Zabbix 2.2 no CentOS 6 via repositório EPEL - Instalação e configuração

  
Comentários
[1] Comentário enviado por pa72 em 04/03/2006 - 15:21h

Isto é um artigo? Nem dica é! É uma banalidade!

Qual é a especificidade da instalação do aMule que foi tratada no artigo e que o distingue da instalação de outra coisa qualquer a partir da source?

Nada!

Toda a instalação a partir da source é:
$./configure
$make
$su
#make install

O que torna a instalação do aMule mais dificil que a instalação de outro programa (a partir da source)?

E quanto aos problemas que possam surgir e como resolve-los? Nada!


[2] Comentário enviado por m3ocs-d4rksun em 04/03/2006 - 15:47h

eaee suse player belezaa?

[3] Comentário enviado por PCMasterPB em 04/03/2006 - 23:06h

pa72, na realidade a única bronca mesmo ao instalar o aMule é o wxGTK com suporte à arquivos grandes, e que na versão 2.6.2 já vem ativada por padrão ao compilar. No resto vai tudo blz. Isso é talvez um fator que faz muita gente não conseguir instalar o aMule. O autor do artigo escreveu bem, embora o artigo não esteja grande, ele abordou de forma correta o assunto. Em outras palavras ele não embromou, foi direto ao assunto. Talvez tenha pecado em não dizer o porque de ter que instalar o wxGTK mais novo, mas no resto tá tranquilo. Essa foi a forma que ele achou de contribuir com a comunidade. Pelo menos ele mostrou uma atitude a meu ver correta, ele quis colaborar e ajudar outros usuários, e eu admiro qualquer contribuição e colaboração, não me importa se o tamanho do artigo ou dica é grande ou pequeno, o que me importa é se com a informação se atinge o objetivo final, que no caso, é instalar o aMule, e se alguém seguir o artigo, ele irá conseguir. Portanto, pra mim tá de bom tamanho. ;D

[4] Comentário enviado por alessandrossp em 05/03/2006 - 03:42h

Acho que o cara que escreveu esta colaborando para os mais desavisados como eu que não sabia que era necessário o wxWidgets para rolar essa porcaria de programa... Já tentei XMule, Imule e Amule, estava atrás do BMule, do Cmule etc... pois não o fazia funcionar de forma alguma.... Em casa vou tentar essa dica do cara para ver se rola... Acho tbém que antes de criticar temos que mostrar que fazemos melhor... Se não funcionar em casa vou tentar outra dica etc, etc, etc... Linux é assim mesmo é tentativa e erro até acertar.

[5] Comentário enviado por coffnix em 05/03/2006 - 03:51h

aí é q tá! no Slackware 10.2, pra rodar perfeitamente basta usar a wxGTK 2.6.1...

segue os link dos TGZ... é só installpkg e boa galera! sem erro, sem complicação.

wxGTK: http://www.linuxpackages.net/pkg_details.php?id=6562
aMule: http://www.linuxpackages.net/pkg_details.php?id=6560


obrigatorio rodar o amule versão 2.0.3

o novo tá cheio de bugs!! abraços



agora, uma observação: porque ao invés de make install, você não recomendou o comando:

# checkinstall -y -S ????????

O -S é para fazer diretamente um pacote para slackware, e o -y é para responder automaticamente “sim” para todas as perguntas. Outras opções, estão disponíveis na man-page do checkinstall

[6] Comentário enviado por PCMasterPB em 05/03/2006 - 07:34h

chemonz , acho que sobre o comando # checkinstall -y -S, sirva para o Slack, mas não em outras distros, acho que foi por isso que ele optou por # make install mesmo. Ele poderia também ter compilado o wxGTK e wxWidgets e depois, numa distro baseada em pacotes RPM, fazer um # rpmbuild -ta aMule-2.1.0.tar.gz e com isso gerar um pacote de instalação RPM, contudo, distros que não usam sistemas de pacotes RPM não poderiam aproveitar o artigo. Eu mesmo compilei no Suse, pq minha máquina dá pra fazer isso, porém, tive de criar um pacote de instalação RPM, pois numa máquina fraquinha que tem aqui, compilar nem pensar, demora demais. ;D

[7] Comentário enviado por ghodoy em 05/03/2006 - 13:59h

Concordo..........O artigo me sanou duvidas.....e cinceramente.....creio que agora posso instalar sem erros....valeu pelo artigo

[8] Comentário enviado por removido em 06/03/2006 - 20:22h

Só uma coisinha para os iniciantes em compilação:

Faltou o
$ ./configure
antes do make

[9] Comentário enviado por m3ocs-d4rksun em 06/03/2006 - 20:31h

sorry

[10] Comentário enviado por pa72 em 07/03/2006 - 15:48h

Além de tudo, o artigo está errado! Falta o ./configure!

É bom as pessoas quererem ajudar, mas é bom tambem que não criem confusão nos outros!

Para publicar artigos como este, para quê a moderação? Mais vale publicar tudo e deixar de haver lista de espera de 3 meses. Assim alguns artigos quando saem já perderam atualidade - como este, pois já saiu o aMule-2.1.0 tem mais de um mês.

Para saber quais as dependências do aMule - ou de outro programa qualquer - é só executar o ./configure que ele vai avisar todas as que estão faltando. Não precisa procurar em artigos ...

[11] Comentário enviado por andrefranca em 07/03/2006 - 22:20h

pa72, estamos vivendo um momento bom para a comunidade linux. Cada dia mais e mais pessoas estão instalando o SO em suas máquinas em casa. Isso para nós é excelente, pois assim, cada dia mais nossa comunidade será mais forte.

Falo isso, pois eu tenho certificações Micro$oft, sempre respirei Micro$oft, e hoje estou descobrindo a maravilha que é trabalhar com linux, respirar um ar mais puro.

Creio que atitudes como a sua desestimulam qualquer um a tomar a iniciativa de escrever uma dica ou artigo. E se não é pra ajudar, porque atrapalhar?

No mais, só tenho a agradecer ao nosso amigo m3ocs-d4rksun a contribuição, e garantir que eu não sou o único usuário que ficou satisfeito com o que leu em seu artigo.

Sucesso a todos, e

Viva o linux.

[12] Comentário enviado por m3ocs-d4rksun em 07/03/2006 - 22:24h

valew pelo apoio...
fico feliz que me tenha apoiado.. ehhe

[13] Comentário enviado por pa72 em 09/03/2006 - 10:05h

A comunidade so será reforçada se os artigos tiverem informação válida. No caso contrario as pessoas vão procurar outros sitios para obter informação (ou ficam confundidas e voltam p'ro ruindows)

O VOL tem uma boa reputação na comunidade Linux que deve ser defendida - tem 587 artigos e 493 dicas reprovados - a moderação faz o seu trabalho (neste caso falhou).

É bom ter muita gente a escrever artigos, mas que sejam válidos, com informação correta e que acrescentem valor e prestígio ao VOL.

Isto não é uma corrida a ver quem escreve mais artigos, para mostrar para a namorada que ja tem x pontos.

Não são os meus comentarios que atrapalham, as informações erradas é que atrapalham.

Quanto ao autor, em vez de fazer o papel do coitado ("obrigado pelo apoio..."), deveria assumir os erros e para a próxima documentar-se melhor antes de publicar o artigo. Estarei cá também para reconhecer e louvar os pontos positivos, se for o caso.

Isto não é nenhum ataque nem ofensa pessoais.
(Ao contrário de algumas mensagens privadas que recebi entretanto...)

[14] Comentário enviado por m3ocs-d4rksun em 09/03/2006 - 15:00h

não é coitado..
as pessoas me apoiaram.. você é o unico que está criticando-me...
não acho que estou errado..
acho que em vez de criticar... deverias publicar mais artigos...
creio que você não ajude muito na comunidade linux....

[15] Comentário enviado por U-Neeks em 09/03/2006 - 22:21h

po nunca tive problema em instalar o amule, mas praticamente toda vez que vou instalar algum programa q nao conheço, dou uma olhadinha aki ou em outro site, pra ver se tem alguma dica etc.. só o fato de saber os arquivos q o programa depende e que compila de boa usando os comandos padroes já facilita bastante..

(o amule 2.1.0 tava usando muita memoria e cpu .. ae voltei pro 2.0.3 que esta bem melhor.)

legal o artigo, acredito q vai ajudar muita gente. principalmente q ainda nao tem experiencia com o linux.

flws

[16] Comentário enviado por paulloal em 22/03/2006 - 07:44h

não consigo instala as depedencias dis que
make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.
[email protected]:/home/kurumin/wxGTK-2.6.2# make install
make: *** Sem regra para processar o alvo `install'. Pare.
[email protected]:/home/kurumin/wxGTK-2.6.2#

por que acontece isso..?
valeu

[17] Comentário enviado por coffnix em 22/03/2006 - 16:26h

Paulloal, instale o tgz da versão anterior... dá certo

http://www.linuxpackages.net/pkg_details.php?id=6562

flw

[18] Comentário enviado por led zeppelin em 29/03/2006 - 23:32h

Aew paulloal... o erro acontece por que no artigo foi esquecido de dizer que tem que dar o comando:

./configure antes do make. Na documentação do wxGTK diz pra executar:

$./configure --with-gtk
$make
#make install

Na do wxWidgets diz pra executar:

$./configure --with-x11
$make
#make install
#ldconfig


tenta aí.


flws.

[19] Comentário enviado por removido em 31/03/2006 - 10:04h

Olha só!, cheguei aqui justamente porque instalei o aMule pelo tgz e ele não funciona, (assim como o bendito Kaffeine), no Kurumin não tem rolo basta um apt-get e tudo funciona, instalei o slapt-get, slackpkg, tentei o swaret (esse nao acho) mas nada funciona..

Agora descobri que faltam dependencias (no slackzine crypto, gd, wxbase e wxGTK) aqui fala no wxWidgets, meio confuso, mas dane-se, vou tentar tudo isso (nao achei no linuxpackage o crypto, mas vai que funciona sem ele)

Mas pelo menos achei essas informacoes que faltavam e que pode resolver o problema. Receita de bolo bem feita pro Linux não existe, mas pequenas dicas podem dar o rumo, isso é que vale.

[20] Comentário enviado por removido em 31/03/2006 - 11:07h

Ok, instalei o gd-2.0.26, wxBase e o wxGTK e a coisa funcionou....

[21] Comentário enviado por skateboarder em 31/03/2006 - 11:25h

há dias atrás eu instalei o xMule, graças ao 'checkinstall -S' [sim, eu odeio ter que ficar baixando e/ou compilando o mesmo source sempre.], porém, ele SEMPRE me retorna lowid. vc tem idéia do que pode ser?

D-Link 500g -> ADSL 500Kbps by Speedy da Lixofônica.
Slackware 10.2 -> Kernel 2.4.31
não me lembro qual porta ele usa e não tenho conhecimento de quaisquer firewalls instalados, seja iptables/ipchains ou de terceiros. unicamente a opção '1 - standalone', escolhido dentro do # pppoe-setup.

ps: caso não consiga identificar o problema, eu mudo pro aMule pra ver se resolve.

[22] Comentário enviado por lucianodj em 06/04/2006 - 22:17h

Olá pessoal,

me desculpem a ignorancia, mas li todos os posts acima e ainda to com dúvida! Comecei a usar linux esta semana e tá meio complicado a instalação de programas, apesar do apt-get.
To usando o Kurumin 6.0 beta1a e gostaria de saber se digitar:
apt-get install amule »» resolve meu problema ou tenho que fazer mais algo?
Obrigado antecipadamente :)

[23] Comentário enviado por removido em 07/04/2006 - 09:04h

sim, desde que:
tenha feito um apt-get update,

pra atualizar os mirros e, esteja conectado a internet, senão terias que fazer um apt-get no cd-rom onde teria o programa... me corrijam se tiver errado...

[24] Comentário enviado por removido em 07/04/2006 - 09:06h

skateboarder:

Aqui eu sempre recebo lowid, porque o serviço de adsl é que barra ou digamos coloca esse tipo de impencilho... pode ser que a telefonica esteja fazendo isso

[25] Comentário enviado por santoskywalker em 07/04/2006 - 18:59h

Olá, to tentando instalar o amule mas ta dando um pau na hora de instalar o wxGTK, eu tenho o GTK instalado mas ele da essa mensagem:

checking for GTK+ version...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the*** exact error that occured. This usually means GTK+ is incorrectly installed.configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

[26] Comentário enviado por m3ocs-d4rksun em 07/04/2006 - 19:33h

tente reinstalar o GTK+ apartir da source...
[]'s darksun

[27] Comentário enviado por santoskywalker em 07/04/2006 - 20:18h

putz já tentei e continua dando pau... tem algo como um path que pode estar errado!(interrogação)

[28] Comentário enviado por PCMasterPB em 08/04/2006 - 17:58h

santoskywalker,
De acordo com a msg:

checking for GTK+ version...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no

Vc não tem instalado em seu sistema o GTK+ da versão 2.0 ou superior, e provavelmente seus arquivos de desenvolvimento. Não sei qual é sua distro, mas as que se baseiam em pacotes RPM isso é resolvido ao se instalar o pacote do GTK+-2.x e seu respectivo pacote devel. Não confunda GTK+-1.x e GTK+-2.x, são versões diferentes das bibliotecas GTK. Qualquer coisa, entre nessa URL:

http://www.gtk.org/download/

E baixe uma das versões 2.x (aqui em minha distro estou usando a 2.6) e veja se o problema continua. Isto é claro, se vc for compilar vc mesmo, caso queira pacotes RPM, dê uma procurada nos CD's de sua distro ou na boa e velha web por pacotes para ela ok. Isto, acho eu, deve sanar seu problema. ;D

Qualquer novidade, nos avise ok! Boa Sorte!

[29] Comentário enviado por arkanum em 08/05/2006 - 22:54h

Não estou conseguindo compilar. Dei o comando abaixo e deu erro:

[email protected]:/mnt/hd3/wxGTK-2.6.3$ ./configure --with-gtk
-bash: ./configure: /bin/sh: bad interpreter: Permission denied

Onde estaria o erro?

[30] Comentário enviado por coffnix em 11/05/2006 - 23:59h

caro arkanum,

Para compilar não, mas para instalar qualquer programa, vc deve estar obrigatoriamente como root.

$ su

[31] Comentário enviado por jcneves em 20/08/2006 - 16:27h


Instalando o wxGTK-2.6.2:

$ tar -zxvf wxGTK-2.6.2.tar.gz
$ cd wxGTK-2.6.2
$ ./configure
$ make
$ su
# make install

Instalando o wxWidgets-2.6.2:

$ tar -zxvf wxWidgets-2.6.2.tar.gz
$ cd wxWidgets-2.6.2
$ ./configure
$ make
$ su
# make install

Estou usando esses procedimentos para instalar esses arquivos, só que o comando "make" não é reconhecido, aparece a msg "command not found". O que isso quer dizer??

Como vcs perceberam, eu não sei nada de Linux.

Obrigado

[32] Comentário enviado por PCMasterPB em 21/08/2006 - 09:02h

jcneves, isso acontece pq vc não tem instalado o make, e provavelmente tb não tem instalado o gcc, instale os dois para facilitar sua vida no linux ok. ;D

[33] Comentário enviado por quartodazona em 21/08/2006 - 15:52h

Olá gente! Ontem eu havia tentado instalar o amule em meu Slackware 10.2 e fiz todos os procedimentos acima. Primeiro o installpkg, ./configure, make (que demorou pra burro!), depois o make install. Belezinha!

O problema:

Quando eu chamo o "amule" pelo shell, aparece a seguinte mensagem:

"amule": error while loading shared libraries: libwx_gtk-2.4.so: cannot open shared object file: No such or directory

http://i21.photobucket.com/albums/b295/pombo666/Informatica/amule.jpg

Eu não havia instalado o wxWidgets-2.6.2 será que é por isso? Porque no outro tutorial não havia sido especificado isso.

[34] Comentário enviado por jcneves em 03/09/2006 - 12:13h

checking for --enable-official_build... no
saving argument cache configarg.cache
checking for toolkit... gtk
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
[[email protected] wxWidgets-2.6.2]$

Por favor, alguem pode me dizer o que é isso. Aconteceu após o comando "./configure". Apareceu uma serie de "Enable..." e em seguido isto que colei acima.

Muito Obrigado

[35] Comentário enviado por Raptor em 04/11/2006 - 01:35h

jcneves você deve instalar o pacote gcc. Provavelmete resolverá seu problema.

[36] Comentário enviado por zerax em 12/11/2006 - 19:34h

[email protected]:~$ cd gtk+-2.10.3
[email protected]:~/gtk+-2.10.3$ /configure --with-gtk
-bash: /configure: Arquivo ou diretório não encontrado
[email protected]:~/gtk+-2.10.3$ ./configure --with-gtk
./configure: line 1225: config.log: Permission denied
[email protected]:~/gtk+-2.10.3$ ./configure --with-gtk
./configure: line 1225: config.log: Permission denied
[email protected]:~/gtk+-2.10.3$ su
[email protected]:/home/xarez/gtk+-2.10.3# ./configure --with-gtk
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for native Win32... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/i486-slackware-linux/bin/ld
checking if the linker (/usr/i486-slackware-linux/bin/ld) is GNU ld... yes
checking for /usr/i486-slackware-linux/bin/ld option to reload object files...-r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... g77
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether g77 accepts -g... yes
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/i486-slackware-linux/bin/ld
checking if the linker (/usr/i486-slackware-linux/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for g77 option to produce PIC... -fPIC
checking if g77 PIC flag -fPIC works... yes
checking if g77 supports -c -o file.o... yes
checking whether the g77 linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
checking for nm... /usr/bin/nm -B
checking whether to enable maintainer-specific portions of Makefiles... no
checking for some Win32 platform... no
checking whether build environment is sane... yes
checking for strerror in -lcposix... no
checking for gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether make sets $(MAKE)... (cached) yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for BASE_DEPENDENCIES... Requested 'glib-2.0 >= 2.12.0' but version of GLib is 2.6.1
configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
[email protected]:/home/xarez/gtk+-2.10.3# por caranba ta dificio intalar o amule no slack 10.1 alguem poderia me ajudar?

[37] Comentário enviado por IcePeak em 26/12/2006 - 15:45h

Po irmao! suas libs tao fora do q ele pede! basta lerrr!!!

Precisa do glib 2.12, do pango 1.12 e do cairo 1.2


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts