Instalação do aMSN-0.97b em três maneiras diferentes

Instalação do mais famoso clone do MSN Messenger. Para você que várias vezes se deparou com problemas durante sua instalação, aqui encontrará várias formas de instalar e proliferar o uso do aMSN!

[ Hits: 97.209 ]

Por: Rafael Silva de Santana em 14/04/2007


Um pouco sobre o aMSN



Hoje no mundo da tecnologia e informação, quem por uma vez já não escutou falar de Instant Messenger ou Mensageiro Instantâneo? É por essa e outra que você usuário Linux merece ganhar uma matéria dedicada a um dos mais conhecidos IM (Instant Messenger) para Linux. O aMSN!

O aMSN é um programa de mensagens instantâneas via Internet que foi desenvolvido para ser um "clone" do MSN Messenger. É uma aplicação que permite o envio e recebimento de mensagens de texto em instantes. Através destes programas o usuário é informado quando algum de seus amigos, cadastrados em sua lista de contatos, está online, isto é, conectou-se à rede. A partir daí, eles podem manter conversações através de mensagens de texto as quais são recebidas pelo destinatário em poucos segundos.

Desenvolvido por Álvaro J. Iradier utilizando a linguagem Tcl/TK sob a licença GPL, é um programa leve que não consome muita memória e incorpora diversos outros recursos, como envio de figuras ou imagens animadas (emoticons), mensagens em áudio (VoiceClips) - utilizando as caixas de som e microfone do sistema, além de vídeo conferência (webcam), pode rodar em várias instâncias (múltiplos logins), transferência de arquivos, suporte a grupo, histórico de chat, suporte à conferência, suporte a Proxy, configuração de fontes, diferentes profiles por login, detecção de contatos que o removeram da lista, controle remoto, etc. Aceita troca de peles (skin) que podem ser baixadas no Site oficial. Também suporta o acréscimo de plug-ins como o aMSN Plus!, semelhante ao Messenger Plus com ferramentas como nick colorido e comandos na própria janela de conversação. Por ser escrito em Tcl/TK o software é multiplataforma, o que significa que roda em todos os Sistemas Operacionais (Windows, Linux, Macintosh, etc) que possuam Tcl/Tk instalado.

Neste artigo iremos mostrar três maneiras muito eficientes de promover a instalação do aMSN em sua versão beta a 0.97 com suporte anti-aliasing.

Para quem não sabe o que é aliasing, comumente conhecido como serrilhado, é o efeito em forma de serra ao formar uma reta em diagonal, deixa "dentes", não formando uma reta perfeita. Portanto parece uma serra, que é de onde vem o nome. Este efeito ocorre devido ao fato dos monitores possuírem divisões discretas (pixel).

Logo, Anti-aliasing é uma contrapartida para acabar com esse efeito, assim formando uma reta perfeita. O Anti-Aliasing embaça essas bordas dando a impressão visual de um contorno mais suave. Esta técnica é muito conhecida na pintura tradicional.

Mais informação no site do projeto:
Então chega de conversa e mãos a obra!

    Próxima página

Páginas do artigo
   1. Um pouco sobre o aMSN
   2. Maneira 1: Instalando o aMSN-0.97b via SVN
   3. Maneira 2: Instalando aMSN em pacote .deb
   4. Maneira 3: Instalação do aMSN-0.97b em .deb, mas com a cara do SVN
   5. Conclusão
Outros artigos deste autor

Livre arbítrio - exerça!

Exclusivo - Entrevista com Fábio Berbert, criador e mantenedor do projeto Viva o Linux!

RSS - O antes e o depois já nas bancas!

Sistemas Operacionais - Experiência

Use Linux!

Leitura recomendada

Transmission-CLI - Gerenciando torrents via CLI

Compartilhando acesso à internet com iptables

Comportamento das tecnologias WEB e seus meios de acesso

MSN-Proxy no Debian Etch

Openfire em Ação nos meios Corporativos

  
Comentários
[1] Comentário enviado por tenchi em 14/04/2007 - 15:10h

O aMSN tem coisas que o seu priminho MSN não tem, como poder 'roubar' a foto das pessoas da sua lista de contatos, e é claro, dezenas de plugins, como o chamelon, que permite a mudança da aparencia, verificar os e-maisl do gmail, tradutor iinstantaneo (em vários idiomas), verificador ortografico, dentre outras centenas de recursos.
Pena se mostrar bastante instável (não sei se é por eu estar usando a versão superinstavel do tcl/tk).
Mas mesmo assim é um ótimo programa.

[2] Comentário enviado por nunesvictor em 14/04/2007 - 16:28h

pow...e pas outras distro???

qria ver como faz isso Slackware :p

se me ajudar vou fikar bem agradecido

flwz

[3] Comentário enviado por andreotti em 14/04/2007 - 19:50h

vitimnunes...

tenta pelo yum

# yum install amsn

[4] Comentário enviado por tenchi em 14/04/2007 - 21:55h

vitimnunes, no slack eh facil:
Baixe a tcl-8.5 e compile com a opção --prefix=/usr
baixe o tk-8.5 e compile com a opção --enable-xft --prefix=/usr
baixe o tile (no site http://tktable.sourceforge.net/) e compile normalmente.
baixe o amsn:
http://amsn.sourceforge.net/amsn_dev.tar.gz (tarball)

Ou:
$ svn co 'https://amsn.svn.sourceforge.net/svnroot/amsn/trunk/amsn/' amsn
$ cd amsn/
$ ./configure --prefix=/usr --with-tcl=/usr/lib --with-tk=/usr/lib
$ make
$ make install

em seguida, entre no seu diretótio de confs do amsn (~/.amsn/ ou /usr/share/amsn/) - recomendo a segunda opção - e:
$ rm -r {plugins,skins}
$ svn co 'https://amsn.svn.sourceforge.net/svnroot/amsn/trunk/amsn-extras/plugins' plugins
$ svn co 'https://amsn.svn.sourceforge.net/svnroot/amsn/trunk/amsn-extras/skins' skins

Voialá! Está instalado o SuperaMSN no seu slack (ou qualquer outra distro)!!!
Ah, eu até disponibilizaria os pacotes já compilados, mas recomendo que vc compile dos fontes, que é mais seguro, por assim dizer.

Ah, e deixo claro aqui que com esse processo vc não deve reclamar da instabilidade do programa. os bugs serão muitos, e recomendo que vc os reporte aos desenvolvedores.


Cierrto?

[5] Comentário enviado por fulllinux em 14/04/2007 - 22:08h

vitimnunes...

O aMSN é um aplicativo totalmente flexível no ato de sua instalação. Então para instalação no Slackware fica facil, é só baixar os fontes como o amigo "tenchi" disse acima, descompactar e compilar assim como foi esplicado na 1ª maneira de instalação...

No Slack vc pode utilizar algumas flag's como abaixo.

tcl
./configure --prefix=/usr --sysconfdir=/etc --enable-shared
ou
./configure --prefix=/usr

tk
./configure --prefix=/usr --sysconfdir=/etc --enable-shared --enable-xft
ou
./configure --prefix=/usr --enable-xft

e no aMSN um simples:
./configure --prefix=/usr --with-tcl=/usr/lib/ --with-tk=/usr/lib/

Qualquer problemas reporte.

Aew pessoal vlw pelo apoio!

[6] Comentário enviado por fulllinux em 14/04/2007 - 22:17h

Nossa comunidade no Orkut

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[7] Comentário enviado por f360c4 em 16/04/2007 - 14:18h

aki nem deu certo

FIZ do jeito que esta ae em cima e me falha no FINAL :( . . bom to com o kurumin aki

root@cpd03:/usr/src/amsn# ./configure --prefix= /usr --with-tcl= usr/lib/ --with-tk= /usr/lib/
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /usr
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: usr/lib/
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /usr/lib/
configure: error: Your current Tcl/Tk installation has a version number of 8.3. The minimal version required for aMSN to run is Tcl/Tk 8.4

alguem ajuda?

[8] Comentário enviado por User-kuruma em 16/04/2007 - 15:14h

Amigo tenho o tk e tlc 8.4, junto com o aMSN 0.96 instalados(sem anti-aliasing). O tk e tcl eu instalei através de pacotes .deb e o aMSN eu compilei e criei um pacote .deb seguindo a dica do blog do dudanogueira.com.br. Para instalar o aMSN 0.97 da 1° maneira que você explicou eu devo desinstalar primeiro o tk e tcl, pra compilar e instalar o 8.5 e depois desinstalar o aMSN 0.96 e compilar e instalar o do SVN? Ou posso instalar tudo por cima?

[9] Comentário enviado por fulllinux em 16/04/2007 - 17:22h

f360c4...

Primeiro vc de instalar as versões 8.5 do tcl tk, pq aversão instalada no seu sistema consta como sendo 8.3 e não irá te dar o suporte necessário para a libXft.so.2, então vc naum terá o suporte anti-aliasing.

Segundo vc deve corrigir os comandos que vc digitou assima... existem falhas na sua digitação então ele nao alcança o diretório /usr/lib/, as linha tem que ser assim:
# ./configure --prefix=/usr --with-tcl=/usr/lib/ --with-tk=/usr/lib/

Qualquer dúvida entre encontato!


User-kuruma...

Kara, sim é recomendo que vc remova as versões anterios por uma questão de incompatibilidade, porém, já fis este tipo de instalação sem precisar remover o tcl/tk em sua versão anteriormente instalado e não me deu problemas... simplesmente removi o amsn instalei as versões 8.5 do tcl/tk e o aMSN-0.97b via SVN e fui bem sucedido!

Qualquer dúvida estamos a disposição!

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[10] Comentário enviado por User-kuruma em 16/04/2007 - 19:12h

Cara fiz a instalação dos TK 8.5 e TCL8.5 e do aMSN do SVN. So que ao invés de dar um make, dei um make DEB e criei um pacote .deb. O problema foi que o anti-antialinsig não foi ativado.

[11] Comentário enviado por fulllinux em 16/04/2007 - 20:36h

User-kuruma...

Faça o seguinte então...

Remova o TCL/TK ao qual vc instalou e faça o get deles já no seu formato pré-compilado, siga da seguinte maneira:

$ cd /usr/src/
$ wget -c http://kaisman.free.fr/tcl_tk/tcl8.5a3_8.5a3-1_i386.deb
$ wget -c http://kaisman.free.fr/tcl_tk/tk8.5a3_8.5a3-1_i386.deb
# dpkg -i tcl8.5a3_8.5a3-1_i386.deb
# dpkg -i tk8.5a3_8.5a3-1_i386.deb
# cd /usr/lib
# ln -sf libtk8.5.so.0 libtk8.5.so
# ln -sf libtcl8.5.so.0 libtcl8.5.so

Agora reinicie o seu X e acesse o seu aMSN

$ amsn &

Qualquer problema é só relatar!

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[12] Comentário enviado por User-kuruma em 16/04/2007 - 23:44h

Desculpe incomodar mais uma vez. Eu instalei o tk e o tcl pelos fontes, compilando como na sua instrução de número 01. Agora como faço pra desinstalar o tk e o tcl instalado dos fontes? O aMSN com um sudo apt-get remove amsn tá desinstalado, mas o tk e tcl desconheço os comandos pra desinstalar. Apesar que acredito que o problema é do pacote do aMSN que criei e não do tk e tcl.

[13] Comentário enviado por fulllinux em 17/04/2007 - 08:09h

User-kuruma...

Primeiramente era para desinstalar só o TCL/TK e não o aMSN, mas como vc o desinstalou terá que refazer todo o procedimento de instalação!

Quanto a desinstalação do TCL/TK, vc disse que criou um pacote DEB durante o processo de make, então é só vc dar o seguinte comando:

# dpkg -r <nome_atribuido_ao_pacote>.deb

Já que vc desinstalou o aMSN e irá remover o TCL/TK, sugiro que vc faça todo o procedimento número 1 e dessa vez sem usar o MAKE DEB, porque isso poderá desabilitar as flag's programadas para rolar o TCL/TK e o mais importante que é o anti-aliasing.

Quanto ao incomodo isso naum existe para mim pode ficar tranquilo, pois, estou acostumado a responder todas a pergutas em nossa comunidade no Orkut!

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[14] Comentário enviado por f360c4 em 17/04/2007 - 08:52h

OBRIGADO AE . . OTIMO ARTIGO PARABENS
FUNFOU . . PODER

[15] Comentário enviado por User-kuruma em 17/04/2007 - 09:54h

Amigo eu iniciei a instalação do aMSn da maneira número 01. Compilei o tk e o tcl e instalei sem criar o pacote .deb. Quando ia instalar o aMSN propriamente dito que criei o pacote .deb somente do aMSN. Eu desinstalei o aMSN com o sudo apt-get remove amsn, porém com o tk e tcl isso não funciona por que não criei os .debs dos mesmos. Será que posso instalar tudo por cima: os tk, tcl e amsn em .deb?? Valeu e muito obrigado pela atenção!

[16] Comentário enviado por fulllinux em 17/04/2007 - 10:29h

User-kuruma...

Você pode disfuncionar os já instalados deletando as pastas TCL/TK que encontram-se no diretório /usr/lib, simplesmente para naum dar problemas de incompatibilidade.

Mas vc pode sim reinstalar tudo por cima em .deb mas nuam esqueca de linkar o TCL/TK para que o aMSN os possa enxerga-lo.

# cd /usr/lib
# ln -sf libtk8.5.so.0 libtk8.5.so
# ln -sf libtcl8.5.so.0 libtcl8.5.so

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[17] Comentário enviado por paulloal em 17/04/2007 - 16:11h

eu instalei o tk8 tcl8 so que quando vou instar o amsn ele nao encontra o tcl8 e o tk8..

ta seguinho o amsn kkk
como resolver isso

[18] Comentário enviado por humbhenri em 17/04/2007 - 18:39h

Problemas na compilação do tk:
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1283: erro: syntax error before ')' token
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1283: erro: syntax error before ')' token
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1284: erro: syntax error before ')' token
/home/humberto/tk8.5a5/unix/../generic/tk3d.c: Na função 'TkDebugBorder':
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1364: erro: 'borderPtr' undeclared (first use in this function)
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1367: erro: invalid operands to binary *
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1367: erro: syntax error before ')' token
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1370: erro: request for member 'borderTable' in something not a structure or union
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1370: erro: request for member 'borderTable' in something not a structure or union
/home/humberto/tk8.5a5/unix/../generic/tk3d.c:1372: erro: syntax error before ')' token
make: ** [tk3d.o] Erro 1

Tem um monte de linha como essa. Parece erros fáceis de corrigir, mas são em um monte de linhas. Outro problema tive quando instalei os pacotes deb, na instalacao do amsn falava que estavam faltando os pacotes tcl e tk, só que eles foram instalados corretamente, daí o pacote amsn ficava quebrado. Até que o amsn funciona, mas nao dá pra instalar mais nada pelo apt-get porque ele reclama que o pacote tá quebrado e o único conserto é desinstalar o amsn.

[19] Comentário enviado por sidiney em 17/04/2007 - 18:54h

Consegui instalar o AMSN, segui os passos corretamente no kurumin, foi um pouco trabalhoso e fiz via SVN, mesmo o kuruma sendo uma distro debian, consegui instalar tranquilo! Valeu, obrigadão rafael, já num sabia mais o que fazer pra conseguir atualizar o messenger.

[20] Comentário enviado por fulllinux em 17/04/2007 - 23:08h

paulloal...

Como vc fez a instalação dos pacotes TCL/TK 8.5 pelos fontes ou precompilados .deb?

Se foi pelos fontes vc naum terá erro se na hora de sua compilação vc usou os flag's que citei... é lógico que existem inumeros outros mas estes atiram no local certo para o aMSN achalos!

Agora se vc usou os pre-compilados vc pode ter algum erro de incompatibilidade de distro então vou disponibilizar uma um link para vc que conserteza irá dar certo!

http://download.sougeek.net/pacotes/debian/tcl8.5_8.5.0.a5-3v1ubuntu0_i386.deb
http://download.sougeek.net/pacotes/debian/tk8.5_8.5.0.a5-3v1ubuntu0_i386.deb

Esses links são do nosso amigo Tiago da comunidade aMSN Brasil / Linux lá no Orkut

Mas não se esqueça de linka-los pra o aMSN poder utilizalos...

# cd /usr/lib
# ln -sf libtk8.5.so.0 libtk8.5.so
# ln -sf libtcl8.5.so.0 libtcl8.5.so

humbhenri...

Parece que a fonte que vc baixou quebrou durante o download... Quanto a os pacotes .deb vc pode baixa-los nos links que citei acima! e linka-los como já citei para que o aMSN possa usa-los. Depois rode o comando:

# apt-get install -f

Para que ele possa ajustar algo que falte e então abra seu aMSN.

sidiney...

Legal kara fiquei contente... muitos iguais vc estão me agradecendo via email e fazendo outras questões, fico muito contente!

aMSN Brasil / Linux
http://www.orkut.com/Community.aspx?cmm=768392

[21] Comentário enviado por nilpgs em 17/04/2007 - 23:35h

Ola, tem como instalar o Amsn 0.97b no Suse 10.2???

[22] Comentário enviado por paulloal em 18/04/2007 - 01:06h

fulllinux

pelomenso deu pra instala

ta fis tudo isso que vc disse quando vou abrir da isso

wish: error while loading shared libraries: libtk8.5.so: cannot open shared object file: No such file or directory

o que ser? ajude-meee
valeu fulllinux

[23] Comentário enviado por fulllinux em 18/04/2007 - 19:32h

nilpgs...

Sim... temos vários pacotes rpm no site http://rpm.pbone.net/
mas tambem pode ser instalado pelos fontes!

paulloal...

O aMSN não está fazendo a leitura do libtk8.5.so ao qual vc fez tal link! A conselho que remova o TK e refaça a instalação... remova ele por completo inclusive o link que vc criou da seguinte maneira:

# dpkg -r tk8.5_8.5.0.a5-3v1ubuntu0_i386.deb
# rm -rf libtk8.5.so.0 libtk8.5.so

depois refaça a instalação do TK novamete, mas dessa vez vou passar um pacote deb testado e aprovado de um outro link que diponibilizei siga da seguinte maneira:

# cd /usr/src
# wget -c http://www.eportifolio.com/downloads/tk8.5_8.5.0-1~neto3_i386.deb
# dpkg -i tk8.5_8.5.0-1~neto3_i386.deb
# cd /usr/lib
# ln -sf libtk8.5.so.0 libtk8.5.so

Reinicie o seu X se caso for preciso e abra seu aMSN


[24] Comentário enviado por humbhenri em 18/04/2007 - 22:19h

Acho que pra mim não vai ter jeito. Tá pedindo aki uma libc6 mais nova do que a que tem no ubuntu dapper. Será que só atualizando pro edgy :( ?

[25] Comentário enviado por fulllinux em 19/04/2007 - 10:04h

humbhenri...

Já instalei tambem no Dapper, mas parece que estão atualizando as dependencias para esse aplicativo... Então se quizer atualizar para Edgy, abra seu sources.list e troque todas de Dapper de Edgy. Depois faça o update do seu Ubuntu e tente a reinstalação de seu aMSN novamente.

Se bem, creio que não seja esse o problema!

[26] Comentário enviado por paulloal em 19/04/2007 - 10:11h

FULLINUX

agora deu pau no tcl8.5..

:( so comigo que acontece isso aloko
se tem outro link para o tcl8.5 ?

[27] Comentário enviado por fulllinux em 19/04/2007 - 10:31h

paulloal...

Kara até tenho porém ainda naum testei este pacote.... mas naum custa nada tentar naum é?

O tk8.5 que vc baixou eu mesmo o disponibilizei pela noite... posso fazer o mesmo com Tcl porem agora estou desprovido deste pacote... mas se não quiser esperar tente com o link que diponibizei abaixo e siga como o seguinte:

# dpkg -r tcl8.5_8.5.0.a5-3v1ubuntu0_i386.deb
# rm -rf libtcl8.5.so.0 libtcl8.5.so

# cd /usr/src
# wget -c http://jacques2203.perso.cegetel.net/paquets/tcl8.5_8.5-1_i386.deb
# dpkg -i tcl8.5_8.5-1_i386.deb
# cd /usr/lib
# ln -sf libtcl8.5.so.0 libtcl8.5.so

[28] Comentário enviado por paulloal em 19/04/2007 - 23:19h

deu isso agora

root@paulloal-laptop:/usr/lib# wish: error while loading shared libraries: libtcl8.5.so: cannot open shared object file: No such file or directory

qdo manda me avisa

[29] Comentário enviado por fulllinux em 20/04/2007 - 00:00h

paulloal...

bom agora já disponibilizei o pacote TCL, mas primeiro remova esse que vc colocou:

# dpkg -r tcl8.5_8.5-1_i386.deb
# rm -rf libtk8.5.so.0 libtk8.5.so

depois refaça a instalação do TCL novamete, mas dessa vez vou passar um pacote deb testado e aprovado de um outro link que diponibilizei siga da seguinte maneira:

# cd /usr/src
# wget -c http://www.eportifolio.com/downloads/tcl8.5_8.5.0-1~neto3_i386.deb
# dpkg -i tcl8.5_8.5.0-1~neto3_i386.deb
# cd /usr/lib
# ln -sf libtk8.5.so.0 libtk8.5.so

Reinicie o seu X se caso for preciso e abra seu aMSN

e dessa vez vai!!!

[30] Comentário enviado por paulloal em 20/04/2007 - 01:30h

AAAAAAAAAAAHHHHHHHHHHHHHHHHHH

tem um modo mais facil.. hehe que eu achei
segue os comando para instalaçao .deb
quem usa o gnome
# gedit /etc/apt/sources.list
quem usa o kedit
#kedit /etc/apt/sources.list

adinao esse repositorios aque

deb http://download.tuxfamily.org/3v1deb edgy 3v1n0
deb-src http://download.tuxfamily.org/3v1deb edgy 3v1n0

depois faça isso

# apt-get update
# apt-get install amsn
# amsn
espera um pouco ai vai aparece uma janelinha ai clique en atualizar
e boa depois so
$ amsn

e curtir o novo amsn fico filé



[31] Comentário enviado por paulloal em 20/04/2007 - 10:57h

fulllinux

valeu pelas ajudas =D

[32] Comentário enviado por tyty em 24/04/2007 - 11:36h

Belo tutorial, instalei pelo svn, só q dá primeira vez deu um erro assim "Falha de segmentação", ai voltei e refiz todos os passos, desde a compilação das "libs", refiz o download do amsn do svn e mandei instalar, ai funcionou =)
Valeu pelo belo tutorial ae!
[]'s

[33] Comentário enviado por removido em 25/04/2007 - 19:21h

Estou usando Ubuntu 7.04 em um AMD64. Não está funcionando a instalação...
Estou seguindo a primeira parte do artigo, usando svn.
Baixo, compilo e instalo tudo normalmente, sem nenhuma mensagem de erro. Mas quando vou rodar o aMsn, abre a caixa de dialogo solicitando para instalar o TLS. Até ai tudo normal...
O problema é que eu mando baixar o tls, versao x86_64, ele baixa um arquivo e diz que instala. Quando eu vou executar o aMsn novamente, ele pede pra instalar novamente o TLS.
Via apt-get também não funciona, ele tenta instalar o tcl8.3 (que já está instalado por default no ubuntu).
Eu já tentei instalar a versão x86_64, a versão i386, até mesmo baixei o código fonte, compilei e copiei para a pasta das libs, mas mesmo assim não vai...
No aMsn tem uma configuração que pede pra informar o diretório do TLS se ele não localizar sozinho. Eu já tentei informar lá os diretórios /usr/lib/ e /usr/lib/tls/ e não funciona nem assim.

Alguém pode me ajudar ???

[34] Comentário enviado por fulllinux em 26/04/2007 - 09:54h

elieser_topassi...

Kara quando vc escolher a versão o TLS e ela instalar, logo em seguida vc tem que reiniciar o seu X, "CTRL + ALT + Backspace".

Não tente logar o aMSN sem antes reiniciar o seu X, OK!?

Agora se vc não conseguir faça o seguinte:

$ cd /usr/src
$ sudo wget http://easynews.dl.sourceforge.net/sourceforge/amsn/tls1.4.1-linux-x86.tar.gz
$ sudo tar xzf tls1.4.1-linux-x86.tar.gz
$ cd /usr/src/tls1.4
# mkdir /usr/lib/tls
# mv * /usr/lib/tls/

Depois informe o caminho para o aMSN.

tyty...

Valew pelo apoio!

paulloal...

Quando tiver dúvidas é só perguntar, Valew!

[35] Comentário enviado por removido em 26/04/2007 - 11:44h

já havia reiniciado o X sim... e tb o computador... mesmo assim nao tava indo...
bom, mas eu já consegui... para alguém que tiver tendo o mesmo problema, vou deixar abaixo o que encontrei em um maillist:

link: http://www.archlinux.org/pipermail/arch/2006-May/010838.html

conteudo:
I've fixed this now, the problem was described in the aMSN FAQ: in the
file /usr/lib/tls1.50/pkgIndex.tcl change 1.5 to 1.50, so the line
reads

package ifneeded tls 1.50 "[list load [file join $dir ..
libtls1.50.so] ] ; [list source [file join $dir tls.tcl] ]"

Mesmo assim obrigado fulllinux pela ajuda...

[36] Comentário enviado por samuK em 29/04/2007 - 23:50h

instalei tudo, entrou no amsn certinho, mas quando eu logo ele sai do programa. Com alguém deu isso? Há algo a fazer?
abraço

[37] Comentário enviado por teknoflight em 02/05/2007 - 15:06h

eu digito os comandos e acontece isso

[usuario@localhost ~]$ dpkg -i tcl8.5_8.5.0-1~neto3_i386.deb
bash: dpkg: command not found

oq fasso

Obrigado

[38] Comentário enviado por renators em 03/05/2007 - 19:14h

baixei e compilei pelo svn e funcionou perfeitamente! obrigado pelo artigo, cara.

uma coisa que ue notei que eu não sei se é bug do amsn, eu instalo as plugins elas aparecem na janela de plugins mas não tem opção de colocalas para uso ou configura-las.

[39] Comentário enviado por fulllinux em 03/05/2007 - 23:27h

samuK...

Nunca aconteceu isso comigo, mas mesmo assim vamos ver se conseguimos. Abra ele pelo terminal e poste o erro que dah!


teknoflight...

kara corrija está comando, faça assim:
$ sudo dpkg -i tcl8.5a3_8.5a3-1_i386.deb


renators...

Tente dar permissão para execução para esses pluguins assim:
# chmod -R +x [diretório onde se encontra os plugins instalados]

[40] Comentário enviado por leodneto em 06/05/2007 - 11:14h

desculpa cara, mais nao consegui.... de uns problemas e eu nao sei oq fazer... pode add no msn pra mi ajudar??
ou alguem q saiba como fazer isso, add tbm
pelo amor de deus
leo.dn@hotmail.com

[41] Comentário enviado por moisesfilocre em 06/05/2007 - 15:22h

é o seguinte no meu da isso ai:

quando eu vou insalar o amsn..

dpkg -i amsn_0.97b_tcl0.95.deb
(Lendo banco de dados ... 106651 arquivos e diretórios atualmente instalados.)
Preparando para substituir amsn 0.96RC1-1 (usando amsn_0.97b_tcl0.95.deb) ...
Descompactando substituto amsn ...
dpkg: problemas de dependência impedem configuração de amsn:
amsn depende de tcl8.5; porém:
Pacote tcl8.5 não está instalado.
amsn depende de tk8.5; porém:
Pacote tk8.5 não está instalado.
dpkg: erro processando amsn (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante processamento de:
amsn


ai tento instalar de novo as dependencias..

veje:

dpkg -i tk8.5a3_8.5a3-1_i386.deb
(Lendo banco de dados ... 106651 arquivos e diretórios atualmente instalados.)
Preparando para substituir tk8.5a3 8.5a3-1 (usando tk8.5a3_8.5a3-1_i386.deb) ...
Descompactando substituto tk8.5a3 ...
Instalando tk8.5a3 (8.5a3-1) ...

com outra acontece a mesma coisa..

não esta tudo instalado?
e pq ele fala q esta com dependecia e não esta instalado?

Abraços!

Desde ja agradeço!

[42] Comentário enviado por fulllinux em 07/05/2007 - 10:51h

leodneto...

Logo te add no aMSN!


moisesfilocre...

Os pacotes que vc baixou acima pode estár quebrado então estou passando links direto do meu portifólio para vc fazer os downlods!

http://www.eportifolio.com/downloads/tcl8.5_8.5.0-1~neto3_i386.deb
http://www.eportifolio.com/downloads/tk8.5_8.5.0-1~neto3_i386.deb
http://www.eportifolio.com/downloads/amsn_0.97b_tcl0.95.deb

Depois dos downloads vc instala como vc fez assima de pois da instalação não esqueça de rodar o comando:

# apt-get -f install

Para que ele instale dependencias pendentes!

Vlw...

[43] Comentário enviado por WeRx em 13/05/2007 - 14:57h

funciono blz.. so tive q resolver o problema de TLS. mas nda de mais...
vlw

[44] Comentário enviado por diegosilvacg em 15/05/2007 - 21:14h

Galera eu fiz a instalação só que quando inicio o amsn, ele da o seguinte erro:
Erro ao instalar o módulo TLS: Couldn't get http://switch.dl.sourceforge.net/sourceforge/amsn/tls-1.5.0-linux-x86.tar.gz

Se alguem puder me ajudar ficarei grato!!!!

[45] Comentário enviado por diegosilvacg em 15/05/2007 - 21:50h

Galera consegui resolver o problema, era so alterar um arquivo que jah esta instalado!!
Qualquer coisa tem ai como fazer
http://carlosdoki.wordpress.com/2007/04/24/amsn-097b-pedindo-instalacao-tls/
VLW

[46] Comentário enviado por spektrums em 16/05/2007 - 22:11h

E ai galera beleza?

Eu utilizo o Ubuntu 7.04 64 bits, tive um problema para a instalação da tls 1.5, o aMSN não conseguia baixar o arquivo nem com reza.
Para as pessoas que conseguiram instalar o aMSN 0.97, mas não consegiu instalar o raios do tls 1.5, lá vai a dica para vocês.
Como eu fiquei apanhando hoje o dia inteiro, pesquisando para lá e para cá, não acharia justo negar informações a comunidade que também me ajuda.

Deixe o seu aMSN fechado.

Abra o seu console, como root e abra o arquivo abaixo:

# vi /usr/lib/tls1.50/pkgIndex.tcl

Dentro deste arquivo, procure pela linha

ifneeded tls 1.5

Apenas inclua o 0(zeroooo) no final de 1.5 e vai ficar do seguinte modo:

ifneeded tls 1.50

Pronto acabou...

Salve o seu arquivo

Apertando o (ESC), aperte : e X e depois o enter.

Eu utilizei o pico, para editar o arquivo, para salvar, aperte CTRL + O e para sair CTRL + X.

Feito isso, já pode abrir o seu aMSN, comigo aconteceu dele ficar pesado, muito lento, tive que reiniciar o X para ele voltar ao normal, aperte CTRL + ALT + BACKSPACE.

Após reinicar o X acabou a tortura, pode abrir o aMSN e se divertir.

Espero que tenha ajudado.

Abraços a todos

[47] Comentário enviado por eduardok em 17/05/2007 - 16:36h

Ai Spektrums!!

Ptuz!! Tava com o mesmo problema!!!! Sua dica ajudou muito!!!!


Vlw

[48] Comentário enviado por vsauer em 20/05/2007 - 04:05h

Sou novo nesse mundo online linux, mas já me aventuro há pouco tempo.

Estou vendo em vários fóruns e site na net problemas pra instalar a versão 0.97b do amsn, e como eu optei por usar o Slack, creio que a resolução do meu sofrimento pode ajudar alguns.

Como todos estão enfrentando esse mal, o amsn não está baixando automaticamente o TLS, mas a fonte funciona. Logo, é só baixá-lo usando o endereço http://switch.dl.sourceforge.net/sourceforge/amsn/tls1.5.0-src.tar.gz
Baixando esse tar fica tudo mais tranquilo. A única diferença que ele tem em relação ao oferecido no site do projeto é que já etá corrigido o erro do arquivo pkgIndex, que todos falam acima.

Na hora de compilar a única diferença indicar os arquivos tclConfig.sh e tcl.h assim:
./configure --with-ssl-dir=/usr --with-tcl=/usr/local/lib/tcl8.5 --with-tclinclude=/usr/local/include/tcl8.5
substituindo os "/usr/local/lib/tcl8.5" e o "/usr/local/include/tcl8.5" pelos locais onde se encontram os arquivos tclConfig.sh e tcl.h
Pra encontrá-los, basta dar um "find / | grep tclConfig.sh" o mesmo pro outro. Termine com o make e make install.

Usando qualquer outro tar, eu enfretei problemas de "Segmentation fault".

Espero ter ajudado alguém.
Abraços.

[49] Comentário enviado por removido em 20/05/2007 - 21:32h

Rafael,

Gostaria de parabenizá-lo pelo artigo e também pelo excelente suporte aos comentários/dúvidas dos leitores. Bons artigos são comuns aqui mas, suporte por parte dos autores é raro. Até porque tem muita gente que escreve sem entender do assunto tratado e este certamente não é seu caso.

Por outro lado, eu, infelizmente não consegui concluir a instalação. Estou tentando executar o processo usando o "aptitude" no Kurumin_7. E estão faltando algumas dependências que não existem mais nos repositórios oficiais: libx11-dev, libxext-dev, libxt-dev...

Bom, não vou insistir com a instalação desse programa. Apesar de o Amsn ser, na minha opinião, o melhor mensageiro, há outras ótimas opções disponíveis e prontas.

Abraço,

Wesley

[50] Comentário enviado por fulllinux em 21/05/2007 - 14:32h

spektrums...

Cara fico grato por colaborar com o artigo, pois ele estáva precisando desta atualização, uma vez que a 2 meses atrás não tinhamos quais quer problemas com a instalação do TLS.

Fico muito grato por sua colaboração.


vsauer...

Muito bom... pois esse link que nos trouxe a atenção é o mesmo que o aMSN baixa depois de sua instalação. Mas devo tomar nota que a configuração que nos trouxe a atenção é local e no tutorial que fiz a instalação é infiltrada no sistema, diretamente no diretório /usr/lib.


Caiapó...

Muito o brigado pelo elogio, pois isso nos fortalece e ajuda a sempre contribuir com a comunidade VOL, levando em consideração que tambem recebi muito comentários com tons de sinismo... Mas por sua vez comentários sinceros igauis ao seus é digno de nota muito obrigado mesmo...

Quanto as dependencias... não tive complicações para instalas no kurumin 7, talves sejá necessário vc procurar repositórios para esse instalação.

Grato!

[51] Comentário enviado por leodneto em 25/05/2007 - 14:09h

debian:/usr/src/tcl8.5a5/unix# apt-get install libx11-dev libxft-dev
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
E: Impossível achar pacote libx11-dev
debian:/usr/src/tcl8.5a5/unix#


e agora?
(uso o debian)

[52] Comentário enviado por leodneto em 28/05/2007 - 22:00h

wget -c http://ufpr.dl.sourceforge.net/sourceforge/amsn/amsn-0.97RC1.tar.gz
cd /usr/src/amsn-0.97RC1

novo link pra baixar o amsn....

ae qm kiser baxar plugins eh soh por na pasta: /home/usuario/.amsn/plugins


[53] Comentário enviado por nunesvictor em 30/05/2007 - 09:52h

pow..
to com um slack 11 aki
mas ta dificil de instalar o amsn
td vez da um erro diferente, ja instalei a TK e a TCL, mas faltava a TLS
agora ele tah falando que "Loading TkCximage failed"
to qse desistindo e voltando pro amsn 0.96 msm

ajudem por favor

[54] Comentário enviado por fulllinux em 30/05/2007 - 17:26h

Como a versão RC1 já está a disposição pelos fontes e é altima revisão antes da final, vou aqui

fazer uma atualização do artigo!

Instale todas as dependencias com descrita no artigo, mas na hora de baixar o aMSN via SVN não o

faça, pois o repositório está sendo bugado e pode haver problemas.

Então faça o get no seguinte link e da seguinte forma.
# cd /usr/src/
# wget -c http://ufpr.dl.sourceforge.net/sourceforge/amsn/amsn-0.97RC1.tar.gz
# tar zxf amsn-0.97RC1.tar.gz
# cd amsn-0.97RC1
# ./configure --prefix=/usr --with-tcl=/usr/lib/ --with-tk=/usr/lib/
# make
# make install

Feito isso vamos resolver o grande problema do "TLS", para isso iremos usar a versão estável 1.4

para corrigir esse problema.

# cd /usr/src
# wget http://easynews.dl.sourceforge.net/sourceforge/amsn/tls1.4.1-linux-x86.tar.gz
# tar xzf tls1.4.1-linux-x86.tar.gz
# cd /usr/src/tls1.4
# mkdir /usr/lib/tls
# mv * /usr/lib/tls/

Agora já pode acessar seu aMSN-0.97RC1 com o seguinte comando!

$ amsn &

Valeu!

[55] Comentário enviado por nunesvictor em 31/05/2007 - 22:08h

cara, a mesma coisa ainda

Loading TkCximage failed

ajudem por favor

> Slackware 11 - KDE 3.5 <

[56] Comentário enviado por errodecalculo em 01/06/2007 - 15:52h

Como faço pra instalar no suse 10.2???

o sistema nao possui os comando apt-get e nem dpkg.
o dpkg é so pra descompactar, mas e como eu instalo sem
apt-get???

[57] Comentário enviado por fulllinux em 02/06/2007 - 16:06h

Entrem na comunidade do Orkut, aMSN Brasil / Linux e resolvam todos os seus problemas.

http://www.orkut.com/Community.aspx?cmm=768392

Rafael Santana,
Linux Maníaco.

[58] Comentário enviado por riick em 09/06/2007 - 13:12h

po, compilei no Slackware 11.0 e quando fui rodar:

Loading TkCimage failed. Thias modele is needed to run AMSN. Please compile AMSN first, instructions on how to compile are located in the file INSTALL

:(

[59] Comentário enviado por fulllinux em 12/06/2007 - 13:15h

Compilei no meu Slackware 11 e não tive problemas... inclusive o anti-aliasing!

[60] Comentário enviado por riick em 13/06/2007 - 20:33h

Pois é, cara.
Aqui eu continuo tentando, mais tá dando esse mesmo erro.
Acho que nem vai dá mesmo.

[61] Comentário enviado por arthurcdb em 19/06/2007 - 10:16h

elieser valew pela dica, quebrou um galhao, mas como esse erro pode estar acontecendo?? putz 1 numero do conf ja ferra tudo, muito loko... ubuntu 7.04.

[62] Comentário enviado por User-kuruma em 04/07/2007 - 07:42h

Que erro é esse?? Estou tentando instalar no PC com Kurumin e está dando esse erro abaixo:

root@paudoleo:/home/kurumin/amsn# make install
rm -Rf /usr/share/amsn
mkdir --parents /usr/share/amsn
mkdir --parents /usr/bin
mkdir --parents /usr/share/applications/
mkdir --parents /usr/share/pixmaps/
find /usr/share/amsn -name '.svn' -print | xargs rm -Rf
ln -sf /usr/share/amsn/amsn /usr/bin/amsn
ln -sf /usr/share/amsn/amsn-remote /usr/bin/amsn-remote
ln -sf /usr/share/amsn/amsn-remote-CLI /usr/bin/amsn-remote-CLI
cp ./amsn.desktop /usr/share/applications/
ln -sf /usr/share/amsn/desktop-icons/48x48/apps/amsn.png /usr/share/pixmaps/
root@paudoleo:/home/kurumin/amsn#

Todas as depências estão instaladas e a compilação não passa disso aí nem com reza braba.

[63] Comentário enviado por garetiro em 04/07/2007 - 16:12h

ow eu fiz isso tudo
# apt-get install make gcc libc6-dev
# cd /usr/src
# wget -c ftp://ftp.tcl.tk/pub/tcl/tcl8_5/tcl8.5a5-src.tar.gz
# tar xzf tcl8.5a5-src.tar.gz
# cd /usr/src/tcl8.5a5/unix
# ./configure --prefix=/usr
# make
# make install

a pasta apareceu em file:/usr/src/tcl8.5a5
apareceu uma pasta e esse arquivo tar:/usr/src/tcl8.5a5-src.tar.gz/

e agora o que faço onde acho o msn?????

[64] Comentário enviado por garetiro em 04/07/2007 - 16:14h

onde encontro o msn eu fiz o primeiro exemplo de como installar o amsn..

[65] Comentário enviado por spektrums em 17/07/2007 - 18:52h

E ai User-kuruma

Cara... ah um tempo atrás eu tinha instalado de boa o aMSN 0.97 via SVN em meu Ubuntu 7.04 X64.... mas havia encontrado problemas no bendito tls 1.5, até que consegui resolver o problema com muita pesquisa, se você for ver está até encima postado uma dica minha.

Ontem eu zerei a minha máquina e instalei tudo de novo, estava apresentando umas frescuras, de tanto eu fuçar... hehehehe
Nisso, quando fui instalar novamente o aMSN, fiz tudo certinho, mas na ultima parte de compilação, quando mandei um # make install, apresentou está mesma mensagem que você postou.
Então eu fiquei procurando algumas coisas e resolvi testar a dica do fulllinux.

Então faça o get no seguinte link e da seguinte forma.
# cd /usr/src/
# wget -c http://ufpr.dl.sourceforge.net/sourceforge/amsn/am...
# tar zxf amsn-0.97RC1.tar.gz
# cd amsn-0.97RC1
# ./configure --prefix=/usr --with-tcl=/usr/lib/ --with-tk=/usr/lib/
# make
# make install

No último comando apresentou as mesmas mensagens, mas consegui fazer o amsn rodar. Mas não pelo link que ele cria em Aplicações > Internet.

Entrei na pasta que ele criou e rodei ele na mão.

user@maquina:/usr/src/amsn-0.97RC1$ amsn &

Ele abriu, mas ficou pesado, quando reiniciei o X, e entrei novamente, mas digitando o comando dentro da pasta citada acima, foi aberto normalmente.

As vezes ele está desconectando, mas por enquanto não sei lhe dizer é se o meu acesso a internet que esta zuado ou é o aMSN.

Não sei ao certo, mas o pacote deve ter sido alterado. Suponho eu!!

Melhor criar um link simbolico.

No momento estou usando ele assim.....

Qualquer coisa só avisar, que ajudo vocês também..

Abraços a todos

[66] Comentário enviado por levi_alb em 27/07/2007 - 16:16h

?comentario=
Instalei deu tdo certo, abri o amsn via wish8.5, mas comofaço para colocalar um atalho na área de trabalho?
obrigado pela ajuda pois já ta tentando instalar o novo amsn ha um tempão e não estava conseguindo.

[67] Comentário enviado por spektrums em 06/08/2007 - 16:09h

E ai Levi_alb,

Faz o seguinte:

Na sua área de trabalho, clique com o botão direito e selecione Criar Lançador.
No campo Nome, indique qual o nome do aplicatico, como estamos falando de aMSN, digite aMSN.
No campo Comando, indique onde está o amsn. Exemplo
/usr/local/amsn/amsn
Clique em Ok e pronto, do lado esquerdo desta janela, tem um botão chamado Sem Icone, clique no mesmo e coloque um ícone a desejar, se souber onde está a imagem do ícone do aMSN melhor ainda.

Espero que tenha ajudado.

Abraços

[68] Comentário enviado por flavioc em 01/09/2007 - 11:38h

O AMSN 0.97, ta dando um problema que a versão anterior não tinha. A imagem da área coberta pela minha webcam é de um pequeno quadradinho...1/4 da tela. Assim aparece apenas um pedaço do meu rosto. A imagem que recebo da webcam da pessoa com quem estou conversando é normal. Mas a minha imagem ta muito reduzida. Como resolver isso?

[69] Comentário enviado por kawka em 05/01/2008 - 18:40h

tipo, pra instalar o amsn 0.97, so da pra instalar com tk/tcl 8.5??
eu tenho a tk/tcl 8.4...
mais na hora de instalar ele da isso:
[pedroh@localhost amsn-0.97]$ ./configure && make && make install
checking for prefix by checking for wish... /usr/bin/wish
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking tcl build dir... using tcl library in /usr/lib
checking tk build dir... using tk library in /usr/lib
configure: error: You dot not have a devel package of Tk
alguem sabe oq eu posso faser??
abraço!

[70] Comentário enviado por nunesvictor em 05/01/2008 - 21:09h

cara...se vc utiliza a tcl/tk 8.4 é melhor vc baxar um pacote pre-compilado em x86 para tcl/tk 8.4

issu é muito facil de axar, agora vc pode tentar passar os parametros da tcl/tk no configure (nao sei se funciona)

tente:

$ ./configure --with-tcl=/usr/lib/tcl --with-tk=/usr/lib/tk

claro q os caminhos vao ser subtituidos pelo caminho da instalação da tcl/tk da sua distro (neste caso é oq serve para slack)

espero ter ajudado!

[71] Comentário enviado por rogerbady em 26/02/2008 - 03:53h

O meu amsn nao abre ele começa a carregar e some alguem sabe oq pode ser?
pelo terminal aparece o seguinte erro:
"Error in startup script: extra characters after close-brace
while executing"
Uso Ubuntu 7.10

[72] Comentário enviado por saron em 25/05/2008 - 17:56h

Consegui instalar o amsn 0.96 só que não consigo usá-lo ou configurá-lo para usar o microfone. Alguém pode me ajudar? Não encontro menu ou outra saída que me leve a configurar o microfone. Tem que ser passo a passo, pois ainda estou "engatinhando" no linux.

Grata.

[73] Comentário enviado por removido em 20/06/2008 - 14:31h

Olá amigo muito bom esse artigo me ajudou muito... Valeu!

[74] Comentário enviado por diegolx em 04/10/2008 - 02:51h

Aqui apareceu o seguinte erro:

Error in startup script: extra characters after close-brace
while executing
"set command [list $self {*}$Snit_optionInfo(configure-$option) $option]
"
(procedure "snit::RT.CacheConfigureCommand" line 36)
invoked from within
"snit::RT.CacheConfigureCommand $type $selfns $win $self $option"
(procedure "::snit::RT.method.configurelist" line 7)
invoked from within
"::snit::RT.method.configurelist $type $selfns $win $self $args"
(procedure "::snit::RT.method.configure" line 4)
invoked from within
"$self configure -width $arrow1width"
(procedure "::pixmapscrollbar::Snit_constructor" line 52)
invoked from within
"::pixmapscrollbar::Snit_constructor ::pixmapscrollbar ::pixmapscrollbar::Snit_inst1 .plugins_log.ys .plugins_log.ys -command {.plugins_log.info yview}"
("eval" body line 1)
invoked from within
"eval [linsert $arglist 0 ${type}::Snit_constructor $type $selfns $instance $instance]"
(procedure "RT.ConstructInstance" line 9)
invoked from within
"RT.ConstructInstance $type $selfns $name $args"
(procedure "::snit::RT.widget.typemethod.create" line 62)
invoked from within
"scrollbar $window.ys -command "$window.info yview""
(procedure "::pluginslog::draw" line 12)
invoked from within
"::pluginslog::draw"
invoked from within
"if { $initialize_amsn == 1 } {
::pluginslog::draw
}"
(file "pluginslog.tcl" line 210)
invoked from within
"source pluginslog.tcl"
("uplevel" body line 28)
invoked from within
"uplevel \#0 {

# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
source amsncore.tcl
source audio.tc..."
(procedure "reload_files" line 2)
invoked from within
"reload_files"
(file "/usr/bin/amsn" line 277)


Alguém pode me ajudar ?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts