Criando Fluxogramas? Use o Dia!

Você adora Linux, adora informática e está louco de vontade de aprender a programar, pesquisa sobre o assunto e baixa da internet uma introdução do Python, do C, e quando vai começar a estudar, aparece um monte de dúvidas? Pare, respire, você é normal, só que ainda não aprendeu a Lógica de Programação, mas e depois? Como passar aqueles fluxogramas pro computador? Simples, eu lhes apresento o Dia!

[ Hits: 85.730 ]

Por: Matheus Santana Lima em 27/06/2006


Enfim, o Dia!



Para abrir o programa, abra um terminal e digite:

$ dia


Depois de carregar o programa, você poderá notar que visualmente ele é um programa bem simples, com apenas duas janelas, uma para o desenvolvimento do diagrama e outro para manipular os recursos do software.


Vamos selecionar agora a opção fluxograma:


Agora, enfim vamos por a mão na massa, para tanto vamos desenvolver um simples algoritmo que servirá de base para o desenho do fluxograma.

O exemplo que eu criei foi o seguinte:

Um sistema que lê o gabarito de uma prova contendo dez questões (Valendo um ponto cada uma). Lendo depois os códigos de matrícula e as respostas das provas das de 100 alunos; depois calcular a nota de cada aluno e imprimir o código de matricula, a nota e o resultado(a nota de aprovação deve ser igual ou maior que 7); em seguida imprimir a quantidade de alunos aprovados e a nota média da turma.

Dicionário de Dados


Dados        Identif:   Tipo 

Gabarito Prova         GP    Vetor:L
Contador Resp          CR    Numérica
Respostas Alunos       RA    Matriz:L
Contador Alunos        CA    Numérica
Índice Resp            IR    Numérica
Total de pontos        TP    Numérica
Total Alunos Ap.       TAA   Numérica
Total geral de pontos  TGP   Numérica
Média da turma         MT    Numérica
Algoritmo Correcao_de_Prova:

Início

   GP: vetor[1..10] Literal
   RA: matriz[1..100,1..11] Literal
   CR, CA,IR, TP, TAA, TGP, MT: Numérico

   Para CR de 1 até 10 faça:
      Leia CP[CR]
   Fim_para

   TAA <- 0
   TGP <- 0

   Para CA de 1 até 100
      Para IR de 1 até 11 faça
         Se IR=1
            Então escreva "Código da Matrícula"
            Senão escreva "Resposta:" IR - 1
         Fim_se

         Leia RA [CA,IR]
      Fim_para
   Fim_Para

   Para CA de 1 até 100 faça
      IP <- 0
      Para IR de 2 até 11 faça
         Se GP[IR] = RA [CA, IR]
            Então TP <- TP +1
         Fim_se
      Fim_para

      Escreva RA [CA,1], IP

      SE TP >= 7
         Então escreva "Aprovado"
         TAA <- TAA + 1

         Senão escreva "Reprovado"

      Fim_se

      TGP <- TGP + TP
   Fim_para

   Escreva TAA
   MT <- TGP / 100
   Escreva MT

Fim

O desenvolvimento do diagrama é muito fácil e de forma intuitiva, você escolhe a figura do processo desejado e desenha na área do programa, como se faz em editores de imagem como Photoshop e Gimp:


Depois de "desenhar" o fluxograma do algoritmo criado anteriormente, a imagem ficará assim:


Para salvar, clique na área de desenho com o botão direito, vá em 'Arquivo' e depois em 'Exportar...'; veja o grande número de opções de extensões que temos para salvarmos nosso projeto:


Neste breve artigo, mostrei a vocês essa poderosa ferramenta para o desenvolvimento de diagramas que é o Dia, muito útil para desenvolvedores com experiência e para aqueles que estão começando. Comentem sobre o que acharam para eu poder sempre estar melhorando!

Obrigado

Matheus Santana Lima

[email protected]

Página anterior    

Páginas do artigo
   1. Introdução
   2. Instalação
   3. Enfim, o Dia!
Outros artigos deste autor

Polimorfismo - Uma visão em C++ e Java

Gerenciando serviços de sistemas Linux

Apresentando e pondo a prova o Mono

Linux, 100% compatível!

Visopsys - Sistema Operacional aberto e portátil para manipulação de discos rígidos

Leitura recomendada

Criando o seu próprio wallpaper com o Gimp

Instalando Compiz Fusion no Slackware 12.0

Enfeite o LILO com uma imagem de seu gosto

"Tatuando" pessoas com o Gimp

Experimentando o XGL/Compiz no Mandriva 2007

  
Comentários
[1] Comentário enviado por hellnux em 27/06/2006 - 14:40h

Olá,

Bom artigo, usei esse software em vez do M$ Visio, simples e fácil de usar.

[]´s

[2] Comentário enviado por rgmmelo em 27/06/2006 - 18:09h

legal o artigo, sou apaixonado por linguagens de programação, mas nunca vou fundo em alguma pois esbarros nas duvidas e duvidas!
Quando li as palavras fluxograma e engenharia química(meu curso) por um momento pensei que fosse o algo parecido com o modo simulink do matlab, mas não eh!

[3] Comentário enviado por in54no em 27/06/2006 - 19:58h

dahora o artigo...
uma coisa dahora tambem eh habilitar o Anti-Aliasing...
os objetos ficam mais bonitos... mais redondinhos...
teh mais, fique com Deus!

[4] Comentário enviado por metatron em 27/06/2006 - 20:33h

Boa noite,

Eu adoro o Dia, e para quem não sabe, existem programas associados, um deles é o dia2code ( http://dia2code.sourceforge.net/ ), que toma um diagrama em UML e gera um esqueleto de código (inclusive em C!), outro é o autodia ( http://testers.astray.com/ ) que faz o contrário, toma como entrada um programa com suporte a OOP (C++, php, java e perl) e gera (tenta pelo menos) um diagrama UML que o Dia pode ler.

[5] Comentário enviado por leandroalmeidab em 28/06/2006 - 09:10h

Gostei muito do seu artigo...

Já uso o dia há algum tempo mais consegui informções novas a respeito do programa....

Parabéns e valews

[6] Comentário enviado por brunokino em 29/06/2006 - 00:01h

Aeeee parabéns pelo artigo!!
Com certeza o dia é ótimo :-p
Vlw

[7] Comentário enviado por labam em 29/06/2006 - 09:41h

style veioo
eu estudo logica na escola!
gostei do soft
vou instalar
abraço!

[8] Comentário enviado por nilvando em 29/06/2006 - 18:09h

Muito bom, parabens Matheus!

[9] Comentário enviado por removido em 25/07/2006 - 14:50h

Opa... acho que alguém aprendeu com o mestre fabião !!
Fala ae Matheus...

[10] Comentário enviado por eddye00 em 08/11/2008 - 17:56h

Ótimo artigo ! Consegui instalar com sucesso o DIA no slackware 12.1 através do slapt-get.
Porém, o programa não iniciava porque faltava libgio-2.0.so.0.

Consegui resolver instalando o glib2 pelo slapt-get mesmo.

abraços

[11] Comentário enviado por douglas.giorgio em 08/04/2009 - 11:29h

muito bom

achei oq estava procurando

parabens!!!

flw

[12] Comentário enviado por penelopecharmosa em 07/02/2013 - 18:48h

Interessante! Parece mais facil que ms project, para utilização de um administrador.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts