Certificado Digital para Peticionamento Eletrônico (2018)

Sempre foi complicado usar certificado digital com Linux, ainda mais quando pouca gente se interessa em ajudar ou mesmo possibilitar uso correto e fácil. Aqui vai, então, uma pequena ajuda de quem usa e já foi obrigado a comprar uma máquina Windows para poder fazer isso.

[ Hits: 6.107 ]

Por: Andre (pinduvoz) em 11/07/2018 | Blog: http://casadopinduvoz.wordpress.com/


Instalação



I. Atualize completamente o SO (Debian, Ubuntu ou Mint):

sudo apt update && sudo apt upgrade

II. Instale os seguintes pacotes:

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libengine-pkcs11-openssl

III. Baixe da minha pasta do Google Drive as "libs" necessárias em arquivo compactado e as copie -- após descompactar o arquivo, obviamente -- para a pasta "/usr/lib" do seu sistema. Isso precisa ser feito como "root" (ou com "sudo").

Link para baixar:
IV. Faça a instalação dos "plug-ins" ou extensões para Firefox e Google Chrome/Chromium, que você encontra aqui:
V. A instalação dos "plug-ins" implicará no download de um novo pacote "deb" -- o "websigner-setup-64.deb" -- que você também deve instalar.

VI. Reinicie o sistema e teste o funcionamento do seu certificado digital no site do TJSP.

    Próxima página

Páginas do artigo
   1. Instalação
   2. Por que você precisa baixar as minhas "libs"? (ou criar as suas)
   3. Adendo e imagens
Outros artigos deste autor

Apresentando agora o Scientific Linux

Instalação de Programas no Ubuntu (atualização)

Cadê minha área de trabalho?

Instalando um novo tema no Acer Aspire One

Distribuições GNU/Linux em computadores limitados ou antigos

Leitura recomendada

Uma interface mais bonita com efeitos de transparência e sombras

Como fazer RAID 0 com mdadm no Debian

Atualizando seu Gnome para o 2.6 experimental no Debian

Iniciando no NFS

Faça um incrível espetáculo de efeitos visuais com vídeo em tempo real

  
Comentários
[1] Comentário enviado por pinduvoz em 15/05/2019 - 09:56h

OBSERVAÇÃO: sigam a dica do comentário abaixo, pois sem o pacote em questão este tutorial não funciona mais. Funcionava quando escrito, mas o pacote libgdbm_compat.so.3 foi removido dos repositórios e não é mais instalado como dependência daqueles listados neste passo a passo. Segue o comentário do leitor Julian no meu blog:

Finalmente, consegui fazer funcionar!!! Deixo registrada a solução para o próximo…O problema era uma dependência no arquivo libaetpkss.so.3. Com o comando “ldd -r /usr/lib/libaetpkss.so.3” descobri que faltava a biblioteca libgdbm_compat.so.3.Então, bastou ir em https://launchpad.net/ubuntu/bionic/amd64/libgdbm3/1.8.3-14 e instalar essa biblioteca.


__________________________________
Linux Registered User nº 439378
Ubuntu Forum Member Since Nov/07/2006
VOL Member SInce Jul/01/2008


Contribuir com comentário