Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

1. Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 22/02/2021 - 03:54h

Bom dia, amigos. Uso o Linux Mint desde o ano passado, e nunca tive problemas com ele; Acontece que hoje, ao ligar o meu notebook, ele não conectou no wifi como costuma fazer, e tampouco reconheceu qualquer rede wireless. É como se tivesse desligado o wifi do notebook da noite pro dia e ligado o modo "cabo", inclusive até consta nas redes que tive uma conexão cabeada, mas isso nunca aconteceu; sempre usei o wifi, e agora ele não acha nenhuma rede. Será que fiz alguma coisa e desliguei o meu wifi sem querer? Problema na internet eu sei que não é, pois estou criando esse tópico pelo celular, então assumo que o problema seja inteiramente no notebook. Estou desesperado, já procurei por soluções em outros lugares mas nada resolveu meu problema. Irei anexar uma foto da situação atual, agradeço por qualquer ajuda possível!!


  


2. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Marcos Fernandes
markirius

(usa Arch Linux)

Enviado em 22/02/2021 - 10:35h

Tente o seguinte através do terminal:

sudo systemctl start NetworkManager 


se funcionar faça o seguinte:

sudo systemctl enable NetworkManager 


obs: se fosse apenas o wifi, em um notebook poderia ser a "chave" do wifi que desligou via hardware, mas como está tudo desativado pode ser com serviço de rede do sistema.


3. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 22/02/2021 - 13:03h

markirius escreveu:

Tente o seguinte através do terminal:

sudo systemctl start NetworkManager 


se funcionar faça o seguinte:

sudo systemctl enable NetworkManager 


obs: se fosse apenas o wifi, em um notebook poderia ser a "chave" do wifi que desligou via hardware, mas como está tudo desativado pode ser com serviço de rede do sistema.


Obrigado pela resposta, Markirius! Fiz conforme me instruiu, mas nada aconteceu; segue um print:




4. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/02/2021 - 14:14h

Tente habilitar via teclas fn do notebook. Se não funcionar abra um terminal, rode e cole
sudo rfkill list all
dmesg | grep -i wifi


5. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 22/02/2021 - 17:22h

leandropscardua escreveu:

Tente habilitar via teclas fn do notebook. Se não funcionar abra um terminal, rode e cole
sudo rfkill list all
dmesg | grep -i wifi


Fiz o que me instruiu, Leandro. Porém, nem com as teclas fn e nem com o comando o meu wifi voltou ao normal. O problema persiste, SS:




6. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 23/02/2021 - 01:28h

Verificando, resumidamente se hardware wifi e cabo aparecem e quem está ativado:
inxi -Niz
sudo lshw -c network




7. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 23/02/2021 - 04:26h

ricardogroetaers escreveu:

Verificando, resumidamente se hardware wifi e cabo aparecem e quem está ativado:
inxi -Niz
sudo lshw -c network



Opa, obrigado pela resposta, Ricardo! Digitei os comandos que você me passou, e eis o resultado:




8. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 24/02/2021 - 01:13h

Infelizmente não há hardware (reconhecido) de rede wifi no notebook.
Apenas hardware de rede a cabo.
Ou o hardware foi desconectado (ou desligado) fisicamente ou pelo setup ou pifou.



9. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 24/02/2021 - 03:38h

ricardogroetaers escreveu:

Infelizmente não há hardware (reconhecido) de rede wifi no notebook.
Apenas hardware de rede a cabo.
Ou o hardware foi desconectado (ou desligado) fisicamente ou pelo setup ou pifou.


Eu já temia que tivesse pifado, pois parou de funcionar do nada e nada do que fiz pareceu resolver. Mas, só para ter certeza, vou formatar ele e reinstalar o Linux Mint assim que conseguir um pen drive. Se o problema for no setup, creio que deve voltar ao normal. Obrigado por me dar uma luz, Ricardo. Futuramente posto o resultado após reinstalar o Mint, pra ver se vou conseguir salvar o meu not..



10. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 25/02/2021 - 00:25h

Lukeleal escreveu: ... só para ter certeza, vou formatar ele e reinstalar o Linux Mint ... Se o problema for no setup, creio que deve voltar ao normal. ...

Acho melhor não "formatar" precipitadamente.
Habilitar/desabilitar hardware pelo setup ou por um suposto botão ou pelas teclas "fn" ou um suposto mal contato, nada tem a ver com sistema operacional.
Normalmente um sistema operacional não pode "by passar" o BIOS/UEFI e muito menos a desconexão física de um componente de hardware.
Verifique se, usando a mídia de instalação, o wifi é reconhecido.
Se for reconhecido, ai sim, o problema está no sistema instalado.


11. Re: Meu Wifi parou de funcionar do nada [Linux Mint 19.3 Tricia]

Lucas Limar Leal
Lukeleal

(usa Linux Mint)

Enviado em 25/02/2021 - 01:19h

ricardogroetaers escreveu:

Lukeleal escreveu: ... só para ter certeza, vou formatar ele e reinstalar o Linux Mint ... Se o problema for no setup, creio que deve voltar ao normal. ...

Acho melhor não "formatar" precipitadamente.
Habilitar/desabilitar hardware pelo setup ou por um suposto botão ou pelas teclas "fn" ou um suposto mal contato, nada tem a ver com sistema operacional.
Normalmente um sistema operacional não pode "by passar" o BIOS/UEFI e muito menos a desconexão física de um componente de hardware.
Verifique se, usando a mídia de instalação, o wifi é reconhecido.
Se for reconhecido, ai sim, o problema está no sistema instalado.


Farei isso! Assim que tiver um pen drive para usar como bootavel..
Obrigado pela disposição, meu caro.