erro no dpkg

1. erro no dpkg

leonardo da silva
Leoskt

(usa Outra)

Enviado em 02/09/2020 - 06:05h

olá galera !
recentemente instalei o ubuntu 20.04 e estou tento problemas na instalação de qualquer programa desdo basicos iniciais ao google chrome, antivirus, skype, zoom.
enfim quando tento instalar pelo terminal acontece o seguinte problema!(copiei e colei abaixo)
[email protected]:~$ sudo apt-get install clamav clamav-daemon
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
clamav : Depende: clamav-freshclam (>= 0.102.4+dfsg) mas não será instalado ou
clamav-data
Depende: libclamav9 (>= 0.102.4) mas não será instalado
Depende: libcurl4 (>= 7.16.2) mas não será instalado
Depende: libjson-c4 (>= 0.13.1) mas não será instalado
Recomenda: clamav-base mas não será instalado
clamav-daemon : Depende: clamav-base (= 0.102.4+dfsg-0ubuntu0.20.04.1) mas não será instalado
Depende: clamav-freshclam (>= 0.102.4+dfsg) mas não será instalado ou
clamav-data
Depende: procps (>= 1:3.3.2) mas não será instalado
Depende: ucf mas não será instalado
Depende: libclamav9 (>= 0.102.4) mas não será instalado
Depende: libcurl4 (>= 7.18.2) mas não será instalado
Depende: libncurses6 (>= 6) mas não será instalado
Recomenda: clamdscan mas não será instalado
man-db : Depende: bsdmainutils mas não será instalado
Depende: groff-base (>= 1.18.1.1-15) mas não será instalado
Depende: libgdbm6 (>= 1.16) mas não será instalado
Depende: libpipeline1 (>= 1.5.0) mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
[email protected]:~$ apt --fix-broken install
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock-frontend - open (13: Permissão negada)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
[email protected]:~$ sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
cabextract distro-info-data groff-base libdbus-1-3 libexpat1 libfontenc1 libfreetype6 libgdbm6 libglib2.0-0 libmpdec2 libmspack0
libpipeline1 libpng16-16 libpython3-stdlib libpython3.8-minimal libpython3.8-stdlib libreadline8 libsqlite3-0 libuchardet0 lsb-release
man-db mime-support patch python-apt-common python3 python3-apt python3-chardet python3-dbus python3-debconf python3-debian
python3-distro-info python3-distupgrade python3-minimal python3-pkg-resources python3-six python3-update-manager python3.8
python3.8-minimal readline-common ubuntu-release-upgrader-core update-manager-core update-notifier-common x11-common xfonts-encodings
xfonts-utils
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
bsdmainutils debianutils groff-base libbsd0 libgdbm6 libpipeline1 libuchardet0
Pacotes sugeridos:
cpp wamerican | wordlist whois vacation groff gdbm-l10n
Os pacotes a seguir serão REMOVIDOS:
ttf-mscorefonts-installer
Os NOVOS pacotes a seguir serão instalados:
bsdmainutils debianutils groff-base libbsd0 libgdbm6 libpipeline1 libuchardet0
0 pacotes atualizados, 7 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/1.280 kB de arquivos.
Depois desta operação, 5.127 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] n
Abortar.
[email protected]:~$ sudo apt autoremove
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
man-db : Depende: bsdmainutils mas não está instalado
Depende: groff-base (>= 1.18.1.1-15) mas não está instalado
Depende: libgdbm6 (>= 1.16) mas não está instalado
Depende: libpipeline1 (>= 1.5.0) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
[email protected]:~$ sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
cabextract distro-info-data groff-base libdbus-1-3 libexpat1 libfontenc1 libfreetype6 libgdbm6 libglib2.0-0 libmpdec2 libmspack0
libpipeline1 libpng16-16 libpython3-stdlib libpython3.8-minimal libpython3.8-stdlib libreadline8 libsqlite3-0 libuchardet0 lsb-release
man-db mime-support patch python-apt-common python3 python3-apt python3-chardet python3-dbus python3-debconf python3-debian
python3-distro-info python3-distupgrade python3-minimal python3-pkg-resources python3-six python3-update-manager python3.8
python3.8-minimal readline-common ubuntu-release-upgrader-core update-manager-core update-notifier-common x11-common xfonts-encodings
xfonts-utils
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
bsdmainutils debianutils groff-base libbsd0 libgdbm6 libpipeline1 libuchardet0
Pacotes sugeridos:
cpp wamerican | wordlist whois vacation groff gdbm-l10n
Os pacotes a seguir serão REMOVIDOS:
ttf-mscorefonts-installer
Os NOVOS pacotes a seguir serão instalados:
bsdmainutils debianutils groff-base libbsd0 libgdbm6 libpipeline1 libuchardet0
0 pacotes atualizados, 7 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/1.280 kB de arquivos.
Depois desta operação, 5.127 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
dpkg: aviso: a interpretar o ficheiro '/var/lib/dpkg/status' perto da linha 235 pacote 'gpgv':
linha em branco no valor do campo 'Description'
dpkg: erro: falhou ao abrir arquivo de informações do pacote '/var/lib/dpkg/available' para leitura: Arquivo ou diretório não encontrado
E: Sub-processo dpkg --set-selections retornou um código de erro (2)
E: Couldn't record the approved state changes as dpkg selection states


Ja tentei de diversas formas concertar mas não funfa, se alguem puder me auxiliar agradeço desde ja!


  


2. Re: erro no dpkg

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 02/09/2020 - 08:07h

-tente desbloquear o apt
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get update
sudo apt-get upgrade