Problema com apt-get

1. Problema com apt-get

Amanda Aparecida Machado Goulart
aamgoulart

(usa Outra)

Enviado em 02/12/2018 - 12:48h

Bom dia.

Comecei a instalar com o comando apt-get e tive que interromper bruscamente a download, no dia seguinte instalei normalmente pelo comando. Posteriormente fui instalar outra coisa.
E retorna esse erro:

dpkg: erro: arquivo de gatilho interessados duplicado para o arquivo chamado '/usr/lib/gio/modules' e pacote 'libglib2.0-0:i386'
E: Sub-process /usr/bin/dpkg returned an error code (2)

Tentei os seguintes comandos, sem nenhum sucesso:

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo rm /var/lib/apt/lists/* -vf

sudo apt-get update

sudo apt-get clean

sudo apt-get autoclean

sudo apt-get autoremove

sudo dpkg --configure -a


  


2. Re: Problema com apt-get

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 02/12/2018 - 13:17h

qual a distro ???

manda aí
ls /usr/lib 


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



3. Re: Problema com apt-get

Amanda Aparecida Machado Goulart
aamgoulart

(usa Outra)

Enviado em 02/12/2018 - 16:37h

Uso ubuntu


amanda@rogerio-US41II1:~$ ls /usr/lib
accountsservice libmbim
apg libnatpmp.so.1
apt libnetpbm.so.10
aspell libnetpbm.so.10.0
at-spi2-core libqmi
avahi libreoffice
bfd-plugins linux
bijiben linux-boot-probes
binfmt.d locale
bluetooth lp_solve
cnf-update-db man-db
colord memtest86+
command-not-found mime
compat-ld modules-load.d
cups mozilla
dbus-1.0 mutter
dconf mypaint
debug networkd-dispatcher
deja-dup NetworkManager
dpkg notification-daemon
eject nvidia
emacsen-common openssh
environment.d os-prober
evince os-probes
evolution os-release
evolution-data-server p7zip
file packagekit
firefox pcmciautils
firefox-addons pkgconfig
fwupd pm-utils
fwupdate policykit-1
gcc pppd
gcr pulse-11.1
gdm3 python2.7
geoclue-2.0 python3
gettext python3.6
ghostscript python3.7
girepository-1.0 rhythmbox
git-core rsyslog
gjs rtkit
glib-networking sasl2
gnome-control-center shim
gnome-disk-utility shotwell
gnome-initial-setup snapd
gnome-online-accounts software-properties
gnome-session speech-dispatcher-modules
gnome-settings-daemon ssl
gnome-settings-daemon-3.0 sudo
gnome-shell sysctl.d
gnome-terminal syslinux
gnupg SYSLINUX
gnupg2 syslinux-legacy
gold-ld systemd
groff system-service
grub sysusers.d
grub-legacy tar
gst-install-plugins-helper tc
gvfs thunderbird
i386-linux-gnu thunderbird-addons
ibus tmpfiles.d
initramfs-tools tracker
inkscape ubiquity
ispell ubuntu-release-upgrader
jvm udisks2
kernel unity-settings-daemon-1.0
klibc update-notifier
language-selector upower
libcue.so.1 valgrind
libcue.so.1.0.4 vino
libgjs.so.0 wx
libgjs.so.0.0.0 X11
libinotifytools.so.0 x86_64-linux-gnu
libinotifytools.so.0.4.1 xorg
libiptcdata.so.0 xserver-xorg-video-intel
libiptcdata.so.0.3.3 zeitgeist



4. Re: Problema com apt-get

meianoite
meianoite

(usa Nenhuma)

Enviado em 02/12/2018 - 17:31h

aamgoulart escreveu:

Bom dia.

Comecei a instalar com o comando apt-get e tive que interromper bruscamente a download, no dia seguinte instalei normalmente pelo comando. Posteriormente fui instalar outra coisa.
E retorna esse erro:

dpkg: erro: arquivo de gatilho interessados duplicado para o arquivo chamado '/usr/lib/gio/modules' e pacote 'libglib2.0-0:i386'
E: Sub-process /usr/bin/dpkg returned an error code (2)

Tentei os seguintes comandos, sem nenhum sucesso:

sudo apt-get --fix-broken install

sudo apt-get clean

sudo apt-get install -f

sudo dpkg --configure -a

sudo apt-get update

sudo rm /var/lib/apt/lists/* -vf

sudo apt-get update

sudo apt-get clean

sudo apt-get autoclean

sudo apt-get autoremove

sudo dpkg --configure -a




Já removeu esse tal libglib2.0-0:i386 do sistema deve esta nas pastas do apt-get da vida?
Já verificou os logs do sistema?

É normal isso no kali. kkkkk



5. Re: Problema com apt-get

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 02/12/2018 - 22:15h

aamgoulart escreveu:
Uso ubuntu


vamos descobrir aonde é que está constando esse pacote ... fisicamente ele não está

manda aí
grep libglib2 /var/lib/dpkg/status


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



6. Re: Problema com apt-get

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 03/12/2018 - 11:17h

Entre em /var/cache/apt/archives e digite:

# dpkg -i --force-all pacote-que-ta-dando-ruim.deb

Ele irá ignorar esse problema de arquivo conflitando entre 2 pacotes e irá instalar o que está dando erro.

Depois rode um:

# apt-get -f install

Isso acontecia muito quando eu usava distribuições versões instáveis, onde é comum o conflito de pacotes devido a pressa em empacotar tudo.


7. Re: Problema com apt-get

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 03/12/2018 - 11:33h

Você está usando Ubuntu 1404 1604 ou 1804?

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




8. Re: Problema com apt-get

Amanda Aparecida Machado Goulart
aamgoulart

(usa Outra)

Enviado em 03/12/2018 - 14:22h

fabio escreveu:

Entre em /var/cache/apt/archives e digite:

# dpkg -i --force-all pacote-que-ta-dando-ruim.deb

Ele irá ignorar esse problema de arquivo conflitando entre 2 pacotes e irá instalar o que está dando erro.

Depois rode um:

# apt-get -f install

Isso acontecia muito quando eu usava distribuições versões instáveis, onde é comum o conflito de pacotes devido a pressa em empacotar tudo.


root@rogerio-US41II1:~# dpkg -i --force-all libglib2.0-0:i386.deb
dpkg: erro: arquivo de gatilho interessados duplicado para o arquivo chamado '/usr/lib/gio/modules' e pacote 'libglib2.0-0:i386'

ele não aceita este comando também




9. Re: Problema com apt-get

Amanda Aparecida Machado Goulart
aamgoulart

(usa Outra)

Enviado em 03/12/2018 - 14:24h

clodoaldops escreveu:

Você está usando Ubuntu 1404 1604 ou 1804?

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)



18.04


10. Re: Problema com apt-get

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 03/12/2018 - 14:36h

Tente desbloquear o APT
sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




11. Re: Problema com apt-get

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 03/12/2018 - 14:39h

Se desbloquear APT não resolver tente
https://www.vivaolinux.com.br/topico/Duvidas-frequentes/dpkg-returned-an-error-code-2

--------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




12. Re: Problema com apt-get

Xerxes Lins
xerxeslins

(usa Outra)

Enviado em 03/12/2018 - 15:44h

aamgoulart escreveu:

dpkg: erro: arquivo de gatilho interessados duplicado para o arquivo chamado '/usr/lib/gio/modules' e pacote 'libglib2.0-0:i386'
E: Sub-process /usr/bin/dpkg returned an error code (2)



Vamos lá...

O negócio, ao que parece, é bug do Ubuntu. E pela mensagem de erro há nomes duplicados no arquivo "File".

Execute o seguinte comando para navegar até o diretório triggers:

$ cd /var/lib/dpkg/triggers/

Depois execute o seguinte comando para listar as duplicações:

$ cat File | cut -d" " -f 2 | uniq -c

O número que aparecerá no começo será a quantidade de vezes que uma linha está duplicada.

A solução será acessar o arquivo "File" e deletar essas linhas duplicadas, deixando só uma.

Use o comando:

$ sudo gedit File

Procure por aquelas linhas duplicadas e delete-as, deixando só uma. Salve e feche o arquivo.

Por fim execute:

$ sudo apt-get install -f

Isso deve resolver.

--
If it ain't broke, fix it until it is.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts