Falha ao obter tamanho de gama para o padrão de saída ao tentar adicionar nova resolução de tela [RE

1. Falha ao obter tamanho de gama para o padrão de saída ao tentar adicionar nova resolução de tela [RE

Gustavo Alves
GAlves58

(usa XUbuntu)

Enviado em 13/01/2020 - 13:30h

Olá a todos,

Eu sempre fui usuário Windows e passei a utilizar o linux há 2 semanas, ainda estou aprendendo.

A primeira distribuição que instalei foi LMint Xfce 19.3 (modo de compatibilidade), mas percebi lentidão, provavelmente causada pelo hardware de meu PC.

Processador: Intel Pentium 4 (Northwood) 2.60 GHz
RAM: 2 GB
HD: 146 GB
Monitor: AOC LM522 [Cod. TFT1560PSA] LCD 15 polegadas

Não há drivers adicionais disponíveis para download.

Por isto troquei para o Xubuntu 18.04. Na live do sistema pelo pen drive tudo estava certo, mas ao instalá-lo definitivamente, a resolução do monitor ficou com problemas. Pesquisei em alguns sites e não consegui resolver utilizando o comando xrandr. A resolução atual é de 640x480, mas meu monitor é 1024x768.

A resposta do terminal ao comando xrandr é:
gustavo@gustavo-STI:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 73.00*

gustavo@gustavo-STI:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync

gustavo@gustavo-STI:~$ sudo xrandr --newmode "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
[sudo] senha para gustavo:
xrandr: Failed to get size of gamma for output default

Usando o comando lshw -c video, sua resposta foi:
gustavo@gustavo-STI:~$ sudo lshw -c video
*-display DISPONÍVEL
descrição: VGA compatible controller
produto: CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
fabricante: VIA Technologies, Inc.
ID físico: 0
informações do barramento: pci@0000:01:00.0
versão: 01
largura: 32 bits
clock: 66MHz
capacidades: vga_controller bus_master cap_list
configuração: latency=32 mingnt=2
recursos: memória:d8000000-dbffffff memória:dc000000-dcffffff memória:c0000-dffff

Em lspci, um dos resultados é:
 01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro] (rev 01) 

Eu também criei o arquivo xorg.conf com o código:
sudo Xorg :1 -configure 

e enviei para /etc/X11 sem mudar com o código:
sudo cp xorg.conf.new /etc/X11/xorg.conf 

Também tentei fazer a instalação do pacote xserver-xorg-video-openchrome pelo comando:
sudo apt install xserver-xorg-video-openchrome 

E a resposta foi:
gustavo@gustavo-STI:~$ sudo apt install xserver-xorg-video-openchrome
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
xserver-xorg-video-openchrome : Depende: xorg-video-abi-23
Depende: xserver-xorg-core (>= 2:1.18.99.901)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


O que posso fazer para corrigir este problema?

Atenciosamente,
Gustavo


  


2. Re: Falha ao obter tamanho de gama para o padrão de saída ao tentar adicionar nova resolução de tela [RE

Gustavo Alves
GAlves58

(usa XUbuntu)

Enviado em 17/01/2020 - 10:20h

Olá a todos,

Quero deixar documentado aqui como foi resolvido o problema para que possa servir de ajuda a todos.

O Ubuntu normalmente já é fornecido com drivers, mas apenas os mais comuns, como as versões de código aberto da Intel, AMD e Nvidia. No entanto, placas gráficas da VIA são bastante antigas e por isto, o Ubuntu parece não incluir mais elas por padrão. Logo é importante fazer a instalação manual do driver Openchrome que fiz no post anterior.

Como visto, não deu certo...
A solução para isto é tentar fazer o downgrade do pacote ou reinstalar uma versão mais antiga:
http://cdimage.ubuntu.com/xubuntu/releases/18.04.1/release/

Infelizmente, o driver openchrome não parece ter uma versão HWE e para instalá-lo, ele precisa do pacote xserver-xorg-core original que, infelizmente, os lançamentos mais recentes do 18.04 não o possuem mais por padrão. Portanto, é recomendado fazer o downgrade para que o sistema tenha o pacote xserver-xorg-core e companhia adequados para que não conflitam entre si, além de ser muito mais rápido e seguro.

No link a cima, procure a versão marcada como xubuntu-18.04-desktop-XXX.iso, onde XXX corresponde a arquitetura de seu PC: amd64 para 64 bits ou i386 para 32 bits. Também é possível utilizar a versão xubuntu-18.04.1-desktop, mas evite o download de versões superiores à 18.04.2, uma vez que terão os stacks atualizados.

Segue abaixo os códigos realizados após a instalação do xubuntu-18.04.1-desktop-i386.iso em minha máquina:
gustavo@gustavo-STI:~$ sudo Xorg :1 -configure
X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-119-generic i686 Ubuntu
Current Operating System: Linux gustavo-STI 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:37:27 UTC 2018 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=620aa2b4-4178-4171-9ecc-a687a943b98b ro quiet splash vt.handoff=1
Build Date: 13 April 2018 08:08:02PM
xorg-server 2:1.19.6-1ubuntu4 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Jan 14 12:08:52 2020
List of video drivers:
ati
intel
nouveau
qxl
radeon
vmware
vesa
modesetting
fbdev
amdgpu
(++) Using config file: "/home/gustavo/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /home/gustavo/xorg.conf.new

To test the server, run 'X -config /home/gustavo/xorg.conf.new'

(EE) Server terminated with error (2). Closing log file.

gustavo@gustavo-STI:~$ sudo cp xorg.conf.new /etc/X11/xorg.conf

gustavo@gustavo-STI:~$ sudo apt install xserver-xorg-video-openchrome
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
xserver-xorg-video-openchrome
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 496 não atualizados.
É preciso baixar 153 kB de arquivos.
Depois desta operação, 555 kB adicionais de espaço em disco serão usados.
Obter:1 http://br.archive.ubuntu.com/ubuntu bionic/universe i386 xserver-xorg-video-openchrome i386 1:0.6.0-3 [153 kB]
Baixados 153 kB em 0s (1.087 kB/s)
A seleccionar pacote anteriormente não seleccionado xserver-xorg-video-openchrome.
(Lendo banco de dados ... 145089 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../xserver-xorg-video-openchrome_1%3a0.6.0-3_i386.deb ...
A descompactar xserver-xorg-video-openchrome (1:0.6.0-3) ...
Configurando xserver-xorg-video-openchrome (1:0.6.0-3) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
A processar 'triggers' para man-db (2.8.3-2) ...

gustavo@gustavo-STI:~$ apt-cache policy xserver-xorg-video-openchrome
xserver-xorg-video-openchrome:
Instalado: 1:0.6.0-3
Candidato: 1:0.6.0-3
Tabela de versão:
*** 1:0.6.0-3 500
500 http://br.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
100 /var/lib/dpkg/status

Reinicie para atualizar o sistema.

Espero que com estas informações eu possa ajudar outras pessoas que tiveram os mesmos problemas que eu!

Até mais!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts