Conflito de dependências LibreOffice [RESOLVIDO]

1. Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 15/07/2021 - 01:30h

Boa noite,

Estou com conflito de dependências com o pacote LibreOffice e não consigo resolver de jeito nenhum.
Meu sistema tinha o LibreOffice nativo, mas precisei de retirá-lo para instalar manualmente a versão mais atualizada. Desconfio que instalei de forma equivocada e com isso os arquivos não foram pros diretórios corretos. O aplicativo funciona - mas parece um pouco instavel (os menus somem as vezes) - mas não é reconhecido na gnome software. E agora não consigo atualizar pelo apt.


Uso Debian 10.

Alguém tem alguma sugestão?

Já tentei:
sudo apt --fix-broken install (sugestão do proprio terminal)

sudo dpkg configure -a

e uma infinidade de outras sugestões que fui achando para problemas semelhantes aqui. mas nada resolve.



  


2. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/07/2021 - 01:41h

manda pra gente ver como está a bagunça aí
cat /etc/apt/sources.list 

apt list libreoffice* 

sudo apt update && sudo apt upgrade 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 15/07/2021 - 09:10h

cat /etc/apt/sources.list :

# See https://wiki.debian.org/SourcesList for more information.
deb http://deb.debian.org/debian buster main contrib non-free contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free contrib non-free
deb http://deb.debian.org/debian buster-updates main contrib non-free contrib non-free
deb-src http://deb.debian.org/debian buster-updates main contrib non-free contrib non-free
deb http://security.debian.org/debian-security/">http://security.debian.org/debian-security/ buster/updates main contrib non-free contrib non-free
deb-src http://security.debian.org/debian-security/">http://security.debian.org/debian-security/ buster/updates main contrib non-free contrib non-freen
# deb http://ftp.debian.org/debian buster-backports main


apt list libreoffice*
Listing... Pronto
libreoffice-avmedia-backend-gstreamer/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-avmedia-backend-gstreamer/stable 1:6.1.5-3+deb10u7 i386
libreoffice-avmedia-backend-vlc/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-avmedia-backend-vlc/stable 1:6.1.5-3+deb10u7 i386
libreoffice-base-core/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-base-core/stable 1:6.1.5-3+deb10u7 i386
libreoffice-base-drivers/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-base-drivers/stable 1:6.1.5-3+deb10u7 i386
libreoffice-base/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-base/stable 1:6.1.5-3+deb10u7 i386
libreoffice-calc/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-calc/stable 1:6.1.5-3+deb10u7 i386
libreoffice-canzeley-client/stable,stable 0.5.1-4 all
libreoffice-common/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-core/stable,now 1:6.1.5-3+deb10u7 amd64 [installed,automatic]
libreoffice-core/stable 1:6.1.5-3+deb10u7 i386
libreoffice-dev-common/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-dev-doc/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-dev/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-dev/stable 1:6.1.5-3+deb10u7 i386
libreoffice-dmaths/stable,stable 4.4.0.0+dfsg1-1 all
libreoffice-draw/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-draw/stable 1:6.1.5-3+deb10u7 i386
libreoffice-evolution/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-evolution/stable 1:6.1.5-3+deb10u7 i386
libreoffice-gnome/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-gnome/stable 1:6.1.5-3+deb10u7 i386
libreoffice-gtk2/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-gtk2/stable 1:6.1.5-3+deb10u7 i386
libreoffice-gtk3/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-gtk3/stable 1:6.1.5-3+deb10u7 i386
libreoffice-help-ca/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-common/stable,stable,now 1:6.1.5-3+deb10u7 all [installed,automatic]
libreoffice-help-cs/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-da/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-de/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-dz/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-el/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-en-gb/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-en-us/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-es/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-et/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-eu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-fi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-fr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-gl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-hi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-hu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-it/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-ja/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-km/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-ko/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-nl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-om/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-pl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-pt-br/stable,stable,now 1:6.1.5-3+deb10u7 all [installed]
libreoffice-help-pt/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-ru/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-sk/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-sl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-sv/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-tr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-vi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-zh-cn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-help-zh-tw/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-impress/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-impress/stable 1:6.1.5-3+deb10u7 i386
libreoffice-java-common/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-kde5/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-kde5/stable 1:6.1.5-3+deb10u7 i386
libreoffice-kde/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-af/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-am/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ar/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-as/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ast/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-be/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-bg/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-bn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-br/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-bs/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ca/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-cs/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-cy/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-da/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-de/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-dz/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-el/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-en-gb/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-en-za/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-eo/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-es/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-et/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-eu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-fa/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-fi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-fr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ga/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-gd/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-gl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-gu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-gug/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-he/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-hi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-hr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-hu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-id/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-in/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-is/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-it/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ja/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ka/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-kk/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-km/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-kmr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-kn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ko/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-lt/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-lv/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-mk/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ml/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-mn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-mr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-nb/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ne/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-nl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-nn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-nr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-nso/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-oc/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-om/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-or/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-pa-in/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-pl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-pt-br/stable,stable,now 1:6.1.5-3+deb10u7 all [installed,automatic]
libreoffice-l10n-pt/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ro/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ru/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-rw/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-si/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-sk/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-sl/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-sr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ss/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-st/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-sv/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ta/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-te/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-tg/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-th/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-tn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-tr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ts/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ug/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-uk/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-uz/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-ve/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-vi/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-xh/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-za/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-zh-cn/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-zh-tw/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-l10n-zu/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-librelogo/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-lightproof-pt-br/stable,stable 1:6.2.0-1 all
libreoffice-math/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-math/stable 1:6.1.5-3+deb10u7 i386
libreoffice-mysql-connector/stable 1.0.2+LibO6.1.5-3+deb10u7 amd64
libreoffice-mysql-connector/stable 1.0.2+LibO6.1.5-3+deb10u7 i386
libreoffice-nlpsolver/stable,stable 0.9+LibO6.1.5-3+deb10u7 all
libreoffice-numbertext/stable,stable 1.0.5-1 all
libreoffice-officebean/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-officebean/stable 1:6.1.5-3+deb10u7 i386
libreoffice-ogltrans/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-pdfimport/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-report-builder-bin/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-report-builder-bin/stable 1:6.1.5-3+deb10u7 i386
libreoffice-report-builder/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-script-provider-bsh/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-script-provider-js/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-script-provider-python/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-sdbc-firebird/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-sdbc-firebird/stable 1:6.1.5-3+deb10u7 i386
libreoffice-sdbc-hsqldb/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-sdbc-hsqldb/stable 1:6.1.5-3+deb10u7 i386
libreoffice-sdbc-postgresql/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-sdbc-postgresql/stable 1:6.1.5-3+deb10u7 i386
libreoffice-smoketest-data/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-style-breeze/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-style-colibre/stable,stable,now 1:6.1.5-3+deb10u7 all [installed,auto-removable]
libreoffice-style-elementary/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-style-sifr/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-style-tango/stable,stable,now 1:6.1.5-3+deb10u7 all [installed,auto-removable]
libreoffice-subsequentcheckbase/stable,stable 1:6.1.5-3+deb10u7 all
libreoffice-texmaths/stable,stable 0.43-2 all
libreoffice-voikko/stable 5.0-3 amd64
libreoffice-voikko/stable 5.0-3 i386
libreoffice-wiki-publisher/stable,stable 1.2.0+LibO6.1.5-3+deb10u7 all
libreoffice-writer2latex/stable,stable 1.4-8 all
libreoffice-writer2xhtml/stable,stable 1.4-8 all
libreoffice-writer/stable 1:6.1.5-3+deb10u7 amd64
libreoffice-writer/stable 1:6.1.5-3+deb10u7 i386
libreoffice7.1-base/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-calc/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-debian-menus/now 7.1.4-2 all [installed,local]
libreoffice7.1-dict-en/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-dict-es/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-dict-fr/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-dict-pt-br/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-draw/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-en-us/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-impress/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-math/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-pt-br/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-ure/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1-writer/now 7.1.4.2-2 amd64 [installed,local]
libreoffice7.1/now 7.1.4.2-2 amd64 [installed,local]
libreoffice/stable 1:6.1.5-3+deb10u7 amd64
libreoffice/stable 1:6.1.5-3+deb10u7 i386
libreofficekit-data/stable,stable 1:6.1.5-3+deb10u7 all
libreofficekit-dev/stable 1:6.1.5-3+deb10u7 amd64
libreofficekit-dev/stable 1:6.1.5-3+deb10u7 i386


sudo apt update && sudo apt upgrade
Atingido:1 http://security.debian.org/debian-security buster/updates InRelease
Atingido:2 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:3 http://deb.debian.org/debian buster InRelease
Atingido:4 http://deb.debian.org/debian buster-updates InRelease
Atingido:5 https://packages.microsoft.com/repos/ms-teams stable InRelease
Atingido:6 http://repository.spotify.com stable InRelease
Atingido:7 https://updates.signal.org/desktop/apt xenial InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
All packages are up to date.
W: Skipping acquire of configured file 'non-freen/source/Sources' as repository 'http://security.debian.org/debian-security buster/updates InRelease' doesn't have the component 'non-freen' (component misspelt in sources.list?)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libreoffice-core : Depende: libreoffice-common (> 1:6.1.5) mas não está instalado
libreoffice-help-common : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-help-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-l10n-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-colibre : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-tango : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).


como o apt upgrade já sugere a execução de apt --fix-broken install, tá aí também a saída:

sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
ant ant-optional coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5
coinor-libosi1v5 culmus fonts-beng fonts-beng-extra fonts-deva fonts-deva-extra fonts-gargi fonts-gujr
fonts-gujr-extra fonts-guru fonts-guru-extra fonts-hosny-amiri fonts-hosny-thabit fonts-kalapi
fonts-lohit-taml-classical fonts-mlym fonts-nakula fonts-sahadeva fonts-samyak-deva fonts-samyak-gujr
fonts-samyak-mlym fonts-samyak-taml fonts-sarai fonts-sil-scheherazade fonts-smc fonts-smc-anjalioldlipi
fonts-smc-chilanka fonts-smc-dyuthi fonts-smc-karumbi fonts-smc-keraleeyam fonts-smc-manjari fonts-smc-meera
fonts-smc-rachana fonts-smc-raghumalayalamsans fonts-smc-suruma fonts-smc-uroob fonts-taml fonts-telu
fonts-telu-extra fonts-yrsa-rasa gstreamer1.0-gtk3 java-wrappers libabw-0.1-1 libandroid-json-java
libantlr3-runtime-java libantlr4-runtime-java libaopalliance-java libargs4j-java libasm-java
libatinject-jsr330-api-java libcdi-api-java libcglib-java libcodemodel-java libcommons-cli-java
libcommons-codec-java libcommons-compress-java libcommons-io-java libcommons-logging-java libdom4j-java
libdtd-parser-java libe-book-0.1-1 libepubgen-0.1-1 libetonyek-0.1-1 libfastinfoset-java libfontbox-java
libfreehand-0.1-1 libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java
libglazedlists-java libgoogle-gson-java libguava-java libguice-java libhawtjni-runtime-java
libhttpasyncclient-java libhttpclient-java libhttpcore-java libhttpmime-java libistack-commons-java
libjansi-java libjansi-native-java libjava-string-similarity-java libjaxb-api-java libjaxb-java libjaxen-java
libjcip-annotations-java libjempbox-java libjgoodies-common-java libjgoodies-forms-java libjgoodies-looks-java
libjhlabs-filters-java libjsoup-java libjsr305-java liblightcouch-java liblog4j2-java libmariadb-java
libmaven-file-management-java libmaven-parent-java libmaven-resolver-java libmaven-shared-io-java
libmaven-shared-utils-java libmaven3-core-java libmicroba-java libmspub-0.1-1 libmwaw-0.3-3 libpagemaker-0.0-0
libpdfbox-java libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java
libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java
libplexus-sec-dispatcher-java libplexus-utils2-java libpostgresql-jdbc-java libqxp-0.0-0
librelaxng-datatype-java librngom-java libsisu-guice-java libsisu-inject-java libsisu-ioc-java
libsisu-plexus-java libslf4j-java libsnappy-java libsnappy-jni libspin-java libstaroffice-0.0-0
libstax-ex-java libstreambuffer-java libswing-layout-java libswingx-java libtxw2-java libunirest-java-java
libwagon-http-java libwagon-provider-api-java libwps-0.4-4 libxml-commons-resolver1.1-java libxsom-java
libxz-java libzmf-0.0-0 lp-solve python3-libvoikko
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
libreoffice-common
Os NOVOS pacotes a seguir serão instalados:
libreoffice-common
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
9 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/36,8 MB de arquivos.
Depois desta operação, 85,6 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-dict-es'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-nlpsolver'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-pt-br'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-mediawiki-publisher'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-ooolinguistic'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-en-us'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-xsltfilter'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-impress'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-ogltrans'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-calc'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-javascript-script-provider'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-calc'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-debian-menus'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-writer'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-librelogo'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-en-us'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-python-script-provider'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-ooofonts'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-draw'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-pyuno'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-beanshell-script-provider'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-math'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-draw'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-onlineupdate'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-libreofficekit-data'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-writer'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-firebird'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-images'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-report-builder'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-base'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-gnome-integration'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-dict-pt-br'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-postgresql-sdbc'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-ure'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-dict-en'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-math'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-dict-fr'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-pt-br'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-base'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-core'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-extension-pdf-import'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libreoffice7.1-impress'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-graphicfilter'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'libobasis7.1-kde-integration'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 280801 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libreoffice-common_1%3a6.1.5-3+deb10u7_all.deb ...
A descompactar libreoffice-common (1:6.1.5-3+deb10u7) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libreoffice-common_1%3a6.1.5-3+deb10u7_all.deb (--unpack):
a tentar sobre-escrever '/usr/bin/soffice', que também está no pacote openoffice-debian-menus 4.1.10-9807
rmdir: falhou em remover '/var/lib/libreoffice/share/prereg/': Arquivo ou diretório inexistente
rmdir: falhou em remover '/var/lib/libreoffice/share/': Arquivo ou diretório inexistente
rmdir: falhou em remover '/var/lib/libreoffice/program/': Arquivo ou diretório inexistente
rmdir: falhou em remover '/var/lib/libreoffice': Arquivo ou diretório inexistente
rmdir: falhou em remover '/var/lib/libreoffice': Arquivo ou diretório inexistente
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libreoffice-common_1%3a6.1.5-3+deb10u7_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)






4. Re: Conflito de dependências LibreOffice

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/07/2021 - 14:42h

vamos começar por arrumar esse seu sources.list

exclua dele
* todas as linhas começardas por 'deb-src'
* todas as ocorrencias duplicadas de 'contrib non-free'

Tô vendo aí que vc tem coisa d+ do libreoffice nos repositórios, adicionou algum outro repositório ??? manda aí
ls /etc/apt/sources.list.d 

Vi tb que tem ocorrências de pacotes 32bit, por acaso andou tentando ( ou instalou ) o wine aí ???


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




5. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/07/2021 - 14:48h

esqueci de pedir ...

sudo apt autoremove 


NOTA: de o comando, de enter e me mande o que vai aparecer, não de outro enter pq primeiro quero ver se a execução não vai levar junto o sistema !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




6. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 15/07/2021 - 16:27h


Mauriciodez escreveu:

vamos começar por arrumar esse seu sources.list

exclua dele
* todas as linhas começardas por 'deb-src'
* todas as ocorrencias duplicadas de 'contrib non-free'

Tô vendo aí que vc tem coisa d+ do libreoffice nos repositórios, adicionou algum outro repositório ??? manda aí
ls /etc/apt/sources.list.d 

Vi tb que tem ocorrências de pacotes 32bit, por acaso andou tentando ( ou instalou ) o wine aí ???


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



clipgrab-team-ubuntu-ppa-groovy.list mendeleydesktop.list signal-xenial.list
clipgrab-team-ubuntu-ppa-groovy.list.save mendeleydesktop.list.save signal-xenial.list.save
google-chrome.list onlyoffice.list spotify.list
google-chrome.list.save onlyoffice.list.save spotify.list.save
libreoffice-ubuntu-ppa-impish.list paolorotolo-ubuntu-droidcam-groovy.list teams.list
libreoffice-ubuntu-ppa-impish.list.save paolorotolo-ubuntu-droidcam-groovy.list.save teams.list.save





7. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 15/07/2021 - 16:47h


sudo apt autoremove

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libreoffice-core : Depende: libreoffice-common (> 1:6.1.5) mas não está instalado
libreoffice-help-common : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-help-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-l10n-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-colibre : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-tango : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).



E já precisei de instalar o wine uma vez sim.


8. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Bilufe
bilufe

(usa KDE Neon)

Enviado em 15/07/2021 - 18:48h

Você baixou o LibreOffice do site oficial? Se sim, tem certeza que você instalou todos os pacotes .DEB que foram fornecidos?


9. Re: Conflito de dependências LibreOffice

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/07/2021 - 19:11h

paromanomello escreveu:
clipgrab-team-ubuntu-ppa-groovy.list mendeleydesktop.list signal-xenial.list
clipgrab-team-ubuntu-ppa-groovy.list.save mendeleydesktop.list.save signal-xenial.list.save
google-chrome.list onlyoffice.list spotify.list
google-chrome.list.save onlyoffice.list.save spotify.list.save
libreoffice-ubuntu-ppa-impish.list paolorotolo-ubuntu-droidcam-groovy.list teams.list
libreoffice-ubuntu-ppa-impish.list.save paolorotolo-ubuntu-droidcam-groovy.list.save teams.list.save



a principio vc vai ter que tirar esse repositório ( libreoffice-ubuntu-ppa-impish.list ) pq tem no repositório oficial e um vai conflitar com o outro ... remova tudo o que não use
sudo rm /etc/apt/sources.list.d/libre* 

se não for usar a arquitetura 32bit remova
sudo dpkg --remove-architecture i386 


atualize o sistema pra gente começar a corrigir o erro no libreoffice
sudo apt update 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



10. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 16/07/2021 - 06:59h


Mauriciodez escreveu:

paromanomello escreveu:
clipgrab-team-ubuntu-ppa-groovy.list mendeleydesktop.list signal-xenial.list
clipgrab-team-ubuntu-ppa-groovy.list.save mendeleydesktop.list.save signal-xenial.list.save
google-chrome.list onlyoffice.list spotify.list
google-chrome.list.save onlyoffice.list.save spotify.list.save
libreoffice-ubuntu-ppa-impish.list paolorotolo-ubuntu-droidcam-groovy.list teams.list
libreoffice-ubuntu-ppa-impish.list.save paolorotolo-ubuntu-droidcam-groovy.list.save teams.list.save



a principio vc vai ter que tirar esse repositório ( libreoffice-ubuntu-ppa-impish.list ) pq tem no repositório oficial e um vai conflitar com o outro ... remova tudo o que não use
sudo rm /etc/apt/sources.list.d/libre* 

se não for usar a arquitetura 32bit remova
sudo dpkg --remove-architecture i386 


atualize o sistema pra gente começar a corrigir o erro no libreoffice
sudo apt update 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------


sudo rm /etc/apt/sources.list.d/libre*
[sudo] senha para paromanomello:
[email protected]:~$ sudo dpkg --remove-architecture i386
dpkg: erro: nao pode remover a arquitectura 'i386' actualmente em utilização pela base de dados
[email protected]:~$ sudo apt update
Atingido:1 http://deb.debian.org/debian buster InRelease
Atingido:2 http://security.debian.org/debian-security buster/updates InRelease
Atingido:3 http://deb.debian.org/debian buster-updates InRelease
Atingido:4 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:5 https://updates.signal.org/desktop/apt xenial InRelease
Atingido:6 http://repository.spotify.com stable InRelease
Atingido:7 https://packages.microsoft.com/repos/ms-teams stable InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
1 package can be upgraded. Run 'apt list --upgradable' to see it.
[email protected]:~$ sudo apt list --upgradable
Listing... Pronto
google-chrome-stable/stable 91.0.4472.164-1 amd64 [upgradable from: 91.0.4472.114-1]
N: There is 1 additional version. Please use the '-a' switch to see it
[email protected]:~$ sudo apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libreoffice-core : Depende: libreoffice-common (> 1:6.1.5) mas não está instalado
libreoffice-help-common : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-help-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-l10n-pt-br : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-colibre : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
libreoffice-style-tango : Depende: libreoffice-common (= 1:6.1.5-3+deb10u7) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).



11. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Paulo Antonio
paromanomello

(usa Debian)

Enviado em 16/07/2021 - 07:10h


bilufe escreveu:

Você baixou o LibreOffice do site oficial? Se sim, tem certeza que você instalou todos os pacotes .DEB que foram fornecidos?


Sim, foi o site oficial. E instalei todos os DEBs. não me parece que seja em função disso. O programa ta funcionando, mas tá com um problema nas dependencias. acho que é por eu ter adicionado mais de um repositório com versões diferentes do libreoffice. E não consigo nem limpar a bagunça agora.


12. Re: Conflito de dependências LibreOffice [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 16/07/2021 - 14:46h


sudo apt-get purge ".*:i386" && sudo dpkg --remove-architecture i386 


já adianta e remove o libreoffice
sudo apt remove --purge libreoffice* 

sudo apt update 


se tudo correu bem atualize o sistema e reinstale o libreoffice
sudo apt upgrade 
sudo apt install libreoffice 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------