Instalação do Adobe Flash Player em distros Debian-like

Publicado por edps (última atualização em 15/05/2010)

[ Hits: 5.652 ]

Homepage: https://edpsblog.wordpress.com/

Download install-flashplayer.sh




Script simples para a instalação do Adobe Flash Player em distros Debian-like.

Espero que seja útil.

  



Esconder código-fonte

#!/bin/sh

echo ""
echo " * Você deseja instalar o Adobe Flash Player?"
echo ""
echo " * Caso não queira, tecle \"N\""
echo ""

echo -n " * Instalação do Adobe Flash Plugin? (Y|n) > "
    read a
    if [ "$a" = "y" ] || [ "$a" = "Y" ] || \
    [ "$a" = "" ]; then
echo ""

echo " * Instalando o Adobe Flash Plugin..."
echo ""
sleep 2

apt-get install -y flashplugin-nonfree
sleep 2
echo ""

echo " * Instalação concluída!"
echo ""
sleep 2

echo " * Configurando o Flash Player..."
echo ""
/usr/sbin/update-alternatives --config flash-mozilla.so
sleep 2

else

echo ""
echo " * Abortando a instalação..."
sleep 1

fi

Scripts recomendados

Lixeira para console

Omelete.bsh

asbuild (Auto-SlackBuild)

Script para atualização do UVSCAN

Instalação de pacotes em uma lista


  

Comentários
[1] Comentário enviado por alaxricard em 15/05/2010 - 18:27h

Muito bom amigo.

[2] Comentário enviado por alaxricard em 15/05/2010 - 18:28h

Gostei demais do seu script.

[3] Comentário enviado por removido em 15/05/2010 - 21:35h

uma correção, na linha:
/usr/sbin/update-alternatives --config flash-mozilla.so

deixe assim:
sudo /usr/sbin/update-alternatives --config flash-mozilla.so

[4] Comentário enviado por removido em 07/04/2012 - 13:15h

aqui diz que o programa não foi encontrado. o que fazer?

[5] Comentário enviado por removido em 07/04/2012 - 14:34h

@soliver, provavelmente é porque não citei que esse pacote faz parte das seções 'contrib' e 'non-free' do Debian por isso dá esse erro, tente assim:

# nano /etc/apt/sources.list

e nas linhas referentes a sua versão do Debian acrescente ao final: 'contrib' e 'non-free' (sem as aspas), tipo isso:

deb http://sft.if.usp.br/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free

Sale e feche com CTrl+O e Ctrl+X.

Depois siga com:

# apt-get update

e ou use o script:

# ./install-flashplayer.sh

ou faça apenas isso:

# apt-get install -y flashplugin-nonfree


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts