Envia e-mails periodicamente com back-up do servidor

Publicado por André A. Ferreira 30/05/2008

[ Hits: 6.160 ]

Homepage: www.sempredejesus.com.br

Download bkp_por_email.rsc




Este script, que está bem comentado no próprio arquivo, apesar de simples tem uma importante funcão: enviar e-mails com os back-ups do servidor diariamente para o e-mail do administrador.

  



Esconder código-fonte

 


# By André 
#
# Este script faz o back-up todo dia 00:01hs e envia as 00:03hs por email.
# Testado com a versão 3.3 do mk
# 
#
# Nas opções abaixo troque serve=ip por server=200.200.200.200 
#      (onde 200.200.200.200 é o ip do seu servidor de e-mais.
#
# Na opção [email protected] coloque o email que o mikrotik
#                     vai usar pra enviar os e-mails.
#


/tool e-mail set server=200.200.200.200
/tool e-mail set [email protected]


#
#
#  Abaixo modifique a opção "[email protected]" com o 
#   e-mail do destino dos back-ups.
#
#

/system script
add name="backup" policy=ftp,reboot,read,write,policy,test,winbox,password,snif\
     source="/system backup save name=backup" 
add name="email" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff\
     source="/tool e-mail send [email protected] \
    subject=backup_mikrotik file=backup.backup" 



#
#
#
#  Agora o agendamento do back-up, primeiro para gerar o back-up, depois
#         para usar executar os scripts criados e enviar o back-up,
#                          Não altere nada abaixo.
#
#



/system scheduler 
add comment="" disabled=no interval=1d name="GRAVAR BKP DO DIA" \
    on-event="system script run backup" start-date=jan/01/1970 \
    start-time=00:01:00 
add comment="" disabled=no interval=1d name="ENVIAR EMAIL DE BKP" \
    on-event="system script run email" start-date=jan/01/1970 \
    start-time=00:03:00 

Scripts recomendados

Script de Instalação de Layer7 no CentOS 6.0

Atualização de horário

UNIX - Alerta de espaço em disco via e-mail

Renomeia diretorio,subdiretorio e arquivos de maiuscula > minuscula

Backup com TAR em LOG usando FITA LTO/DLT com filtro de arquivos, SPLIT em FITAS, envio de LOG por E


  

Comentários

Nenhum comentário foi encontrado.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts