Algorítimo de maior e menor

Publicado por Osandi augusto (última atualização em 15/09/2009)

[ Hits: 7.251 ]

Download Maior_Menor.txt




Algorítimo de verificação de maior ou menor número.

  



Esconder código-fonte

algoritmo "maior_menor"
// Função : verificar qual maior número
// Autor : Osandi augusto
// Data : 8/14/2009
// Seção de Declarações
var
vet:vetor[0..10] de inteiro
y, x, tam,maior,menor:inteiro
inicio
tam <- 3
// Seção de Comandos
para x de 0 ate tam - 1 faca
escreva("Digite seu numero: ")
leia(vet[x])
se vet[x] <= 0 entao
escreval("erro!!!, voltando ao inicio")
escreva("Digite seu numero: ")
leia(vet[x])
senao
fimse
fimpara

maior <- vet[0]
menor <- vet[0]

escreval("=============================")
escreval("Posição ","Valor recebido")

para y de 0 ate tam - 1 faca
se vet[y] > maior entao
maior <- vet[y]
senao
se vet[y] < menor entao
menor <- vet[y]
senao
fimse
fimse
fimpara

para x de 0 ate tam - 1 faca
escreval(" ",x," ",vet[x])
fimpara
escreval("")
escreval("O maior numero digitado foi: ",maior)

fimalgoritmo

Scripts recomendados

Octave - Método de Euler-Modificado para solução de EDO

Octave - Sistemas lineares por Gauss-Seidel

Octave - Decomposição LU

Script em Bath "DOS" para Upload e Download de arquivos usando o SSH

Octave - Calcular raiz pelo método de Newton


  

Comentários

Nenhum comentário foi encontrado.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts