opi, o facilitador para instalar pacotes da comunidade e multimídia para openSUSE

Publicado por niquelnausea em 27/08/2020

[ Hits: 490 ]

 


opi, o facilitador para instalar pacotes da comunidade e multimídia para openSUSE



O número de pacotes disponibilizados por cada distro em seus repositórios oficiais varia bastante, desde a organização, aplicativos e versões. Distros como o Slackware são espartanas, enquanto o Debian possuiu muitos pacotes, porém nem sempre os desenvolvedores tem possibilidades ou mesmo interesse em disponibilizar certas aplicações.

Como solução algumas distros ou mesmo usuários criam espaços onde pacotes ou scripts possam estar ao alcance de seus usuários, entre os mais famosos estão o SlackBuilds.org e AUR, e o openSUSE também tem o seu espaço, o OBS (openSUSE Build Service).

Para gerir estes pacotes, existem os "facilitadores", no caso do openSUSE, existe o opi (OBS Package Installer).
Para usuários da versão estável Leap 15.2 e também a rolling release Tumbleweed, o pacote já esta nos repositórios oficiais, basta instalar com o zypper:

# zypper install opi

E seu uso não poderia ser mais simples, basta usar o comando opi seguido do termo a ser pesquisado:

opi pacote-desejado
Outro recurso interessante é a opção de instalar os codecs multimídia de modo simples, bastando usar as opções "opi packman" ou "opi codecs".

Ao contrário do AUR que fornece uma espécie de script para construção do pacote (seja somente empacotamento ou compilação) juntamente com as suas possíveis dependências usando somente a estrutura pacotes oficiais + pacotes AUR, o OBS disponibiliza o pacote já compilado com a estrutura de um repositório. Usando o opi, é perguntado se o usuário deseja manter o repositório que disponibiliza aquele pacote (facilitando futuras atualizações) ou apenas instalar o pacote.

Apesar de ser muito mais simples que o yaourt, yay e sbopkg, o opi cumpre bem o seu papel de facilitar as buscas e instalação de pacotes oferecidos pela comunidade do openSUSE.

Outras dicas deste autor

Boot automático pelo último kernel ou sistema utilizado (GRUB 2)

Leitura recomendada

Editores PHP para Linux

Usando sempre o Firefox mais recente

Resolvendo bug de trocar avatar e enviar arquivos do aMSN 0.97

Desmembrando o Transmission no Slackware

Instalando LibreOffice no Debian 9 - versão recente

  

Comentários
[1] Comentário enviado por mauricio123 em 27/08/2020 - 12:22h


Muito bom.

___________________________________________________________
[code]Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento [/code]



Contribuir com comentário