Sis671/771 no Ubuntu 10.10

Publicado por Lúcio SLV em 28/10/2010

[ Hits: 28.513 ]

 


Sis671/771 no Ubuntu 10.10



Linux: Sis671/771 no Ubuntu 10.10 A cada lançamento do Ubuntu Linux que ocorre ininterruptamente de seis em seis meses, nós nos deparamos com um desagradável incomodo persistente chamado chipset Sis671/771. Não adianta espernear, ameaçar os caras com o Hugo Chaves, Obama ou Talibã. Eles simplesmente ignoram o fato de que há um grande contingente de usuários de computador que usam o Linux como um SOO (Sistema Operacional Operante) e nos deixaram as favas com um driver muito meia-boca de 2D que graças ao esforço de destemidos e intrépidos usuários avançados que compilam o que foi feito para o Red Hat em alguma versão jurássica deste Linux comercial para as versões atuais do x-window que basta atualizar e adeus compatibilidade do driver com a versão posterior do Ubuntu com o lançamento semestral da Canonical.

O interessante é que só nós lembramos desta famigerada marca nesse período em que temos em mãos o que na minha humilde opinião é a melhor distro da atualidade o bonitão Ubuntu Maverick, homônimo de um celebre carro esportivo dos anos 70 e que agora está tinindo em minhas mãos. Mas o velho problema persiste e após uma consulta com o "Oráculo Google" e tentativas malsucedidas aqui e ali.

Encontrei um driver compilado baseado no Mandriva em que o site julianosodeiro.wordpress.com informou que poderia funcionar no Ubuntu e que de fato funciona, basta criar um shell script básico para instalação e bingo! Resolução 1280x800 para quem tem olhos de águia ou 1024x768 que para mim é mais confortável e só daqui a seis meses é que vou xingar novamente a Sis (Síndrome de Incompetência Social).

Assim, vou disponibilizar para os amigos iniciantes e iniciados algo pronto para o imediato uso sem muita frescura e dogmatismo e que quero deixar claro que não compilei nada, não inventei nada e não descobri absolutamente nada de novo e mirabolante. Somos uma fraterna comunidade que gostamos de compartilhar conhecimentos, experiências e um driver sem-vergonha que insistem em não disponibilizarem o código fonte para o GNU/Linux em que eles não teriam nem sequer o trabalho de entregar, pois nós iríamos buscar para evitar a fadiga (nossa, é claro!:). Isto posto, vamos ao que interessa.

Um pouco de terminal não faz mal a ninguém

1) Baixe o arquivo Sis.671_771.tar.gz no link abaixo:

http://www.4shared.com/file/T5o1ORl0/Sis_671_771tar.html

2) Vamos descompactá-lo:

tar -zxvf Sis.671_771.tar.gz

3) Acesse a pasta Sis.671_771:

cd Sis.671_771

4) De permissão para executar o script conforme abaixo:

chmod +x sisimedia.sh

5) Vamos executá-lo:

./ sisimedia.sh

6) O sistema irá solicitar a senha de root, não seja medroso!

7) Reinicialize o sistema e corra pro abraço!

Ah! Vê se da próxima vez que comprar um notebook (não faça igual a mim) pergunte ao vendedor qual é o chipset ou controlador de video da máquina. E diga a ele que você tem um livecd do Ubuntu no bolso para constatar a veracidade da informação dada. Se ele tremer e gaguejar, corra pois o perigo está literalmente à vista (800x600), você foi avisado!

Viva o Linux :)

Lúcio M.V.Silva

Outras dicas deste autor

Como configurar o Grub2 no Ubuntu 9.10

Acessando a internet via wireless de modo automático no Ubuntu 9.10

Configurando resolução do X em notebooks com placa de vídeo Sis 771/671

Deletar kernel antigo para não aparecer no GRUB2

Pesquisar por arquivos no GNU/Linux

Leitura recomendada

Fedora com MATE e Compiz (Spin ou não)

Detecção automática de impressora no Linux

Instalando o MATE Menu no Debian 10 MATE

Configurando o libinput na unha

Adicionando repositório no SuSE

  

Comentários
[1] Comentário enviado por markysnr em 30/10/2010 - 08:27h

Já há um tópico aki no VOL para tratar desse problema. Comigo deu certo.

http://www.vivaolinux.com.br/dica/Driver-SIS-671-771-+-Xorg-no-Ubuntu-10.04-Lucid-Lynx

[2] Comentário enviado por gravitacoes em 30/10/2010 - 16:19h

O colega que criou o tópico está correto, a dica do Ubuntu 10.04 não serve para o Ubuntu 10.10. Pelo que entendi o drive deve estar de acordo com a versão do xorg. Resolvi o problema de outra maneira, mas creio que a dica acima funciona bem.
Contribuindo mais um pouco para resolver os problemas dessa lastimosa placa.
1) videos em fulscreen no youtube e demais playes flash lento.
Abra um video no youtube e clique com o botão direito em cima do video>configurações>em exibição e desmarque a opção “aceleração por hardware”
2) Para quem usa o VLC.
Preferências>video e na opção saida de video deixe selecionado saida de video do X11.

Eu peguei essas dicas na web e não recordo os autores, se alguém souber, por favor coloque os créditos.

[3] Comentário enviado por leodeusdead em 20/11/2010 - 13:35h

cara, valeu
Nunca foi tão fácil resolver esse problema... claro que eu já tinha quebrado a cabeça antes para tentar resolver esse problema, mas com esse script foi muito fácil.

E só para enfatizar, realmente esse chip da gráfico da sis é uma porcaria mesmo. Alem de ser muito fraco para jogos, não da suporte para Linux.

Pensem duas vezes antes de compra um note com esse chip
falo

[4] Comentário enviado por jaschi em 21/11/2010 - 19:18h

FUNCIONOU em um Notebook Intelbras i61 com o Ubuntu 10.10. Este possui placa Sis Mirage 3, chipset Sis 671.
COMPLEMENTEI O QUE O AUTOR DA DICA HAVIA POSTADO, POIS COMO ESTOU INICIANDO COM O LINUX, MAIS ESPECIFICAMENTE COM O UBUNTU 10.10, TIVE ALGUNS CONTRATEMPOS AO SEGUIR À RISCA A DICA ORIGINAL. ASSIM, FIZ ALGUMAS ALTERAÇÕES E COMPLEMENTOS PARA FACILITAR PARA QUEM ESTÁ INICIANDO.

1. Baixar o arquivo Sis.671_771.tar.gz:
http://www.4shared.com/file/T5o1ORl0/Sis_671_771tar.html
Ele será baixado para a pasta Downloads: Locais - Computador - Downloads

2. Descompactar o arquivo baixado:
Clique com o botão direito do mouse e clique em Extrair aqui
OBSERVAÇÃO: Sugere-se renomear a pasta para "sis" e movê-la para o diretório /home/<usuário>/ para facilitar o acesso.

3. Acessar a pasta que foi extraida do aquivo baixado, pelo terminal:
Clique em: Aplicativos - Ferramentas de Sistema - Terminal como Root
OBSERVAÇÃO: Poderá ser solicitada a senha do usuário root: digite a respectiva senha, prossiga e execute o comando abaixo caso tenha movido a pasta "sis" para o diretório /home/<usuário>/ como foi sugerido:
cd sis

4. Executar o comando abaixo para que se conceda a permissão para a execução do script:
chmod +x sisimedia.sh

5. Executar o comando abaixo para executar o script:
./sisimedia.sh
OBSERVAÇÃO: Poderá ser solicitada a senha do usuário root: digite a respectiva senha e prossiga

6. Reinicializar o sistema.

7, Após reinicializar, mudar a configuração de video:
Clique em: Sistema - Preferências - Monitores
No campo resolução, escolher a resolução desejada: 1280x800(16:10), 1024x768(4:3), 800x600(4:3) ou 640x480(4:3).

8. Procedimento Finalizado.

ESPERO TER CONTRIBUÍDO. AGRADEÇO A POSTAGEM DA DICA ORIGINAL POIS RESOLVEU UM ANTIGO PROBLEMA.

[5] Comentário enviado por clebinho10 em 30/11/2010 - 00:44h

Meu irmão o meu notebook é um Positivo Sim+ 2044 com Ubuntu 10.10, sou novo no mundo Linux, e quando fiz o que vocês mandaram meu pc perdeu a parte gráfica, tive de ir e excluir o xorg.conf pra poder usar novamente a parte gráfica

[6] Comentário enviado por Lúnix:) em 01/12/2010 - 10:11h

Amigão

1) Abre o seu terminal e digita ou cola, como queira, o comando abaixo:


lspci | grep VGA


2) O resultado deve ser parecido com isto:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)


3) Caso seja diferente o script não vai funcionar nem que a vaca tussa! Mas se for, os parâmetros do arquivo xorg.conf precisam ser configurados de acordo com as especificações da tela LCD do seu note. Pra isso você deve consultar o manual do mesmo e se lá não encontrar nada, liga para o SAC da positivo e pede para que eles lhe informem as especificações técnicas.

Abs,

Lúnix

[7] Comentário enviado por Roniel em 02/12/2010 - 14:41h

Cara, eu fiz tudo o que voce falou, mas quando eu reinicio o pc, ele só entra em modo de texto, pedindo login e senha, mas n sai do modo de texto, oq deve ter acontecido? como arrumar?


[8] Comentário enviado por Lúnix:) em 03/12/2010 - 15:16h

Roniel

Antes de mais nada é preciso entender que a dica só funciona para o chipset :
( Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter) caso contrário não vai funcionar o driver e o arquivo xorg.conf da forma como esta configurado vai resultar somente em tela de texto ou prompt sem a parte gráfica. Pra voltar ao que estava basta digitar os seguintes comandos:

$ cd /etc/X11
$ sudo rm /etc/X11/xorg.conf
$ sudo reboot

Quando reinicializar o sistema a parte gráfica estará restaurada e se você estiver usando o ubuntu 10.10 a resolução estará em 800x600. Abra o terminal e digite:

lspci | grep VGA

O resultado deve ser exatamente igual a isso:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Se o resultado for exatamente igual, então os parâmetros do arquivo xorg.conf precisam ser configurados de acordo com as especificações da tela LCD do seu note. Pra isso você deve consultar o manual do mesmo e se lá não encontrar nada, liga para o SAC do fabricante e pede para que eles lhe informem as especificações técnicas.

E se você leu com atenção o texto da minha dica, vai perceber que isso é um problema antigo e que por mais que tentemos ajudar as coisas nem sempre saem a contento, devido a falta de padronização e do código fonte o que se consegui é quase um milagre.

Abs,

Lúnix


[9] Comentário enviado por zecapinheiro em 09/12/2010 - 09:41h

Valeu pela dica, deu certinho na primeira !!!

[10] Comentário enviado por 82maicon em 18/12/2010 - 16:02h

Obrigado. Funcionou certinho.

Abraços.

[11] Comentário enviado por anaum21 em 06/01/2011 - 15:02h

Moçada ainda nao obtive sucesso... Tenho um Notebook de um fornecedor local (Ibyte) e estou utilizando o Kubuntu 10.10, executei o lspci conforme o Lúnix instruiu e as informações batem certim mas ainda assim quando executo o script ./sisimedia.sh conforme passado no post me aparece o seguinte erro:

# ./sisimedia.sh
./sisimedia.sh: linha 5: zenity: comando não encontrado
./sisimedia.sh: linha 9: zenity: comando não encontrado
./sisimedia.sh: linha 13: zenity: comando não encontrado

o que faço? falta algum pacote que preciso baixar antes de executar o script? teria algum outro mirro de onde posso fz o download o arquivo?

desde ja agradeço a força.

[12] Comentário enviado por camilahtinha em 07/01/2011 - 00:17h

Pessoal, uso Ubuntu Maverick em meu note philco. Eu baixei o arquivo do 4sh. fui na pasta, pelo menu de contexto cliquei extrair...
depois entrei na pasta gerada Sis.671_771 e dei duplo clique em sisimedia.sh, executar e tudo foi automático, depois pediu para reiniciar e pronto.

[13] Comentário enviado por douglas.ufpa em 31/01/2011 - 16:51h

Valew Lúcio, meu note agora tá tinindo com esse ubuntu maverick,rsrsrs....Sua dica foi excelente.

[14] Comentário enviado por andre.manzoni em 10/02/2011 - 23:19h

uhu!!! finalmente, depois de 24 horas de procura, valeu mesmo!!

[15] Comentário enviado por danilo rg silva em 24/02/2011 - 09:36h

Eu estava com o mesmo problema que o Roniel.
Valeu pelo post Lúnix!
Que Deus continue te abençoando!

[16] Comentário enviado por slaxlinux em 01/03/2011 - 20:07h

Pessoal e o contrário é válido? ou seja este script serve para o Ubuntu 10.04?

[17] Comentário enviado por eduardo.almeida em 16/03/2011 - 21:39h

DICA PERFEITA!!!

Tenho um Notebook Positivo Sim+ 1470, que veio com outra Distribuição Linux instalada. Quando reformatei o HD fiquei de volta nos 800x600. Segui fielmente os passos e tudo rodou perfeitamente. Vocês estão de parabéns!!! Abraços, Eduardo.

[18] Comentário enviado por carloeasantos em 22/03/2011 - 00:55h

boa noite, tenho um kennex U50SI que tem a placa gráfica SIS. Meu problema de resolução foi resolvido utilizando a dica acima.
Agora como possa saber o desempenho em 3d? iniciei hj meus estudos em linux

[19] Comentário enviado por natanfrost em 01/04/2011 - 01:52h

Estave eu atualizando do Ubuntu 10.04 para o 10.10 já como todos procedimentos pra fazer essa porcaria de driver da SiS funcionar. Porém, bati com a cara na porta.

Logo de cara foi para tela preta após eu dar reboot, e pediu senha e usuario, e nao saía disso. Então, deletei o xorg e ele reiniciou normalmente só que ainda me deixando esse problema da resolução da tela.

Cheguei no teu tópico e fiz como descrito e funcionou perfeitamente.

Até fui obrigado a criar uma conta aqui para poder agradacer ;)

E continua a dica: fiquem LONGE de qualquer coisa que venha com essa SiS. É furada, e das grandes.

Abraço.

[20] Comentário enviado por Thiago.Tacio em 08/04/2011 - 13:58h

Quero agradecer por este belo post, resolveu meu problema de resolução, agora está perfeito e do jeito que eu gosto, muito obrigado!

[21] Comentário enviado por rafaelbcs em 04/11/2011 - 13:25h

O link para baixar driver esta quebrado...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts