Porta paralela não criada no boot do Debian 7

Publicado por jairus lopes em 20/05/2013

[ Hits: 3.206 ]

 


Porta paralela não criada no boot do Debian 7



Debian Bug report logs - #351668
Parallel port /dev/lp0 is not created on boot

Olá!

Para que minha impressora conectada à porta paralela funcionasse, era necessário que, ao iniciar o sistema, a porta paralela fosse criada no diretório de dispositivo "/dev/".

Verifiquei todos os possíveis problemas, como por exemplo, se os módulos "parport" e "parport_pc" estavam carregados, no meu caso estavam. Mas a solução estava em outro módulo, o "lp". Este módulo não estava carregando no momento da inicialização do sistema, por isso, o dispositivo não era criado.

Então, quando executei o comando:

#> modprobe lp

E verifiquei o diretório "/dev/", lá esta o dispositivo criado "lp0". Para que ficasse de forma automática, ou seja, ao iniciar o sistema, fiz a inclusão de uma linha no seguinte arquivo: "/etc/modules".

A linha foi:

lp

Após a inserção desta linha, o módulo ficou carregando automáticamente no boot. O problema foi resolvido.


Jairus Lopes
Adm System Linux

Outras dicas deste autor

Mensagem de erro: "PHP Fatal error: Call to undefined function pg_connect()" [Resolvido]

Atualizar o Debian ETCH (4.0) para o LENNY (5.0)

DIRF 2013 no Wine - Acertando formato da data

Usando fontes Arial e Times New Roman no BrOffice

Comentar em bloco

Leitura recomendada

rdate - data e hora sempre corretas no Linux

Removendo Kernels Antigos do Fedora 33 via Interface Gráfica

Idioma Português no Fedora KDE Spin

Problemas de som (KDE)

Dica de script de ttyrec

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts