Erro: "insufficient privileges" [Resolvido]

Publicado por Xerxes Lins em 12/03/2019

[ Hits: 1.175 ]

Blog: https://voidlinux.org/

 


Erro: "insufficient privileges" [Resolvido]



Dica testada no Void Linux com i3-gaps.

Após adicionar o NetworkManager-pptp (que a propósito foi solicitação minha à equipe do Void), notei que apenas root poderia adicionar conexões VPN pelo nm-applet. Para corrigir isso é necessário alguns passos simples.

Edite o arquivo:

sudo nano /etc/polkit-1/rules.d/50-org.freedesktop.NetworkManager.rules

Adicione:

polkit.addRule(function(action, subject) {
    if (action.id.indexOf("org.freedesktop.NetworkManager.") == 0 && subject.isInGroup("network")) {
        return polkit.Result.YES;
    }
});

Salve e feche.

Adicione o usuário ao grupo network:

sudo gpasswd -a <usuário> network

Obs.: perceba que usei "network" porque o arquivo acima diz "network". Mude de acordo com um grupo da sua distribuição.

Faça logoff e entre novamente. Agora tente criar uma VPN pelo nm-applet e verá que vai conseguir.

Fonte: NetworkManager - Gentoo Wiki

Outras dicas deste autor

Quem precisa de Pidgin?!

Como habilitar sombras no MATE Desktop 1.6

Deixando o SeaMonkey em português

Instalação do MEGAsync no Void Linux

Flare - Jogo Open Source estilo Diablo

Leitura recomendada

Como usar o Dnsmasq para criar um cache de DNS local

Plugins, Codecs e Softwares Proprietários com o Autoplus

Erro na instalação do Slackware 10.2: CDROM travando

Bloqueando usúarios com o usermod

Scanner Kodak i2600 no Ubuntu

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts