Modem HSP56MR - Smartlink no Ubuntu 7.04

Publicado por Perfil removido em 09/05/2007

[ Hits: 15.424 ]

 


Modem HSP56MR - Smartlink no Ubuntu 7.04



Para configurar esse tipo de modem no Ubuntu 7.04 você precisará de um outro sistema operacional com internet funcionando para poder baixar os pacotes para instalação.

Primeiro passo, vamos instalar o driver do modem. Primeiro baixe os drivers aqui:
Agora, para instalá-los, entre no terminal como root e dê o comando:

# dpkg -i sl-modem-source_2.9.10+2.9.9d+e-pre2-5ubuntu1_i386.deb

Depois o outro:

# dpkg -i sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5ubuntu1_i386.deb

Se preferir, simplesmente dê um duplo-clique no pacote para instalar pela interface gráfica mesmo.

Obs: caso precise de alguma depêndencia para instalar esses pacotes, retorne à página de download do pacote e baixe-a.

Segundo passo, vamos instalar o Gnome-PPP, que é o discador. Primeiro, baixe o pacote aqui:
Esse pacote vai pedir muitas dependências, então você vai ter que ir baixando as dependências no site e instalando, é chato, mais não tem outra maneira (pelo menos por esse método não tem nenhuma que eu conheça).

Abaixo uma lista de dependências que foram pedidas quando eu instalei aqui:
  • bzip2_1.0.3-6build1_i386.deb
  • debhelper_5.0.42ubuntu1_all.deb
  • dpkg-dev_1.13.24ubuntu6_all.deb
  • gettext_0.16.1-1ubuntu2_i386.deb
  • gettext-base_0.16.1-1ubuntu2_i386.deb
  • html2text_1.3.2a-3_i386.deb
  • intltool-debian_0.35.0+20060710.1_all.deb
  • libgnutls11_1.0.16-13.2sarge2_i386.deb
  • libgnutls11-dev_1.0.16-13ubuntu0.3_i386.deb
  • libtasn1-2_0.2.10-4ubuntu0.0.5.04.1_i386.deb
  • po-debconf_1.0.8_all.deb
  • module-assistant_0.10.10_all.deb

Aqui eu precisei de todas essas dependências, então você já pode baixá-las de uma vez, porém na hora de instalar vá instalando de acordo com o que for pedindo, pois tem uma ordem certa pra instalar e a lista que eu postei não está na ordem.

Para instalar, dê um duplo-clique para instalar pela interface gráfica ou use o comando:

# dpkg -i pacote.deb

Terceiro passo, depois do driver instalado e o Gnome-PPP instalado, sá falta configurar o Gnome-PPP. Execute o aplicativo "Aplicações / Internet / Gnome-PPP" ou simplesmente digite gnomeppp no terminal.

Aberto o Gnome-PPP, coloque:
  • Nome de usuário;
  • Senha;
  • Numero do telefone (provedor para o qual vc desenha discar).

Depois clique em "Configurações" e na aba Modem. Em "Dispositivos", clique em "Detectar" para que ele detecte em que porta seu modem está conectado (geralmente é /dev/ttySL0), depois selecione "Tom" ou "Pulso" dependendendo da sua linha. Na aba "Opções" deixe marcada as seguintes opções:
  • Mostrar na área de notificação;
  • Abortar conexão se a linha estiver ocupada;
  • Abortar conexão se não tiver tom de discagem;
  • Verificar portadora;
  • Verificar rota padrão;
  • Ignorar seqüências de terminal (Modo Burro).

Depois disso seu Ubuntu 7.04 está configurado e pronto para acessar a internet. \o/ \o/

Se apresentar algum erro na hora de conectar, tente fazer os seguintes procedimentos:

Alguns modems precisam ter a opção "Verificar Portadora" desabilitada para funcionar corretamente, então no caso de algum erro na hora de conectar tente desmarcar essa opção pra ver se funciona.

Caso dê algum problema tente também executar o seguinte comando no terminal:

$ sudo /etc/init.d/sl­modem­daemon restart

Se mesmo assim não funcionar poste sua dúvida que eu ajudarei a medida do possível.

Outras dicas deste autor

Configurando placa de rede para IP fixo no Debian

Ubuntu 12.04 - aMule não inicia [Resolvido]

Base de dados mais organizada em shell script

Debian 5 Lenny - Iceweasel como Firefox no Orkut e similares

Vídeo aula: Instalando o Cedega

Leitura recomendada

lsof - Pequeno guia de referência

Modem ZTE mf645 no Linux sem aperreio

Instalação do VMWare Server no Debian 5

Iniciando na programação com o interpretador UAL

Conexão SSH entre servidores Linux sem senha

  

Comentários
[1] Comentário enviado por pleao em 10/05/2007 - 21:41h

somente para reforcar sua materia:

Apos seguir suas dicas de isntalacação tive o seguinte erro:
./sl-modem-daemon start
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

Realizei esta mudanca no arquivo /etc/default/sl-modem-daemon

#SLMODEMD_DEVICE=auto
SLMODEMD_DEVICE=hw:0
SLMODEMD_COUNTRY=BRAZIL
#SLMODEMD_COUNTRY=GERMANY

e ai ...

./sl-modem-daemon start
Starting SmartLink Modem driver for: hw:0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.


Consegui detectar o modem e ter resposta

ainda da NO CARRIER na hora de efetuar coneção + acho que estou no caminho ...


[2] Comentário enviado por removido em 12/05/2007 - 22:12h

como assim?
da dando algum erro?
vc nao estava conseguindo detectar o modem, agora esta conseguindo, porem esta dando NO CARRIER?
é isso?

[3] Comentário enviado por pleao em 14/05/2007 - 21:22h

Isto mesmo.
Eu comecei a ter problemas estranhos pois qdo algum dispositivo ia acessar o driver alsa travava o software, amarok, kaffeine.

segui o tutorial do dicas-l e ai rolou, agora ate conectar ja consegui.
http://www.dicas-l.com.br/dicas-l/20070509.php

[4] Comentário enviado por brasileiro em 05/06/2007 - 19:02h

Olá!
Valeu pela dica.
Fiz a instalação. O modem está vivo e consigo conectar. Mas toda vez que ligo a máquina e acesso o usuário tenho que efetuar o seguinte comando: /etc/init.d/sl-modem-daemon restart, para conseguir me conectar.
Existe alguma maneira de evitar este problema?

[5] Comentário enviado por pleao em 06/06/2007 - 21:13h

tenta fazer isto :
ln -s /etc/init.d/sl-modem-daemon /etc/rc5.d/S12sl-modem-daemon

[6] Comentário enviado por fabianekr em 05/07/2007 - 15:42h

Ola,
Segui os passos do tutorial. Consegui instalar e ateh mesmo discar (coisas que nao tinha conseguido ainda). Ele disca, chama, mas nao consegue efetuar a conexao. Depois de um tempo da o erro de NO CARRIER e isso nao muda mesmo alterando as opcoes de Verificar Portadora. O comando de restart tambem nao funciona.
Voce tem alguma ideia do que posso tentar fazer?
Muito obrigada pela ajuda.

[7] Comentário enviado por carlosaluisio em 09/07/2007 - 12:09h

Tche.. configurar driver em Linux é sempre isso....

Custava fazerem uma interface gráfica, instalando o modem, e fazendo ele funcionar direitinho, sme ter que ficar editando arquivo, e sudo pra lá, e configure pra cá ???

Isso é coisa dos xiitas do Linux, que não está nem aí com o usuário final, e fazem essa porcarias de coisas de vez em quando. Ainda bem que existe o Ubuntu e o Kurumin, que visam quebrar esse pardigma. A mesma coisa que o feniz, que uns xiitas que gostam de slackware, nerds que gostam de ficar fuçando em computador pra resolver problema em vez de usar ele para ganhar dinheiro prontamente criticam até não poder mais.

Que nem o celular M65, que não teve jeito de fazer funcionar no Ubuntu 7.04

Olha só isso:

ln -s /etc/init.d/sl-modem-daemon /etc/rc5.d/S12sl-modem-daemon

Vê se eu tenho tempo pra ficar fazendo essas coisas, pelo amor de Deus ! Não é mais fácil clicar em "avançar , instalar, pronto, funcionando, sem o minimo de dor dde cabeça" ???
meu amigo, a resposta é o seguinte, eu memso, perdi dois dias tentando fazer essa porcaria do modem smartlink funcionar no ubuntu, e te digo: não funciona, parte pra outra. Os drivers funcionam em algumas máquinas, em outras n,ão. Esquece. Ele até acha o modem, responde, mas persiste no "sem tom de linha"...

[8] Comentário enviado por Ariomar em 13/07/2007 - 20:25h

Pessoal

Consegui instalar o modem e consigo me conectar. Só que toda vez que inicializo o computador tenho que ir no terminal e digitar o seguinte comando:

/etc/init.d/sl-modem-daemon restart.

Tentei o comando citado acima:

ln -s /etc/init.d/sl-modem-daemon /etc/rc5.d/S12sl-modem-daemon.

Mas dá a seguinte mensagem:

[email protected]:/home/carvalho# ln -s /etc/init.d/sl-modem-daemon /etc/rc5.d/S12sl-modem-daemon
ln: criando link simbólico `/etc/rc5.d/S12sl-modem-daemon' to `/etc/init.d/sl-modem-daemon': O arquivo já existe

Por favor, alguém sabe como resolver esse problema?
Quero agradecer por essa dica. Sem sobra de dúvidas, uma das melhores. Facilita muito a nossa vida.

Ariomar

[9] Comentário enviado por pleao em 13/07/2007 - 23:19h

Isto pode ainda estar acontecendo porque o driver nao ativou no momento certo.

Faca o seguinte teste:

#> sudo rm -rf /etc/rc5.d/S12sl-modem-daemon
#> sudo ln -s /etc/init.d/sl-modem-daemon /etc/rc5.d/S99sl-modem-daemon

Desta forma vc vai passar o servico para ser um dos ultimos a ativar.
Deve funcionar.


[10] Comentário enviado por removido em 16/07/2007 - 09:45h

Será que funciona com o modem LG IN56?

ele é Smart Link... deve funcionar, né? mas se alguém puder confirmar enquanto eu baixo os pkgs, eu agradeço...

[11] Comentário enviado por gandiva em 08/09/2007 - 14:21h

Ola pessoal, apartir deste artigo eu instalei o meu modem LG netodragon no kubuntu7, num entanto, como o pleao sinalizou, ele apresenta a mensagem, NO CARRIER (sem portadora), quero saber se alguem ja achou a solucao??
Abracos!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts