Instalando o Flash Player no Debian Etch em máquinas 64 bits

Publicado por Perfil removido em 30/11/2007

[ Hits: 13.416 ]

 


Instalando o Flash Player no Debian Etch em máquinas 64 bits



O Flash Player não tem versão 64 bits, então para instalá-lo é necessário alguns pacotes wrappers extras para que o plugin da Adobe funcione corretamente.

Os pacotes são respectivamente o nspluginwrapper e o ia32-libs-gtk (não oficiais!).

Então (assumindo que tenha o Iceweasel ou Firefox instalado), no Debian Etch precisamos fazer os seguintes passos.

Abra um terminal e como root faça o seguinte:

1. Adicione o seguinte repositório em /etc/apt/sources.list:

deb http://www.dipconsultants.com/debian etch main

2. Atualize a base do apt:

# aptitude update

3. Instale as chaves de autenticação do repositório:

# aptitude install markybob-keyring

4. Atualize a base do apt novamente:

# aptitude update

5. Instale os pacotes necessários:

# aptitude install ia32-libs-gtk nspluginwrapper

Agora, logue como usuário comum, faça os seguintes procedimentos no seu respectivo /home/USER.

1. Baixe o instalador do Adobe Flash:

$ wget http://fpdownload.macromedia.com/get/flashplayer/current/\
install_flash_player_9_linux.tar.gz


2. Descompacte os arquivos:

$ tar -zxf install_flash_player_9_linux.tar.gz

3. Mova-os para o diretório .mozilla/plugins (caso não tenha um crie com mkdir .mozilla/plugins):

$ mv install_flash_player_9_linux/flashplayer.xpt install_flash_player_9_linux/libflashplayer.so /home/USER/.mozilla/plugins/

4. E finalmente instalando o plugin:

$ nspluginwrapper -i ~/.mozilla/plugins/libflashplayer.so

5. Restarte o Iceweasel/Firefox e visite um site que use flash (YouTube, Last.fm, etc) ou confira digitando about:plugins na barra de endereço do navegador.

Você pode conferir estes mesmos passos no seguinte endereço:
Enjoy! =)

Outras dicas deste autor

Modificando a aparência do Opera

Como compartilhar pasta em rede no Ubuntu [vídeo]

Como criar uma calculadora no Gambas3 [Vídeo]

Vídeo aula - Executando o VirtualBox

Webcams: luz, camera, ação!

Leitura recomendada

Reportando bugs do Fedora e dos produtos RedHat

ompload - uploader de arquivos via terminal

Beryl no Kurumin 7 com Nvidia

Estilos de Bash Prompts

Clonando ou copiando VCD com cdrdao

  

Comentários
[1] Comentário enviado por Brunonormandia em 30/11/2007 - 18:08h

Excelente dica!

Saberia me indicar como faço para minha placa de som (Nvidia) e dispositivos Usb (pendrive,mp3,etc) serem detectados pelo sistema??
Porque pelo que tenho notado a unica maneira de funcionarem seria atualizando o kernel.....

alguém conhece outro jeito??

agradeço desde já...
flw

[2] Comentário enviado por removido em 03/12/2007 - 10:35h

Oi Bruno,

Não entendi a sua dúvida (kernel 64?) mas acho que em fóruns como o do Ubuntu ou as listas do Debian você pode achar soluções para esses problemas de instalação dos módulos facilmente.

Abs

[3] Comentário enviado por reinaldovale em 24/03/2008 - 17:40h

Não funcionou comigo. Quando executo o seguinte comando: "aptitude install ia32-libs-gtk nspluginwrapper". O aptitude diz:
----------------------------
Os pacotes a seguir possuem dependências não satisfeitas :
libc6-i386: Depende: libc6 (= 2.3.6.ds1-13etch5) mas 2.7-9 está instalado.
lib32asound2: Depende: libasound2 (= 1.0.13-2) mas 1.0.16-2 está instalado.
Resolving dependencies...
As seguintes ações resolverão essas dependências :

Instalar os pacotes a seguir :
lib32asound2 [1.0.16-2 (now)]
libc6-i386 [2.7-9 (now)]

Pontuação é -12

Aceitar esta solução ? [Y/n/q/?]y
-------------------------------------------------------
Após eu esclhoer "Y" ele repete a mesma mensagen acima e fica nesse loop e não resolve. O que faço?

[4] Comentário enviado por reinaldovale em 25/03/2008 - 19:06h

Finalmente consegui instalar o Flash 9 no meu Debian Etch AMD64, porém não da forma que o Eriksen mostrou. Eu fiz o seguinte:
#aptitude install flashplayer-mozilla. Simples não? Ele faz de forma automática o que foi dito pelo Eriksen, porém no meu caso precisei rebaixar algumas libs. Não se preocupem pois não tive nenhum efeito colateral rebaixando essas libs. Um abraço.

[5] Comentário enviado por removido em 26/03/2008 - 00:26h

Você foi mais rápido que minha resposta!

Só lembrando que para instalar o flashplayer-mozilla (não lembro se já estava empacotado na época que escrevi) você precisa ter o repositório debian-multimedia, basta adicionar a seguinte linha no sources.list:

# vi /etc/apt/sources.list
deb http://www.debian-multimedia.org stable main

Mais informações sobre o pacote:
http://debian-multimedia.org/dists/stable/main/binary-amd64/package/flashplayer-mozilla.php



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts