Instalando e configurando o Ubuntu em Dell Optiplex 320

Publicado por Jakson Galeti em 06/03/2008

[ Hits: 16.573 ]

 


Instalando e configurando o Ubuntu em Dell Optiplex 320



Para fazer a instalação dê o boot pelo CD. Antes de inicializar a instalação pressione F6 e escreva o seguinte parâmetro ao final da linha:

pci=nomsi acpi=off

Em seguida, pressione Enter. É comum demorar um pouco, pois estamos entrando no live CD.

Siga a instalação normal até o momento do particionamento, onde merece uma atenção maior, pois em caso de querer trocar de distro sua partição home e swap serão preservadas.

Uma dica legal é dividir o HD em no mínimo 3 partições: na primeira partição coloque com o "/" raiz do sistema, na segunda coloque como "swap" e na terceira com o diretório "/home" do usuário.

Agora vamos a parte mais legal, quando acaba a instalação o Ubuntu tenta dar boot, mas não consegue então vamos dar um boot pelo Live CD para consertar as coisas.

Não sei porque mas a série Dell Optiplex 320 não consegue carregar o GRUB, então vamos ter que entrar pelo live CD e instalar e configurar o Lilo.

Depois que entrar no live CD, entre em um terminal e siga rigorosamente os comandos abaixo:

sudo passwd root - aqui você troca a senha do root;
cd / - vamos para a raiz;
fdisk -l - verifique onde esta localizado o "/" do seu sistema;
mkdir ubuntu - criamos este diretório para alocar o nosso sistema;
mount /dev/sdaX /ubuntu - neste ponto montamos o raiz do sistema no diretório ubuntu;
mount -t proc none /ubuntu/proc
mount -o bind /dev/ /ubuntu/dev
- estamos montando partes essenciais ao sistema em ubuntu;
chroot ubuntu - neste ponto estamos entrando como root no ponto em que montamos o sistema, que no caso e o diretório /ubuntu;

Execute o seguinte comando para instalar o Lilo:

# apt-get install lilo

Após ter instalado vamos ter que trocar o nosso fstab, para isso faça:

# nano /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc            /proc      proc   defaults   0   0
# /dev/sda2
/dev/sda2        /        ext3     defaults,errors=remount-ro 0     1
# /dev/sda3
/dev/sda3        /home        ext3     defaults     0     2
# /dev/sda1
/dev/sda1        none        swap     sw     0     0
/dev/scd0        /media/cdrom0     udf,iso9660 user,noauto,exec 0     0

O GRUB usa parâmetros diferentes do Lilo no fstab por isso vamos apagar os UIDS e vamos inserir as partições onde se refere cada ponto de montagem.

Acima é um exemplo de como ficou o meu fstab após a substituição dos dispositivos.

Feito isso é hora de rodar o outro comando:

# liloconfig

Este comando ira rodar o configurador do Lilo, marque sua partição "/" como arranque, instale o Lilo na MBR e marque sua partição como ativa.

Agora vamos ao arquivo de configuração do lilo.conf, execute este comando no terminal:

# nano /etc/lilo.conf

# Specifies the location of the map file. If MAP is
# omitted, a file /boot/map is used.

map=/boot/map

# Specifies the VGA text mode that should be selected when
# booting. The following values are recognized (case is ignored):
# NORMAL select normal 80x25 text mode.
# EXTENDED select 80x50 text mode. The word EXTENDED can be
# abbreviated to EXT.
# ASK stop and ask for user input (at boot time).
# <number> use the corresponding text mode. A list of available modes
# can be obtained by booting with vga=ask and pressing [Enter].

vga=normal

# Defines non-standard parameters for the specified disk.
#disk=/dev/sda
# bios=0x80

# If you are using removable USB drivers (with mass-storage)
# you will need to tell LILO to not use these devices even
# if defined in /etc/fstab and referenced in /proc/partitions.
# Adjust these lines to your devices:
#
# disk=/dev/sda inaccessible
# disk=/dev/sdb inaccessible

# These images were automagically added. You may need to edit something.


image=/boot/vmlinuz-2.6.22-14-generic
    label="Gusty_Jakson"
    initrd=/boot/initrd.img-2.6.22-14-generic
    append="pci=nomsi acpi=off splash"
    read-only

image=/boot/memtest86+.bin
    label="Memory Test+"
    read-only

# If you have another OS on this machine (say DOS),
# you can boot if by uncommenting the following lines
# (Of course, change /dev/hda2 to wherever your DOS partition is.)
# other=/dev/hda2
# label="MS Windows"


Desta forma ficou o meu lilo.conf, fica a gosto a personalização deste arquivo, podendo deixar o padrão sem nenhum problema.

Em seguida rode o comando:

# lilo

Para adicionar o suas configurações ao lilo.conf ao gerenciador lilo.

Agora vamos reiniciar a máquina e sair do live CD para podermos usar o nosso Ubuntu neste Micro.

Bom agora vamos a personalização do sistema;

Problemas com áudio

Se você logar e não escutar o som dos tambores africanos é porque ainda temos que configurar o alsamixer do ubuntu.

Vamos novamente no terminal, execute os comandos como root:

# alsamixer

Este comando abre a configuração do alsamixer, com as setas do teclado navegue pelos controles que estão com MM e pressione a tecla M para tirar do modo mudo, após ter feito todas as alterações sairá do alsamixer e volte ao terminal.

Compiz-Fusion no Ubuntu

Como fica chato instalar o Ubuntu e não ter o desktop 3D!

Para instalar o compiz-fusion é necessário que o driver de vídeo esteja instalado.

Execute o seguinte comando no terminal:

# apt-get install xserver-xgl

Você está instalando xserver-xgl que da suporte a sua placa a executar aplicações 3D.

Se faz necessário a reinicialização do sistema, então faça-o.

Agora vamos instalar o Compiz Fusion. Indo no menu Sistema -> Administração -> Gerenciador de Pacotes Synaptic. Clique em procurar e escreva Compiz. Marque:
  • compizconfig-settings-manager
  • compiz-fusion-plugins-extra
  • compiz-fusion-plugins-main

E mande instalar os pacotes selecionados.

Para configurar compiz, clique no menu Sistema -> Preferências -> Advanced Desktop Effects, e personalize a gosto.

Outras dicas deste autor

Driver SIS 671/771 + Xorg no Ubuntu 9.10 Karmic Koala

Driver SIS 671/771 + Xorg no Ubuntu 10.04 Lucid Lynx

Checando dependências de pacotes em Debian Linux e derivados

Leitura recomendada

Alterando o gerenciador de sessão no Fedora 21

Proxy no Xfce 4

Recuperando o Boot Booster no Asus EEE PC 1001HA

Módulo de Segurança do BB no Debian 10 - Sem Frescuras

Adicionando o Timestamp no History

  

Comentários
[1] Comentário enviado por dfsantos em 07/03/2008 - 09:17h

POW EM FIM UMA PERFEITA DICA A RESPEITA DESSE MODELO DELL OPTPLEX 320 QUE E FECHADIM FECHADIM PA RODA LINUX, POSSUO AKI NA EMPRESA VARIOS MODELOS DESTE E ESSA DICA FOI MUITO UTIL PARA OBTER SUCESSO NESSA LUTA.... OBRIGADOO POR COMPARTILHAR SEU CONHECIMENTO CONOSCO, POR ISSO QUE O VOL CONTINUA CRESCENDO
SO TEM FERA AKI!!!

[2] Comentário enviado por arthurzanona em 02/09/2008 - 01:08h

Excelente artigo,me ajudou muito, só gostaria que acrescentar algumas informações, no kubuntu precisei acrescentar ao boot pnpbios=off

[3] Comentário enviado por jgaleti em 02/09/2008 - 08:46h

Obrigado, que bom que você obteve sucesso e ainda incorporou algo mais. Essa é a verdadeira idéia do software livre compartilhar informação e deixar ser melhorada para que todos possam tela próximo a perfeição.
Viva O Linux.

[4] Comentário enviado por napvasconcelos em 11/09/2008 - 08:27h

Ola,

tenho uma maquina dessas (Dell Optplex 320) com Windows e gostaria de usar como dual boot.
Nela temos ja duas particoes: sda1 (recovery) e sda2(main windows). Sendo assim instalei o Linux no sda3 (/) e sda4(swap).
Na hora que vou instalar o lilo, no momento que roda o liloconf, aparece essa tela abaixo.

E ai' ??


WARNING! │
│ │
│ Your /etc/fstab configuration file gives device /dev/sda3 as the root filesystem device. This doesn't look to me like an "ordinary" block device. │
│ Either your fstab is broken and you should fix it, or you are using hardware (such as a RAID array) which this simple configuration program does not │
│ handle. │
│ │
│ You should either repair the situation or hand-roll your own /etc/lilo.conf configuration file; you can then run /usr/sbin/liloconfig again to retry │
│ the configuration process. Documentation for LILO can be found in /usr/share/doc/lilo/.

[5] Comentário enviado por jgaleti em 11/09/2008 - 13:18h

Ola napvasconcelos, Boa tarde!

Você trocou as entradas de: /etc/fstab?
Antes de rodar o liloconfig, você tem que mudar o /etc/fstab, porque as entradas que estavam lá são provenientes do gerenciador GRUB. Troca as entradas e se der erro posta os logs aqui.

[6] Comentário enviado por rafiulx em 15/09/2008 - 13:56h

Olá Colega.. Estou iniciando no mundo linux e tenho um optiplex 320 e não consegui resolver o meu problema na instalação.. Fiz td o que vc ensinou, atualizei o LILO e quando executo liloconfig, consido definir a partição de arranque e quando vou definir o bitmap e escolho por exemplo coffee.bmp simplesmente aparece ERRO! Corrija manualmente o /etc/lilo.conf e volte a correr /sbin/lilo... ai o liloconfig fecha-se e volta pro terminal onde aparece a mensagem: searching for installed kernels and updating image entries ...
/bin/ls: impossivel acessar /boot/vmlinuz*: Arquivo ou diretário inexistente
Warning: Partition 3 on /dev/sda is not market Active.
Warning: Unable to determine video adapter in use in the present system
Warning: Video adapter does not support VESA BIOS extensions needed for display of 256 colors. Boot loader will fall back to TEXT only operation.
Fatal: No images have been defined

Me ajude!

[7] Comentário enviado por jgaleti em 15/09/2008 - 15:17h

Poste aqui como esta configurado o seu fstab, para que eu possa saber onte esta montado o seu sistema e como esta montado.

[8] Comentário enviado por rafiulx em 15/09/2008 - 19:47h

Esquece amigo... consegui.. É que eu tinha particionado meu HD em 4 sendo a primeira particão com 100mb com ponto de montagem /boot, a segunda com 4000gb como swap, a terceira com 30gb como / , e a quarta como /home.. Não sei o que tava dando, mas tirei a partição /boot e funcionou normalmente obrigado... Só que agora tenho outro problema.. Fiz algumas atualizações e agora o ubuntu para na tela "loading Lin_2.6.25img0" e fica parado.. o que eu faço?

[9] Comentário enviado por Jhonny Roger em 06/12/2008 - 02:09h

Muito bom este post já vou salvar!!

[10] Comentário enviado por odone.machado em 20/07/2009 - 22:37h

Infelizmente nao obtive exito, tenho um Opti 320 que nao roda Ubuntu de jeito nenhum. Segui todos os passos sem sucesso nele, tenho um Dimension e a dica funcionou certinho. Testei o Ubuntu desde a 7.04 sem sucesso que nao bootava. Ja li que o Kurumin funciona bem nele. Pretendo colocar o Kurumin e atualizar o Firefox, Open Office, java e flash. É a ultima máquina Windows em casa :-) A melhor lição que aprendi é que temos que escolher o hardware de fabricantes que Privilegiam o Linux. O meu Dimension é cem por cento Intel e é só alegria com o Ubuntu 9.04. Um abraço a todos.



Contribuir com comentário