Driver SIS 671/771 + Xorg no Ubuntu 10.04 Lucid Lynx

Publicado por Jakson Galeti em 14/05/2010

[ Hits: 58.703 ]

 


Driver SIS 671/771 + Xorg no Ubuntu 10.04 Lucid Lynx



Como de costume, há mais de três anos venho acompanhando os lançamentos das versões do Ubuntu e em todas elas travo uma batalha para poder desfrutar desta bela distro no meu notebook. A 10.04 não vem com o xorg.conf e, para piorar, quem tem notebook e usa o driver SIS 671/771 simplesmente fica restrito a resolução 800x600.

Mais uma vez garimpando na net achei a forma de contornar este problema desagradável. Vamos à solução.

Verifique se sua placa de vídeo tem a saída parecida com a seguir:

lspci | grep -i vga
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Se sim, abra o Firefox e baixe os arquivos para um local de sua preferência. Neste exemplo eu salvei no desktop. Abaixo seguem os links.
Abra um terminal e execute os comandos abaixo.

Com o comando abaixo vamos entrar no diretório que iremos trabalhar:

cd /etc/X11/

Copie para este diretório os arquivos baixado:

sudo cp /home/jakson/Área\ de\ Trabalho/sis_driver_* ./
$ sudo cp /home/jakson/Área\ de\ Trabalho/xorg.conf.tar.gz ./
$ sudo tar zxvf sis_driver_*
$ sudo tar zxvf xorg.conf.tar.gz


Até este passo já baixamos e descompactamos os arquivos no diretório padrão. O arquivo do xorg.conf já esta nele. Quanto ao arquivo do driver, vamos copiá-lo para o seu destino. Dentro de /etc/X11/ foi criado um diretório 32-bit ou, caso tenha feito o download de 64 bits, o diretório é 64-bit.

Entre no diretório e execute os seguintes comandos:

cd 32-bit/
$ ls

readme.txt
sis671_drv.la
sis671_drv.so

Copie os arquivos "sis*" para "/usr/lib/xorg/modules/drivers":

sudo cp sis671_drv.* /usr/lib/xorg/modules/drivers

E para finalizar, reinicie o note.

init 6
ou
reboot

Quando iniciar, logue-se com seu usuário, clique em "Sistema -> Vídeo" e em resolução aplique a que melhor se enquadra ao seu note. Eu segui estes passos e tive sucesso em um notebook da CCE, espero que esta dica ajude mais alguém.

Créditos: www.google.com.br + ajoliveira.com/ajoliveira/uk/

Outras dicas deste autor

Checando dependências de pacotes em Debian Linux e derivados

Instalando e configurando o Ubuntu em Dell Optiplex 320

Driver SIS 671/771 + Xorg no Ubuntu 9.10 Karmic Koala

Leitura recomendada

Plymouth Splash - Testando sem reiniciar o computador

Instalação do ZoneMinder no CentOS 5.5 64 bits

Instalação do Java JDK no Ubuntu 11.10

Atualizando Linux Mint to 13 para o 14

Como fazer o lilo funcionar em HDs com mais de 1024 cilindros (10Gbyte)

  

Comentários
[1] Comentário enviado por no.molas em 24/05/2010 - 16:21h

Cara Obrigado pelo compartilho dessa informação!!!
me ajudou muito!!
vlw mesmo!!
fiz isso no ubuntu 10.04 64bits, funcionou blz!!

abraços

[2] Comentário enviado por jgaleti em 24/05/2010 - 16:28h

OK.
Abraços.

[3] Comentário enviado por odone.machado em 30/05/2010 - 13:12h

Segui os passos no meu note Intelbras I10 e funcionou certinho.
Muito obrigado pela dica
Me ajudou muito

Um abraço

[4] Comentário enviado por sandro@sandro em 30/05/2010 - 20:17h

olá pessoal estou com problemas com esse driver sis mas... ao execultar esses comandos o resultado e COMANDO NOT FOUND talvez estou fazendo algo errado pois so uso ubuntu a uma semana se alguem puder me ajudar ficarei grato vlw.

[5] Comentário enviado por gabrielneutzling em 03/06/2010 - 23:17h

Obrigado por compartilhar essas informações.
Parabéns pelo detalhamento e explicação.
Tenho um note da Philco [PHN 14118] e funcionou ok.

Abraços.

[6] Comentário enviado por PauloDeLimma em 04/06/2010 - 21:12h

Olá Jakson,

Eu também quero agradecer por você ter compartilhado esse procedimento que foi muito útil pra mim. Sou novato no Ubuntu e vinha usando o Lucid Lynx durante esse tempo todo achando que aquela resolução esquisita era o padrão dele. Agora a definição tá bem mais agradável.... :-)

Mas ainda tenho umas dúvidas: fiz tudo do jeito que você especificou, mas no menu "Sistema" não tem nenhuma opção "Vídeo". E outra: se esse é o driver de vídeo do meu notebook, por que ele ainda inicia e desliga mostrando uns chuviscos ao invés do logotipo do Ubuntu? Por que eu ainda não consigo habilitar os efeitos visuais? E por que quando eu vou em "Sistema -> Administração -> Drivers de hardware" vejo uma mensagem dizendo que não há drivers proprietários em uso no sistema?

[7] Comentário enviado por pako em 06/06/2010 - 12:37h

Parabéns! Adorei seu tutorial, deixou a resolução da tela excelente! Continue com o ótimo trabalho e mais uma vez parabéns! Pako

[8] Comentário enviado por landex em 06/06/2010 - 19:14h

Cara muito bom foi esta dica que me ajudou a configurar o meu note... heheh valeu!!!

[9] Comentário enviado por landex em 10/06/2010 - 08:58h

Cara tenho um nova data que usa esta placa e a um ano toda as atualizações do ubuntu tenho quer realizar este tramiti de configurar a placa. A detalhe eu sempre tenho que fazer uma atualização limpa ou seja formatar e instalar a nova versão do Ubuntu...

[10] Comentário enviado por removido em 10/06/2010 - 17:36h

Eu estou com o driver 2D do Barros Lee e está com um desempenho muito bom. É só ir no blog dele e ir no SiS on Ubuntu 10.04 e pedir um driver nos comentário ele manda via email e por isso obviamente você tem que deixar seu email.

[11] Comentário enviado por removido em 12/06/2010 - 09:43h

Amigão! Deu certo aqui com o Debian Squeeze em um Notebook CCE.

[12] Comentário enviado por dida101 em 24/06/2010 - 14:59h

otimo topico amigo, tenho certza que o topico resolvera o meu problema, porem sou extremamente novo no linux e nao estou conseguindo executar os passos, como por exemplo abrir os locais atravas dos passos citados e nem identificar como descompactar os arquivos para os locais citados, reconheço que é por falta de experiencia minha, mas se alguem ai puder se oferecer para me reexplicar o tutorial, mais bem detelhado (mastigado), pois tenho dificuldade de resolver os passos, porem... ficarei mto gratoo..

vlww...

[13] Comentário enviado por Lukez em 29/06/2010 - 22:56h

Não funcionou comigo. Fiz e revisei todos os procedimentos exatamente como citados, e assim mesmo não deu.

Aqui está meu log do xorg, se for útil:

http://www.4shared.com/file/04QvBtlY/log.html


Se possivel, mande uma resposta por e-mail.
Obrigado.

[14] Comentário enviado por pedro_mcp em 06/07/2010 - 20:52h

Srs,

Esta é a mesma solução para o Debian Squeeze....

Testei tanto o 64 quanto o 32...

[15] Comentário enviado por themonteiro em 06/07/2010 - 21:14h

Jakson,
Meus parabéns pela tua dedicação, funcionou perfeito no meu Note I415 Intelbras. A resolução ficou ótima. Fique com Deus.

[16] Comentário enviado por (xinelo) em 17/07/2010 - 23:04h

Testei na minha partição de experiências aqui com o squeeze 32bit (i386), ficou perfeito! Boa dica, abraços

[17] Comentário enviado por markone em 21/07/2010 - 21:29h

Olá Jackson,

Segui o seu tutorial conforme explicado, entretanto meu vídeo ficou completamente transfigurado. Ele se repartiu ao meio horizontalmente, a resolução melhorou em dobro aproximadamente, e aparece um chuvisco de linhas horizontais na tela. Além do mais na janela Sistema>Preferências>Monitor a resolução se reduziu somente para 640x480.
O que pode ter acontecido? Você poderia me ajudar a resolver esse pepino?

Atenciosamente,

[18] Comentário enviado por landex em 23/07/2010 - 08:35h

Markone, como esta configurado o xorg da sua máquina. Se possivel poste aqui.

[19] Comentário enviado por markone em 25/07/2010 - 14:59h

Landex,

Sinto te dizer mas eu reinstalei o Ubuntu 10.04 por cima do mesmo,logo fiquei sem o xorg.conf para postar. Meu notebook é CCE, estou no aguardo de alguém me esclarecer por que ocorreu esta bagunça na minha tela.

Atenciosamente,

[20] Comentário enviado por markone em 25/07/2010 - 17:14h

Olá landex,

Mesmo sem o xorg.conf gravado no sistema, baixei-o novamente no link aconselhado por Jackson. E estou detalhando-o abaixo (sem os comentários iniciais no arquivo):

Section "Device"
Identifier "Configured Video Device"
Driver "sis671"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
End Section

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Espero ter ajudado a desvendar o problema. Por favor, escreva se tiver alguma novidade sobre o resolução do problema.

[21] Comentário enviado por rsmp.rsmp@gmail. em 26/07/2010 - 17:39h

Tenho laptop novadata ndp500-n800z. Pois, foi com sua dica que resolvi o problema.
Muito obrigado! Valeu mesmo.

[22] Comentário enviado por JOPAGO em 29/07/2010 - 12:45h

A minha tela ficou preta. Dá a entender que ele tá exibindo a imagem mas ela não aparece pra mim. E agora?

[23] Comentário enviado por Osni em 31/07/2010 - 22:17h

Obrigado Jakson, sou iniciante no linux, segui esses passos e consegui colocar a resolução 1280x800 no meu notebook Novadata. Só que tenho as mesmas dúvidas do usuário PauloDeLimma, não consigo ativar os efeitos visuais (nem sei se é possível com essa VGA) e o que mais me incomoda, os "chuviscos" quando inicializa ou quando mudo para os tty's 1, 2, 3... (CTRL + ALT + F1, 2, 3...). Alguém sabe me dizer qual o "sistema" que gera os gráficos nesses modos, para que eu possa pesquisar a solução? Se não entenderem a pergunta, me avisem xD.


sandro@sandro e dida101, vocês conseguiu executar os comandos?


deus vermelho, vocẽ pode excluir o arquivo /etc/X11/xorg.conf que voltará ao modo que era antes.

[24] Comentário enviado por mayconplanet em 06/08/2010 - 18:17h

Cara!Valeu mesmo! Muito show essa sua dica! Está de parabéns aqui deu certinho eu tenho um notebook da Positivo mobile Z896 e minha placa de video é SIS 671. Foi batata.

[25] Comentário enviado por Jmetal07 em 16/08/2010 - 16:50h

Cara, na hora de copiar para o diretório, dps que digito o primeiro comando aparece :"Falta o operando arquivo de destino após", e qd tento continuar aparece:"Saindo com estado de falha devido a erros anteriores". Dá pra ajudar??
Obs: Sou novato no Linux.

[26] Comentário enviado por Jmetal07 em 17/08/2010 - 10:37h

Vlw cara consegui resolver por outro blog, mas o processo é bem parecido com o seu. Valeu Mesmo!!!!!!!

http://julianosodeiro.wordpress.com/2010/04/25/23/

[27] Comentário enviado por eronildo em 03/09/2010 - 22:33h

só tenho a agradecer meu amigo voce me salvou ja esta pronto para comprar outro notebook pq o que ja procurei para mudar isto e nada muito obrigado

[28] Comentário enviado por faragao em 05/09/2010 - 12:39h

Amigos gostei do tópico e realizei todo o procedimento, mas, no meu caso, nao resolveu o que eu gostaria de resolver e agora sempre que ligo o pc aparece uma mensagem de erro de driver e pede para reconfigurar e nao sei como fazer isso ainda.
O meu video é "01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter". Meu problema é assistir videos em avi e mp4, o som fica normal mas o a imagem fica toda preta, ja tentei usar os players Kmplayer, Mplayer, o reprodutor de filmes, vlc e o realplayer e é a mesma coisa todos, detalhe, rmvb funfa normal.

[29] Comentário enviado por francisquiny em 05/09/2010 - 16:13h

Procedimento executado ok no note POSITIVO R430L.
Valeu!!!

[30] Comentário enviado por jacambu em 14/09/2010 - 17:48h

Amigo , meus parabéns pelo post, comprei recentemente um notebook Qbex e funcionou muito bem conforme seu tutorial, estou com uma pequena duvida a respeito desta placa de video, tipo, após inicializar o sistema funciona legal em modo texto , mas se eu teclar CTRL+ALT+F2 ou Fxxx para ir ha um terminal a tela esta cheia de riscos como uma TV antiga mal sintonizada, nao entendo por que o modo grafico funciona e o modo texto fora do GDM não. Alguem ja viu alguma solução para isto? Onde configramos o video no modo texto?

[31] Comentário enviado por emerson.soares em 29/09/2010 - 10:44h

Jakson, parabéns!! Fiz no meu note Philco e funcionou certinho. Já havia perdido muito tempo e nada de solucionar o problema. Obrigado.

[32] Comentário enviado por lparadox em 03/10/2010 - 22:28h

Muito bom! finalmente conseguir fazer ficar com uma qualidade melhor já estava desistindo.
vlw pela dica

[33] Comentário enviado por kaciolino em 04/10/2010 - 10:54h

jakson, fiz o tutorial como esta ali demonstrado porem quando reinicio o pc, ele da um erro e cai em uma tela com algumas opçoes ali mas independente do se faça voce no maximo consegue sair dela e logar na parte grafica, com a querida da mesma resolução 800X600, voce ja se deparou com uma situação dessas?

[34] Comentário enviado por markysnr em 07/10/2010 - 22:51h

Fiz no meu positivo premium p457p e funfou perfeitamente.


Muito obrigado!

[35] Comentário enviado por removido em 09/10/2010 - 13:06h

no meu carro naum consigo nem dá boot, já tentei até o live cd e da erro no video =\

na 9.10 funfava legal.

[36] Comentário enviado por mauro766 em 22/10/2010 - 23:40h

Muitíssimo obrigado vlw mesmo funcionou no Ubuntu 10.04, certinho

[37] Comentário enviado por jsanz em 28/10/2010 - 21:43h

Grato amigo,

Consegui sucesso total com esse post.

[38] Comentário enviado por barcarossa em 29/10/2010 - 12:18h

Boas, eu sou o António Oliveira ( o do http://ajoliveira.com ) e informo que pus drivers novos para lucid/maverick 32/64-bit hoje no sítio referenciado por esta mensagem (já agora em Português):

http://ajoliveira.com/ajoliveira/pt/software/xorg.php

para os tentar tornar compativeis com 1366x768, para além de 1280x800. Se alguém tiver esse problema, pode ser que ajude...

há umas instruções no fim para resolver o problema da mensagem #30.

Um abraço trans-atlântico para vocês desde Sintra, Portugal.

António

[39] Comentário enviado por gvstavvs em 08/12/2010 - 12:05h

Olha só, eu tenho um note cce Jm51 e não consigo sair da resolução 800X600 quanto instalo o ubuntu 10.10. Já tentei quase todos os tutoriais da net, inclusive este aqui..... e sempre que faço alguma coisa, cai numa tela preta (ao reiniciar) pedindo login e senha... não sei sair da tela e não consigo reiniciar o note..

alguém por favor, poderia ajudar... eu quero muito usar o ubuntu no note...

obrigado

[40] Comentário enviado por claitonjs em 07/02/2011 - 19:55h

Olá,
a solução acima funcionou na minha SIS 671 utilizando o Debian Squeeze 6.0.

Obrigado!

[41] Comentário enviado por elsonj em 02/03/2011 - 10:13h

Cara deu certinho num Philips SIS 672, com Debian Squeeze AMD64...

Obrigado!!!

[42] Comentário enviado por guerrinha em 29/03/2011 - 08:41h

Bom dia,

Primeiramente muito obrigado pelo tutorial =)
Precisei indica-lo para um amigo iniciante e sem prática com linha de comando, dai fiz um script para facilitar a instalação.
Quem precisar pode baixar

http://guerrinha.comum.org/scripts/sisvideo.sh

Lembrando que é necessário conexão com a internet.

Abraços

[43] Comentário enviado por BraveDOG em 22/04/2011 - 14:32h

Ótima dica parabéns !!! Me ajudou muito !!

[44] Comentário enviado por galdimeron em 26/05/2011 - 10:23h

António Oliveira, obrigado pelo Driver fiz um pacote debian para facilitar a instalação.
Lembrando que o driver é 32 bits. Segue link: http://www.megaupload.com/?d=J7X5DMVN

[45] Comentário enviado por ramega em 04/06/2011 - 19:33h

Parabéns pela dica, valeu muito...

[46] Comentário enviado por slaxlinux em 01/07/2011 - 21:50h

Como disse Xerxelins uma vez, sim tenho crise distro.
Recentemente instalei o Debian 2.6.32-5-686. Tentei reconfigurar minha resolução conforme recomendado, mas a exemplo de Markone, a tela também ficou partida ao meio, a solução também encontrada neste post (por enquanto) foi remover o xorg.conf e a resolução 800x600 voltou ao normal. Bem...vou garimpar um pouco e quando arrumar posto novamente.

Notebook amazon smart L100
Placa de vídeo Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
Jackson obrigado por compartilhar.


[47] Comentário enviado por ramonmg em 06/11/2011 - 11:23h

Funcionou certim aki !! Muito bom cara!!

[48] Comentário enviado por duke_nukem em 24/11/2011 - 22:00h


Só no meu deu pau??
Depois de ter seguido todos os passos o Gnome não queria mais inicializar. Porém acabou com o chuviscado no modo terminal.
Eu consegui num outro artigo melhorar a minha resoução de 1240x728 para 1280x728.
Já tava bom mas ce sabe né...
Agora só quero saber como tiro os chuviscados.


[49] Comentário enviado por banor em 25/11/2011 - 21:03h

Muito obrigado Jackson estou atrás dessa solução a mais de 6 meses, para meu notebook Philco Phn 14118 com uma SiS 671, estava com uma resolução horrível de 800x600 e agora está rodando 1280x800 ficou ótimo, espero que outros usuários que possuirem esse modelo e tenham este problema possam solucioná-lo com essa sua dica fenomenal. Pessoas assim como você contribuem para que o software livre seja cada vez mais utilizado ao invés de outros produtos do meio capitalista, e não venham mais ver telas azuis da morte rsssss. Atenciosamente Daniel.

[50] Comentário enviado por caucasd em 31/01/2012 - 23:13h

Maravilha... Obrigado!!!
Funcionou para RedHat 6 NotBook CCE Win J94A...

1 - copiar os arquivos
cp sis671_drv.* /usr/lib/xorg/modules/drivers/
2 - copiar arquivo xorg.conf
cp xorg.conf /etc/X11/

[51] Comentário enviado por elgg em 11/06/2012 - 08:20h

Funcionou perfeitamente em um notebook Positivo Mobile Z93 com sistema Operacional BackTrack 5 64bits (baseado no Ubuntu 10.04 64 LTS). Foi só seguir o que escreveste. O modo como está escrito é claro e simples. Obrigado por compartilhar teu conhecimento. Sucesso.

[52] Comentário enviado por joilsonscosta em 09/12/2012 - 13:33h

Caro Jakson e demais colaboradores eu fico feliz em vê pessoas que contribuem para o melhoramento da nossa liberdade. Passei o Sábado inteiro brigando com essa placa de vídeo e acompanhando o seus passos consegui uma ótima configuração para o meu Notebook que não é uma super máquina, mas consegue resolver os meus problemas.

Notebook- CCE RLE 225 Core 2 Duo, HD 320, 2GB Ram com aproximadamente 5 Anos.

Parabéns mais uma vez! Continue assim.

Prof. Joilson S. Costa
NTE - Floriano/PI

[53] Comentário enviado por engesc em 20/07/2013 - 02:27h

Excelente post, ahora si tengo mi portátil funcional al 100%.

Hay una cosa que puedes resumir y es que no hace falta descargar el Xorg, solo copias del directorio XX-bit el xorg.conf en el directorio X11.

Saludos excelente.

[54] Comentário enviado por Puncker em 25/09/2015 - 13:10h

Migrei de Win para Ubuntu e já estava quase desistindo por conta da resolução, uso dois monitores no trabalho e não tava legal.
Muito bom cara! Salvou minha vida =D



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts