Driver SIS 671/771 + Xorg no Ubuntu 9.10 Karmic Koala

Publicado por Jakson Galeti em 03/11/2009

[ Hits: 38.343 ]

 


Driver SIS 671/771 + Xorg no Ubuntu 9.10 Karmic Koala



A nova versão do Ubuntu 9.10 "Karmic Koala" não vem com o Xorg e para piorar quem tem notebook e usa o driver SIS 671/771 simplesmente fica restrito a resolução 800X600.

Garimpando na net achei a forma de contornar este problema desagradável.

Abra um terminal como root e vá até um diretório de preferência.

Verifique se sua placa de vídeo tem a saída parecida com a seguir:

# lspci | grep -i vga
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Se sim, no terminal e execute o comando abaixo:

# wget http://download201.mediafire.com/tgnxzwjy1dsg/yjjnjxmyzj9/xorg-driver-sis671_0.9_i386.deb

Após baixar o arquivo, siga os passos abaixo.

Instale:

# dpkg -i xorg-driver-sis671_0.9_i386.deb

Crie o arquivo do Xorg:

# nano /etc/X11/xorg.conf

E cole o conteúdo a seguir:

Section "Device"
   Identifier   "Configured Video Device"
   Driver "sis671"
EndSection

E para finalizar, reinicie a sessão ou reinicie o note.

# init 6
ou
# reboot

Quando iniciar, logue com seu usuário clique em: Sistema -> Vídeo

E em resolução aplique a que melhor se enquadra ao seu note.

Eu segui estes passos e tive sucesso em um notebook da CCE, espero que esta dica ajude mais alguém.

Outras dicas deste autor

Checando dependências de pacotes em Debian Linux e derivados

Driver SIS 671/771 + Xorg no Ubuntu 10.04 Lucid Lynx

Instalando e configurando o Ubuntu em Dell Optiplex 320

Leitura recomendada

Como instalar scanner Kodak i2600 via Terminal no Ubuntu

Instalando placa de rede Agere Systems ET131x PCI-E no Linux

Habilitando o serviço de telnet no Conectiva

Instalação e configuração do modem PCTel

GRUB na instalação do Slackware

  

Comentários
[1] Comentário enviado por leo_pr em 04/11/2009 - 17:45h

Para alguns modelos de notebook da Positivo, como o FirstLine, existe um modulo modificado do sis671, que evita o "efeito duplicado".
veja o post
http://curitec.blogspot.com/2009/10/chipset-sis-671-no-ubuntu-904-e-910.html

[2] Comentário enviado por Nilo Jorge em 06/11/2009 - 16:38h

Cara tive vendo sua dica, mas encontrei algumas dificuldades...
oq vc quer dizer com "Abra um terminal como root e vá até um diretório de preferência. " ??

quando eu fiz eu coloquei so no root.. usando sudo -s.....

eu baixei o arquivo usando o comando:
# wget http://download201.mediafire.com/tgnxzwjy1dsg/yjjnjxmyzj9/xorg-driver-sis671_0.9_i386.deb

dai quando eu fui instalar usando o comando:
# dpkg -i xorg-driver-sis671_0.9_i386.deb
acusou q nao conseguiu achar o diretorio.. ou q nao eh valido.. uma coisa assim.. dai eu criei o xorg usando o
# nano /etc/X11/xorg.conf ... colei oq vc pediu... dai eu salvei.... dei um init 6... ai quando o computador inicializou
novamente ele nao entrou com a interface grafica.. ficou a tela preta similar a do DOS do windows... e apareceu
Ubuntu 9.10 nilo lap-top tty1 e abaixo pedindo pra por meu login e dps senha...

entao cara por favor gostaria q vc me ajudasse... aguardo sua resposta tenha uma boa tarde !!!!

[3] Comentário enviado por jgaleti em 06/11/2009 - 21:23h

Ola Nilo Jorge boa noite.

So tive tempo de olhar meus e-mails agora e vi que esta tendo dificuldades com a dica.
Então vou tentar te ajudar.
Siga os seguintes passos e vamos ver se agora funciona:

1º Passo:

Clique em Aplicativos->Acessórios->Terminal

#Neste momento você vai fazer o download do driver, entao escolha um bom lugar para guardar o driver que você vai baixar, te aconselho a salvar no seu home mesmo, ao fazer os passos acima, o prompt do terminal vai ficar no seu home, então salve o arquivo ai mesmo.
Abaixo segue um exemplo de como fiz sem usar o usuário root.

jakson@Tux:~$ wget http://download201.mediafire.com/tgnxzwjy1dsg/yjjnjxmyzj9/xorg-driver-sis671_0.9_i386.deb

2º Passo:

jakson@Tux:~$ sudo dpkg -i xorg-driver-sis671_0.9_i386.deb

#Neste momento você vai instalar o driver.
#Em seguida você deve criar e inserir os seguintes dados no arquivo de configuração do X, que é o /etc/X11/xorg.conf e inserir o conteúdo abaixo.

jakson@Tux:~$ nano /etc/X11/xorg.conf

Section "Device"
Identifier "Configured Video Device"
Driver "sis671"
EndSection
# Para salvar e sair aperte Ctrl + x, e escolha sim.
# Fazendo isso você vai gravar o arquivo, salvar e sair.

3 º Passo:

# Reinicie o computador.

4º Passo:

# Quando o computador reiniciar clique em: Sistema->Preferencia->Video.
# E escolha a resolução que melhor te agrada.

________________________________Fim________________________________

Caso a dica não funcione , basta remover o arquivo de configuração do xorg.conf

jakson@Tux:~$ rm -rf /etc/X11/xorg.conf

Espero ter ajudado.

[4] Comentário enviado por nilo jorge em 06/11/2009 - 23:16h

eu estou tentando aqui.. ele realmente salvou o arquivo no home.. mais quando eu vou instalar aparece o seguinte no prompt:
nilo@nilo-laptop:~$ sudo dpkg -i xorg-driver-sis671_0.9_i386.deb
dpkg: erro processando xorg-driver-sis671_0.9_i386.deb (--install):
impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
xorg-driver-sis671_0.9_i386.deb

[5] Comentário enviado por nilo jorge em 06/11/2009 - 23:19h

de toda maneira mt obrigado msm pela força.. fico no aguardo de sua resposta ! boa noite !

[6] Comentário enviado por nilo jorge em 07/11/2009 - 11:22h

ei cara deu certo aqui....
oq tava acontecendo era q esse comando nao tava salvando um arquivo correto.. dai eu entrei direto na URL e baixei o arquivo........

ei cara mt obrigado msm.. vc ajudou bastante !!
precisando de mim.. estamos ai.....

[7] Comentário enviado por jgaleti em 07/11/2009 - 16:09h

Ola Nilo Jorge, que bom que que resolveu o problema, não tive como te ajudar mais porque trabalho no sábado e só cheguei em casa agora.
Mas que bom que você conseguiu resolver o seu problema, espero que desftute bastante deste mundo livre.

Saudações Livres.

[8] Comentário enviado por nilo jorge em 12/11/2009 - 12:45h

Jakson gostaria de te fazer uma pergunta... o seu note eh um cce j95.... pq se for, ou ate mesmo senao for, pode ser q vc me ajude..
No meu notebook a tecla Fn+F3 desativa o som... mais usando o ubuntu 9.10 quando eu aperto essas 2 teclas juntas pra tirar o som, da uma pane no meu note.. fica tudo travado... sera q vc poderia me ajudar com isso.. obrigado.... boa tarde!!

[9] Comentário enviado por dieg0 em 14/11/2009 - 16:37h

Jackson

Quando vou salvar o xorg.conf aparece a msg de "Permissão negada"

o que devo fazer?

Edit:

Achei a solução.
Foi só criar uma nova senha de root que nao deu mais esse problema

com isso consegui alterar minha resoluçao

obrigado pelo tuto!

[10] Comentário enviado por Felipeigor em 16/11/2009 - 09:13h

brother muito obrigado deu certinho aqui
valeu mesmo

[11] Comentário enviado por mateussantana em 24/11/2009 - 09:54h

Bom dia Jakson,

Cara parece ser uma ótima dica, espero que funcione.
Só estou tendo um probleminha, nao manjo muito de linux, entao antes de ver sua dica, tentei instalar outros pacotes de driver, que nao deram certo.

Ai qnd tento instalar o que vc diz, da erro dizendo que ja tem uma versao do driver instalado. Parece que preciso removê-la antes de instalar a sua, como faço isso?

aguardo.

[12] Comentário enviado por priest em 29/11/2009 - 23:44h

Pessoal, infelizmente, depois que instalei esse driver no meu ubuntu 9.10, a minha GUI fica piscando intermitentemente e pedindo usuário e senha no terminal. Isso já havia acontecido antes quando fiz um upgrade do meu ubuntu antigo (9.04) para 9.10. Não sei o porque disso, apesar de o driver do meu notebook cce ser o mesmo citado neste tópico.

[13] Comentário enviado por marcioferreira em 25/12/2009 - 15:06h

valeu cara... funcionou certinho para mim! Obrigado... e se não se importa fiz um link pro meu site da sua dica! Valeu!

[14] Comentário enviado por br.gilson.sp em 04/01/2010 - 21:21h

Parabéns pelo artigo, Jakson. Para ajudar os leigos em linux, como eu por exemplo, eu fiz o download do driver via browser e utilizei o próprio Instalador de pacote do Ubuntu, depois reiniciei o note e funcionou normalmente.

[15] Comentário enviado por krlosgilson em 05/01/2010 - 14:49h

Ótimo artigo. Até que enfim um artigo simples mas completo para a versão mensionada. A quase 1 mês venho tentando instalar o driver do video e nada, hoje consegui através deste maravilhoso artigo. Meus Parabéns!!!

[16] Comentário enviado por Frenzy em 02/03/2010 - 18:33h

Cara ótima dica, muito obrigado por essa contribuição para a comunidade linux. Agora minha resolução tá beleza.

abraços

[17] Comentário enviado por guinhosilva17 em 04/03/2010 - 13:54h

Man, a dica foi muito boa, mas as configuraçoes de vídeo não ficaram 100%, a resolução mudou, mas os efeitos não funcionam.
não fuinciona nem o compiz.
por favor me ajude.

[18] Comentário enviado por sttuart em 10/03/2010 - 10:53h

Olá , li todos os comentários mais fiquei com uma dúvida. Depois de instalado o driver a resolução pode ser melhorada né ?! mais e os efeitos 3D ? Não tentei instalar o driver ainda. Aguardo resposta !
Desdee já muitoo obriigadoo e tópico muitoo bom, dicas excelentes xD

[19] Comentário enviado por jgaleti em 10/03/2010 - 11:00h

Cara no meu note os efeitos 3D funcionam normalmente, vou verificar com outros colegas se o efeito não foi habilitado.

[20] Comentário enviado por pontozip em 16/03/2010 - 13:37h

Obrigado pela dica. Estou com um positivo z80, já testei Fedora 12, opensuse 11.2 e somente o Ubuntu 9.04 configurou tudo corretamente.

Ats.
Curitiba/Pr.

[21] Comentário enviado por juranir em 25/03/2010 - 16:30h

Boa tarde amigo,

Cara ótima dica, eu ja estava procurando a alguns dias só que ainda não tinha encontrado nada que relmente funcionasse (até lê este post :) ). O unico "problema" agora é conseguir habilitar os efeitos visuais :(

[22] Comentário enviado por djalmarafael em 11/04/2010 - 10:52h

Isso não fuciona. a resposta está em:
http://www.vivaolinux.com.br/dica/Driver-SIS-671-771-+-Xorg-no-Ubuntu-9.10-Karmic-Koala
isso é resolvido, funiona.

[23] Comentário enviado por frusciante em 30/04/2010 - 17:12h

ola pessoal, consegui pelo ubuntu 9 10, obrigado
mas será q no 10.4 irá funcionar?

[24] Comentário enviado por pontozip em 02/05/2010 - 20:26h

Tentei instalar o ubuntu 10.04 em meu positivo z80 a logo a iniciar o live cd, listras roxa cintilantes povoam a tela. Vou tentar instalar em modo texto e depois inserir o modulo do sis 671. Distribuição que não vê problema com a sis 671 é o Mandriva 2010.0 ... roda perfeito perfeito.

Ats.
Curitiba/Pr.

[25] Comentário enviado por leo_pr em 08/05/2010 - 15:42h

Não funciona no 10.04, e para o micro positivo tem que ser o drive sisimedia.

Veja a solução em: http://curitec.blogspot.com/2010/05/sis-671-e-ubuntu-1004-lucid-32bit.html

nele foi adaptado o drive da Mandriva para o Ubuntu, pois hoje é a Mandriva que, oficialmente, mantém esse drive atualizado

[26] Comentário enviado por frusciante em 09/05/2010 - 19:03h

Olá, depois de fazer o procedimento mei note Philco quando roda videos com listras azuis correndo na tela.
Outro detalhe, para quem não consegue salvar o doc xorg.conf na pasta etc/X11 tem que ir no Terminal e digitar
# chmod -R 777 etc/X11/

para liberar as preferencias
Obrigado.

[27] Comentário enviado por leoam14 em 02/12/2010 - 11:47h

Agradeço muito..
Faz quase um ano que procuro por essa resolução..
Obrigado..
tel



Contribuir com comentário