Grub não detecta outras partições após a atualização do Slackware [Resolvido]

Publicado por Mauricio Ferrari em 09/09/2021

[ Hits: 487 ]

Blog: https://github.com/MauricioFerrari-NovaTrento

 


Grub não detecta outras partições após a atualização do Slackware [Resolvido]



Resolvi um dia desses fazer uma atualização no Slackware Current. Logo rodei o comando para atualizar o Grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Então, me deparei com esse problema:

Aviso: os-prober não será executado para detectar outras partições de arranque.
Os sistemas nelas presentes não serão adicionados à configuração de arranque do GRUB.Veja a documentação de GRUB_DISABLE_OS_PROBER.

Não precisei pesquisar muito para resolver editando o arquivo /etc/default/grub:

sudo vim /etc/default/grub

No final do arquivo foi só adicionar:

GRUB_DISABLE_OS_PROBER="false"

E assim, o problema foi resolvido.

Outras dicas deste autor

Ctrl+C e Ctrl+V no Terminal Linux

Comando "less" Colorido no Shell

Skype Atualizado no Ubuntu e Linux Mint

BleachBit 4.0.0 no Slackware Current

ExMplayer no Linux Mint 20

Leitura recomendada

Detectando automaticamente a impressora em rede linux

Windows Update em cache no Squid

X no Slackware

Configurar o VirtualBox para detectar USB automaticamente ao plugar (fstab)

Repositorio do Sarg no Debian 6 Squeeze

  

Comentários
[1] Comentário enviado por LckLinux em 12/09/2021 - 20:38h

Ótima ideia registrar a solução deste problema aqui, em dica, camarada Mauricio. A 1a vez que rolou comigo foi no Arch e demorei um pouco pra achar uma solução (quando atualizei o Slack eu já tinha em mente a trilha das pedras, nesse rio).
Boa!

[2] Comentário enviado por mauricio123 em 14/09/2021 - 20:05h


[1] Comentário enviado por LckLinux em 12/09/2021 - 20:38h

Ótima ideia registrar a solução deste problema aqui, em dica, camarada Mauricio. A 1a vez que rolou comigo foi no Arch e demorei um pouco pra achar uma solução (quando atualizei o Slack eu já tinha em mente a trilha das pedras, nesse rio).
Boa!



valeu. Imaginei que esse problema poderia ser mais frequente. Por isso fiz a dica.

[3] Comentário enviado por dancoslinux em 21/09/2021 - 22:22h

Parabéns! A dica funcionou. Após instalação do Windows 10 e Linux Mint, que estavam funcionando bem, ao instalar o Arch, ele não mostrava aqueles dois sistemas. Após rodar o comando, os três sistemas apareceram no boot. Engraçado que a última versão do Arch que eu havia instalado, esse problema não acontecia. Agora com a atualização do Arch (09/2021), pode ser que tenham modificado alguma função que impeça de outros sistemas de serem detectados após a instalação do Arch. Dica bacana! Abraço!

[4] Comentário enviado por mauricio123 em 23/09/2021 - 13:03h


[3] Comentário enviado por dancoslinux em 21/09/2021 - 22:22h

Parabéns! A dica funcionou. Após instalação do Windows 10 e Linux Mint, que estavam funcionando bem, ao instalar o Arch, ele não mostrava aqueles dois sistemas. Após rodar o comando, os três sistemas apareceram no boot. Engraçado que a última versão do Arch que eu havia instalado, esse problema não acontecia. Agora com a atualização do Arch (09/2021), pode ser que tenham modificado alguma função que impeça de outros sistemas de serem detectados após a instalação do Arch. Dica bacana! Abraço!


Valeu, que bom que te ajudou.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts