Firefox versão 31 não carrega plugins [Resolvido]

Publicado por Wilker Azevedo em 01/09/2014

[ Hits: 4.820 ]

 


Firefox versão 31 não carrega plugins [Resolvido]



Se você baixou a versão 31 do Firefox no formato tar.bz2 e tentou instalar algum plugin, descobriu que não tem o diretório plugins e já foi direto no diretório mozilla/plugins, jogou o Flash e Java lá e, ao rodar o Firefox, percebeu que o mesmo não quis "saber" disso também.

Tentou de tudo, inclusive ajuda no site da Mozilla, mas mesmo assim... NADA DE PLUGINS!!!

Consulta about:plugins direto na barra de navegação, veja que está vazio.

Então, eis a solução!

Não faço ideia do por quê, mas simplesmente o "uso" do diretório plugins está DESATIVADO por padrão nesta versão do Firefox. Isso é muito sinistro!

O pior, é que ele NÃO quer usar o diretório plugins que está em /usr/lib/mozilla/plugins (usr/lib64/mozilla/plugins para as distros 64 bits).

Provavelmente, deve haver um motivo para isso (ou vai ver a Mozilla ficou louca), talvez haja uma maneira diferente agora de usar os plugins... Mas...

Cansei de tentar entender isso, já que eu preciso com urgência de usar Java (IcedTea) e Flash, abri a "barriga do Firefox" e tive que mexer nas tripas do bicho.

Para fazer seu Firefox usar plugins, da forma como sempre foi, então acesse about:config diretamente do seu Firefox, aceite o termo de responsabilidade.
  • Procure por: plugins.load_appdir_plugins
  • Observe que o default é: false
  • Basta dar dois cliques, que vai mudar para: true

Pronto. Reinicie o Firefox e comece a usar os plugins.

Caso queira conferir, acesse: about:plugins

Outras dicas deste autor

Erro procurando TkCximage ao iniciar aMSN (mais aprofundado)

Trocar Linux de patição / HD sem clonagem

Impressora HP Color LaserJet 2600n USB (e similares) no GNU/Linux

Slackabduction - Excelente site de pacotes para Slackware

HPLIP/CUPS - "Filter failed" ao tentar imprimir (depois de atualizar hplip)

Leitura recomendada

Segurança no Iptables

Internet a radio com placa RT2561 com Slackware 12.2

Rodando Apache em máquina com IP falso (rede interna)

Instalando modem ZTE MF645 Vivo 3G no Ubuntu 8.04

named-checkzone - verificação dos arquivos de zona DNS

  

Comentários
[1] Comentário enviado por albfneto em 01/09/2014 - 14:46h

Favoritada sua Dica.

e complementando, você disse não saber o por que... Eu sei porque... Sou Testador Beta da Mozilla.

A pasta Plugins não existe mais e muita vêzes, mesmo feita. não funciona,

é porque a Fundação Mozilla está mexendo no código
do Firefox,

a idéia é criar algo que não use mais Plugins, FlashPlayer, nem Java,

algo que trabalhe com HTML5, Xine e outras tecnologias mais novas.

tanto que os Firefox novos, não usam mais Flash Player, usam Fresh Player e HTML5 player.

[2] Comentário enviado por cytron em 15/09/2014 - 12:44h


[1] Comentário enviado por albfneto em 01/09/2014 - 14:46h:

Favoritada sua Dica.

e complementando, você disse não saber o por que... Eu sei porque... Sou Testador Beta da Mozilla.

A pasta Plugins não existe mais e muita vêzes, mesmo feita. não funciona,

é porque a Fundação Mozilla está mexendo no código
do Firefox,

a idéia é criar algo que não use mais Plugins, FlashPlayer, nem Java,

algo que trabalhe com HTML5, Xine e outras tecnologias mais novas.

tanto que os Firefox novos, não usam mais Flash Player, usam Fresh Player e HTML5 player.


Ótimo comentário!

Até imaginei que poderia ser esse o motivo, mas são tantos anos usando os plugins, que nem acreditei kkkk.

Infelizmente essa decisão levará um BOM tempo para ser aderida ao restante (sites), pois os bancos principalmente, não dão a mínima a esse assunto, onde gerentes de TI ou os que mandam mais e tomam as decisões geralmente "não fazem a menor ideia do que se trata", ou "acham que não usar adobe e sun" é coisa de adolescente ou hacker kkkk. E até mesmo usam adobe e sun por ser o que sempre usaram (em time que está ganhando não se mexe) ... (acaba ficando superados, ultrapassados e definham).

O Itaú e Caixa por exemplo, insistem em usar o Java proprietário, já tentei acessar o internet banking usando outros plugins java e não vai. Só acessa quando coloco o velho e famoso jre. Parece que a cada 5 minutos lançam uma nova versão, daí o site da Caixa bloqueia o acesso enquanto não atualizarmos o plugin.

Até mesmo no Youtube ainda existem alguns vídeos que não rodam em HTML5. Mas parabenizo o Google por ser o mais dedicado a fazer o que é certo (sem nos esquecermos de certas coisas).

Assim como a MS abriu mão do MSN de uma forma tão surpreendente, as grandes da net, que influenciam e outras que obrigam, deveriam abrir mão de certas coisas em prol da padronização, liberdade, desempenho e segurança.

Felizmente, para nós, é uma questão de tempo. Pois tendência e evolução é igual a tsunami... NINGUÉM SEGURA! kkkkkkkkkkkkkkk



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts