Corrigindo problemas no Debian Multiarquitetura

Publicado por Juliao Junior em 19/02/2014

[ Hits: 3.244 ]

 


Corrigindo problemas no Debian Multiarquitetura



Se você instalar o Debian, em sua última versão, pode tomar um susto quando for instalar determinados programas.

Você pode encontrar este aviso, não muito esperançoso:
ia32-libs : Depende de: ia32-libs-i386 mas não está instalável
E: Pacotes quebrados

Veja que problema chato! A biblioteca ia32-libs depende de outros programas que não serão instalados! Mas, não continue assustado, quase tudo tem solução no mundo Linux. E, felizmente, este é um dos problemas que possuem solução.

A questão é o seguinte, a partir da versão 7, o Debian possui uma capacidade bem interessante: a utilização de programas escritos para diversas arquiteturas, todas rodando no mesmo sistema.

E este pacote que você provavelmente tentou instalar, é utilizado para transição nesta funcionalidade. O erro aparece porque você não habilitou a funcionalidade de multiarquitetura.

Portanto, a solução é bem simples, basta habilitar a multiarquitetura.

Faça isso com os comandos abaixo:

# dpkg --add-architecture i386
# apt-get update


Você verá que um monte de pacotes aparece, pedindo a instalação. É assim mesmo. Aceite, instale todos, e siga em frente.

Problema solucionado!

Outras dicas deste autor

Free Image Manipulator, um ótimo manipulador de imagens

Atualizando o Pubuntu para versão 9.04

Multi-toque no Ubuntu

Corrigindo o problema: LaTeX Error: Unknown graphics extension: .eps

OGame - RPG bom demais

Leitura recomendada

Editar crontab com Vi ou Vim

Cedilha no Mozilla não aparece?

Adicionando Sintaxe Highlighting no Editor NANO

Tapeando o Bug no Menu do MATE 1.24 no Linux Mint 20

Deixando o Firefox e Thunderbird do LMDE em português do Brasil

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário