Configurações de cores do LILO

Publicado por Bruno Braz dos Santos Queiroz em 22/09/2004

[ Hits: 6.902 ]

 


Configurações de cores do LILO



Esta dica é para mudar as configurações de cores e posições do LILO.

Edite o arquivo /etc/lilo.conf e perto da linha "boot=/dev/hda" adicione as seguintes linhas:

# na linha abaixo está o bmp que aparece na tela
bitmap=/boot/debian-bootscreen-woody.bmp

# é aqui que você vai editar o lilo
# cores, elas variam de acordo com a paleta de cores do bmp
bmp-colors=1,,0,2,,0

# posição na tela das opções
bmp-table=120p,173p,1,15,17

# posição do relógio
bmp-timer=254p,432p,1,0,0

Para as mudanças funcionarem, digite o seguinte como root:

# lilo -v

Se você quiser mudar a imagem tradicional do LILO, faça uma em 640x480 e depois exporte como .bmp em 16 cores que será totalmente compatível, mas faça teste com imagens .bmp em 640x480 em 256 cores que poderá ser compatível também.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Montando celular Android no Debian 8 - KDE

Internet por DHCP

Resetar configurações de painel do Xfce

Alterar resolução de tela do terminal (modo texto)

Instalando Pantheon e Deepin no Fedora 30

  

Comentários
[1] Comentário enviado por fftrebor em 11/11/2004 - 06:48h

Oi Bruno

Eu tentei seguir os passos de sua dica e tudo está inserido nos locais conforme sua indicação.

O caso é que quando executo o lilo-v no meu Debian, eue recebo esta mensagem:

debian:~# lilo -v
LILO version 22.2, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2001 John Coffman
Released 05-Feb-2002 and compiled at 20:57:26 on Apr 13 2002.
MAX_IMAGES = 27

Reading boot sector from /dev/hda
Merging with /boot/boot-menu.b
Fatal: Boot loader does not support 'bitmap='

O que falta para eu conseguir fazer isto funcionar?

Meu mkernel é este:

debian:~# uname -a
Linux debian 2.2.20 #1 Sat Apr 20 11:45:28 EST 2002 i586 GNU/Linux
debian:~#

Agradeço sua ajuda.

Robert

[2] Comentário enviado por bbsqh4cker em 15/11/2004 - 15:50h

Desculpe robertff, mas como vc está exportando o seu arquivo .bmp? Qual a resolução do seu .bmp? Se possível me passe todas as suas modificações q vc fez nas configurações do LILO.

[3] Comentário enviado por removido em 16/02/2005 - 09:39h

Possivelmente, seu lilo não suporte bmp como na mensagem, tente atualizar o lilo para uma versão mais nova

[4] Comentário enviado por leogsouza em 26/11/2005 - 21:31h

hum interessante vou ver se funciona aki



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts