Aprenda a corrigir o erro de pacote não instalável no Ubuntu (dependência libenet2a)

Publicado por Lucas Alves Santos em 17/07/2015

[ Hits: 10.438 ]

 


Aprenda a corrigir o erro de pacote não instalável no Ubuntu (dependência libenet2a)



Olá amantes de Linux, nesta dica vou mostrar como corrigir um erro muito comum no Ubuntu que muitos usuários iniciantes não estão conseguindo corrigir. Como exemplo, tentei instalar um jogo em meu Linux (Speed Dreams) e obtive o erro citado nesta dica, confira abaixo o erro:

Os pacotes a seguir têm dependências desencontradas:
speed-dreams-base : Depende: libenet2a (>= 1.3.7+ds) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
Bom, como podem ver o erro está ali na segunda linha, o pacote que tentei instalar depende do libenet2a (>= 1.3.7+ds), porém o terminal diz que não é instalável. Sendo assim, vamos instalar esse o tal "pacote não instalável" manualmente, para isso, primeiramente vamos baixar o pacote através do link abaixo:
Ao acessar a página acima você vera que há várias versões do libenet disponíveis, recomendo que baixem o libenet-dev_1.3.8+ds-2, a versão citada terá para computadores 32 bits e para 64 bits, você baixa de acordo com seu sistema. Após ter feito o download, mova o arquivo baixado para a pasta pessoal (home), e logo em seguida abra o terminal e rode o seguinte comando para instalar o pacote baixado:

sudo dpkg -i nomedopacotebaixado.deb

Após rodar o comando acima, o libenet baixado no site estará devidamente instalado no seu computador e você não terá mais problemas com isso.

Abraço e boa sorte!

Outras dicas deste autor

Fazendo o terminal mostrar asteriscos ao digitar senha

LXQt no Debian? Veja como instalar

Ubuntu 17.10 - Problemas com Firefox, Screensaver e 123.sogou.com [Resolvido]

Instalando Firefox no Fedora 22/21

Instalando e rodando Minecraft no Linux

Leitura recomendada

Não consigo adicionar novos wallpapers no Ubuntu 19.04 [RESOLVIDO]

Configurando o teclado ABNT2 no Slackware (KDE)

Personalizar teclas de atalho de F1 até F12 usando inputrc para o Terminal

Saída de comando "route" organizada

Erro na atualização do Fedora 11 (UnicodeDecodeError)

  

Comentários
[1] Comentário enviado por sergeimartao em 22/07/2015 - 22:22h

As vezes essas dependências de lib são uma verdadeira dor de cabeça. Obrigado pela divulgação do site para download, vai ser bem útil.

[2] Comentário enviado por Lwkas em 23/07/2015 - 11:06h


[1] Comentário enviado por sergeimartao em 22/07/2015 - 22:22h

As vezes essas dependências de lib são uma verdadeira dor de cabeça. Obrigado pela divulgação do site para download, vai ser bem útil.


De nada sergeimartao!



Contribuir com comentário