Mini-howto de configuração e utilização do aptitude no Debian

Pela enorme rede percebo muitas pessoas perdidas logo após a instalação do Debian, não sabem como configurar um repositório, instalar um pacote, e/ou atualizar o sistema. Decidi fazer este artigo com as principais dicas deste tema. Também há muita confusão quanto qual repositório usar e como proceder na hora de troca de versão dos debianos, então aqui vai uma dica bem interessante.

[ Hits: 32.242 ]

Por: Slipkd em 26/06/2007


Repositórios não oficiais e confiáveis



Repositório multimídia:

deb http://www.debian-multimedia.org lenny main

Beryl (desktop 3d):

deb http://debian.beryl-project.org/ etch main
deb-src http://debian.beryl-project.org/ etch main

Algumas observações

Servidores:
  • Aconselho a versão ETCH (STABLE).

Desktop vai do gosto:
  • Aconselho LENNY (TESTING). Porque? Acho interessante ver o trabalho do Debian, visualizando todos os pacotes que estão trabalhando atualmente e também posso ter pacotes mais atualizados, coisas que no stable não tem...

Impecílio:
  • Atualmente o Beryl parou no meu LENNY, reparei que foi logo após uma atualização do DBUS, isso ocorre porque às vezes outros pacotes não trabalham em cima da versão TESTING... Isso aconteceu comigo e um outro amigo utilizando Gnome, diz um amigo do fórum que com XFCE isso não procede, vou verificar o problema e volto à alterar este mini guia.

Página anterior    

Páginas do artigo
   1. Introdução
   2. Comandos básicos aptitude
   3. Repositórios não oficiais e confiáveis
Outros artigos deste autor

Oi 3g Huawei E220 HSDPA USB Modem + gnome-ppp (wvdial.conf)

Dicas interessantes após a instalação do seu Debian

Instalação e configuração do Openbox personalizado usando Arch Linux

Leitura recomendada

Falta de padronização no Linux

Como acessar uma partição ReiserFS pelo Windows

Implantação de software livre

LaTeX - Figuras e tabelas

Para o usuário leigo, qual o melhor: Kurumin ou Ubuntu?

  
Comentários
[1] Comentário enviado por juninho (RH.com) em 26/06/2007 - 08:30h

Adorei seu artigo, muito simples, bem explicado e muito funcional, principalmente para iniciantes que não sabem o que Etch/Lenny, ou testing e stable.

O básico as vezes ajuda mais do que se imagina, eu por exemplo não sabia que teria que atualizar nesta ordem que você explicou.

Parabéns!!!

[2] Comentário enviado por scoob em 27/06/2007 - 07:36h

Muito bem!!!

Sobre o problema do Beryl, veja se este meu post resolve para você...

http://www.vivaolinux.com.br/dicas/verDica.php?codigo=8725

Abraços!!!!

[3] Comentário enviado por slipkd em 27/06/2007 - 17:50h

Amigos obrigado, espero contribuir mais com artigos daqui pra frente ...

só cometi alguns equivocos que conserto agora, pois não consegui editar mais o artigo:

Versões Debian:
Unstable == SID (sempre)
Oldstable == SARGE
Stable == ETCH
Testing == LENNY


e pra quem se não ficou claro algumas partes do aptitude:

aptitude clean *pacote*
--> remove um pacote localmente e/ou do cache da sua máquina


aptitude remove *pacote*
--> remove pacote

aptitude purge *pacote*
--> remove o pacote e seus arquivos de configuração


Quanto ao link do Beryl usei e não resolveu, parei de usar testing em desktop no momento e estou com stable mesmo !! :-D


[4] Comentário enviado por adrianoturbo em 27/06/2007 - 22:13h

Bem objetivo seu artigo parabéns a comunidade agradece.

[5] Comentário enviado por removido em 29/06/2007 - 11:31h

Uma retificação:

O comando correto para apagar todos os arquivos baixado seria atitude clean e não aptitude autoclean, conforme consta no seu artigo.

O aptitude autoclean apaga apenas os pacotes mais antigos.

Qualquer dúvida, man aptitude.

[6] Comentário enviado por slipkd em 30/06/2007 - 16:23h

Obrigado brother, na hora de escrever é preciso bastante atenção pra não acontecer isso, vou ficar mais atento no próximo artigo.


Abraço

[7] Comentário enviado por f_Candido em 19/01/2008 - 00:30h

Valeu, ta precisando.
Parabéns

[8] Comentário enviado por fguedess em 20/03/2008 - 17:07h

Uma dúvida que ficou.
Na segunda parte diz:
"Se atualizou sua versão ETCH até aqui, agora mude sua versão para LENNY e faça os mesmos passos. Se atualizou sua versão LENNY até aqui, agora mude sua versão para SID e faça os mesmos passos. "
Porque exatamente este procedimento?
Me parece meio estranho instalar os pacotes do Etch, depois os Lenny por cima (não sei se instala por cima ou junto, desculpa se falei merda, migrei recentemente pra Linux), depois o SID.
Obrigado

[9] Comentário enviado por slipkd em 28/09/2009 - 17:39h

Fala fguedes, isso foi para exemplicar, pois o Debian fica mudando as suas versões e na época que escrevi o artigo era nesta ordem ...

então se atualiza todo o etch se for etch e depois muda para Lenny se achar necessário :)

[ ] ´s


Contribuir com comentário