MPlayer - The Movie Player

cvs

Artigo que mostra como instalar o MPlayer a partir de sua versão CVS, com suporte a bibliotecas que o permite ser executado a partir do console (modo texto). De quebra ainda teremos acesso a um script que o instala automaticamente.

[ Hits: 37.065 ]

Por: Thiago Alves em 15/10/2004 | Blog: http://www.seeufosseopresidente.com.br


Compilação



.
Agora vamos a parte mais legal de todas, vamos compilar esse tal de mplayer e ver como que ele vai ficar.

Lembrando que o diretório do mplayer se chama main, vamos copiar a libavcodec para o dir main:

$ cp -rf ffmpeg/libavcodec main/

Agora vamos arrumar os codecs no lugar certo para que o mplayer possa achá-los na hora de compilar:

$ tar jxvf all-20040916.tar.bz2
$ mkdir /usr/lib/win32
$ cd all-20040916
$ mv * /usr/lib/win32


Agora vamos configurar as fontes logo, pra não ter problema depois:

$ mkdir -p /usr/local/share/mplayer/font
$ tar jxvf font-arial-iso-8859-1.tar.bz2 -C /usr/local/share/mplayer/font
$ cd /usr/local/share/mplayer/
$ cd font/font-arial-iso-8859-1/font-arial-14-iso-8859-1/
$ mv * /usr/local/share/mplayer/font/


Pronto, agora vamos para o mplayer:

$ cd main
$ ./configure --language=pt_BR


Com isso ele vai colocar os manuais em pt_BR, o resto dos plugins ele vai detectar automaticamente. Após terminar o configure, rode o make e depois o make install.

$ make

Nisso aqui pode ir tomar um café, vai demorar um pouco.

$ su
# make install


Pronto, está instalado.

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Downloads
   3. Compilação
   4. Testando
   5. Script para automatizar tarefa
   6. Conclusões
Outros artigos deste autor

Instalando o Apache + PHP + MySQL no Slackware

Slackpkg, uma ótima ferramenta para Slackware

Incremente o iptables com patch-o-matic

Instalando o VMWare no Slackware

Instalação do CentOS 5.3

Leitura recomendada

Usando OpenBSD como desktop

Evite desgaste diário de seus CDs

Executando máquinas virtuais diretamente no GDM

Exclusivo - Entrevista com Fábio Berbert, criador e mantenedor do projeto Viva o Linux!

Atualizando seu Gnome para o 2.6 experimental no Debian

  
Comentários
[1] Comentário enviado por cvs em 15/10/2004 - 09:47h

Havia esquecido de mencionar que o link para o script original feito pelo wrochal é: http://www.linuxit.com.br/scripts/mplayer11

[2] Comentário enviado por borntobewild em 15/10/2004 - 16:55h

Veja o erro que obtenho ao compilar:

/usr/include/linux/err_kernel_only.h:1:2: #error Kernel only header included in userspace
make[1]: *** [vo_mga.o] Error 1
make[1]: Leaving directory `/caetano/main/libvo'
make: ** [libvo/libvo.a] Erro 2

Alguém pode me ajudar?

[3] Comentário enviado por cvs em 15/10/2004 - 17:14h

Qual distribuição vocÊ esta usando?
Qual versão do gcc está usando?
Qual kernel está usando?

[4] Comentário enviado por Hernando em 16/10/2004 - 11:47h

Dae brody valeu mesmo... este artigo ficou manero... tentei diversas formas para instalar o mplayer aqui no meu brinquedo e não conseguia... com este artigo foi tudo fácil...

Abraço!!!

[5] Comentário enviado por luiscarlos em 18/10/2004 - 00:33h

Alguém conhece algum site que dispõem filmes para download?

[6] Comentário enviado por dxwolf em 18/10/2004 - 10:49h

Bom sou um rookie nesta coisa do linux mas com ajuda deste guia consegui instalar o mplayer agora a duvida é eu escrevo na consola $ mplayer -sub xpto.srt spto.avi e o video da so que sem legendas... eu instalei o pack de ARIAL fonts disponivel aki e fiz tudo como diz e nao da legendas.. alguma ideia? eu uso o LInux versao portuguesa Caixa Mágica.

[7] Comentário enviado por agk em 18/10/2004 - 18:21h

Parabéns, excelente artigo, apesar de ser um assunto já bastante "mastigado" esse tutorial me ajudou a resolver um problema que ainda persistia em meu micro a lentidão nos vídeos, um atlhon xp 2.8 com 512 de ram não pode ficar lento para reproduzir uns "videozinhos" não é, pois agora ficou blz.
Valeu!

[8] Comentário enviado por Hernando em 19/10/2004 - 10:38h

Dae brody!!! Mais uma vez valeu pelo artigo mais to com um problema saca!!! meu mplayer não tem skin e só funciona atavés do modo terminal, tenho Red Hat 9. Se tu puder dar uma dica aqui para eu pode roda-lo no gráfico e usar o skin que eu tenho agradeço!!!

Valeu... []'s


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts