Instalando placa de som de modo rápido, fácil e prático

Este artigo é destinado aos usuários iniciantes e com pouco conhecimento em Linux, que enfrentam dificuldades de configurar sua placa de som, seja ela onboard ou não. Utilizaremos os Open Sound System.

[ Hits: 135.540 ]

Por: Perfil removido em 27/05/2004


Introdução



O objetivo do artigo é apresentar uma maneira fácil, rápida e prática de instalar uma placa de som no Linux utilizando a arquitetura Open Sound System (OSS). Para instalar, você deve seguir apenas 4 passos descritos abaixo:

1° passo: Identificando placa de som e a versão do kernel


Para identificar qual é o modelo de sua placa de som, digite no terminal o comando "lspci". Você deve estar logado como ROOT. Este comando vai listar todos os dispositivos que você tem no computador, dentre eles sua placa de som. Como exemplo, no meu computador estou utilizando a seguinte placa (resultado do comando "lspci"):

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)

Para identificar a versão do kernel, no terminal digite o comando "uname -r". Ele vai lhe retornar algo como "2.4.26". O importante são os dois primeiros números, no caso "2.4".

2° passo: Obtendo os pacotes para instalação


Você deve fazer download da última versão dos drivers de som à partir do site da Open Sound, através do link:
Nesta página você deve informar qual é o modelo da sua placa de som e a versão do kernel que você utiliza (obtidos no passo acima), então é disponibilizado um arquivo para você copiar. No meu caso, vou informar "VT8233 AC97" e selecionar "Linux 2.4 (x86)".

Feito isso, vai aparecer um link "Click here for download...". Você deve copiar este arquivo para o diretório "/tmp".

3° passo: Descompactando e instalando os drivers


No terminal, você deve acessar o diretório /tmp com o comando "cd /tmp". Então descompacte o arquivo que você copiou usando o comando:

# tar -xzvf nome_do_arquivo.tar.gz

No meu caso seria:

# tar -xzvf oss3991c-linux-i386-v24.tar.gz

Você precisa definir permissão de execução para o instalador, digite:

# chmod +x oss-install

Agora basta executar o instalador e seguir as instruções na tela, é uma instalação em modo gráfico, muito intuitiva (você deve estar num terminal no KDE, Gnome, etc para rodar a instalação gráfica). Para executar digite:

# ./oss-install

OBS: Use o diretório padrão para instalar os drivers, seria em "/usr/lib/oss".

4° passo: "Ligando" o som sempre que iniciar o computador


Para habilitar o som, você precisa apenas digitar "/usr/lib/oss/bin/soundon". Para ter o som sempre habilitado ao iniciar o Linux, adicione esta linha de comando no arquivo "rc.local" (/etc/rc.d/rc.local). Ajuste o volume para 100%, digitando o comando:

/usr/lib/oss/bin/ossmix pcm 100:100 vol 100:100

Este comando precisa ser digitado apenas uma vez.

Feito isso, seu som está funcionando! :)

Artigo escrito por Alexandro Corrêa (VirtualBoy)
Porto Alegre, 07.05.2004
Versão: 1.1

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor

CentOS 5.5 - Instalação enxuta utilizando netinstall

Usando aMSN com plugin Music com suporte ao Juk e Amarok

Instalando o RealPlayer 10 no Linux

Viva o Linux é uma ferramenta útil hoje em dia?

Como instalar Postgres 8 no Linux em 10 passos rápidos

Leitura recomendada

Dispositivo de Captura de Vídeo Somagic EasyCAP DC60/EasyCAP002 no GNU/Linux

Sucata - Evite gargalos de hardware

Entendendo o gerenciamento de memória no Linux

Funcionamento do Processador

Melhorando a performance das aplicações em redes de longa distância

  
Comentários
[1] Comentário enviado por jragomes em 27/05/2004 - 16:26h

Bom artigo, vai ajudar muita gente que não consegue configurar o som via alsa.

[2] Comentário enviado por taiar em 27/05/2004 - 20:46h

Eu uso o Slackware 9.

Vou precisar recompilar o meu Kernel?

[3] Comentário enviado por taiar em 27/05/2004 - 22:19h

Nem precisou!

Foi perfeito!

VALEWWW

[4] Comentário enviado por removido em 27/05/2004 - 22:24h

Olá!! Você não precisa recompilar o kernel... só seguir os procedimentos descritos no artigo que tudo funciona! :)

[5] Comentário enviado por ygorth em 27/05/2004 - 22:45h

Legal o artigo!

[6] Comentário enviado por davidsonpaulo em 28/05/2004 - 16:33h

O programinha é bom, realmente prático, simples e eficiente, melhor do que qualquer instalador pra rWindows. Entretanto, aos que tiveram o cuidado de prestar atenção na página de download puderam constatar que o pacote é distribuído com licença "evaluation", ou seja, para testes por um período de tempo (após o qual possivelmente os drivers não funcionarão mais), e que para adquirir uma licença permanente é necessário desenbolsar US$ 20,00 (isso mesmo, vinte dólares, mais de sessenta reais). R$ 60,00 reais por um conjunto de drivers? Quer saber? Pra mim esse programa foi muito útil pra eu descobrir qual o driver da minha placa de som, e então baixar um driver livre... falou!

[7] Comentário enviado por removido em 28/05/2004 - 17:13h

Olá, depois que o período 'evalution' expira, toda vez que vc iniciar seu linux vai aparecer uma mensagem no console por mais ou menos 10 segundos (a mensagem vai ficar rolando na tela)... depois disso você não tem mais encômodos e tudo funciona perfeitamente!

[8] Comentário enviado por caduardo em 28/05/2004 - 21:21h

Foi o que precisava para o meu som funcionar!!!
Excelente! :)

[9] Comentário enviado por pereira.celso em 28/05/2004 - 22:40h

pô veio, valeu mesmo....

tava apanhando com o som aki....
[]'s

valeu

[10] Comentário enviado por unilx em 31/05/2004 - 14:35h

Valeu funcionou sem nenhum problema , , ,


[11] Comentário enviado por cladorf em 01/06/2004 - 16:24h

Não consegui baixar o driver para minha placa.

[12] Comentário enviado por removido em 01/06/2004 - 23:26h

Informe a sua placa, talvez possamos resolver o problema.

[13] Comentário enviado por sandrocarva em 04/06/2004 - 11:00h

muito interessante.. estava precisando disso.. valeu..

[14] Comentário enviado por RaXiD em 14/06/2004 - 23:50h

Muinto bom esse Artigo Min salvou ele :)

[15] Comentário enviado por _S4MUR4I_ em 24/06/2004 - 02:38h

mas quem n estiver afim de esperar esses 10 segundos? Como se deve proceder para desfazer tdo isso?

[16] Comentário enviado por removido em 24/06/2004 - 10:46h

Se você quiser desfazer, é só remover a linha de inicialização do seu rc.local e depois apagar os drivers que ficam em "/usr/lib/oss"... assim você fica sem som também. Outra opção é pagar a licensa dos drivers, ou tentar usar um livre tipo www.alsa-project.org que é um pouco mais complicado...
O objetivo deste artigo era ensinar a forma mais fácil de se instalar uma placa de som no linux.

[17] Comentário enviado por hendrix em 09/07/2004 - 11:56h

Muito bom cara, me ajudou muito.

[18] Comentário enviado por Alexandre Duarte em 19/08/2004 - 20:41h

Olá alexandre

A minha placa é mesma que a sua, mas eu não estou conseguindo instalar ela aqui não, sigo todos os prcedimentos e quando vou executar o instalador não acontece nada, por favor veja se pode me ajudar, uso mandrake 10.1 beta 1 kernel 2.6.8

obrigado

[19] Comentário enviado por removido em 19/08/2004 - 21:59h

Voce descompactou e definiu permissoes do instalador corretamente?

# tar -xzvf oss3991c-linux-i386-v24.tar.gz
# chmod +x oss-install

Verifique estes itens... qualquer problema escreva novamente! :)

[20] Comentário enviado por mophox em 29/08/2004 - 03:46h

Alexandre, segui todos os seus passos, porém quando inicializo minha
máquina aparece no final do boot do meu slack 9 a seguinte msg:

"devices.cfg is missing - run soundconf to create it"

Entro no soundconf, vejo que ele reconheceu minha vt8233, faço o teste
e tudo ok, salvo e saio, porém quando vou tentar algum .wav ou .mp3
o som não sai.

O que pode estar ocorrendo?

Outra coisa, quando tento executar o ossmix ele retorna que não encontrou o meu /dev/mixer, sendo que ele existe.

Espero resposta.

[21] Comentário enviado por mophox em 01/09/2004 - 16:17h

Pronto, problema resolvido! Sabe como?

SuSE Linux 9.1 nele!

A minha VT8233 foi configurada automaticamente e o som está uma
beleza sem que fosse necessário perder nenhuma noite de sono :)

Adoro o Slack, mas daqui pra frente pretendo recuperar as noites de
sono perdidas.

Abraço a todos.

[22] Comentário enviado por marion em 04/09/2004 - 19:36h

É o seguinte, por teimosia mesmo, quero colocar o som para funcionar num velho itautec 233mhx usando o kurumin 1.13, com placa Aztech AZT2320, que é suportado no oss. Acontece que no final da instalação, não consigo acessar o etc/rc.d/rc.local, pois não há o rc.d, mas sim rc.Sd, rc.0d, rc.1d... e assim por diante...
Faz algum tempo que batalho no linux, mas tenho vontade de enfrentar essas dificuldades, mas não entendi essa do Kuruma 1.13
Obrigado pela atenção e um abraço...

[23] Comentário enviado por removido em 10/09/2004 - 10:36h

Olá! No artigo eu dei o exemplo do arquivo "rc.local" porque praticamente todas as distribuições executam esse arquivo sempe que iniciam o sistema. Mas você pode substituir isso por qualquer outro que seja inicializado da mesma maneira... você teria que analisar como funciona a sua distribuição. Como você está usando Kurumin, mande um e-mail para o Morimoto que certamente ele vai te responder... www.kurumin.com.br

[24] Comentário enviado por roggia em 05/10/2004 - 12:06h

Olá, segui todos os pasos e ao executar o comando "soundon", me aparece a mensagem:
Building the OSS kernel module - plase wait...
Building the OSS/Linux module filed.

e antes disso me da outra mensagem "OSS/Linux kernel module not avaliable. Cannot continue.

O que está faltando... teria outra maneira de eu configurar minha placa de som Creative Sound Blaster PC128 (ES1373)

Obrigado

[25] Comentário enviado por tortieri em 08/10/2004 - 09:18h

valeu... mto bom seu artigo.... brigadão

[26] Comentário enviado por Sl0ck em 09/11/2004 - 22:32h

Foram resolvidos meus problemas com o som atráves deste tutorial
Obrigado

[27] Comentário enviado por pcnmota em 09/01/2005 - 19:05h

Amigo poderia me ajudar o meu som nao ta dando certo ve soh:
root@tiamath:/tmp# chmod +x oss-install
root@tiamath:/tmp# ./oss-install
Checking for any previously installed sound drivers... Done.
=== Loading soundbase module failed. ===
Ensure that you are installing the right OSS package.
/usr/lib/oss/logs/soundon.log contains more info about the problem.
Please send it to support@opensound.com.
*** Kernel compatibility test failed ***

Please submit a service request at http://www.opensound.com/support.cgi.
Remember to include /usr/lib/oss/bin/soundon.log in the request.

E qdo rodo o /usr/lib/oss/bin/soundon
root@tiamath:/usr/lib/oss/bin# soundon
devices.cfg is missing - run soundconf to create it.

Se puder me responder tbm pelo email pcnmota@tricor.com.br
Obrigado!
Paulo Cesar

[28] Comentário enviado por rodrigomanowar em 20/02/2005 - 17:48h

ja apanhei demais pra conseguir configurar essa minha placa de som. O cvs é amigo meu, estuda comigo e nao conseguimos, apesar do esforço grande dele. Achei o seu link com a dica e foi muito facil. Vivendo e aprendendo!! Nota 10.0 para sua dica aqui virtualboy!!! Valeu tb cvs (Thiago) pela ajuda e amizade!!

[29] Comentário enviado por ETerNal em 18/03/2005 - 02:29h

funcionou muito bem!
Artigo curto e direto assim q eh bom.
Um Abraco,
Germano Zang

[30] Comentário enviado por BrunnaumM em 01/04/2005 - 13:45h

Fala Alexandro..
seguinte.. segui seus passos..
ao iniciar o oss-install
recebo a msg de q meu kernel tá lendo um driver já e fala pra eu tirar usando rmmod sound (que num funciona) e se naum funcionasse desligar o X e tentar de novo (tmb num rolo)...
daí eu fui no Alsa de pedi pra ele saí fora:
cd /etc/init.d/ | ./alsa unload
..num funciono, aí eu apelei:
cd /etc/init.d/ | ./alsa -f unload ..num deu
cd /etc/init.d/ | ./alsa suspend
cd /etc/init.d/ | ./alsa stop ...=(((( num foi..

como eu faço pro meu kernel esquece que eu já instalei um kernel?? É que o alsa encontrou um driver pra mim.. só que esse não deixa eu usar programas como solfege e rosagarden eles apontavam um erro..

"The Rosegarden sequencer could not be started, so sound and recording will be unavailable for this session. no caso o rosegarden!!!

to com receio de tá atirando pro lado errado..

será que rola aqueeele conselho??

Braçaum

[31] Comentário enviado por silva.rodrigo em 04/04/2005 - 15:03h

Apanhei bastante para configurar a minha placa de som, após lido esse artigo fiz numa boa.

Valew virtualboy muito bom artigo!

[32] Comentário enviado por capeleiro em 19/12/2005 - 20:53h

Cara, este arquivo é demais, eu que sou iniciante no GNU/Linux, e logo no Slackware, só depois desta dica consegui colocar o som no meu notebook, com o slackware instalado para funcionar, já havia tentado um pouco de tudo , fuçando pelos tutoriais encontrados na net, após este arquivo, meu notebook, ficou com o som bombando.
Valeu mesmo Obrigado, um ótimo artigo. :-|)

[33] Comentário enviado por amarpini em 20/06/2006 - 15:29h

valeu! ajudou muito, pois iniciante como, não tive problema para instalar acompanhado os passos. Valeu mesmo CORREA. Obrigado!

[34] Comentário enviado por cybertux em 09/01/2007 - 10:39h

Este artigo me ajudou muito para instalar no meu not, realmente funcionou muito bem e de maneira muito prática, porém quando reinicio a máquina no meio do init do slack aparece a msn para comprar a licença e trava meu not, sendo obrigado a reinstalar o pinguim novamente, tentei outras conf mas não deu em nada

[35] Comentário enviado por _brunobr_ em 04/09/2007 - 15:05h

Olá

Estou utilizando o linux (ubuntu 7.04) há cerca de 2 dias. Não estou conseguindo configurar minha placa de som, mesmo seguindo os passos pois não sei utilizar muito bem os comandos.
quando digito:

# chmod +x oss-install

ele mostra uma mensagem "chmod: impossível acessar `oss-install': Arquivo ou diretório inexistente"

Eu devo entrar em algum diretório antes de executar esse comando?


[36] Comentário enviado por leoreiss em 03/05/2008 - 13:17h

O site mudou o arquivo de instalação dos drives, agora é diferente... como faz?!

[37] Comentário enviado por angeloo em 25/05/2008 - 13:52h

Caro virtualboy, fiz exatamente como vc falou em seu artigo, só que baixei os drivers .deb (oss-linux_v4.0-1015_i386.deb),
para instalar usei o comando #dpkg -i oss-linux_v4.0-1015_i386.deb
instalou normal e identificou normal, porém houve um problema, peço sua ajuda....
Quando vou executar o comando para habilitar o som,

#####################################################

retirei do seu artigo
"4° passo: "Ligando" o som sempre que iniciar o computador

Para habilitar o som, você precisa apenas digitar "/usr/lib/oss/bin/soundon". Para ter o som sempre habilitado ao iniciar o Linux, adicione esta linha de comando no arquivo "rc.local" (/etc/rc.d/rc.local). Ajuste o volume para 100%, digitando o comando:

/usr/lib/oss/bin/ossmix pcm 100:100 vol 100:100"

#####################################################

debian:/# /usr/lib/oss/bin/soundon
bash: /usr/lib/oss/bin/soundon: Arquivo ou diretório não encontrado

ou seja Arquivo ou diretório não encontrado
neveguei então até o diretório oss e não encontrei nada relacionado ao arquivo soundon

######################################

debian:/usr/lib# cd oss/
debian:/usr/lib/oss# ls
build etc logs modules.regparm objects.regparm sysfiles.list
conf include modules objects save version.dat
cuckoo lib modules.noregparm objects.noregparm scripts
debian:/usr/lib/oss#


QUAL A SUA SUGESTÃO??? O QUE DEVO FAZER???

[38] Comentário enviado por cdmortal em 04/02/2009 - 01:16h

Preciso de ajuda o som sumiu


O ícone do alto falante esta com um x o programa kmix abre e demonstra que não detecta o drive da placa de som não sai o som nos fones de ouvido. O que devo instalar para resolver isto, o programa kamix-0.6.6.tar.bz2 e o alsa-driver-1.0.19.tar.bz2 gostaria de um passo a passo para saber como devo utilizar o programa possa fazer o som voltar. Utilizo linux educacional em uma escola ou devo reinstalar o linux será que o som volta.ou devo configurar minha placa de som. queroi um passa a passso com os comandos para fazer a instalação dos programa para reinstalar o som que sumiu


[39] Comentário enviado por dilinu em 27/03/2009 - 01:48h

meu problema é, instalei o ubunto num virtual pc (virtual box)

e quando eu digito o comando "lspci" aparece isso
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)

a placa de som parece não estar na lista,
meu kernel e :2.6.27-7-generic

alguma sugestão?

[40] Comentário enviado por ratomem em 16/06/2009 - 22:02h

No meu micro não funciono! Talves ele tenha uma problema com o linux, pois com o bill funciona!
Eu digo que talves tenha um problema com o meu micro, pois tudo o que tedo configurar nele, usando O LINUX, não funciona! com o ubuntu é mais facil admito, mas é só uma forma de expreção, não significa facil de verdade.
não existe uma opção tipo install, next, next e seja feliz com o seu hardware?!
o linux é muito cansativo!

[41] Comentário enviado por eugeniom em 26/10/2009 - 21:38h

Perfeito, minha bronca era toda o ALSA, e comoo som melhorou com o OSS, blz e parabéns !

[42] Comentário enviado por jeefferson.xd@ho em 04/12/2009 - 20:54h

nao consigo instalar nomeupc odispositivo de som ecsgeforce6100

[43] Comentário enviado por edumak em 29/02/2012 - 11:17h

Olhando as primeiras postagens deste artigo, relembramos da história do Linux, como ele era e como ele está. O suporte aos hardwares está muito melhor, atigamente nós precisávamos trabalhar um pouco para conseguir fazer coisas que hoje acontecem sem ninguém ver no boot dos live cds.
Eu ainda gosto de ver como tudo funciona, não gosto de nada rodando no backgroud sem eu saber, mas, nada se pode fazer, sou das antigas, de 99, tempo de Conectiva quatropontozero...

Deixar um obrigado ao autor, porque sem este artigo, tenho certeza, muita gente teria abandonado este espetacular Sistema Operacional. Eu não estaria com Linux se alguém não tivesse explicado sobre Winmodem (na época do 56k, nenhuma saudade da conta telefônica), por exemplo.

[44] Comentário enviado por pais em 05/04/2012 - 20:47h

Ola Alex virtualbox blz.
Meu som derrepente sumiu.
Fiz todo o procedimento endicado acima exeto a parte que pedi para indicar o nome da placa d som ou algo parecido ,não achei onde inserir essa informação na pagina antes do download e nem na propria pg do download .
O arquivo baixado foi o tar.bz2 não encontrei o tar.gz
Mas segui o tuto até aqui e deu esse resultado .
r@alenslack:/tmp$ chmod +x oss-install
chmod: cannot access `oss-install': No such file or directory
uname -r
2.6.33.4-smp
root@alenslack:/home/alencar# lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
Um abraço

[45] Comentário enviado por High3r em 18/12/2012 - 15:30h

Gente é o seguinte, eu uso o backtrack 5 r1, eu estava já com som, mas não conseguia configurar o nível dele no ícone de som da barra de ferramenta superior, fiz o tutorial aí perdi o som completamente, não sou nenhum expert, e não sei como reverter o processo, alguém pode me ajudar ?

[46] Comentário enviado por luisfalkowski em 05/11/2015 - 13:51h


Não consegui identificar a placa de som pelo terminal no Tahr6.0 (derivado do PUPPY LINUX)
Meu Notebook Philco 14|2 P744LM AMD
No momento o tahr esta rodando com kernel 3.14.20
Consegui algumas informações sobre sobre o audio
Audio Devices:
Audio Adapter___________________HDA-intel-HD-Audio generic
Audio Adapter___________________HDA-intel-HDA ATI SB
Audio Adapter___________________PC-Speaker-pcsp
Se alguem saber a solução para ter som no meu notebook agradeço muito


[47] Comentário enviado por Senger_Linux em 02/04/2016 - 19:17h

Pessoal, estou com um probleminha aqui no linux mint, eu baixei uns videos do youtube, mas o áudio não está funcionando, como faço pra assistir videos baixados do youtube?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts