Instalando Compiz Fusion no Slackware 12.0

Nesse tutorial explicarei como instalar o famoso Compiz Fusion (que é a fusão do Beryl + Compiz) no Slackware 12.0 de modo simples e prático, sem muita dor de cabeça. Porém é desejável que você tenha algum tipo de experiência nesse assunto para facilitar ainda mais o trabalho.

[ Hits: 79.251 ]

Por: Vinicius em 03/08/2007


Algumas considerações importantes



1) Antes de começar, eu queria primeiramente pedir desculpas ao pessoal da comunidade, pois isso não é um tutorial/artigo propriamente dito e sim uma "dica muito interessante", que na qual achei muito importante para o pessoal que usa a distribuição do Slackware.

2) NÃO tenho nenhum tipo responsabilidade, por quaisquer danos relacionado ao seu sistema operacional que venha a acontecer, use por sua conta e risco, aliás antes de tentar fazer alguma coisa, sugiro que você faça (antes de tudo) um "backup" de seus arquivos de trabalho.

3) Tudo o que é exposto aqui foi executado em 2 computadores, portanto "ocorreram algumas diferenças comigo", e pode ser que aconteça com vocês também, ou seja, como isso é uma das primeiras tentativas de instalação do Compiz Fusion no Slackware, é óbvio que o mesmo ainda é "instável". Se você não gosta de sistema instável, então por favor nem tente!

4) Depois de tudo instalado e funcionando corretamente, deverá aparecer alguma coisa relacionada ao "Ubuntu Linux" (como por exemplo: dentro do cubo aparecer o logotipo do Ubuntu), mas não se assuste, pois os pacotes para o Slackware foram criados a partir da distribuição Ubuntu Linux.

5) Instale o Slackware 12.0 no "modo completo", e se possível (não é obrigatório), sugiro que instale o Dropline GNOME 2.18.3 Beta para Slackware 12.0, que você pode baixar aqui:

http://osdn.dl.sourceforge.net/.../dropline-installer-2.18-i686-3dl.tgz

OBS.: Só instale isso em "última instância", caso não funcione no KDE, daí você terá que instalar o Gnome (em uma das minhas duas máquinas foi preciso instalar, na outra não precisou).

Dúvidas para instalar o Dropline Gnome? Leia aqui ou leia o arquivo "install" contido dentro do pacote do dropline gnome!

6) Esse tutorial (ou dica, como preferir), é de grande valia aos que já tentaram ao menos experimentar instalar um Beryl ou o Compiz, pois assim já possuem uma certa experiência no assunto proposto.

7) Quaisquer dúvidas ou sugestões, postem aqui os seus comentários para que possamos analisar em conjunto, lembrando que não darei "suporte exclusivo", só estou repassando apenas o que eu vi nessa fonte aqui:
Bom, chega de papo, vamos ao que interessa...

    Próxima página

Páginas do artigo
   1. Algumas considerações importantes
   2. Obtendo e instando os pacotes
   3. Pós-configurações e inicialização do Compiz Fusion
   4. Extras
Outros artigos deste autor

Outro método (rápido/fácil) de instalação e configuração do gdesklets no Slackware 10

Compartilhamento de Internet via NAT/DHCP (Speedy Home)

Instalando o XMMS Coverviewer no Slackware 10.2

Leitura recomendada

Alterando as imagens de splash no Ubuntu

Trabalhando com foto usando Cheese + GIMP + Xmorph

Para iniciantes: Deu tela preta? Não se desespere!

Personalizando o tema do usplash nos Ubuntu-like

Uma pequena jóia sobre ilusionismo visual

  
Comentários
[1] Comentário enviado por removido em 03/08/2007 - 11:19h

"Antes de começar, eu queria primeiramente pedir desculpas..." - deixa de frescura. O trabalho tá excelente!!!
;-)

[2] Comentário enviado por brevleq em 03/08/2007 - 11:50h

Já tentei vários tutoriais mas num tem jeito!!
Naum adianta!! Aqui não funciona de jeito nenhum:

brevleq@brevleq:~$ compiz --replace
Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

placa de vídeo ATI Radeon Xpress 200M

[3] Comentário enviado por rodrigofranco em 03/08/2007 - 13:17h

cara no meu note ta dando o mesmo erro que o seu n sei como resolver isso mas espero que alguem ajude

placa de video Nvidia 6150

[4] Comentário enviado por cybercop em 03/08/2007 - 13:45h

Esqueci de mencionar um detalhe importante, que tem que adicionar no /etc/X11/xorg.conf :

Em 'Server Layout", adicione:


Option "AIGLX" "true"

[5] Comentário enviado por rodrigofranco em 03/08/2007 - 13:54h

Cara coloquei isso mas ta dando o mesmo erro vc tem ideia do que possa ser?

[6] Comentário enviado por cybercop em 03/08/2007 - 13:58h

Mas no "compiz normal" que vem no proprio slackware (default) tambem aparece a mesma coisa e nao funciona?

[7] Comentário enviado por fabio em 03/08/2007 - 14:00h

brevleq,

Qual a saída do seu comando:

$ glxinfo | grep -i rendering

?

Tem que estar como YES.

[8] Comentário enviado por rodrigofranco em 03/08/2007 - 14:51h

ta como Yes

[9] Comentário enviado por tenchi em 03/08/2007 - 15:17h

Caramba!!! Muito legal...
Eu já havia pego o compiz pelo git esses dias atrás, e instalado normalmente (via código-fonte), mas não obtive um resultado tão bom quanto o seu, basicamente porque os plugins extras simplesmente não compilam... Mas os efeitos básicos (cubo, redimensionamento, efeito exposé, efeito meleca, etc, todos funcionaram). Mas a manipulação de janelas ficou um pouco mais pesada do que o beryl no feisty.
Será que somente com as libs do GNOME os plugins extras funcionam?.. Se sim eh uma pena, pois eu sou fã do KDE, e rodar o KDE+as libs do GNOME = Muito pesado!!!
O painel de controle do compiz também eh bem complicado de instalar sem o GNOME...

Bom artigo. Já pros favoritos, pq um dia vai me servir.

[10] Comentário enviado por removido em 03/08/2007 - 15:34h

Legal. Fiz um artigo semelhante de quando usava Slackware (na época foi bem no lançamento do 11) com o Beryl. Tive que dar os parabéns por esse artigo.
O Compiz-Fusion está legal, vou esperar mais uns 2 meses e vou instalar o svn snapshot. Achei que ele veio muito gnomizado e bugado quando instalei 1 semana atrás. Por enquanto, estou com o Beryl.

[11] Comentário enviado por xkillerrx em 03/08/2007 - 16:04h

Aqui ta rodando redondo o Compiz - Fusion + ATI Radeon XPRESS 200M, com o drive proprietario da ATI ja que o drive livre RADEON nao suporta o 3D nessa placa, lembrando que so roda o compiz no XGL e nao no AIGLX !

[12] Comentário enviado por removido em 03/08/2007 - 17:02h

parabéns pelo texto !!!
;0)

[13] Comentário enviado por Brunonormandia em 03/08/2007 - 19:46h

kra desculpa a ignorancia, mas quais são os requesitos minimos para rodar(blz) o compiz no slack 12??

vlw

[14] Comentário enviado por removido em 03/08/2007 - 19:50h

E pra que isso serve?

[15] Comentário enviado por brevleq em 03/08/2007 - 22:54h

glxinfo | grep -i rendering
direct rendering: Yes

a aceleração 3D e o openGL da minha placa estão configurados!!

[16] Comentário enviado por removido em 04/08/2007 - 14:15h

Parabéns pelo artigo, realmente ótimo. Aqui em casa ta funcionando perfeitamente. Enfim um artigo de instalação do Compiz-Fusion que não seja para Debian ou Ubuntu.

Gostaria de deixar uma contribuição para quem interessar. Para o Compiz iniciar com o kde fiz um script no Autostart e funciona sem problemas. Quem quiser tentar:

$ cd /home/o_seu_usuário/.kde/Autostart

$ mcedit compiz

Obs: compiz foi o nome que dei ao Script, escolha o nome que achar melhor.

Adicione essas linhas:

#!/bin/bash

kde-window-decorator --replace & compiz --replace gconf &

Salve com F2 e saia com F10 e agora torne o script executavél:

$ chmod +x compiz

Para mim esse pequeno script funcionou perfeitamente, creio que para outros usuários do slack também funcinará.

Mais uma vez, parabéns pelo artigo, realmente muito bom.

[17] Comentário enviado por dtux em 04/08/2007 - 16:09h

Cara não aparacem as bordas e os botões......... a configuração está de acordo com o artigo, mas num vai, ele ativa os efeitos e tudo mais, mas as janela não se mavem...... há alguma configuração adicionla.... por enquanto estou usando o beryl mesmo,

[18] Comentário enviado por cybercop em 04/08/2007 - 16:42h

Diego-p-g:

Aconteceu isso comigo no meu "outro computador", e a solução foi:

1º) Depois de instalado, sugiro REINICIAR o computador.

2º) Instalar o Dropline Gnome.

[19] Comentário enviado por tenchi em 04/08/2007 - 16:50h

Diego, o compiz substitui a decoração das janelas.
Tente executar isto:
$ kde-window-decorator

[20] Comentário enviado por arauto em 04/08/2007 - 20:25h

Muito bem cybercop, funciounou direitinho. Valeu pelo artigo!!!!

[21] Comentário enviado por ftonello em 05/08/2007 - 15:07h

Meus parabéns!!! Ótimo tutorial!!!!

A comunidade agradece!! hehehe

[22] Comentário enviado por rafaelfreitas em 06/08/2007 - 11:31h

Alguém saberia explicar o erro q dá quando eu rodo o Compiz, ele dá um erro no Dbus.... informando o tal erro em uma janela... aconteceu isso com alguém?

e parabéns pelo artigo... merece conceito 1.000

[23] Comentário enviado por lk1mur4 em 06/08/2007 - 12:48h

Ótimo artigo cara, parabéns!
Consigo rodar o Compiz q vem no Slack 12 normalmente dentro do Xfce, mas ainda não tive êxito em fazer o compiz-fusion funcionar (mesmo no KDE)..
Com esses pacotes, é possível rodar o compiz-fusion num WM q não seja o KDE ou Gnome?

[24] Comentário enviado por ftonello em 06/08/2007 - 18:00h

amigos,
eu instalei tudo blz, só que não está aparecendo o barra do kde nas janelas. O botão de fexar e essas coisas sabe..
eu instalei o dropline gnome lá mas mesmo assim está dando esse erro. Agluem pode ajudar?

[25] Comentário enviado por manser em 07/08/2007 - 20:19h

O primeiro link não funciona...

[26] Comentário enviado por slywitch em 11/08/2007 - 09:30h

Olá a todos, eu segui o tutorial e os comentários postados, mas continua dando erro no kde-window-decorator

a msg é a seguinte

o aplicativo kwd (kde-window-decorator) terminou anormalmente e casou o sinel 4 (SIGILL)

alguem poderia ajudar??

obrigado

[27] Comentário enviado por removido em 14/08/2007 - 01:10h

Gostaria de deixar uma dica para a galera que usa Slackware.

Eu não gosto muito da decoração de janelas do kde, quebrei muito a cabeça para conseguir usar o Emerald junto com o Compiz-Fusion até que recentemente encontrei a resposta.

Quem tem o Emerald instalado e quiser usá-lo como decorador de janelas junto com o Compiz-Fusion use esse comando quando lançar o Compiz no terminal:

$ kde-window-decorator --replace & compiz --replace -c emerald &

Bom, aqui no meu PC funcionou.


[28] Comentário enviado por mcdgo em 14/08/2007 - 20:46h

eu apenas digitei

$ compiz -v --replace

Me apareceu uns erros e não aparecia o barra principal das janelas.. Apenas digigei denovo..

$ compiz -v --replace

E ficou tudo bonitinho..
:D

[29] Comentário enviado por EDU4RDO em 15/08/2007 - 03:42h

?comentario=Aki funcionou mais sem a barra principal das janelas. Também gostaria de saber se ele tem algum gerenciador feito o berry onde pode aplicar as funções.

[30] Comentário enviado por lippec em 17/08/2007 - 19:15h

Olá... sou novo usuario de Linux escolhi o Ubuntu ..
1° maravilhado com os graficos .
mas estou com uma pequena dificuldade quanto ao plugin screen saver ele não esta funcionando . gostaria de saber se tem que configurar algum parametro todos meus efeitos estao funcionando normalmente tenho uma placa ATI X1050 pci e.
haaaaaaa e quanto as configurações das janelas pegando fogo no beryl as configs sem problemas mas no compiz fusion nao consegui alguem poderia me ajudar ? celltec.com@hotmail.com


[31] Comentário enviado por slywitch em 29/09/2007 - 19:06h

alguem sabe onde posso pegar estes pacotes, tipo .tar, tar.gz, onde eu mesmo possa compilar??

obrigado

[32] Comentário enviado por s4l4t1r em 04/10/2007 - 20:32h

ai eu ate comsegui fazer as telas reodarem mais deixar aparecendo o cubo e configurar nao foi possivel. o adesklets tambem sumiu.

[33] Comentário enviado por cybercop em 22/10/2007 - 19:16h

ATENÇÃO/ATUALIZAÇAO:

Quem esta com problemas para abrir a "decoracao de janelas", ou seja, a barra principal das janelas, instalar os seguintes pacotes (adicionando aos que ja tem ai nesse tutorial):

Emerald: http://www.zshare.net/download/43820567e6b9e9/

Emerald-themes: http://www.zshare.net/download/4382257db49763/

E executar a linha que nosso amigo wdmatheus postou ai:

kde-window-decorator --replace & compiz --replace -c emerald &

[34] Comentário enviado por tufo em 25/10/2007 - 13:23h

O driver da ATI com suporte a AIGLX saiu hoje. Segue o link:

http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run

[35] Comentário enviado por tufo em 25/10/2007 - 15:47h

Eu instalei em meu note, porém quando executo no gnome, as barras de título desaparecem. Alguém sabe como resolver isso?

[36] Comentário enviado por removido em 26/10/2007 - 00:13h

Testei o novo driver da ati e assim como no anterior ganhei um brinde extra no canto direito inferior. Watermark? Negativo. Agora se transformou em duas barrinhas separadas uma da outra que incrivelmente uma delas fica em cima do system tray (LoL).
O desempenho do Driver - desconsiderando o Compiz - até seria bom se não fosse esse detalhe...
Alguem teve o mesmo problema??
Estou acompanhando o forum Phoronix e ninguem achou (eu nao achei?) a solução pra isso.

Té mais pessoal!


EDIT: Dica correção do Watermark em:
http://padoca.wordpress.com/2007/10/26/dicas-para-a-nova-driver-da-amdati-8423-compiz-fusion-com-uma...

[37] Comentário enviado por mcdgo em 01/11/2007 - 02:00h

amigos.. eu consegui resolver o preblema da ati só não me lembro direito como!

mas sei que fiz uma gambiarra com uma lib GL que tanto da erro nas ATI.. e resolvi o problema! :P

[38] Comentário enviado por i00nsu em 05/11/2007 - 04:55h

Oix...

Eu também uso ATI

Eu tenho este erro quando faço -<> kde-window-decorator --replace & compiz --replace gconf &
:
Adding compiz option --replace to command line
Checking for Unsupported sessions: present.
Fatal: Compiz can't be ran using VESA or VGA divers.
:
..
eu antes de ir pra frente com este tuturial fiz uma actualização às drives da ATI.

Pode ajudar: tenho uma ATI Readon 9600.
Uso KDE.

PArece estar tudo instalado.. tipo se for a Settings tem lá o CompizConfig Settings manager que abre normalmente, mas o Compiz Settings Manager já não abre.

Já li os comments do resto do ppl, tentei fazer o que eles fizeram mas nao deu certo.

Alguém me dá uma dica sff?


[39] Comentário enviado por goss em 08/11/2007 - 19:52h

Desculpe perguntar novamente mas isso não foi respondido, é possivel instalar o Compiz e FLUXBOX ou FVWM?

Um abraço.

[40] Comentário enviado por caarlos0 em 17/12/2007 - 11:58h

versões novas!!
compiz-fusion 0.6

http://www.linuxpackages.net/search_view.php?by=name&name=fusion&ver=12.0

[]'s
Carlos

[41] Comentário enviado por phelipe em 22/02/2008 - 20:10h

Dica para quem estiver recebendo a mensagem abaixo quando inicia o compiz:

compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Inicie o compiz da seguinte forma:

LIBGL_ALWAYS_INDIRECT=true compiz --replace ccp & emerald --replace &

[42] Comentário enviado por removido em 24/02/2008 - 17:29h

jairo@Kizzo:~$ compiz --replace
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

[43] Comentário enviado por enricolo4 em 29/02/2008 - 21:25h

Olah!!!!
Fiz tudo o que o tutorial falou mas quando dou o comando
$ kde-window-decorator --replace & compiz --replace gconf & ou
$ compiz --replace ele da um erro e nao executa o compiz-fusion

Esse é o erro:

enrico@medium:~$ $ kde-window-decorator --replace & compiz --replace gconf &
[1] 13680
[2] 13681
enrico@medium:~$ -bash: $: command not found
/usr/bin/compiz.real: error while loading shared libraries: libXcomposite.so.1: cannot open shared object file: No such file or directory
kwin: impossível chamar a o gerenciador de seleção, outro gerenciador sendo executado? (tente usando --replace)
Fatal: Can't run kwin

O mesmo erro acontece se eu der $ compiz --replace.
Sera que alguem poderia me ajudar eu estou usando o SLAMD64. Valeu ai galera

[44] Comentário enviado por enricolo4 em 01/03/2008 - 15:25h

Bom com o meu post acima, ele ainda continua dando erro, achei q estivesse faltando uma lib, essa bXcomposite.so.1, como nao encontrei para fazer download acabei encontrando um pacote chamado libcompizconfig-0.6.0-i486-1bmg.tgz q eu instalei agora ele esta dando outra mensagem de erro.

root@medium:/home/enrico/Programas/Compiz-Fusion# compiz --replace
No protocol specified
xset: unable to open display ":0.0"
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xvinfo: Unable to open display :0.0
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xdpyinfo: unable to open display ":0.0".
No protocol specified
xdpyinfo: unable to open display ":0.0".
Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

[45] Comentário enviado por xerxeslins em 19/03/2008 - 02:56h

fiz tudo o que você disse mas ainda estou sem bordas quando ativo o compiz! mesmo com o emerald instalado! O que eu faço? so voce pode me ajudar!

[46] Comentário enviado por predador em 06/04/2008 - 21:16h

Cara e o seguinte, instalei o compiz conforme o seu artigo. Mas na hora de dar esses comandos:
$ kde-window-decorator --replace & compiz --replace gconf &
$ compiz --replace
dar os seguintes erros:
Fatal: Compiz can't be ran using VESA or VGA divers.

Ou esse:

Fatal: Compiz can't be ran using VESA or VGA divers.
[1] Done kde-window-decorator --replace
[3]+ Exit 1 compiz --replace gconf

Não sei se isso e por causa da minha placa de video.
Quando vou no Menu K => Configurações => CompizConfig Settings Manager , ele está la, com as opções de com configurações. Mas quanto aperto as teclas <Control><Alt>Down não acontece nada também. Se puder me ajudar ai valeu mesmo.

[47] Comentário enviado por removido em 11/04/2008 - 11:01h

Ola tudo bem?
toda vez que estart o compiz --replace
ele funfa mas o problema é que some as barras aonde fica o botao fechar. minimizar etc.
alguem sabe a solução pra isto?
Grato.

[48] Comentário enviado por xerxeslins em 12/05/2008 - 10:28h

Obrigado ^^

[49] Comentário enviado por Alex_conde em 01/07/2008 - 19:51h

ow mas tranquilo, ñ vou perder nda, pq instalei o linux esses dias, ñ fiz nda de mais nele. vou arriscar, valeu abraço

[50] Comentário enviado por yanalex em 28/08/2008 - 01:29h

bom segundo meu entender a placa de video não suporta por causa dos pixel (estranho issu),
pq minha placa com problemas até na alma suporto

[51] Comentário enviado por slack felix em 15/10/2008 - 17:33h

Olá,

Fiz todas as instalções e configurações mas quando efetuo o comando: compiz --replace ele retorna

compiz: symbol lookup error: compiz: undefined symbol: XCompositeGetOverlayWindow

Instalei o pacote libXcomposite-0.4.0-i486-1.tgz e o problema persiste. Além disso as janelas ficam sem bordas e o sistema fica travado.

Slackware 11
kernel 2.6.17.13
nVidia GeForce 6200

[52] Comentário enviado por jansen.kurumin em 09/01/2009 - 12:42h

oi esse pacote eh para kurumin tbm

[53] Comentário enviado por jean.carlo em 26/04/2009 - 04:40h

to usando o bactrack3 e o seguinte erro retornou quando eu dei um compiz --replace

xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
xdpyinfo: error while loading shared libraries: libdmx.so.1: cannot open shared object file: No such file or directory
Fatal: Failed test: Composite extension
Checks indicate that it's impossible to start compiz on your system.

o 3d tah ativo

minha placa é uma intel 945 gm

lspci da placa


lspci | grep 945
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)


alguempode me ajudar?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts