Driver Nvidia atual + Ubuntu + Beryl

Recentemente inventei de instalar o driver atual da Nvidia Geforce disponível no site da própria e acabei me deparando com alguns probleminhas durante o processo. Foi então que resolvi escrever este artigo para o caso de alguém estar tendo os mesmos probleminhas que tive. De quebra vou dar uma passada rápida pela instalação do Beryl.

[ Hits: 67.744 ]

Por: Rodrigo Teixeira Andreotti em 03/05/2007


Introdução



Neste artigo estarei falado um pouco sobre a instalação da Geforce, no meu caso utilizo a FX5500, porém serve para todas as placas que utilizam o driver Nvidia Forceware. Atualmente este driver está na versão 9755 para Linux.

Durante a instalação do mesmo em meu Ubuntu me deparei com alguns probleminhas que estarei relatando aqui e também falando as formas para corrigí-los e deixar o driver rodando redondinho.

Também estarei dando uma passada pela instalação do nosso querido Beryl, um excelente gerenciador de janelas que torna o uso do Ubuntu, assim como de qualquer outra distro, ainda mais agradável que já é....

Instalando o driver para sua Nvidia

Bom, vamos partir do suposto que você tenha todos os repositórios configurados (Universe e Multiverse).

Faça o download do driver no site da fabricante e salve em uma pasta a seu critério:
Inicie o Ubuntu em modo texto... você pode iniciá-lo em modo gráfico, ao chegar ao GDM dar um <ctrl>+<alt>+<f1>, logar como root e finalizar o processo GDM. Caso não saiba como finalizá-lo...uma forma é esta:

# ps -e

Procure pelo processo GDM e olhe pelo seu ID:

# kill id_do_processo

Antes de continuar uma pequena ressalva:

O driver Nvidia no meu Ubuntu retornou durante a instalação o seguinte warning:

WARNING: nvidia-installer was forced to guess the X library path '/usr/lib/xorg/modules/lib' and X module path
'/usr/lib/xorg/modules/lib/xorg/modules'; these paths were not queryable from the system. If X fails to find the
NVIDIA X driver module, please install the `pkg-config` utility and the X.Org SDK/development package for your
distribution and reinstall the driver.

Pois bem, isto não impede que o driver se instale, mas pode fazer com que ele dê algum tipo de problema mais adiante (inclusive impedir que o ambiente gráfico inicie).

Para eliminar o possível warning acima, instalaremos antes do driver os pacotes necessários:

# apt-get install pkg-config xorg-dev

Este comando instalará os dois pacotes necessários.

Agora instalaremos o driver:

Navegue até a pasta onde você salvou o download do driver e digite o comando:

# bash NVIDIA-Linux-x86-1.0-9755-pkg1.run

Responda a todas as perguntas feitas durante o instalador, na última pergunta ele atualizará seu xorg.conf para utilizar os drivers instalados, responda "SIM" e depois "OK".

Pronto, o driver está instalado!

Vamos conferir se ele está funcionando corretamente...

    Próxima página

Páginas do artigo
   1. Introdução
   2. Vendo se está tudo OK com o driver
   3. Ativando suporte a AIGLX
   4. Instalando o Beryl
Outros artigos deste autor

Clone de HDs e backup de MBR

Leitura recomendada

Recebendo notificações de seus servidores no seu celular e e-mail

Migrando de Red Hat para Debian

Otimizando seu web server com Apache2 + Lighttpd

Assistindo TV usando a placa VideoHighway Xtreme (ou outra baseada no bttv)

Configuração de CDRW

  
Comentários
[1] Comentário enviado por tbispo em 03/05/2007 - 11:29h

Para instalar o dirver da NVidia eu costumo usar o Automatix end. http://www.getautomatix.com/

Acho bem mais simples com ele. Que alem da nvidia instala mais um monte de coisas como por exemplo o java e o amsn.

[2] Comentário enviado por RodriAndreotti em 03/05/2007 - 11:44h

Legal cara, boa dica..

No caso o meu intuito neste artigo foi a instalação na unha mesmo, pois assim não ficamos dependentes do automatix, pios nem sempre otemos em mãos...

né???

abraços e valeu pelo comentário.

[3] Comentário enviado por RodriAndreotti em 03/05/2007 - 12:23h

Galera, esqueci de colocar um pacote que precisa ser baixado caso ocorra o erro descrito na página 2, desde já peço desculpas e posto aqui o procedimento a ser seguido...

instale o pacote Linux-restricted-modules (a versão mais atual)
# apt-get install linux-restricted-modules
escolha a versão mais atual para instalar.
depois instale o kernel-source da nvidia
# apt-get install nvidia-kernel-source

e reinicie o computador.


OBS.: inicie a máquina usando o kernel antigo mesmo que funciona...

abraços.

[4] Comentário enviado por sektor em 03/05/2007 - 22:04h

eu não uso ubuntu, mas o seu tuto ta bem legal, parabens.
=)

[5] Comentário enviado por removido em 03/05/2007 - 22:05h

Uma pergunta amigo:

Por enquanto os drivers que eu instalei, pelo Automatix, são os mais atuais, os mesmos que você instalou pelo tutorial. Mas, inevitavelmente, sairá uma versão mais recente e eu gostaria de saber como proceder numa eventual atualização.

Eu posso instalar o driver mais recente por cima deste que eu tenho, seguindo o seu tutorial, mudando, claro, apenas a parte referente a versão do driver, ou eu devo desisntalar o driver antigo, pelo Automatix e depois seguir seu tutorial?

Vlw!

[6] Comentário enviado por RodriAndreotti em 03/05/2007 - 23:12h

Cara pelo menos nesta versão do driver quando eu instalei ele removeu a versão antiga que eu tinha automaticamente, ele pergunta em um determinado momento da instalação seu você deseja que ele remova automaticamente a versão instalada...

não sei se as versões mais atuais vão vir com esta facilidade também, mas creio que sim.

abraços

[7] Comentário enviado por removido em 04/05/2007 - 16:19h

Ola,
Primeiro parabens pelo seu artigo...

Bem, mas eu fiz toda a instalação segundo seu tutorial... nao tive nenhum problema...
mas quando inicio o Beryl acontece algo estranho: todas as janelas ficam sem bordas e barras de título. Você já viu algo assim acontecer ?
o que sugere que eu faça ? seria algum problema do driver ? ou do beryl ?

ah, uso Ubuntu 7.04 i386 em uma maquina amd64, mas acho que isso não faz diferença... baixei o driver da nvidia para i386 tb...

[8] Comentário enviado por RodriAndreotti em 04/05/2007 - 17:28h

cara, obrigado pelos parabéns....

com relação ao beryl...sim já vi acontecer é normal...você passou pela terceira página do artigo????

Lá tem um trecho falando do seu xorg.conf
para você resolver o problema das barras de títulos você vai precisar edita-lo.
acesse um terminal e digite:

$ sudo nano /etc/X11/xorg.conf
nele procure por Section "Screen"
e abaixo dela adicione a linha abaixo:

Option "AddARGBGLXVisuals" "True"

Esta option permite a execução de elementos visuais glx...

salve seu arquivo (ctrl + x)
e reinicie o X Server (ctrl + alt + Backspace)

espero ter ajudado...
abraços.

[9] Comentário enviado por dbahiaz em 04/05/2007 - 17:29h

elieser, tente adicionar na seção scream:


Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Geforce 6600GT"
Monitor "T910B"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "TripleBuffer" "true"
SubSection "Display"

As bordas minha sempre volta quando adiciono isso, talvez resolva seu caso tb, sempre instalo seguindo um outro tutorial do vol, mais antigo, mais cada caso é um caso, é so uma dica mesmo.
http://vivaolinux.com.br/artigos/verArtigo.php?codigo=6148&pagina=2

E Parabens pelo artigo andreotti, é sempre bom ter artigos atualizados!

[10] Comentário enviado por RodriAndreotti em 04/05/2007 - 17:31h

Obrigado dbahiaz,

[11] Comentário enviado por removido em 04/05/2007 - 18:30h

Andre,
eu já havia lido o tutorial inteiro sim... ja havia adicionado a linha
Option "AddARGBGLXVisuals" "True"
e todas as outras que você diz lá também...

dbahiaz,
Mesmo adicionando esse Option "TripleBuffer" "True" não funcionou...

Mais alguma idéia ???

[12] Comentário enviado por RodriAndreotti em 04/05/2007 - 18:34h

vc usa KDE ou Gnome????

Bom, de qualquer forma tente clicar com o botão direito do mouse sobre o Rubi do Beryl...e procure por:
"Selecionar decorador de Janelas" e escolha:
Aquamarine ou Emerald
só relembrando...
KDE -> Aquamarine
Gnome -> Emerald

Apesar de que eu testei o Emerald no KDE e funfo...até que fica legalzinho....hehehe

[13] Comentário enviado por removido em 04/05/2007 - 22:58h

Não consigo encontrar essa opção...
clicar onde mesmo ? que rubi ?

[14] Comentário enviado por RodriAndreotti em 04/05/2007 - 23:12h

Perto do Relógio do seu linux, quando você carrega o beryl, você tem um Rubi (Tipo um diamante vermelho) você vai clicar com o botão direito nele e vai procurar pela opção:
"Selecione o decorador de janelas"
dentro destaopção tem outras duas, (se você instalou os pacotes delas claro)
* aquamarine
* Emerald

você pode escolher qualquer uma das duas...

qualquer coisa...
me passa seu email q eu te mando um screenshot...

abraços

[15] Comentário enviado por removido em 04/05/2007 - 23:22h

Andre,
realmente não aparece esse rubi proximo ao relogio não.
Uma coisa que eu percebi agora, é que não existe no meu sistema o comando beryl-manager que você diz para usar... eu uso simplesmente beryl para iniciar o gerenciador de janelas.
Existe um comando beryl-settings que abre uma janela com um monte de opções, mas pelo que estive olhando, nenhuma faz voltar as barras de titulos... acabei de perceber tb que quando inicio o beryl, o terminal e o run (Alt+F2) não iniciam mais...
Ah, estou usando Gnome.

[16] Comentário enviado por removido em 04/05/2007 - 23:39h

RESOLVIDO!!!

Bem, tive a ideia de #apt-get install beryl-manager e ai tudo funcionou...
De qualquer forma obrigado pela ajuda...

o problema com a decoração da janela era mesmo que não estava usando o esmerald, mas sim o tema default do gnome (GTK) por isso tava sem barras de títulos e bordas...

[17] Comentário enviado por rommul em 06/05/2007 - 22:48h

eu estou me batendo na segunda parte do seu tutorial.
muito bom, mas eu ja estou a algum tempo tentando instala esta vga e so apanho para ela.
será que podemos conversar por email ?
meu email bruno@tanervoso.com.br

[18] Comentário enviado por RodriAndreotti em 12/05/2007 - 15:07h

Pessoal pequena atualização...

Instalei hoje o Ubuntu Feisty, o problema com a versão do kernel continua....
e a solução para o mesmo continua igualzinha...

primeiro instalem o linux-restricted-modules
depois instalem o nvidia-kernel-source

e reinstalem o driver nvidia
depois basta reiniciar o pc...e iniciar pela versão normal do seu linux (não a nova que foi instalada, mas sim a genérica, que já era utilizada)

quanto ao beryl...os repositórios para o Feisty são quase os mesmos do Edgy, porém ao final de cada repositório troque a palavra "edgy" para "feisty" e pronto...
abraços a todos!!!

[19] Comentário enviado por luisaslima em 15/05/2007 - 15:30h

uma pergunta a minha placa e uma nvidia geforce 6200 256mb 8x 64bits e quando fiz o testeste a resposta foi rendering NO.
da para instalar o beryl ou nao.?

[20] Comentário enviado por RodriAndreotti em 16/05/2007 - 20:59h

não...você só vai conseguir utilizar o beryl se a resposta para rendering for YES

[21] Comentário enviado por jstequino em 18/05/2007 - 00:06h

Show de bola este artigo. Parabéns.

[22] Comentário enviado por lubuntu em 08/06/2007 - 12:52h

Eu uso UBUNTU 7.04 e esse tutorial ta show de bola mesmo!!!!!

[23] Comentário enviado por michelcias em 26/07/2007 - 07:39h

Estou usando o Ubuntu 7.04. Segui a risca todos os passos deste tutorial, mas mesmo assim, pelo que eu entendi, o driver nvidia continua dando conflito de versões com o módulo do kernel.

Tentei
# apt-get install nvidia-kernel-source
mas não serviu de nada.

Estou usando uma GeForce 8600GT.

A versão do drive que usei foi 100.14.11

Talvez o meu problema seja porque eu não saiba ainda mexer muito bem no linux. Gostaria muito que alguém me ajudasse a instalar o Beryl.

Obrigado.

Abraços a todos.

[24] Comentário enviado por jiraya-sama em 30/07/2007 - 22:06h

?comentario= Estou com o mesmo problema de michelcias, o "nvidia-kernel-source" diz que o mesmo está obsoleto ou não disponivel... =[

O que vocês poderiam nos recomendar?

Obrigado.

[25] Comentário enviado por ryudelima em 10/04/2008 - 18:14h

ja tentaram baixar o envy ... ele facilita bastante a estalaçao de drivers

[26] Comentário enviado por RodriAndreotti em 10/04/2008 - 20:28h

Cara, eu estou utilizando ele, e realmente facilita sim....mas mesmo assim tem que realizar alguns procedimentos para o driver funcionar perfeitamente...
os procedimentos que tive que tomar nele são os mesmo que precisei tomar no debian:

1º - desisntalar o driver 3d do próprio ubuntu;
2º - instalar o pacote module-assistant
3º - instalar os pacotes xserver-xorg-dev e pkg-config
4º - executar o comando m-a prepare
5º - instalar o driver.

depois disso só seguir o restante dos passos para o beryl, ou no caso o compiz-fusion que é melhor.

[27] Comentário enviado por anso10 em 21/08/2008 - 21:25h

cara eu fiz tudo como vc falo mas no comando "apt-get install beryl " da:

Lendo lista de pacotes... Pronto
Construindo árvore de dependências
Lendo estado da informação... Pronto
Alguns pacotes não puderam ser instalados. Isso pode significar que
você solicitou uma situação impossível ou se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram tirados do Incoming.

Já que você solicitou uma única operação é bem provável que o pacote
esteja simplesmente não instalável e um relato de erro sobre esse
pacotes deve ser enviado.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
beryl: Depende: beryl-settings mas não vai ser instalado
E: Pacotes quebrados
anderson@anderson-desktop:~$

o q eu faco? desde ja valew.

[28] Comentário enviado por RodriAndreotti em 21/08/2008 - 22:45h

opa...e aew cara...blz????

Deixa eu te perguntar antes de mais nada....

Qual versão do debian você está utilizando???

[29] Comentário enviado por anso10 em 21/08/2008 - 23:34h

ubuntu 8.04

[30] Comentário enviado por RodriAndreotti em 22/08/2008 - 17:07h

Cara, no ubuntu 8.04 você pode instalar direto pelos repositórios dele mesmo o COmpiz-fusion, que é a fusão do Compiz com o Beryl, ou então, pode também alterar nos repositórios, onde está a palavra "edgy" para "hardy" e instalar normalmente, mas creio que seja mais fácil instalar o compiz-fusion através dos reposítórios do próprio Ubuntu 8.04. Para isto use:

apt-get install compiz

espero ter ajudado.

Abraços

[31] Comentário enviado por anso10 em 23/08/2008 - 11:31h

ok vo tentar assim!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts