Como manter GNOME2 em Sabayon Linux

Este artigo descreve como manter o ambiente gráfico GNOME2, evitando que seja atualizado ao GNOME3, o que
quebraria o GNOME2 completamente! Isto acontece pois o Sabayon é uma distribuição Rolling Release, constantemente
atualizável.

[ Hits: 16.998 ]

Por: Alberto Federman Neto. em 29/08/2011 | Blog: https://ciencialivre.blog/


Terceiro Método - Mascarando os pacotes de GNOME3



O terceiro método é o melhor, por isso é o recomendado, mas é também o mais trabalhoso.

Veja a lista de todos os pacotes que o Entropy (equo, Sulfur) instalou no seu Sabayon. Para isso, use o próprio Sulfur e anote os pacotes, ou veja o conteúdo do arquivo "/etc/entropy/sets/install_base".

Dentro do arquivo verá algo do tipo (aqui coloquei apenas alguns dos pacotes de GNOME instalados):

...................
..........
gnome-base/gconf:2
gnome-base/gnome-desktop:0
gnome-base/gnome-keyring:0
gnome-base/gnome-menus:0
gnome-base/gnome-mime-data:0
gnome-base/gnome-mount:0
gnome-base/gnome-panel:0
gnome-base/gnome-vfs:2
gnome-base/gvfs:0
....................
.........


Deste modo, poderá ver os nomes de todos os pacotes de GNOME que seu sistema Sabayon tem instalado.

Agora usando essa lista de nomes, mascare TODOS os pacotes de GNOME3, para que não sejam mais atualizados. Isso pode ser feito em editor de texto (ou manualmente com comando echo), editando o arquivo "/etc/entropy/packages/package.mask".

Mas o jeito mais prático é executar um comando (exemplificado abaixo, com todos os meus pacotes de GNOME3 da minha instalação do Sabayon):

sudo equo mask \
file-roller-3.0.2 brasero-3.0.0 seahouse-3.0.2 gedit-3.0.6 evince-3.0.2 gdm-3.0.4 gnome-control-center-3.0.2-r2 gnome-keyring-3.0.3-r300 gnome-menus-3.0.1 gnome-panel-3.0.2 gnome-settings-daemon-3.0.2-r2 gsettings-desktop-schemas-3.0.1 gvfs-1.8.2-r1 libgnome-keyring-3.0.3-r1 libgnomekbd-3.0.0.1 nautilus-3.0.2 evolution-data-server-3.0.2.1 gcalctool-6.0.2 gconf-editor-3.0.0 seahorse-3.0.2 gdm-3.0.4-r1 gnome-session-3.0.2 gnome-shell-3.0.2 gnome-color-manager-3.0.0-r2 gnome-games-3.0.2 gnome-games-extra-data-3.0.0 gnome-packagekit-3.0.3 gnome-power-manager-3.0.2-r1 gnome-screensaver-3.0.0-r1 gnome-system-monitor-3.0.1-r1 gnome-user-docs-3.0.4 gnome-utils-3.0.1 gnome-web-photo-0.10.2-r300 nautilus-sendto-3.0.0 nm-applet-0.8.9997 yelp-3.0.4 evolution-3.0.2 eog-3.0.2 gimp-2.7.2 sound-juicer-2.99.0_pre20110405 cheese-3.0.2 totem-3.0.1 gnome--nettool-3.0.0 empathy-3.0.2 pidgin-2.9.0 networkmanager-0.8.9997 networkmanager-openvpn-0.8.9997 networkmanager-vpnc-0.8.999 vinagre-3.0.2 vino-3.0.3 gnome-bluetooth-3.0.1 epiphany-3.0.4 gnome-nettool-3.0.0 gnome-terminal-3.0.1 gnome-backgrounds-3.0.2 networkmanager-pptp-0.8.999


Feito o comando, observem o arquivo "packages.mask", com os pacotes do GNOME3 mascarados:
# package.mask file
#
# In this file you can specify atoms, one per line, that you would mask.
# Masking a package (atom) means that you will deny Entropy to pull in a package even if it's marked as "NOT experimental".

# LINE CONSTRUCTION:
# <atom>
# See examples below

# EXAMPLES:
# >=media-libs/foo-1.2.3
# media-libs/foo
# <media-libs/foo-1.2.3
# media-libs/foo:1
# >=media-libs/foo-1.2.3#2.6.23-sabayon-r1
#
# :1 means package with SLOT="1"
# #2.6.23-sabayon-r1 means package with kernel tag = 2.6.23-sabayon-r1
gcalctool-6.0.2
gnome-control-center-3.0.2-r2
libgnomekbd-3.0.0.1
evolution-data-server-3.0.2.1
gedit-3.0.6
nautilus-3.0.2
gconf-editor-3.0.0
gnome-keyring-3.0.3-r300
gnome-panel-3.0.2
gnome-menus-3.0.1
file-roller-3.0.2
gvfs-1.8.2-r1
gsettings-desktop-schemas-3.0.1
gnome-settings-daemon-3.0.2-r2
brasero-3.0.0
evince-3.0.2
libgnome-keyring-3.0.3-r1
gnome-packagekit-3.0.3
gnome-shell-3.0.2
gdm-3.0.4-r1
gnome-session-3.0.2
seahorse-3.0.2
gnome-color-manager-3.0.0-r2
gnome-screensaver-3.0.0-r1
gnome-power-manager-3.0.2-r1
gnome-games-3.0.2
gnome-games-extra-data-3.0.0
eog-3.0.2
epiphany-3.0.4
gnome-utils-3.0.1
networkmanager-0.8.9997
totem-3.0.1
cheese-3.0.2
gnome-bluetooth-3.0.1
yelp-3.0.4
nm-applet-0.8.9997
gnome-web-photo-0.10.2-r300
pidgin-2.9.0
networkmanager-openvpn-0.8.9997
vinagre-3.0.2
nautilus-sendto-3.0.0
gnome-user-docs-3.0.4
vino-3.0.3
gimp-2.7.2
gnome-system-monitor-3.0.1-r1
sound-juicer-2.99.0_pre20110405
networkmanager-vpnc-0.8.999
evolution-3.0.2
empathy-3.0.2
>=gnome-backgrounds-3.0.2
>=gnome-nettool-3.0.0
>=gnome-terminal-3.0.1


Querendo aproveitar para mascarar todas as versões futuras de GNOME3, faça como no exemplo acima, colocando um sinal de maior ou igual (>=) em frente ao pacote. Significa, por exemplo: "mascarar todas as versões de gnome-terminal maiores ou iguais à 3.0.1"

Na Figura 3, meu Sabayon 6.0 todo atualizado mas com GNOME2, e não GNOME3. Os pacotes todos foram mascarados e não são mais chamados para atualização:
Linux: Como manter GNOME2 em Sabayon Linux.
Caso haja necessidade de atualizar pacotes de sistema cujas dependências sejam de GNOME3, verifique a instalação e depois instale com opção sem dependências, pois muitas serão supridas pelo próprio GNOME2. No exemplo abaixo, com vários pacotes de sistema, que eram chamados para atualização:

sudo equo install --pretend --nodeps tracker libreoffice abiword php folks icu libxml libxsit glade gconf gtkhtml libgda banshee vlc pidginlibsoup webkit-gtk-1.4.2-r300 bluez chromium gtksourceview openbox thunar xfce-utils xfce-panel xfconf thunar-vfs

sudo equo install --verbose --nodeps tracker libreoffice abiword php folks icu libxml libxsit glade gconf gtkhtml libgda banshee vlc pidginlibsoup webkit-gtk-1.4.2-r300 bluez chromium gtksourceview openbox thunar xfce-utils xfce-panel xfconf thunar-vfs
Página anterior     Próxima página

Páginas do artigo
   1. Introdução e Primeiro Método
   2. Segundo Método - Não atualizar o GNOME2
   3. Terceiro Método - Mascarando os pacotes de GNOME3
   4. Recuperando o GNOME2 e Conclusão
Outros artigos deste autor

Sabayon 5.0 - Uma nova distro multimídia (parte 1)

Para iniciantes: Deu tela preta? Não se desespere!

Sabayon Linux: Migrando KDE4 para KDE5

Como instalar pacotes no Sabayon

Atualizando Compiz Fusion em Sabayon Linux

Leitura recomendada

Metisse (3D Desktop): Um novo conceito de interface gráfica!

Asterisk e Asterisk GUI - Instalação e Configuração no Debian Squeeze

O GIMP: Pincéis e texturas

Convertendo sistemas físicos em máquinas virtuais

Atualizando o clamav via YUM no Fedora Core 3

  
Comentários
[1] Comentário enviado por albfneto em 30/08/2011 - 12:07h

COMPLEMENTO:

Atualizado até 15 de Setembro de 2015.

Útil para proteger o KDE4, para que não seja atualizado ao KDE5.
Basta usar os pacotes do KDE4 e não os do GNOME2.


[2] Comentário enviado por mcnd2 em 30/08/2011 - 22:25h

Belo artigo.

Quando você fala em 'quebrar' atualizando para o gnome 3, isto significa que o sistema não vai mais subir ou apenas não poderá ter mais o gnome2?

Tô curiosos para testar esse método, mas como meu note dell deu pau e esta na garantia vou ficar na vontade...

Parabéns @albfneto.

[3] Comentário enviado por albfneto em 30/08/2011 - 23:19h

Não terá mais GNOME2, nem compiz, nem Screenlets, nem Cairo-Dock... ambiente GNOME2 não funcionará mais (e seue pacotes serão sobrescritos) e nem nada que funcione nele...
o que não for sobresacrito,, como compiz, screenlets e cairo-dock, estarão ainda ativos, precisa tira-los, senão não abre GNOME3.
portanto é assim, com GNOME2 apagado, deletado, e gnome3 que não abre!
o que aconteceria é isso aqui:

http://forum.sabayon.org/viewtopic.php?f=57&t=25057

ao menos em Sabayon, GNOME3 é muito ruim. vc verá em meu outro artigo, ele destrói XFCE, LXDE e os outros ambientes gráficos, menos KDE, e compiz tb!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts